Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Various BSOD errors during normal use and sleep

26 Dec 2012   #1

Windows 7 Home Premium 64bit
Various BSOD errors during normal use and sleep


Hi. I upgraded my computer a few weeks ago with a new motherboard, CPU, RAM, and SSD, and lately I have been having various BSOD errors. They seem to happen at random, and often I will come back to my computer with it having the BSOD error message up (or, before I changed it, the computer restarted saying that it crashed). I have updated my BIOS and reinstalled my drivers (with the exception of the Intel VGA driver which will not install). I have reinstalled Windows several times and updated to SP1 (I had trouble with errors when installing SP1, but those were fixed when I reinstalled Windows).

I have search around for an answer, both on these forums and through Google, but all the solutions to the problem seem to be specific to the computer and the dump, so I decided to make an account and a post. Any information would be useful! Thanks in advance!

My System SpecsSystem Spec
26 Dec 2012   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Welcome to SevenForums..

Is the firmware of your SSD up to date?

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 50, {fffff80002000000, 8, fffff80002000000, 2}

*** WARNING: Unable to verify timestamp for athurx.sys
*** ERROR: Module load completed but symbols could not be loaded for athurx.sys

Could not read faulting driver name
Probably caused by : athurx.sys ( athurx+9f3bb )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arg1: fffff80002000000, memory referenced.
Arg2: 0000000000000008, value 0 = read operation, 1 = write operation.
Arg3: fffff80002000000, If non-zero, the instruction address which referenced the bad memory
Arg4: 0000000000000002, (reserved)

Debugging Details:

Could not read faulting driver name

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800036c6100
GetUlongFromAddress: unable to read from fffff800036c61c0
 fffff80002000000 Nonpaged pool

fffff800`02000000 ??              ???







TRAP_FRAME:  fffff88002b638a0 -- (.trap 0xfffff88002b638a0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80002000000 rsp=fffff88002b63a30 rbp=0000000000000000
 r8=0000000000000000  r9=0000000000000f44 r10=fffff80003418000
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na pe nc
fffff800`02000000 ??              ???
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff8000343d8e0 to fffff80003496fc0

fffff800`02000000 ??              ???

fffff880`02b63738 fffff800`0343d8e0 : 00000000`00000050 fffff800`02000000 00000000`00000008 fffff880`02b638a0 : nt!KeBugCheckEx
fffff880`02b63740 fffff800`034950ee : 00000000`00000008 fffff800`02000000 00000000`00000000 00000000`00000000 : nt! ?? ::FNODOBFM::`string'+0x437f6
fffff880`02b638a0 fffff800`02000000 : fffffa80`40820089 fffff880`038af3bb fffffa80`00000000 fffff880`00004048 : nt!KiPageFault+0x16e
fffff880`02b63a30 fffffa80`40820089 : fffff880`038af3bb fffffa80`00000000 fffff880`00004048 fffff800`00000000 : 0xfffff800`02000000
fffff880`02b63a38 fffff880`038af3bb : fffffa80`00000000 fffff880`00004048 fffff800`00000000 00000000`00000000 : 0xfffffa80`40820089
fffff880`02b63a40 fffffa80`00000000 : fffff880`00004048 fffff800`00000000 00000000`00000000 00000000`00000000 : athurx+0x9f3bb
fffff880`02b63a48 fffff880`00004048 : fffff800`00000000 00000000`00000000 00000000`00000000 fffffa80`08636030 : 0xfffffa80`00000000
fffff880`02b63a50 fffff800`00000000 : 00000000`00000000 00000000`00000000 fffffa80`08636030 fffff880`02b63bdc : 0xfffff880`00004048
fffff880`02b63a58 00000000`00000000 : 00000000`00000000 fffffa80`08636030 fffff880`02b63bdc fffffa80`0667c840 : 0xfffff800`00000000


fffff880`038af3bb ??              ???


SYMBOL_NAME:  athurx+9f3bb

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  athurx.sys


FAILURE_BUCKET_ID:  X64_0x50_BAD_IP_athurx+9f3bb

BUCKET_ID:  X64_0x50_BAD_IP_athurx+9f3bb

Followup: MachineOwner

1: kd> lmvm athurx
start             end                 module name
fffff880`03810000 fffff880`039ee000   athurx   T (no symbols)           
    Loaded symbol image file: athurx.sys
    Image path: \SystemRoot\system32\DRIVERS\athurx.sys
    Image name: athurx.sys
    Timestamp:        Wed Apr 20 16:07:45 2011 (4DAEB071)
    CheckSum:         001E1C78
    ImageSize:        001DE000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Perform a clean install of the above Atheros driver.

Click on the Start ► Control Panel ► Programs ► Uninstall a program ► Uninstall everything related to; ATHEROS & restart the computer. Delete remnants of its drivers/older drivers using Driver Fusion/Sweeper
Atheros Driver:

If its wireless, match your device from here:If its not a wireless, match your device from here:Perform a System File Check:
  • Click on the start
  • Type CMD on Search
  • Left click and Run as Administrator
  • Type SFC /scannow
Full tutorial here:Disk Check on your hard drive for file system errors and bad sectors on it:If this does not bring stability, test the RAM.

Take memtest. Run for 8 passes and test each stick in a know good slot for an additional 6 passes.
The goal is to test all the RAM sticks and all the motherboard slots.

Check your motherboard manual to ensure the RAM sticks are in the recommended motherboard slots. Some motherboards have very specific slots required for the number of RAM sticks installed.

If you get errors, stop the test and continue with the next step.

1. Remove all but one stick of RAM from your computer (this will be RAM stick #1), and run Memtest86 again, for 7 passes.
*Be sure to note the RAM stick, use a piece of tape with a number, and note the motherboard slot.
If this stick passes the test then go to step #3.

2. If RAM stick #1 has errors, repeat the test with RAM stick #2 in the same motherboard slot.
*If RAM stick #2 passes, this indicates that RAM stick #1 may be bad. If you want to be absolutely sure, re-test RAM stick #1 in another known good slot.
*If RAM stick #2 has errors, this indicates another possible bad RAM stick, a possible motherboard slot failure or inadequate settings.
3. Test the next stick of RAM (stick #2) in the next motherboard slot.
*If this RAM stick has errors repeat step #2 using a known good stick if possible, or another stick.
*If this RAM stick has no errors and both sticks failed in slot#1, test RAM stick #1 in this slot.
4. If you find a stick that passes the test, test it in all the other motherboard slots.

If Part 2 testing shows errors, and all tests in Part 3 show errors, you will need to test the RAM sticks in another computer and/or test other RAM in your computer to identify the problem.

In this way, you can identify whether it is a bad stick of RAM, a bad motherboard, or incompatibility between the sticks.
information   Information
Errors are sometimes found after 8 passes.

Tip   Tip
Do this test overnight, before going to bed.

Let us know your results.
My System SpecsSystem Spec
02 Jan 2013   #3

Windows 7 Home Premium 64bit

Sorry it took so long to reply; I was waiting to see if I got another BSOD.

Yes, my SSD firmware is current.

I did the two disk checks on both my drives and no errors were found.

I also reinstalled the Atheros driver from the website you linked, but that didn't seem to fix the problem (I am still getting BSOD's, but this time they don't have an error message. I am attaching the latest grab from the diagnostic tool here.

I did a basic memory check (no removing RAM) with memtest before on the new set of RAM and no errors were found, but I'll do the full one you posted just to make sure and edit this post with the results.
My System SpecsSystem Spec

02 Jan 2013   #4

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

There are no .dmp files after the 26th of last month
My System SpecsSystem Spec
03 Jan 2013   #5

Windows 7 Home Premium 64bit

That's odd. The crash screen I got said that it dumped the memory, but it wasn't the normal BSOD (it didn't have an error message and was longer). I just ran the diagnostic tool again and verified that there isn't a dump inside, so I'm not sure how to report the crash.

Also, I ran memtest for 8 passes on all my RAM with no errors found. I'll do the "individual RAM piece" tests tomorrow.
My System SpecsSystem Spec
03 Jan 2013   #6

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

I will check the files again.

Do let us know the results from memtest.
My System SpecsSystem Spec
07 Jan 2013   #7

Windows 7 Home Premium 64bit

Ok, I ran 8 passes on all the RAM and 6 passes on each stick, but it didn't find any errors. I just flashed an updated version of the BIOS; I'll see if that has fixed the blue screens.
My System SpecsSystem Spec
07 Jan 2013   #8

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

OK, and after that we'll enable driver verifier.
My System SpecsSystem Spec
07 Jan 2013   #9

Windows 7 Home Premium 64bit

I just got another "odd" BSOD with that:
  1. Didn't have an error message
  2. Dumped the memory somewhere but the diagnostic tool doesn't grab it
  3. Didn't automatically restart after it dumped the memory (which I have it set to in settings)
It happened during various activities; I had music playing through Youtube, updating Visual Studio, and renaming a shortcut on my HDD. I'll attach what the Diagnostic Tool found, but it doesn't include the memory dump from the last BSOD.
My System SpecsSystem Spec
07 Jan 2013   #10

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Do you get BSOD-s in safe mode?

Upload a screenshot of your hard disk using CrystalDiskInfo:Make a hard drive test from the hard drive manufacturers website:Run Disk Check on your hard disk for file system errors and bad sectors on it:Hard drive test both short and long with: Also the DOS version of:
My System SpecsSystem Spec

 Various BSOD errors during normal use and sleep

Thread Tools

Similar help and support threads
Thread Forum
BSOD during normal work and placing computer into sleep mode
I don't actually see the BSOD when I put it into sleep, but when it's happened, it takes a long time to "sleep" before it unexpectedly shuts off, and then I have to boot up the computer again I get the whole "window did not shut off properly screen", and I get the message about the minidumps when I...
BSOD Help and Support
BSOD normal or safe mode, multiple errors
Greetings! A couple of years ago I made a post detailing my previous BSOD issues (original thread I dont know if i found the cause but i did find a workaround. Basically I started re-seating the memory modules in my ASUS m50vm and found that putting either of my two...
BSOD Help and Support
BSOD after resuming from sleep. Various Errors.
I have a refurbished Dell XPS 15 laptop from 5 months. Every time i resume my windows from sleep, after a few minutes i got different Blue Screen errors. I've re-installed my OEM windows, once (from recovery Partition) but still the same errors. I've attached my mini-dumps files, with the report...
BSOD Help and Support
Sleep Mode errors - system won't sleep, 12 errors in energy-report
Issue at large: Win7-64 won't go into sleep mode. Recent issue in last week. Also seems to be automatically resetting from Balanced power mode to High Performance? Below is the energy-report.html results, if they're helpful: Power Efficiency Diagnostics Report Computer Name HOME-PC Scan...
Performance & Maintenance
BSOD after entering sleep, now also on normal use
Hi, i always get a BSOD after my machine (windows 7 x64) has just awoken from sleep. it happens after you log back in, as soon as you move the mouse. So, i never let my computer sleep. However, i had another BSOD just as i was working away normally, the PC hadnt slept, this has motivated me...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:27.
Twitter Facebook Google+