Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD in the last two days, bad pool header, 0x00000019

01 Jan 2013   #1

Microsoft Windows 7 Home Premium 64-bit
BSOD in the last two days, bad pool header, 0x00000019

Right so I made myself a new computer not that long ago, September I think, and have had no problems with it, until two days ago anyway. The first time it BSOD was while playing minecraft restarted, checked the hard drive for errors, was clean. Then checked to see if I had a virus or anything, again clean. Then I thought nothing of it, today it just happened again while browsing the internet. I have no idea how to fix this, so found this site and it looks like you guys seem to be able to help, so thought I would try here.

Anyway, I have had the error bad pool header, and 0x00000019. I have also attached a report created from SF tool.
Any help would be appreciated thanks in advance.

My System SpecsSystem Spec
01 Jan 2013   #2

Win7 Ultimate X64

Hello Slimwich, Welcome to SF

OK first off the general stuff
If your OCing in anyway stop, return everything to stock settings for the purposes of testing

If you havent already, fill in your system specs so we know what we are dealing with
System Info - See Your System Specs

Make sure you have read the guide on asking for help with BSOD so you know what we need
And if necessary set your machine to create minidumps (Method 2 Step 2 is easiest IMO)
Dump Files - Configure Windows to Create on BSOD

Run some scans to check against virus or infection
Windows Defender Offline

Run some basic hardware tests
RAM - Test with Memtest86+
Disk Check (windows based check)
Hard Drive Diagnostic Procedure (bootable disk check)

Now the nitty gritty
Your dump file indicates an error code 0x19 BSOD Index
usual causes of this a device drivers
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
Use !analyze -v to get detailed debugging information.
BugCheck 19, {22, 9400000000000, 0, 0}
Probably caused by : ndis.sys ( ndis!ndisRestartMiniportFilterStack+336 )
Followup: MachineOwner
0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
The pool is already corrupt at the time of the current request.
This may or may not be due to the caller.
The internal pool links must be walked to figure out a possible cause of
the problem, and then special pool applied to the suspect tags or the driver
verifier to a suspect driver.
Arg1: 0000000000000022, 
Arg2: 0009400000000000
Arg3: 0000000000000000
Arg4: 0000000000000000
Debugging Details:

BUGCHECK_STR:  0x19_22
POOL_ADDRESS: GetPointerFromAddress: unable to read from fffff800036c3100
GetUlongFromAddress: unable to read from fffff800036c31c0
 0009400000000000 Nonpaged pool
LAST_CONTROL_TRANSFER:  from fffff8000341e4ce to fffff80003493fc0
fffff880`03585718 fffff800`0341e4ce : 00000000`00000019 00000000`00000022 00094000`00000000 00000000`00000000 : nt!KeBugCheckEx
fffff880`03585720 fffff800`035c01fa : 00000000`00000000 fffff880`03585870 fffff880`035857f0 00470000`00000001 : nt! ?? ::FNODOBFM::`string'+0x72d6
fffff880`035857b0 fffff880`01853296 : fffff880`03585b30 fffff880`03585b30 00000000`00000000 fffff880`00000000 : nt!ExFreePoolWithTag+0x46a
fffff880`03585860 fffff880`01853932 : fffffa80`00000000 fffffa80`0c1c81a0 fffffa80`00000000 fffff880`01863110 : ndis!ndisRestartMiniportFilterStack+0x336
fffff880`03585af0 fffff800`0349d641 : fffff880`0189e010 fffff800`03786501 fffff800`03631280 fffffa80`00000000 : ndis!ndisQueuedRestartFilter+0x192
fffff880`03585b70 fffff800`0372ae5a : 00000000`00000000 fffffa80`06719b50 00000000`00000080 fffffa80`066769e0 : nt!ExpWorkerThread+0x111
fffff880`03585c00 fffff800`03484d26 : fffff880`03365180 fffffa80`06719b50 fffff880`0336ffc0 00000000`00000000 : nt!PspSystemThreadStartup+0x5a
fffff880`03585c40 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16

fffff880`01853296 8b5360          mov     edx,dword ptr [rbx+60h]
SYMBOL_NAME:  ndis!ndisRestartMiniportFilterStack+336
FOLLOWUP_NAME:  MachineOwner
IMAGE_NAME:  ndis.sys
FAILURE_BUCKET_ID:  X64_0x19_22_ndis!ndisRestartMiniportFilterStack+336
BUCKET_ID:  X64_0x19_22_ndis!ndisRestartMiniportFilterStack+336
Followup: MachineOwner
dump is blaming driver ndis.sys but this is a driver supplied by windows install disk or windows update so i think we can rule that one out, so im afraid its not a clear cut case, there is two ways to go about this we can sit back and wait for it to happen again and try to narrow it down or we can be proactive go at it updating drivers and running driver verifier its up to you

Will have a look through your drivers and programs and update in a bit
My System SpecsSystem Spec
01 Jan 2013   #3

Win7 Ultimate X64

Here is some of your older drivers that could do with updating if possible

jswpslwfx.sys 15/05/2008 D-Link USB Wireless Adapter Driver D-Link | Support
athrx.sys 05/10/2009 Atheros network adapter driver
NVTCAMD2.SYS 14/07/2010 ? think this is usb camera ?
nvtcam.sys 14/07/2010 ? NTK camera driver
athurx.sys 11/10/2010 Atheros AR9271 Wireless Network Adapter

I notice you are using AVG i personally would remove it and install Microsoft Security Essentials - Microsoft Windows it has much better compatibility and does not cause issues like AVG does
You have an xbox program running on startup not sure what it is but i would get rid of it on startup just run on demand if its something you use/need if not uninstall it have seen BSOD issues with xbox controllers and stuff before

Start Menu\Programs\AVG Public
Start Menu\Programs\DAEMON Tools Lite Public
Start Menu\Programs\Free Registry Cleaner Public
Start Menu\Programs\MSI Afterburner
Start Menu\Programs\MSI Afterburner\SDK
Heres some programs that are not great, MSI afterburner is an OC program which is bad for BSOD
Daemon tools has known issues with win 7 as a cause of BSOD
Registry cleaners are just crap they cause more problems than they solve and are best avoided, if you need one to accomplish a specific task try Ccleaner
My System SpecsSystem Spec

01 Jan 2013   #4

Microsoft Windows 7 Home Premium 64-bit

Thanks for the quick response and help so far!

Right so at the moment, I have ran both of the virus checks, that you suggested. I have ran a disk check, (only the windows one so far) I have updated my info about my specs on my profile, and am now currently updating my drivers. But so far there have been no errors, nor any virus. Hopefully updating the drivers will do the trick though.

specs are as follows

OS : Microsoft Windows 7 Home Premium 64-bit
CPU : Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
Motherboard : Gigabyte Technology Co., Ltd. Z77X-UD3H
Memory : 8.00 GB
Graphics Card(s) :AMD Radeon HD 6800 Series
Sound Card : (1) VIA High Definition Audio (2) USB Audio Device
Hard Drive : Seagate 1TB Barracuda Internal Hard Drive
PSU : Corsiar TX850M
My System SpecsSystem Spec
01 Jan 2013   #5

Win7 Ultimate X64

I dont understand you have a gigabyte motherboard and MSI afterburner program installed, have you changed hardware and not clean installed windows, if so that could be half the problem
My System SpecsSystem Spec
01 Jan 2013   #6

Microsoft Windows 7 Home Premium 64-bit

I wasn't using it to OC I just wanted to check the temperature, one of my friends suggested MSI so that was what I tried. Could it really be something as simple as that conflicting?

I didn't know that it was exclusively for that to be honest.
My System SpecsSystem Spec
01 Jan 2013   #7

Win7 Ultimate X64

Just hit the gigabyte website and get their software, we have exact same mobo and i got easytune 6 (et6) to access bios from desktop
GIGABYTE - Motherboard - Socket 1155 - GA-Z77X-UD3H (rev. 1.1)
I was getting worried you had HDD from old install and plugged into new build (you would be surprised how many people think it will work)
My System SpecsSystem Spec
02 Jan 2013   #8

Microsoft Windows 7 Home Premium 64-bit

Update: Right I have done everything you suggested, and today I got a crash, not BSOD though so progress? haha
My System SpecsSystem Spec
02 Jan 2013   #9

Win7 Ultimate X64

OK lets stay positive
You say you did all the above
1 how did you get on with the hardware tests, did you run a bootable HDD diagnostic (IMO its more thorough than windows dskchk)
2 memtest did it run with no errors and how many passes did it run.
3 did you remove suggested programs
4 did you update all 5 drivers listed, if not which ones?

If those hardware tests came out ok there are two more we can try (but need to constantly watch temps while doing them) which are
Graphics stress test Video Card - Stress Test with Furmark
General hardware stress test Hardware - Stress Test With Prime95

If all the earlier tests passed (awaiting your results) and then these two come out ok then we can be reasonably confident the mechanics of the system are ok, that would leave the driver situation, the best way to check this out IMO is to run driver verifier to stress all the drivers out and try to force a crash which will hopefully flush out any faulty/corrupted/non compatible drivers just be aware there are some risks in doing this although slight please read up before enabling as in a few circumstance this will cause system to not boot and you may need recovery options to get back in and turn verifier off again so please ensure you have backups in place and means to restore system if necessary ie bootable recovery disc and/or original install media

Its up to you what order you wish to proceed or which road you want to go down hopefully all paths will lead to the same place, if your not sure or have any questions please ask
My System SpecsSystem Spec
02 Jan 2013   #10

Win7 Ultimate X64

Just having a look through your list of drivers again theres a really old one in there it actually predates windows 7 might be worth trying to update it also
jswpslwfx.sys 15/05/2008 D-Link USB Wireless Adapter Driver D-Link | Support
My System SpecsSystem Spec

 BSOD in the last two days, bad pool header, 0x00000019

Thread Tools

Similar help and support threads
Thread Forum
bsod bad pool header 0x00000019 Please help guys:(
BSOD Help and Support
BSOD Bad Pool Header 0x00000019 (Random)
I also added the dump that I know for certain that was made during BSOD because I set it up myself to do this so I included it (092015-229087-01.dump.rar) This problem has happened on a gradient, once a week, once a day, now 2-3 times daily. Thanks Patrick Batman
BSOD Help and Support
BSOD, error 0x00000019 Bad Pool Header on start-up
*Typing from my phone as I cannot use my computer* It all started yesterday when my laptop was suddenly shut down because the battery ran out. When I started it back up again I got the Bad Pool Header BSOD. I tried to use the system repair, but it had no effect. I also tried CHKDSK /f...
BSOD Help and Support
BSOD from Photoshop - Bad Pool Header 0x00000019
So, today I was going to do some image editing, so I opened up photoshop cs6, and the computer crashed. So, I restarted the computer and opened up photoshop again. To my chagrin, it crashed again. So I opened up the laptop reseated the ram, made sure nothings wrong, rebooted, and opened up...
BSOD Help and Support
BSOD Bad Pool Header error 0x00000019
I have been getting a BSOD Bad Pool Header. I have recently updated my CPU and memory. My specs have also been updated to reflect the new hardware. Thank you for any info on what might be causing these. Jerry
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:39.
Twitter Facebook Google+