Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD 0x000000f4 (Dump file)

30 Jan 2013   #1

Windows x64 N Enterprice
BSOD 0x000000f4 (Dump file)


When I play 3D games my Windows crashes. I have also tried a clean install but I still get blue screen with error code:

0x000000f4 (0x0000000000000003, 0xfffffa800fd6d060, 0xfffffa800fd6d340, 0xfffff80002f98460). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 013013-20078-01.

I dont know what cause this or how to fix it, please help

Here is the minidump file under windows\minidump:

Here is the MEMORY.DMP file (uncompressed 689MB):

Here is my MSINFO32:

My System SpecsSystem Spec
30 Jan 2013   #2
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

This crashdump shows that during a disk-to-RAM I/O operation an error occurred that the associated object was not found. What that is exactly, I'm not sure, but I know it involves the drive.

I see that you are using an OCZ drive. Just as a forewarning, OCZ drives are very unstable and often cause a lot of problems, notably being one of the least reliable SSD brands in the industry. There is a very good possibility your drive may be bad. You should first find and download and install any new drivers and firmware for it (firmware is very important!), then run CrystalDiskInfo, take a snapshot of the results and send it to us.
My System SpecsSystem Spec
30 Jan 2013   #3
x BlueRobot


A process or thread crucial to system operation has unexpectedly exited or been
Several processes and threads are necessary for the operation of the
system; when they are terminated (for any reason), the system can no
longer function.
Arg1: 0000000000000003, Process
Arg2: fffffa800fd6d060, Terminating object
Arg3: fffffa800fd6d340, Process image file name
Arg4: fffff80002f98460, Explanatory message (ascii)
0: kd> !process fffffa800fd6d060 3
PROCESS fffffa800fd6d060
    SessionId: 1  Cid: 0260    Peb: 7fffffd8000  ParentCid: 0250
    DirBase: 3c38f3000  ObjectTable: fffff8a00416c930  HandleCount: 403.
The text in green highlights the address in which the process has failed and been terminated. This can be seen within the Stack Text.

EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.
fffff880`0c5440e8 fffff800`03020822 : 00000000`000000f4 00000000`00000003 fffffa80`0fd6d060 fffffa80`0fd6d340 : nt!KeBugCheckEx
fffff880`0c5440f0 fffff800`02fcce0b : ffffffff`ffffffff fffffa80`104dcb50 fffffa80`0fd6d060 fffffa80`0fd6d060 : nt!PspCatchCriticalBreak+0x92
fffff880`0c544130 fffff800`02f4bf04 : ffffffff`ffffffff 00000000`00000001 fffffa80`0fd6d060 00000000`00000008 : nt! ?? ::NNGAKEGL::`string'+0x176e6
fffff880`0c544180 fffff800`02c98253 : fffffa80`0fd6d060 fffff800`c0000006 fffffa80`104dcb50 00000000`040d0c60 : nt!NtTerminateProcess+0xf4
fffff880`0c544200 fffff800`02c94810 : fffff800`02ce3b7f fffff880`0c544b78 fffff880`0c5448d0 fffff880`0c544c20 : nt!KiSystemServiceCopyEnd+0x13
fffff880`0c544398 fffff800`02ce3b7f : fffff880`0c544b78 fffff880`0c5448d0 fffff880`0c544c20 00000000`040d1800 : nt!KiServiceLinkage
fffff880`0c5443a0 fffff800`02c98642 : fffff880`0c544b78 00000000`000713b8 fffff880`0c544c20 00000000`040d12d8 : nt! ?? ::FNODOBFM::`string'+0x488a4
fffff880`0c544a40 fffff800`02c971ba : 00000000`00000000 00000000`76d08af4 00000000`040d1201 00000000`000713b8 : nt!KiExceptionDispatch+0xc2
fffff880`0c544c20 00000000`77219c12 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x23a
00000000`040d1220 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x77219c12
I found it interesting, that a page fault occurred, which from what I understand (if I'm correct), is when a driver or process references a address which doesn't exist or is available within virtual memory.

Run some hard-drive diagnostics and follow these steps:Find your hard-drive manufacturer and run their tests.

Additional Tests:Post a screenshot of Crystal Disk Info summary: Make sure you have the latest firmware for SSD, and ensure all the SATA and Power cables are connected to the drive.

Check for any file system errors and bad sectors using Option #2 of:Use this command with Disk Check:

chkdsk C: /f /r
EDIT: Vir has posted :)
My System SpecsSystem Spec

30 Jan 2013   #4
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

Page faults are commonplace and normal operation, and yes, they occur when the requested virtual memory does not have its true counterpart present in RAM. However, it's during the pagefault in this case that an I/O error occurred when attempting to retrieve the data to put into RAM. Dumping the raw thread stack will show that it's littered with 3 NTSTATUS error codes:

6: kd> !error c000000e
Error code: (NTSTATUS) 0xc000000e (3221225486) - A device which does not exist was specified.
6: kd> !error c0000005
Error code: (NTSTATUS) 0xc0000005 (3221225477) - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.
6: kd> !error c0000006
Error code: (NTSTATUS) 0xc0000006 (3221225478) - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.
The item of special attention is the first error code, which triggered the rest, in that a specified device (most likely the storage device) does not exist, due to it being inaccessible at the time and was probably offloaded by the system. A common occurrence during hardware failure involving bad drives or bad storage controllers.
My System SpecsSystem Spec
30 Jan 2013   #5
x BlueRobot


Thanks for information Vir :)
My System SpecsSystem Spec
03 Feb 2013   #6

Windows x64 N Enterprice

Thx alot :)

I will check if new firware is awaible for the SSD and also update driver.

Hope that it will help.

My System SpecsSystem Spec

 BSOD 0x000000f4 (Dump file)

Thread Tools

Similar help and support threads
Thread Forum
BSOD, and no dump file was found even though dump file anabled.
BSOD Help and Support
No dump file after BSoD. Dump files ARE enabled
I've been having BSoD's for well over a year now, once or twice almost every day. I've tried multiple times to figure out whats wrong but... I dont have ANY dump files. I've followed instructions on how to enable them but it still doesn't create a file. Im really hoping you all can help me out...
BSOD Help and Support
not getting dump file for BSOD
Hi, I have a laptop that periodically gets a BSOD (I do not have a screenshot of the error message). I have a minidump folder in the Windows directory, but no dump file appears after a BSOD. Is there any kind of tool that I can run to see if any drivers are outdated or corrupted? Any...
General Discussion
Random BSOD 0x000000F4 - csrss.exe referenced in memory dump
Hello all, Trying to troubleshoot an issue I'm having on my laptop with a random BSOD 0x000000f4. I pulled up windbg and opened up memory.dmp and ran an !analyze -v. Here's what the memory.dmp says about whats going on. Could you please help point me in the right direction? Things I've...
BSOD Help and Support
BSOD (0x000000F4) and dump files not generating. Windows 7 Ultimate 64
Hey Everyone, I've been battling a BSOD 0x000000F4 for a while now and can't seem to figure it out. Machine: Intel Core i5 760@ 2.80ghz 8 GB RAM Windows 7 Ultimate 64 Bit (Service Pack 1) Here's the skinny on what I've done so far:
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:20.
Twitter Facebook Google+