Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error Code 315, Spooler Operation Failed

04 Feb 2013   #1

Windows 7 64 Home
Error Code 315, Spooler Operation Failed

I'm getting this error, but I can still print locally and from the network. I have googled this forum and have not found a solution. Seems like a lot of people have this error, if there a fix yet?

Log Name: Microsoft-Windows-PrintService/Admin
Source: Microsoft-Windows-PrintService
Date: 2/4/2013 8:15:49 AM
Event ID: 315
Task Category: Sharing a printer
Level: Error
Keywords: Classic Spooler Event,Printer
Computer: Biostari5-PC
The print spooler failed to share printer hp deskjet 920c with shared resource name hp deskjet 920c. Error 2114. The printer cannot be used by others on the network.
Event Xml:
<Event xmlns="">
<Provider Name="Microsoft-Windows-PrintService" Guid="{747EF6FD-E535-4D16-B510-42C90F6873A1}" />
<TimeCreated SystemTime="2013-02-04T13:15:49.843532600Z" />
<Correlation />
<Execution ProcessID="1776" ThreadID="2336" />
<Security UserID="S-1-5-18" />
<ShareFailed xmlns:auto-ns3="" xmlns="">
<Param2>hp deskjet 920c</Param2>
<Param3>hp deskjet 920c</Param3>

My System SpecsSystem Spec
04 Feb 2013   #2

Microsoft Community Contributor Award Recipient

Windows 7 enterprise 64 bit, Windows 7 Pro 64 bit ,Windows 8 64bit

My System SpecsSystem Spec
04 Feb 2013   #3

Windows 7 64 Home

Thanks for the reply, that really does not tell me how to troubleshoot this issue. I tried changing "Computer Browser" to start automaticaly, but that did not work. The driver was automatically installed by windows and there is no new driver. This is a common error, there must be a fix out there for this by now, but I cannot find one that works.
My System SpecsSystem Spec

04 Feb 2013   #4

Microsoft Community Contributor Award Recipient

Windows 7 enterprise 64 bit, Windows 7 Pro 64 bit ,Windows 8 64bit

Perhapse this will be of better assistance it is more detailed about the procedure:

Event ID 315
My System SpecsSystem Spec
05 Feb 2013   #5

Windows 7 64 Home

I checked everything in that article and found everything in order. Other computers can print to my computer so I do not understand why I am getting this error. Also file sharing works too. I have tried to troubleshoot this in the past without any success. I have solved all the errors on this machine but this one. There has to be a fix for this by now. Doesn't anyone have an fix for this?
My System SpecsSystem Spec
08 Sep 2014   #6

Windows 7 Home Premium 64bit
Solved Error 315, PrintService Failed to share network printer

After much much frustration and dead ends, I found a simple registry fix that works for my Lexmark printer. The solution seems to be a Windows XP fix (as it refers to regedt32). However, it works for Windows 7 Home premium as well. While I cannot guarantee success with other printer brands, it certainly is worth a try. See Lexmark print spoolers conflicting with Windows The solution is to make the Print Spooler service dependent on the Server service, so it will not start until after the Server service is started. 1. Click Start, and then click Run. 2. In the Open box, type regedt32, and then click OK. 3. Locate and click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Spooler 4. Click Add Value on the Edit menu. 5. Type DependOnService in the Value Name box. 6. Click REG_MULTI_SZ in the Data Type box, and then click OK. 7. Type LanmanServer in the Data box, and then click OK. 8. Click Exit on the Registry menu to quit Registry Editor. 9. Restart your computer. For steps 4 through 7: If the "DependOnService" value already exists and has an entry, you can add another by double-clicking the value and entering it on a new line for LanmanServer.
My System SpecsSystem Spec
12 Nov 2015   #7

Windows Server 2008 R2

Thank Sarpol.
This solved my problem.
My System SpecsSystem Spec

 Error Code 315, Spooler Operation Failed

Thread Tools

Similar help and support threads
Thread Forum
The print spooler failed to load a plug-in module - Error Code 0xc1
I have noticed a strange error in Event Viewer relating to printing. Every time I print a document two identical errors are produced in the Event Viewer as below:- The print spooler failed to load a plug-in module C:\Windows\system32\spool\DRIVERS\x64\3\E_IUICHQE.D​LL, error code 0xc1. See...
Performance & Maintenance
Connection Failed: Error Code 23 - Raidcall
(I was going to post this in the software section, but I assumed since it pertains to the network portion of the application and that I can connect through a VPN, that the problem is LAN Network oriented) Hello, I recently installed the software Raidcall (RaidCall-100% FREE Group Communication...
Network & Sharing
Windows Updates Failed BITS failed to start error code 2147024894
anybody have any ideas? have tried sfc /scannow also the steps in this but to no avail, i still receive the error message i have also used take ownership on the downloader file in...
Windows Updates & Activation
Win 7 x64 SP1 Update Failed, Error Code 80070002
This one has me boggled. I've searched high low looking for a solution to this issue without any success thus far. As the title of the thread say, I've been unable to install SP1. Link to my CBS directory (zipped):!107 SFC /SCANNOW...
Windows Updates & Activation
Outlook Error: The attempted operation failed. An object could not be
Hello I have an error using Microsoft Outlook 2010. This happens every time I try to reply or forward an email. I get an error that says, "The attempted operation failed. An object could not be found." I am not running any add-ons. I have read that I need to make sure that I am using...
Microsoft Office
IE9 Update Failed - Error code 9c48
I got error code 9c48 when trying to install the important update for IE9. Not only has the update failed, but it has caused IE9 to be inoperable, resulting in NO browser. I can't seem to find any solution. Please help.
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App