Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD problem - copying many files

09 Mar 2013   #1
Dan Hargrave

Windows 7 Professional (64 bit)
BSOD problem - copying many files

I've been living with this bsod for some months now... soon after building my pc. At first I thought it was a spontaneous reboot until I discovered how to stop the system from rebooting on bsod. I discovered that I could repro the problem by copying huge amounts of files from one drive to another (200 G plus). It usually took 1-3 hours but it would eventually fail. I tried swapping out HDD's and reproed the bsod on both drives so I ruled out the drives. Then I ran memtest86. After running for 5 hours I noticed one memory error. I will attach a screen shot.

So my question is, would this account for the bsod? I am continuing to test each stick individually.

My System SpecsSystem Spec
09 Mar 2013   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Hi -

Bad RAM can cause all sort of problems.

Please make sure you are running good RAM Sticks.

Take memtest. Run for 8 passes and test each stick in a know good slot for an additional 6 passes.
Note   Note
Pay close attention to part 3 of the tutorial in order to rule out the faulty stick.

information   Information
Errors are sometimes found after 8 passes.

Tip   Tip
Do this test overnight, before going to bed.
My System SpecsSystem Spec
10 Mar 2013   #3
Dan Hargrave

Windows 7 Professional (64 bit)


Thank you very much for your reply!!!

I'm running a different version of MemTest86 so I will now run the one the tutorial indicates.

My first test that had one failure was with both sticks, so last night I ran the test with only one stick in the #1 slot. It went thru 10 passes with no errors. I will go thru the stick testing process as indicated and probably have results tomorrow or the next day.

More info:

The debug error codes and dll's are all over the map, which could IMO indicate memory issues.

My mobo has overclocking capabilities but I don't know anything about overclocking. It could be set up for overclocking by default. If so, that may be causing mem problems. More mem testing is in order...

Thanks again!!!
My System SpecsSystem Spec

10 Mar 2013   #4

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Keep us posted.
My System SpecsSystem Spec
10 Mar 2013   #5
Dan Hargrave

Windows 7 Professional (64 bit)

More info FWIW. Most recent crash info. Very random.

3/9/2013 6:48:40 AM ATTEMPTED_WRITE_TO_READONLY_MEMORY lltdio.sys
3/8/2013 7:01:24 PM DRIVER_IRQL_NOT_LESS_OR_EQUAL asmthub3.sys
3/6/2013 8:53:52 PM IRQL_NOT_LESS_OR_EQUAL usbfilter.sys
3/6/2013 6:14:55 PM DRIVER_IRQL_NOT_LESS_OR_EQUAL wfplwf.sys
3/6/2013 12:28:55 AM NTFS_FILE_SYSTEM Ntfs.sys
3/5/2013 11:13:35 PM SYSTEM_SERVICE_EXCEPTION ntoskrnl.exe
My System SpecsSystem Spec
11 Mar 2013   #6
Dan Hargrave

Windows 7 Professional (64 bit)

Ok, last night a ran MemTest86+ v4.2 for 10 passes with mem stick 2 in slot #2 and got no errors (screen shot available if you want). So I figured the original mem failure was probably a seating problem. I have work to do, so I just left the one mem stick in (in case there was a mem problem I would know which stick it came from) and connected both internal drives. Ready to get back to work. In order to get the drives back to their original state I had to copy a 60 GB folder from my D: to my C: I left and came back to find that a BSOD happened after only about 10% of the files were copied (there was plent of disk space on the destination). The bug check was MULTIPLE_IRP_COMPLETE_REQUESTS . I haven't had this one for over 3 months... about 22 BSODs ago. More info if requested.

I deleted the destination folder and tried the copy again. This time it worked. No BSOD.

I'm about ready to take this to a shop, but I'm not sure if they could do a better job? My work is stacking up.

Here are my best guess areas where the probem may be coming from:
Conflicting drivers - I don't know how clean out old drivers. If there's decent s/w for this I'll pay for it.
CPU Temperature problem - I can load windows s/w to monitor this... Do you recommend one?
Failing mobo or bios problem - I'm not sure... oops... I just realized that I may not have the most recent bios... yep, my bios is 0901 and the most recent is 1605 which is supposed to Improve system stability... bios updated.

Well, we'll have to see if the bios update resolves the problem. That will take a few days. I'll keep in touch.
My System SpecsSystem Spec
12 Mar 2013   #7
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

As quoted from the Memtest website:

Please be aware that not all errors reported by MemTest86 are due to bad memory. The test implicitly tests the CPU, L1 and L2 caches as well as the motherboard. It is impossible for the test to determine what causes the failure to occur. However, most failures will be due to a problem with memory module. When it is not, the only option is to replace parts until the failure is corrected.
Once a memory error has been detected, determining the failing SIMM/DIMM module is not a clear cut procedure. With the large number of motherboard vendors and possible combinations of memory slots it would be difficult if not impossible to assemble complete information about how a particular error would map to a failing memory module. However, there are steps that may be taken to determine the failing module. Here are four techniques that you may wish to use:
  1. Removing modules This is simplest method for isolating a failing modules, but may only be employed when one or more modules can be removed from the system. By selectively removing modules from the system and then running the test you will be able to find the bad modules. Be sure to note exactly which modules are in the system when the test passes and when the test fails.
  2. Rotating modules When none of the modules can be removed then you may wish to rotate modules to find the failing one. This technique can only be used if there are three or more modules in the system. Change the location of two modules at a time. For example put the module from slot 1 into slot 2 and put the module from slot 2 in slot 1. Run the test and if either the failing bit or address changes then you know that the failing module is one of the ones just moved. By using several combinations of module movement you should be able to determine which module is failing.
  3. Replacing modules If you are unable to use either of the previous techniques then you are left to selective replacement of modules to find the failure.
  4. Avoiding allocation The printing mode for BadRAM patterns is intended to construct boot time parameters for a Linux kernel that is compiled with BadRAM support. This work-around makes it possible for Linux to reliably run with defective RAM. For more information on BadRAM support for Linux, sail to ISP trouble --- redirect
Sometimes memory errors show up due to component incompatibility. A memory module may work fine in one system and not in another. This is not uncommon and is a source of confusion. In these situations the components are not necessarily bad but have marginal conditions that when combined with other components will cause errors.
Often the memory works in a different system or the vendor insists that it is good. In these cases the memory is not necessarily bad but is not able to operate reliably at full speed. Sometimes more conservative memory timings on the motherboard will correct these errors. In other cases the only option is to replace the memory with better quality, higher speed memory. Don't buy cheap memory and expect it to work reliably. On occasion "block move" test errors will occur even with name brand memory and a quality motherboard. These errors are legitimate and should be corrected.

Referring to your original post, I believe this is one of those uncommon cases where the error actually may be caused moreso by a motherboard, CPU or power supply issue than the memory, though read the entire quote to understand all that's implied when an error is struck in Memtest. If it's a memory module suffering a problem, that same bad bit should be showing up on recurring tests, but it isn't. Instead it seems erratic or almost seemingly happenstance. That leaves me to venture about it being less on the RAM and more on something else.

Here's hoping that BIOS update takes care of things, but also you should test using Prime95 just in case. First, do a preliminary by running it on Torture Test on Blend for 30 minutes and have HwInfo on Sensors only to watch temps. If the CPU temp gets high (above 60 and increasing) then stop Prime95 and consider cleaning your system and/or reinstalling the CPU cooler. Otherwise, if it stabilizes at a good temp, you can start running it overnight. After that is done, regardless of what the results are, do another several hour test on Large FFT settings instead of Blend. Report to us results and provide us crashdumps if present.

The fact, is, whether the MULTIPLE_IRP_COMPLETE_REQUESTS was from drivers or not is immaterial, what is true is that Memtest detected an error with a very high confidence value, so without doubt there's some hardware problem slinking around, but what hardware it is we've yet to discover. I can tell you the hard drive nor GPU would be involved with the Memtest error so you can rule those out. Typically it's the Trio of Trouble, which is CPU/Mobo/PSU. The problem with these is that there's no real definitive software test for them, the only tried and true method is swapping them with reliable parts and crossing fingers. Prime95 may give a better suggestion than what we have now, but I'm not sure it'll be definitive.
My System SpecsSystem Spec
13 Mar 2013   #8
Dan Hargrave

Windows 7 Professional (64 bit)

First, thank you Vir for your thorough response!!! I appreciate immensely all who respond in this board, and for the board itself!

Yesterday I hooked up both drives and left only one memory stick in - #2 in the 2 slot. In the process of getting back to work I copied a lot of files and it had no problems. I was feeling like the bios update probably fixed the problem. I woke up this AM to a BSOD. (sigh) I noted that it was a system_service_exception and that it had been successfully written to disk. I took the system down and swapped the memory putting stick 1 into slot 1 and booted. Here's where it gets a little weird. I came to this forum and noted that there was another thread about system_service_exception so I stopped and checked it out. I only mention this to reinforce the idea that I remembered the exact debug code.

Then I came to this thread, read what had been posted and went to BlueScreenView to see the dump and it was not there! Checked the minidump folder and it wasn't there. Searched both drives and it doesn't exist. I'm going to check my setting and make sure it is set to dump to the hard drive... Did that.

I will try what Vir wrote, but let me say something I may have neglected. Over 50% of the crashes happened during the night when no one is on the computer. This makes me wonder how it could be a temperature problem. Nevertheless I will run the tests.

I am attaching a screen dump of BlueScreenView so that you can see that the crashes are all over the map, without having to download my dmp files.

Thanks again, I'll keep you posted.
My System SpecsSystem Spec
21 Mar 2013   #9
Dan Hargrave

Windows 7 Professional (64 bit)

I apologize for not posting here sooner. I have been trying to catch up on my work that I missed when I was troubleshooting this problem. The system only crashed once since I have been away. Still need to to the above tests. Will try to touch base next week.
My System SpecsSystem Spec
08 Apr 2013   #10
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

Hi there. It's been a couple weeks. Any advancement on this?
My System SpecsSystem Spec

 BSOD problem - copying many files

Thread Tools

Similar help and support threads
Thread Forum
Problem copying any files on home network
Hi all! I have no issues accessing my home network. I can get to and traverse all shares on my network. I can open and view Doc's, Video's and images. But when I try to copy or move something, anything to a network share, it just sits on "Calculating" I ran the troubleshooter, it found no issues....
Network & Sharing
Windows Explorer problem with copying wav files
Hi guys, I'm new to this forum and am glad I found you guys, because we have a strange problem in windows 7 windows explorer. This is what we tried to do. 1. We have a folder with many files with different extensions (*.wav, *.mp3 and *.sib). We want to separate them all in separate folders by...
General Discussion
Problem copying files from XP disk to Win 7 PC
Hi all, I'm trying to transfer all my data from my old Windows XP PC to the new Windows 7 PC. What I did is I removed the main OS drive from my old XP machine and I connected the XP drive to the WIndows 7 PC as an external drive. I then copy/pasted all of the XP contents to a folder in the 2nd...
Installation & Setup
Problem Copying ISO Files Between Harddrives
Hey, recently i've been having a problem when trying to move ISO files from one harddrive to another. I've tried with 3 different ISO files and all come up with the same error: "An unexpected error is keeping you from copying the file. If you continue to receive this error, you can use the error...
Hardware & Devices
Copying files problem?
Hi, Well, when I copy files on my external HDD, it's going fast, until the 1st file is done, after the 1st file, it doesn't really freeze, but stops for like 4-6 secs, and then it suddenly moves on again, with low transfer speed which increases. This happens for each file e.g. and so on...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:25.
Twitter Facebook