Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 0x7b - 0xC34 - Win7 Pro 32bit

16 Mar 2013   #21
Microsoft MVP


If you know where to find the driver which fouled out Win7's boot then try backing up and then deleting it in Recovery console: Copy & Paste - in Windows Recovery Console

I am testing right now a fix I've long wondered about in these last-resort cases: backing up from Recov Console then deleting the System 32\drivers content, to force OS to reload all drivers from Driver Store at boot. Only driver absolutely required is SATA controller which is normally located elsewhere in System32 like iastor.sys.

Only prob is not all drivers are located there, so if you can find it elsewhere in Sys32 folder to delete I'd try that first.

Another fix I'd like to test if possible since patches are also fatal causes as reported by Startup Repair is to delete latest installed updates from their install location. This is very dicey but just might work so I plan to test it after conferring with our Updates experts.

My System SpecsSystem Spec
16 Mar 2013   #22

Win7 Pro 32bit

Let's talk drivers.

10.8 intel drivers have iaStor.sys, 11+, until current 11.7 have iaStoreA, along with a iaStorF and a iaStorV. I've heard 10.8 are still the most stable. Issue is that i can't use FSUTIL to install driver packages outside Win7 itself. Doesn't work from the RE and the only other option would be to image/package DISM the unbootable install and add/remove driver packages from the outside.

I haven't really delved into manually installing drivers via registry keys and creating the driverstore entries, but that was my next step at a point. I updated 11.5>11.7 right now and same thing, which was easy due to the same structure, but 10.8.. don't know. Again, it's all safe, as i keep a backup before i mess into them.

Main locations are sys32, sys32/drivers, and i don't think it loads anything directly from the driverstore.

LE 10.8 drivers :, iaAHCI.inf,, iaStor.inf, iaStor.sys, TXTSETUP.OEM (which includes registry keys used). To note, i don't have any version of these drivers anywhere in my system.
11.7 drivers:, iaAHCIC.inf, iaStorA.sys,, iaStorAC.inf, iaStorF.sys.

I'd like to remind that i have an excel page at the first post containing Start 0 kernel and Start 1 boot level drivers. Ignore any of the notations there.
My System SpecsSystem Spec
16 Mar 2013   #23
Microsoft MVP


My only point is if you think you might have a problem driver or that a driver install has caused the Bad Patch fatal error from Startup Repair, you can uninstall those drivers at Windows/System32/drivers either by name or all of the latest ones by date. Unless you delete System drivers or a SATA storage driver which is (rarely) not provided in Driver Store, it may cause Win7 to start and reload drivers from Driver Store.

Other advanced issues concerning drivers can be addressed by specialists in our Drivers forum.
My System SpecsSystem Spec

16 Mar 2013   #24

Win7 Pro 32bit

I'm sorry, it's 3 AM here on a sunday, i'm still at work with my home PC, and after more than a week of debugging randomly close to 8 hours a day between work-maintenance and sleep, i'm done. There are way too many variables, from power-failure SSD corruption, to driver incompatibilities and now i see i'm having issues keeping the boot sector stable. The BCD showing 'unknowndevice' but still booting is "what?", and now 0mb boot drive in Windows RE, after system repair keeps repairing 'partitions' out of the air and earlier i just hit a system volume corruption? I'm done.

For anyone that gets here via Google and has a similar situation, here's a tip for you, if the rest of the threads on the net don't help, give up. Without a minidump to pin it down, without any leads, you're just patching and tweaking blind and hoping to strike gold. I really gave it all i could, but this is the limit of my IT tech-savvy-ness. Minus getting Microsoft-certified into the kernel-workings of the Vista/7 architecture, this is the limit human patience and internet-researching can reach. If you are more insane than me and pin down a solution to this exact problem, i'd appreciate a PM even if it's a year from now.

The only silver lining in this mess is that i'll finally switch to a 64 bit install, something i've been putting off for a long while.

Thanks Arc and especially gregrocker with the 200mb move that apparently destabilized a shaky drive file structure, otherwise i might have kept trudging stupidly through drivers that might not even be there anymore but the system still recognizes shells.

In any case, off to scrubbing my SSD clean, reinstalling Win7 and getting to sleep. Night all.
My System SpecsSystem Spec
16 Mar 2013   #25
Microsoft MVP


Constructing a new boot partition when the old one is possibly corrupted and won't repair has worked at times in the past.

Seems you've tried everything possible, which is pretty much everything listed in Troubleshooting Windows 7 Failure to Start. Sometimes Win7 simply will not repair.

I'm going to continue to try workarounds for the fatal "Bad Patch" result in Start Repair as it consistently is often listed as the cause when Win7 is irreparable.
My System SpecsSystem Spec
18 Mar 2013   #26

Win7 Pro 32bit

Now that my brain is less frazzeled, Greg, do you want me to upload my old install somewhere? I tried reseating it on an old hard drive totally manually and it hit the same 7B error once the bcd was setup, so i assume it would do the same for you if you wanted to have a broken system to debug your theory on.
My System SpecsSystem Spec
18 Mar 2013   #27
Microsoft MVP


You can try some of the methods for a fix which is being discussed here: Boot failure due to "bad patch" - need fix collaborators

In particular I would manually delete all of the Updates and Drivers which were recently installed.
My System SpecsSystem Spec
19 Mar 2013   #28

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Hi folks :)

Coming in late to this thread (as usual!) so forgive me if I post things which have already been covered in some way.

The CBS log shows something I've not seen before...
2013-03-15 08:23:37, Info    CBS    Failed to load SxsStore.dll [HRESULT = 0x8007007e - ERROR_MOD_NOT_FOUND] 
2013-03-15 08:23:37, Info        CBS    Failed to initialize SxS. [HRESULT = 0x8007007e - ERROR_MOD_NOT_FOUND]
This is going to royally screw many options.

Please run the following commands in an Elevated Command prompt, and post the results. (you'll need to adjust as necessary for however you choose to access the data)

DIR C:\Windows\SxsStore.dll /S
ICACLS C:\Windows\SxsStore.dll /T

Please also upload the Application.evtx and System.evtx files
My System SpecsSystem Spec
10 May 2013   #29

Win7 Pro 32bit


It's been a long time, and i'm i'm not sure how this still relates.

After a computer restart of the fresh install i did two or three months ago, after a month of computer uptime, the system refused to boot again. No blue screen, but stuck in the Windows Starting loop. When safemode, i saw it still did NOT boot and stuck at CLASSPNP.sys.

This felt familiar and gruesome. Lucky for me, i had better memory of what happened in the last month. Checking FileRepository manually i saw that aside from nvidia drivers and the printer driver there was only one other driver listed. The issue was the mcdbus.inf driver, Microsoft iSCSI initiator it seems, that was installed by MagicDisc Virtual Drive. Even thought it was set to On demand start in the registry, it prevented the system from starting and was also set in the PnPLockdown registry setting, i assume, which gets fully started while in safe mode, thus explaining the failure.

The solution was to set the Start dword for it to 4 in the active Controlset, as in NEVER BLOODY START IT, and the system booted.

In absolute retrospect, this might have been the cause of my old installation, since i remember installing this software then too. I will try and see if the old system boots since i still have it around on a harddrive after i do that change there aswell.

Also, it is possible it might have been interfering with the latest Intel Drivers themselves from the motherboard, and may have worked with older intel drivers. In any case, i'm glad i didn't have a meltdown like last time.

PS: Never trust the Microsoft Imaging service. Had an image, it could not load it due to a 'file missing'? And i realized it somehow DELETED the entire 40gb image, since i made sure it was there when i did my backup before i would apply the image, but after trying to do the procedure, not anymore.

LE2: Btw, while triyng to manually rid myself of the issues, i realised that the Registry entry that gets created in enum\ROOT\scsiadapter\0000, made by the above mcdbus contains null characters and most likely is corrupt. That might be the issue, if not for the driver itself conflicting with something. The virtual drive was not added when i installed the software and i found it odd back then, and i find it doubly odd now. I assume the software was just bundled with an old version of said driver.
My System SpecsSystem Spec
10 May 2013   #30
Microsoft MVP


If you have a WD or Seagate HD in the mix you can use their excellent Acronis free imaging/cloning app with an easy-to-understand Manual on the Download page.

What were you using MagicDisk Virtual drive for? I would uninstall it.

At least look over the steps for Clean Reinstall - Factory OEM Windows 7 so you know the Best Practices based on helping with tens of thousands of them here. Win7 is not handled at all like XP.
My System SpecsSystem Spec

 0x7b - 0xC34 - Win7 Pro 32bit

Thread Tools

Similar help and support threads
Thread Forum
Dual Boot Win7 32bit and Win7 64bit on a second SSD drive
Hi folks. I have searched through the various threads that deal with this topic but have not seen anything that deals with this specifically. I have a custom built computer I put together last year. I installed Win7 32bit at the time because I didn't want to bite the bullet and reinstall...
Installation & Setup
Win7 32bit Home Premium to Win7 64bit Ultimate: Possible without Clean
I just bought a ThinkPad T400, and 8GB DDR3 upgrade kit. After first log on, I realized the Windows 7 is 32bit. How can I upgrade to Ultimate x64 instead? Thanks for your help.
Installation & Setup
Cannot read hdd from old desktop Win7 32bit on new laptop Win7 64bit
I have a new Toshiba Laptop (Win7 64bit CORE i3). I would like to run (via usb) and old hdd from my desktop which was 32bit Win7. I have the old hard drive in a SATA enclosure and running it via USB to my laptop. When I attempt to either copy or read the old hard drive I get a write protect error....
Hardware & Devices
Win7 (32bit) to Win7 (64bit) upgrade install error
Hello I have purchased and downloaded both 32 bit and 64 bit Windows7 Professional (no CDs or media here only download version) I sucessfully upgraded from Vista 32 to Win7 32 Then I upgraded my hard disk (140Gb 500GB) and RAM (3GB to to 4GB) Now I would like to go from Win7 32bit...
Installation & Setup
Reinstall Win7 32bit to Win7 64bit /backup disc content
Hey, I purchased the Win 7 Pro Upgrade 32bit via digitalriver, but I've been doing some reseach and probably should have selected the 64bit version. - Any ideas how I can get the 64bit version? - For those who ordered the 32bit back-up disc kit for the extra $15 and have received it,...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:16.
Twitter Facebook