Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: bios not fully acpi compliant stop error

19 Apr 2013   #1

Windows 7 Professional 32bit
bios not fully acpi compliant stop error

Before I get into the details of the issue I want to point out that this computer was running Windows 7 fine without any bsod or other errors for about 6 months. 6 months ago I performed a wipe/ restore of my system drive to clean out the crud that windows/programs build up over time. windows 7 had been running fine since I first installed in back in 2010 to replace xp. So yeah it was time to do a clean up. now on to the issue at hand.

I followed the guide how to enable sata from within win 7 without reinstalling the os. I'd never really tried sata to be honest, I'd just left it set at "Native IDE" in my bios when I did the upgrade from xp to 7. So I followed the guide and everything worked as promised. But my win experience rating didn't improve and I noticed no gains from doing it. The only thing that happened was my boot time increased a bit. So I decided to go back to "native IDE". I went into reg edit and changed the value back to what it was before, then on reboot I went into the bios and changed back to native ide.

Once I did that I got hit with the BSOD " bios not fully acpi compliant. see vender for updated bios"

Now this bios is updated, I had to do it a few years ago in order to enable support for am3 cpus on my am2/am2+ board. more to the point as I pointed out everything had been running smooth up to this point. So i figured no big deal I'll just do a image restore and be back up and running in no time. Man how wrong I was.

No matter what I tried, Macrium Reflect Winpe rescue or inserting the Windows 7 cd nothing worked. Maybe because both reflect's winpe and windows 7 share the same core code base. I don't know. Now Macrium's Linux based restore works fine but once I load my windows 7 backup image I still get hit with the bsod. I was able to install XP however, no bsod no nothing just a smooth install.

Things I've done to try to resolve this:
1. load optimized defaults in bios (failed to work)
2. used jumper to clear bios settings (failed to work)
3. safe mode (failed)
4. install win 7 via cd (failed)
5. Macrium Winpe rescue (failed)
6. install win 7 via usb key (failed)
7. Macrium linux recuse (50/50, failed on win 7 but worked on xp system image)

I don't know why xp installed without hiccups, maybe cause it's older, I'm just glad I didn't delete the old image from my backup drive. I'm stumped here. Guess I learnt my lesson, don't mess with it if it ain't broke. sorry for the long post but I wanted to give as much info as I could.

My System SpecsSystem Spec
19 Apr 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

As a test, can you enter into the BIOS, set the SATA controller mode to AHCI and try it again?

If it work, we will pay attention to the boot time later.
My System SpecsSystem Spec
19 Apr 2013   #3

Windows 7 Professional 32bit

I'll try it when I get home from work. I'm not real concerned with getting ahci to work though. I've been happy with native ide. I only experimented with enabling sata/ahci cause I was curious to see if I'd get any performance boost (that and cause I'd nothing else to do at the time).

If it works, great, I'll leave it be. If it don't and somehow I (or with someone on this forum's advice) get native ide mode to work and install win 7 just like before, I'll take that to.
My System SpecsSystem Spec

19 Apr 2013   #4
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Small suggestion.
Check you motherboard manufacture site and see if there is a bios update that address this exact problem.
My System SpecsSystem Spec
22 Apr 2013   #5

Windows 7 Professional 32bit

My internet was down all weekend so i'm posting this from my work pc.
I followed the advice given by Arc and at first things seemed to work fine, Windows 7 setup loaded and proceeded as normal but towards the end at the point during setup where it says " installing Services" a dialog box came up saying "can't install to this hardware platform" or some such. I did load the sata driver from my motherboard cd. Even went back and tried it without loading the driver but still same dialog box came up.

I checked for any updated bios about this issue but all the bios updates listed are mostly for AM3 cpu support. nothing at all for sata.

Honestly I don't got a clue why it will not work since before I fooled with the sata settings in my bios I'd never had a problem with this board or installing windows 7 before.

It's set to native ide right now and windows xp installed with no hitches. If I have to I'll just stick with XP, least it works. Use my laptop for internet use only once firefox/avg drops xp support and my desktop for everything else. I can always just swap out hdds to get around the 2tb limit, the board don't support drives over 2tb anyway so win 7 wouldn't do me any good on that front to start with.

sorry just rambling, just frustrating is all, you'd think that clearing the bios would reset things but I guess not. oh here's the model of the board foxconn A78AX-K
My System SpecsSystem Spec

 bios not fully acpi compliant stop error

Thread Tools

Similar help and support threads
Thread Forum
Win 8.1 to 7 downgrade bios not fully acpi compliant
I am trying to downgrade a dell inspiron 3531 from 8.1 to 7 by using a memory stick but when booting from from the usb stick it loads files and just comes up with bios not fully acpi compliant error. Have been told to install with a dvd but havn't tried this yet. Read a few threads about this error...
Hardware & Devices
alienware 17 R2 BIOS not fully ACPI Compliant after A08 installed
Updating your Alienware to Bios level A08 from A06 will result in your Windows 7 system booting to a BSOD. Nothing you can do will repair this except reloading A06 again. If your Alienware has M2 SSD with Windows 10 loaded, you can use this system to downgrade to A06. Then Windows 7 is happy again....
BSOD Help and Support
I purchased a new ASUS laptop with Win8. I wanted to replace it with Win7. I wiped, formatted and partitioned the HD. I changed the BIOS so it boots from the DVD. I put my 7 disc in and started. A message says it is loading files. In a minute or so I get the Blue Death Screen with the...
Installation & Setup
BIOS in system not fully ACPI compliant 0xA5 during install
Hi there, so I'm fixing a laptop which suddenly started getting BSODs: It was running Windows 7 before but suddenly it started getting the 0xA5 BSOD no matter what was attempted. So I got the PC and tried booting from linux USB stick to test HDD and RAM - No problems. I figured since it was...
BSOD Help and Support
This bios is not Acpi compliant
For about 5 weeks my pc would not boot up properly and i eventually discovered that one of my ram chips was faulty so i replaced it and now works only upto 3 gig with windows 64 bit but when i install the 4th chip i get a Bsod with the message this bios is not Acpi compliant so i went to the...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:11.
Twitter Facebook