Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD Unable to determine origin

03 May 2013   #1

Windows 7 Ultimate x64
BSOD Unable to determine origin


I seem to be getting the BSOD when playing games, most recently during a game of Dota2.

When the BSOD does occur my computer hangs and a weird, electronic - it's hard to describe - whining sound comes through the speakers.

I've run the SF_Diagnostic_Tool.exe as per the instructions. Any help would be appreciated.


My System SpecsSystem Spec
03 May 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hi bickas.

Daemon Tools, Alcohol 120% and Power Archiver Pro uses SCSI Pass Through Direct (SPTD), which is a well known BSOD causer. Uninstall the program at first. Then download SPTD standalone installer from, and execute the downloaded file as guided below :
  • Double click to open it.
  • Click this button only:
  • If it is grayed out, as in the picture, there is no more SPTD in your system, and you just close the window.
Free up the startup. Windows does not need any other program to auto start with it, but the auto start programs often conflicts and causes various problems including BSODs.
  1. Click on the Start button
  2. Type “msconfig (without quotes), click the resulting link. It will open the System Configuration window.
  3. Select the “Startup” tab.
  4. Deselect all items other than the antivirus.
  5. Apply > OK
  6. Accept then restart.
I would suggest you to uninstall Viscosity Virtual Adapter V9.1, at least as a test.
Unloaded modules:
fffff880`058b5000 fffff880`058c2000   visctap0901.
fffff880`0a13a000 fffff880`0a170000   WUDFRd.sys
fffff880`015d7000 fffff880`015e5000   crashdmp.sys
fffff880`015e5000 fffff880`015f1000   dump_pciidex
fffff880`015f1000 fffff880`015fc000   dump_msahci.
fffff880`010d0000 fffff880`010e3000   dump_dumpfve
Now let us know the results. Please be aware that a Stop 0x101 causes due to a wide range of possible causes, from hardware to software. So the entire troubleshooting may take a time and a lot of alternative tests. ________________________________________________________________________
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 101, {19, 0, fffff88003302180, 6}

Probably caused by : Unknown_Image ( ANALYSIS_INCONCLUSIVE )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An expected clock interrupt was not received on a secondary processor in an
MP system within the allocated interval. This indicates that the specified
processor is hung and not processing interrupts.
Arg1: 0000000000000019, Clock interrupt time out interval in nominal clock ticks.
Arg2: 0000000000000000, 0.
Arg3: fffff88003302180, The PRCB address of the hung processor.
Arg4: 0000000000000006, 0.

Debugging Details:






fffff880`035e7438 fffff800`02f29a3a : 00000000`00000101 00000000`00000019 00000000`00000000 fffff880`03302180 : nt!KeBugCheckEx
fffff880`035e7440 fffff800`02edc6e7 : 00000000`00000000 fffff800`00000006 00000000`00002710 fffff800`02f063f8 : nt! ?? ::FNODOBFM::`string'+0x4e3e
fffff880`035e74d0 fffff800`02e1e895 : fffff800`02e44460 fffff880`035e7680 fffff800`02e44460 00000000`00000000 : nt!KeUpdateSystemTime+0x377
fffff880`035e75d0 fffff800`02ecf153 : 00000000`5f12cf27 fffff800`0304de80 fffff680`0004cf50 fffff800`02ebaf6a : hal!HalpHpetClockInterrupt+0x8d
fffff880`035e7600 fffff800`02f08469 : fffff800`0304de80 fffff880`00000001 00000000`00000000 00000000`00000000 : nt!KiInterruptDispatchNoLock+0x163
fffff880`035e7790 fffff800`02ed7a0c : 00000000`00000000 fffff880`035e78d8 fffff880`00000000 00000000`00004399 : nt!KxFlushEntireTb+0x79
fffff880`035e77d0 fffff800`02f08963 : fffff880`0000202f 00002ff2`00002ff1 fffff800`02e5d000 00002ff6`00002ff5 : nt!KeFlushMultipleRangeTb+0x28c
fffff880`035e78a0 fffff800`02ed7c24 : 00000000`00000000 fffff800`03087f60 00000000`00000000 fffffa80`00000000 : nt!MiReplenishBitMap+0x468
fffff880`035e79b0 fffff800`02ebd47f : fffffa80`066f26f0 00000000`00000400 000110eb`0006e2b0 00000000`00000001 : nt!MiEmptyPteBins+0x10d
fffff880`035e7a00 fffff800`02ebcae8 : 00000000`00000008 00000000`00000001 fffffa80`066f26f0 fffff800`02ebca70 : nt!MiAdjustPteBins+0xbf
fffff880`035e7a40 fffff800`02ebcfc3 : 00000000`00000008 fffff880`035e7ad0 00000000`00000001 fffffa80`00000000 : nt!MmWorkingSetManager+0x40
fffff880`035e7a90 fffff800`03170ede : fffffa80`06708b50 00000000`00000080 fffffa80`066f26f0 00000000`00000001 : nt!KeBalanceSetManager+0x1c3
fffff880`035e7c00 fffff800`02ec3906 : fffff880`009b3180 fffffa80`06708b50 fffff880`009be0c0 00000000`00000000 : nt!PspSystemThreadStartup+0x5a
fffff880`035e7c40 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16



FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: Unknown_Module

IMAGE_NAME:  Unknown_Image




Followup: MachineOwner
My System SpecsSystem Spec
04 May 2013   #3

Windows 7 Ultimate x64

Hi Arc, thanks for the response.

1. I have attempted to uninstall SCSI Pass Through Direct (SPTD) directly, but couldn't find it in the installed programs list (I currently use CCleaner). Instead, I have just uninstalled Daemon Tools which you said used it. I also ran the SPTD standalone installer and found, as your picture indicates, that there was nothing left to uninstall.

2. I have removed all other startup programs as you suggested.

3. I'm not sure how to uninstall Viscosity Virtual Adapter V9.1. How would I go about doing this?

My System SpecsSystem Spec

04 May 2013   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Quote   Quote: Originally Posted by bickas View Post
I'm not sure how to uninstall Viscosity Virtual Adapter V9.1. How would I go about doing this?

You may do it .....
  1. Click the Start Button, type "devmgmt.msc" (without quotation marks) in the Start Menu Search box and press Enter.
  2. Double click to expand "Network adaptors".
  3. Search for Viscosity Virtual Adapter V9.1 in the list.
  4. Right click on it and uninstall.
Let us know the results.
My System SpecsSystem Spec
05 May 2013   #5

Windows 7 Ultimate x64

Great thanks, I've managed to uninstall it.

I'll let you if anything changes!
My System SpecsSystem Spec

 BSOD Unable to determine origin

Thread Tools

Similar help and support threads
Thread Forum
WEI Unable to determine memory performance Error
W7X64 Pro ASUS X99-DELUXE CPU5960X DDR4 Crossair 2800Mhz GTX750Ti/K5000/K20 M.2 Plextor 256GB Extended Drive System C: + Xp941 System C: 512 GB WD Black2TB X3 XT750GB X2 When I run Windows performance Index
Performance & Maintenance
Strange BSODs, Unable to Determine Cause Alone
Occasionally, my entire system will just hang and either be forced to restart, or, very rarely, it will be able to regain control and continue working. I've ran memtest and memtestx86 to determine if the cause is my ram, but both tests showed the ram is working fine. The cause could be my GPU, an...
BSOD Help and Support
BSOD, unable to determine exact cause
Been receiving numerous BSOD for months. I never was able to determine the exact cause the first time. Most of the time the error occurs during a game such as Skyrim, Diablo 3. However, sometimes the error happened when watching videos on YouTube or even while idle. Every time I thought I fixed...
BSOD Help and Support
Unable to Determine BSOD Cause. Occurs Randomly
I built this computer about a year ago. Things were running smooth up until recently. I m usually pretty good at figuring out what is causing Errors on my computers but I cannot figure out what is causing this one. I do see kernel Errors in the event log but that is only about a bug check after it...
BSOD Help and Support
"Setup was unable to determine...BitLocker"
While attempting to do an upgrade from Vista Home Premium 64 bit to Windows 7 Home Premium 64 bit I get the following message; "Setup was unable to determine if BitLocker Drive Encryption is in use." The only option then is to cancel the upgrade. I've tried installing 3 times now with the same...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:25.
Twitter Facebook Google+