Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Corrupt COM+?

13 Oct 2009   #1
decibel3276

Windows 7 Ultimate (RC)
 
 
Corrupt COM+?

I am running Windows 7 Ultimate (Build 7100) and was having no problems at all until about 2 months ago. It seems that any time I try to install something I get an error. For example, I had TortoiseSVN installed on my Windows 7 machine and was notified that an update was available. So, as directed, I uninstalled the current TortoiseSVN installation and ran the installer. It gets to where it goes to hit the registry and I get the following error:

An error occured during the installation of assembly component
{E9192F0E-035C-A6A7-6D781EE24B3D}.
HRESULT: 0x80073712.

From what I was able to find from searching the web, this is usually associated with a service that is either disabled or stopped that is needed. The page I found said most likely the BITS or installer services, both of which are running.

I have checked all services that may have anything at all to do with installing an app and all applicable services are started and/or set to automatic.

I believe my COM+ catalog is corrupted and as I can no longer download the RC of Win7, I am at a loss as to what to do. Does anyone have any suggestions on repairing a corrupted COM+ catalog in Win 7 without the install disc?


My System SpecsSystem Spec
.
13 Oct 2009   #2
H2SO4

Win7x64
 
 

0x80073712

0x3712 = 0n14098

Q:\>net helpmsg 14098
The component store has been corrupted.

It's talking about "component based servicing", not the "COM+ catalog". As a suggestion, try running the "Readiness" tool referenced in this KB article:

Description of the System Update Readiness Tool for Windows Vista, for Windows Server 2008, and for Windows 7
My System SpecsSystem Spec
14 Oct 2009   #3
decibel3276

Windows 7 Ultimate (RC)
 
 
System Readiness Tool Ineffective

I have tried the System Readiness tool as you have suggested but I am still getting the same exact error when installing. The System Readiness tool (according to the KB article) is only suggested for systems that may require it. According to my windows update, I do not require it but I went and downloaded it and let it do it's thing.

Same error:

An error occurred during the installation of assembly component
{E9192F0E-035C-A6A7-6D781EE24B3D}.
HRESULT: 0x80073712.
My System SpecsSystem Spec
.

14 Oct 2009   #4
H2SO4

Win7x64
 
 

Quote   Quote: Originally Posted by decibel3276 View Post
I have tried the System Readiness tool as you have suggested but I am still getting the same exact error when installing. The System Readiness tool (according to the KB article) is only suggested for systems that may require it. According to my windows update, I do not require it but I went and downloaded it and let it do it's thing.

Same error:

An error occurred during the installation of assembly component
{E9192F0E-035C-A6A7-6D781EE24B3D}.
HRESULT: 0x80073712.
It was worth a shot. According to the KB article, the "readiness" tool can repair some types of problems in that subsystem.

Personally, I don't have anything else useful for you at this point. Hopefully somebody else will know more and chime in. Detailed troubleshooting can diagnose anything, but in this case it may take longer than waiting for the 22nd
My System SpecsSystem Spec
Reply

 Corrupt COM+?




Thread Tools




Similar help and support threads
Thread Forum
nvidia fsb overclock,mgr corrupt ,boot image corrupt ,cannot reformat
nvidia sys tool changed the fsb overclock system hanged did a reboot sys boot image corrupt mgr corrupt ,boot image corrupt i cannot reinstall windows as well,when i insert bootable usb windows 7,8.1(also the current os i am runnning ) it auto enters repair mode wihout any option before...
Installation & Setup
Win 7 corrupt MBR
Dear forum members I need some help please. I am currently in Directory services repair safe mode. My MBR is corrupted. The Computer is in a continued restart mode. I can get to safe mode only via f8. I do not know what caused this problem. I do have easy BCD and have tried to reset my MBR but it...
General Discussion
wmi is corrupt
Hello everyone, im not sure if this is the correct place to post this, as you know my wmi is corrupt, i have tried the wmidiag.vbs from MS but to no success, if anyone can help me that would be great, attached is the txt file wmidiag opens
Performance & Maintenance
Corrupt AVI
Hello, I had a problem with Windows Live Movie Maker locking up when I tried to do anything. So I uninstalled and did a reinstall of it. Now, I recently recorded some screen captures with Camstudio v2. WLMM is telling me that all of these files are corrupt, but they play correctly in Divx...
Media Center
Win 7 Corrupt?
Well I recently had Vista totally crash on my laptop. Being that I'm now a college student, my dad recommended seeing if I could get a good deal on Win7. Well I did, but it had me download it to my now re-installed Vista, but it wanted me to install it on a different partition. So I did, but Vista...
BSOD Help and Support
Corrupt ISO's
allright now i got allot of these on my HDD now for some reason almost all of them, and i got alot of LINUX and Windows ISO's that i have downloaded off of the MSDNAA site and my ISPs downlaod site andi really dont want to have to download them again, so do you know if there is a way to fix these?...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App