Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD possibly Google Chrome linked, error 0x000000f4 ntoskrnl.exe

20 May 2013   #1

Windows 7 Home Premium x64
BSOD possibly Google Chrome linked, error 0x000000f4 ntoskrnl.exe

I have been experiencing BSODs about once a day for more than a week, as far as I can remember it's always when using Google Chrome (though I almost always have Chrome open, so it might not be related). The BSOD occurs seemingly randomly, often after hours of using the computer without any problems. Sometimes it is sudden, or sometimes Chrome stops responding though other programs continue to respond for the next 10-30 seconds until an error message tells me Windows is not responding and either a BSOD follows or I reset my computer. Following a BSOD and restart, a black screen with "Reboot and select proper Boot device or Insert Boot Media in Selected Boot Device and press a key" error message comes up, so I suspect there is some issue with booting from the C: drive, which is an SSD (I don't know the make or model, slightly suspicious it is from an untrustworthy source, and thus I wouldn't know where to look to update SSD firmware or anything relating to it), but following a restart the computer will boot successfully. After that the computer will often hang without a BSOD, forcing me to restart again, until I give up for the day. Then the next day it will start all over.

I have tried some troubleshooting on my own but I'm just not knowledgeable enough, and feel a bit swamped by all the possible causes and solutions, so here I am. I bought this custom PC a few months ago and it's still under warranty, but I think it's only a hardware warranty, so unless it's a part that needs replacing or some such thing, returning it is my last resort. A clean reinstall would be my penultimate resort because of the hassle involved, but most of my programs and files are on the D drive so it wouldn't be too bad.

Things I've tried:
  • Blowing out the case with compressed air (it was not very dusty at all, but thought it worth a try), checking all fans work.
  • Disk Check - my C: drive (SSD) at first could not be accessed for a disk check even at start up, but a second try worked and indicated no problems. My 2nd drive (HDD) completed the disk check first time without problems.
  • sfc /scannow - completed without indicating any issues.
  • Updating drivers - I used Slimdrivers Free for this which updated a number of drivers, notably the graphics driver. However this did not solve the issue, and I later experienced a different type of BSOD (IRQL_NOT_LESS_OR_EQUAL), thought this might be caused by one of the updated drivers, and thus did a system restore to 11th May, thus the last week of BSOD memory dumps and the IRQL_NOT_LESS_OR_EQUAL BSOD are missing from my attached zip file, and all updated drivers were rolled back to their previous versions. (No system restore points were available from before the first BSOD, and I can't think of any major software or hardware changes I made anyway, so doubtful it would have been helpful to roll back to before that.)
  • Disabling TRIM - I read somewhere that with some SSDs, TRIM may cause some BSODs and the subsequent "Reboot and select proper boot device..." errors, so I disabled TRIM with the elevated command prompt. But then I had the IRQL_NOT... BSOD, and did the system restore, and then despite disabling TRIM again the original BSOD problem occurred again.

I have suspicions that the SSD is the cause but can't find any concrete proof of that, and I guess software is a more likely cause. So, that's where I stand at the moment. I would be immensely grateful for any advice you could give me, but please bear in mind I am not terribly computer savvy so clear instructions or links to clear guides will likely be necessary. Thank you very much :)

My System SpecsSystem Spec
20 May 2013   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Tip   Tip

If you have an SSD, make sure the following are up to date:
  • SSD firmware
  • BIOS Version
  • Chipset Drivers
  • Hard disk controller drivers/SATA drivers
  • If you have a Marvell IDE ATA/ATAPI device, make sure the drivers are up to date from the Intel site or Marvell site and not from your motherboard/vendor support site.

Thanks to Writhziden for the steps above.

Basic checks: Please run these tests and report back the results

1. SFC /scannow to check windows for corruption - SFC /SCANNOW Command - System File Checker
2. Disk check for errors on the hard drive - How to Run Disk Check in Windows 7
3. Troubleshoot applications by a clean boot - Troubleshoot Application Conflicts by Performing a Clean Startup
4. Memtest86+ paying close attention to part 3 - RAM - Test with Memtest86+
5. Hard drive test from HDD mfg website - Hard Drive Diagnostic Procedure
My System SpecsSystem Spec
22 May 2013   #3

Windows 7 Home Premium x64

SSD firmware - I can't update the SSD firmware, as I stated in my OP, because I don't know what the make/model is. It's some cheap generic SSD I guess, and that's why I suspect it might be the cause of my problems. Device manager gives it the title SSD2SC120GC1DH16T-T, but googling this does not come up with anything.

BIOS version - I am very, very hesitant to update the BIOS version. I think my mobo is an Asus P8Z77-V LX2, and I have American Megatrends BIOS version 1502. Asus's website does indicate there is a newer BIOS version for my mobo, but I am too concerned about ruining my motherboard, and I have no idea if this new BIOS version addresses my problem anyway - the new BIOS version description only said "Fixed can't boot to WinPE 4.0 X64".

Drivers/mervell ide device - I don't know about chipset drivers, hard disk controller drivers; not sure what versions of these I have. I guess I should get the ones from the Asus site for my mobo, but there is a huge list of downloads and I have no idea what any of them are. But my chipset drivers seem to be Intel and I did use the driver update/checker utility thing on their website and they just said my current Intel drivers were valid. No idea if I have a Marvell IDE ATA/ATAPI device. I'm guessing not.

Basic checks

1. sfc /scannow - as said in my OP, I tried this already, did it again and once again no problems found.

2. Disk check - as said in my OP, I tried this already. Both my SSD and HDD passed, but the interesting thing I pointed out in my OP was that the first time I tried to run a disk check on my SSD at startup, it said it could not be accessed. I tried again and it was successful that time and there were no problems reported on either drive. I really think there must be something wrong with accessing the SSD given that problem with the disk check first time round and how I sometimes get a "Reboot and select proper boot device" black screen right after the auto-reboot following a BSOD.I also found some threads in other tech support forums of people with SSDs reporting the BSOD then "reboot and select proper boot device" error. But, in most cases they recommended a firmware update, which isn't an option for me as I've said.

3. Clean boot - I did this per the tutorial and my computer did the typical hang after about an hour, so the cause is apparently not any of the services disabled during clean boot.

4. Memtest - I ran it for 18 hours, 9 passes, 0 errors found.

5. Hard Drive Diagnostic - Since I don't know the make of the SSD, I used Seagate Seatools. Both drives passed all tests I tried.

I also had a look at the CPU temperatures with CoreTemp, I think none of them went above 40-42 degrees C maximum, with the average being more like late twenties or thirties, so it doesn't seem to be an overheating problem...

So... thanks for your assistance so far. What's next?
My System SpecsSystem Spec

23 May 2013   #4

Windows 10 Pro/ Windows 10 Pro Insider

Have you tried going to device manager, select proplerties, go to the details tab. In the center of the page is a dropdown box, clcik that and the second item down is Hardware IG. that should give you the manufacturer's name and the last numbers will mr the firmware revision. You can also download AS SSd, which is a benchmarking program for SSDs. Open it and post a screenshot of it. (Screenshots and Files - Upload and Post in Seven Forums) You don't need to run the benchmark, unless you wan to. The page has some info on the SSD, if you select the SSD in the top of the program. Also, where did you get the SSD?

Just a guess, but based on the numbering scheme, it appears to be some version of an Intel SSD.
My System SpecsSystem Spec
24 May 2013   #5

Windows 7 Home Premium x64

I did already try looking in the Device Manager to find more information about it, but there's no identifying information there.
Attachment 269476Attachment 269477

The SSD came with the PC - I ordered it from one of those places that'll build a custom PC for you. This SSD was the default first hard drive in the specific build I chose. For the most part I was careful to try to make sure the parts I chose were from reliable manufacturers, even if it meant paying more, but somehow I overlooked this one - their site was a little confusing and and I was already overbudget but I really wanted an SSD. So I'm kind of blaming myself if the SSD is the problem, for being cheap. I looked at the store's warranty terms and conditions and it seems like even if the SSD is faulty, the only thing the store will do is replace it with an identical one. So there's no guarantee I wouldn't just have the same problem again, and if it's some other problem like incompatibility, replacing it wouldn't help either.

I noticed from my reading in other tech support forums that many people complaining of SSD-related BSODs said you might get BSODs if you're using IDE with your SSD, and you should use AHCI instead. I thought it was ACHI already, but I notice the device manager says IDE/SSD2SC... so does that mean it's connected with IDE? How can I change it to AHCI? I'm pretty sure my computer supports that, and unless it might break something, it's possibly worth a try...?

P.S. Thanks again for your help so far :)
My System SpecsSystem Spec
24 May 2013   #6

Windows 10 Pro/ Windows 10 Pro Insider

AHCI won't break anything, but you are in AHCI mode already. You are running IaStor driver which is Intel's AHCI driver. So, that is not the problem. The firmware you are showing appears to be from a Mushkin Chronos. The one I found was an mSATA drive. Do you have an Msata drive? It would be helpful to find your complete system specs. You can use this tutorial to fill out your system specs. System Info - See Your System Specs. If you follow the tutorial, it should fill them out for you. Also, you should be able to email or call the company who built the computer and find out exactly what brand of SSD they put in your computer. You may even be able to find an easy way of finding updated firmware from them.

EDIT: If you would like to know what system specs we would like, at the bottom left of this post click on 'My System Specs' and you will see mine. This is the information we need to help you and it will follow you in the future if you need other help. Anyone trying to answer your question can click the system specs in your post to see what you have.
My System SpecsSystem Spec
24 May 2013   #7

Windows 10 Pro/ Windows 10 Pro Insider

Also, have you looked at the drive to see the manufacturer's name on it?
My System SpecsSystem Spec
24 May 2013   #8

Windows 7 Home Premium x64

Ok, I filled out my system info. I haven't looked at the drive yet but I just found the invoice I got with the PC. The SSD is listed as "PNY 120GB SATA III Solid State Drive". So, it's made by PNY. I'll just switch my PC off now and take a look to see what the model is and then I'll check their website for firmware updates.

I feel like a moron :) I should have just looked at the drive from the start, but because I was worried about poking around in the case without knowing what I was doing I put it off.

Edit: Ok, it seems like it's a PNY XLR8 120GB.

Edit again: Ok, I've found their firmware update tool (hampered by a BSOD). Pleasant surprise, I don't even have to burn anything to CD. I will take the time to back up my data and report back after the update.
My System SpecsSystem Spec
24 May 2013   #9

Windows 10 Pro/ Windows 10 Pro Insider

I can't find your exact model number but this is the firmware for the PNY XLR8 120GB SSD. Read it, it says for all PNY XLR8 and XLR8 Pro SSDs.

BIOS updates for asus boards is very simple. You will only wreck your board if you lose power or crash during the update.

look at the drivers, they list several versions of each driver. You would want the latest version. You can tell by the revision number and the release date.

The sata ports on your board are labeled sata port 0, sata port 1 ect. Make sure your SSD is connected to port 0 or 1. Those are the intel 6GB ports, other 6GB ports are controlled by Marvell or Asmedia. marvell has issues with SSD and neither the marvell or ASMedia ports will give you nearly the performance as the Intel ports will.

It's 3 AM here, and I'm going to sleep. We'll talk tomorrow (or today how ever you look at it.) Good luck with whatever you decide. keep us informed of your progress.

If all that is done and the drive keeps disappearing, I would be on the phone with the company you bought the computer from. There should be no incompatability issues and getting another bad part is no different than any other component in your computer. It's part of the 'game'.
My System SpecsSystem Spec
26 May 2013   #10

Windows 7 Home Premium x64

Well, I did the SSD firmware update yesterday morning (about 28 hours ago from this post) which was nice and simple. I wasn't getting my hopes up about this fixing the problem but I ran my computer for 6 hours after that, and then almost 10 hours so far today, and haven't had a single BSOD or freeze. It may take another day or two to be sure another one doesn't happen (my heart skips a bit every time there's some lag in a program responding), but now I feel cautiously optimistic.

Thank you for all your assistance, it turns out if I had just been more diligent finding out what my SSD was so I could find the firmware myself I would not have needed to bother you. If there is another problem I will try some of the other suggestions such as flashing my BIOS, but if all goes well it seems that won't be necessary :)
My System SpecsSystem Spec

 BSOD possibly Google Chrome linked, error 0x000000f4 ntoskrnl.exe

Thread Tools

Similar help and support threads
Thread Forum
BSOD Error (possibly Google Chrome?)
Hello Recently started having alot of blue screens forcing my laptop to restart and losing progress of anything i was doing. Ive not used the computer alot since my first two and today i retried and opened google chrome and my google chrome started lagging (My pc isnt the greatest so usually...
BSOD Help and Support
BSOD ntoskrnl.exe+404e92 , error 0X000000f4
I keep getting this BSOD and can't figure out exactly what the problem is. I have blue screen view, is there a better program to see what might be wrong and if anyone has any ideas into why it might be doing this? Thank you for the help.
BSOD Help and Support
BSOD error 0x000000f4 caused by driver ntoskrnl.exe
Hello all, I recently built a new PC within the last two weeks. The code I get, everytime, is 0x000000f4, and according to BlueScreenView this is caused by ntoskrnl.exe. For the first couple days, it was running fine with no problems. The past week and a half, though, I've been getting BSOD at...
BSOD Help and Support
Random BSOD possibly linked to Chrome
Ok, this is my first time here, so I hope I have done everything right. Attached is the zip file from the SF diag tool. In it are the errors for 3 crash dumps. Here is my story: I've always got blue screens since I built this computer about 8 months ago. It was very rare, we are talking less...
BSOD Help and Support
BSOD while gaming ntoskrnl.exe error 0x000000f4
This has been going on for a while now. I replaced my motherboard and a bad hard drive. I run off an SSD (samsung 830) as my boot drive with a 1 TB hard drive for storage. I ran memtest multiple times with no errors. Could this be a failing PSU? The debug info in WhoCrashed said this was not a...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:07.
Twitter Facebook Google+