Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD Using Python 2.7, error 0x000000f4

29 May 2013   #1

Windows 7 64-bit
BSOD Using Python 2.7, error 0x000000f4

Hello sevenforums,

I have been having a BSOD problem on my Asus laptop running Windows 7, processor is core-i5. The BSOD occurs somewhat randomly when attempting to run python scripts using VIDLE for Python 2.7. The problem usually occurs after around 2 - 10 times of running a script, and it does not depend whatsoever on the contents of the script, as I have seen it BSOD while running a completely blank script. The BSOD does not seem to happen during any other activity on the computer (which is mostly using the internet, some other Physics related programs, and some games).

The error code is 0x000000f4, and BlueScreenViewer is telling me that the likely culprits are discache.sys and ntoskrnl.dll. I've attached my SF Diagnostic Tool log.

Any help would be greatly appreciated.

My System SpecsSystem Spec
30 May 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hello Frey.

Free up the startup. Windows does not need any other program to auto start with it, but the auto start programs often conflicts and causes various problems including BSODs.
  1. Click on the Start button
  2. Type “msconfig (without quotes), click the resulting link. It will open the System Configuration window.
  3. Select the “Startup” tab.
  4. Deselect all items other than the antivirus and the touchpad driver, SynTPEnh.
  5. Apply > OK
  6. Accept then restart.
Get rid of intel rapid storage. First uninstall it from Control Panel > Programs and Features. Then Uninstall the driver from device manager.
  1. Right click on "my computer" icon and click "manage" on the context menu.
  2. It will open the "computer management" window.
  3. Select "Device Manager" in the left pane, It will list all the existing devices up.
  4. Expand "IDE ATA/ATAPI controllers" by clicking on the triangle in front of it.
  5. Select one Intel device item under it, right click, uninstall.
  6. Continue the process for all Intel items under "IDE ATA/ATAPI controllers"
  7. Now restart the computer. At restart, windows will auto configure the appropriate native system driver.
Seatool for dos: SeaTools | Seagate download
  • Burn it in a blank cd. boot from the CD, click on "Accept", wait for it to finish detecting the drives, then in the upper left corner select "Basic Tests", then select "Long Test" and let it run.
Post a screenshot of your HDD using CrystalDiscInfo.
Uninstall the following Bloatware.
  • Start Menu\Programs\ASUS
  • Start Menu\Programs\ASUS\ASUS WebStorage
  • Start Menu\Programs\ASUS Utility
  • Start Menu\Programs\ASUS Utility\ASUS Splendid Utility
  • Start Menu\Programs\ASUS Utility\SmartLogon
Let us know the results.
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck F4, {3, fffffa800a374b30, fffffa800a374e10, fffff8000338b350}

----- ETW minidump data unavailable-----
Probably caused by : wininit.exe

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

A process or thread crucial to system operation has unexpectedly exited or been
Several processes and threads are necessary for the operation of the
system; when they are terminated (for any reason), the system can no
longer function.
Arg1: 0000000000000003, Process
Arg2: fffffa800a374b30, Terminating object
Arg3: fffffa800a374e10, Process image file name
Arg4: fffff8000338b350, Explanatory message (ascii)

Debugging Details:

----- ETW minidump data unavailable-----


PROCESS_OBJECT: fffffa800a374b30

IMAGE_NAME:  wininit.exe


MODULE_NAME: wininit

FAULTING_MODULE: 0000000000000000 

PROCESS_NAME:  pythonw.exe

BUGCHECK_STR:  0xF4_pythonw.exe




LAST_CONTROL_TRANSFER:  from fffff80003412d22 to fffff80003084c00

fffff880`0b7069c8 fffff800`03412d22 : 00000000`000000f4 00000000`00000003 fffffa80`0a374b30 fffffa80`0a374e10 : nt!KeBugCheckEx
fffff880`0b7069d0 fffff800`033bf08b : ffffffff`ffffffff fffffa80`05cf6b50 fffffa80`0a374b30 fffffa80`05c28b30 : nt!PspCatchCriticalBreak+0x92
fffff880`0b706a10 fffff800`0333f144 : ffffffff`ffffffff 00000000`00000001 fffffa80`0a374b30 00000000`00000008 : nt! ?? ::NNGAKEGL::`string'+0x17486
fffff880`0b706a60 fffff800`03083e93 : fffffa80`0a374b30 fffff880`0000000f fffffa80`05cf6b50 00000000`00000f90 : nt!NtTerminateProcess+0xf4
fffff880`0b706ae0 00000000`772b15da : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0008e318 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x772b15da


FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  X64_0xF4_pythonw.exe_IMAGE_wininit.exe

BUCKET_ID:  X64_0xF4_pythonw.exe_IMAGE_wininit.exe

Followup: MachineOwner
My System SpecsSystem Spec
30 May 2013   #3

Windows 7 64-bit

Thanks for your response Arc,

I changed my startup settings so that only the touchpad and antivurs begin at startup, and I got rid of intel rapid storage. I also uninstalled all of Asus's crapware, something which I should have done right when I got the computer but never got around to.

I'm not able to make a boot cd since my computer has not cd drive to boot from, but I have attached both the complete copy of CDinfo and a screenshot of the main page.

Interestingly, after doing all of these things, I tried running a blank python script over and over again to reproduce the BSOD. However, the first thing that happened was that the computer simply froze for a moment, and then forced me back to the Windows login screen. After a second set of running the script repeatedly I was able to reproduce the BSOD again.

I should also mention that the computer will BSOD not only on running the script, but also quite often on closing the python shell (where the scripts are actually run).
My System SpecsSystem Spec

30 May 2013   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

The caution indication can be converted to good using CrystalDiscInfo. Click on the caution Button, you will get another window ....

In the resulting window, there are three sliders in the left. Drag them to the ultimate left, and notice the values at the right side are converting to zeros.

Now click the apply button, and notice that the caution is gone.

I suggest you to run seatools for windows if you cannot make a bootable CD. It is necessary. Also, if possible, back up your important data externally.
Next time, when there will be a BSOD, post it following the Blue Screen of Death (BSOD) Posting Instructions.
My System SpecsSystem Spec
30 May 2013   #5

Windows 7 64-bit

I am at work right now and I don't have time to run the full scan at the moment, but I will do that when I get home and post the results.

As for the BSOD report, I included it in my first post, although I have included another one in this post.
My System SpecsSystem Spec
30 May 2013   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Ok, do it when you have time. No hurry
I will have to work 12 hours tomorrow
My System SpecsSystem Spec
31 May 2013   #7

Windows 7 64-bit

Thanks for your help Arc, but I believe I have solved the problem (or at least found a workaround). If I run the program using my Nvidia graphics driver there is no problem. I'll just keep doing this for now, although Im still going to run a harddrive test just in case.
My System SpecsSystem Spec
31 May 2013   #8

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Its good Let us know how it is working after some days.

I suggested all those, as technically a Stop 0xF4 is a storage related issue, and there were reasons to believe from your uploaded data that the storage is under problem anyhow, which was supported by the CrystalDisc Info Screenshot.

Still, if your solution works, it is most welcome
My System SpecsSystem Spec

 BSOD Using Python 2.7, error 0x000000f4

Thread Tools

Similar help and support threads
Thread Forum
error loading python DLL
wasn't sure where to post... please move it if this is not the right place At the start of windows an error window appear saying: "Error loading Python DLL: c:\use\admin\appdata\local\temp\_mei42443\python27.dll (error code 5)" Also when ever i want to install something a similar error appera...
BSOD Error 0x000000F4
Hello, I would like some help resolving my BSOD error 0x000000F4 that I've been getting a couple of times per a week ever since I built my computer about a year ago. I've done memory tests and hard drive tests to try and fix it, but so far nothing as worked. I uploaded the log from the DM Log...
BSOD Help and Support
BSOD, error 0X000000F4
Thank you for taking the time to help me. Any information will be much appreciated. I attached everything asked for in the guide. . This BDOD was received from trying to: Do windows update to my computer and trying to remove two suspicious viruses using Microsoft Essentials. I also...
BSOD Help and Support
Python sytax error problem
Hi, i have a problem with this python file. Its f-secure's ASCII World map. I dont know how to fix it. The part that has error is this: formats = Attached file below.
BSOD error 0x000000f4
Is Windows 7 - x64 - the original installed OS on the system - OEM - What is the age of system (hardware)? 2 years Error code: 0x000000f4 (0x0000000000000003, 0xFFFFFFA8006AEBC10, 0XFFFFFA8006AEBE48, 0XFFFFF80002124CF0)
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App