Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD while playing Age of Empires II HD

28 Jul 2013   #41
x BlueRobot


BSOD Analysis:

BugCheck 3B, {c0000005, fffff880010123fa, fffff88009032980, 0}

*** WARNING: Unable to verify timestamp for MpFilter.sys
*** ERROR: Module load completed but symbols could not be loaded for MpFilter.sys
Probably caused by : MpFilter.sys ( MpFilter+123fa )
Usual causes:  System service, Device driver, graphics driver, memory
3: kd> !thread
GetPointerFromAddress: unable to read from fffff80003311000
THREAD fffffa8007f1b2c0  Cid 0bc8.0bcc  Teb: 000007fffffde000 Win32Thread: 0000000000000000 RUNNING on processor 3
IRP List:
    Unable to read nt!_IRP @ fffffa8005f69850
Not impersonating
GetUlongFromAddress: unable to read from fffff80003250ba4
Owning Process            fffffa8007f1cb30       Image:         WmiPrvSE.exe
Attached Process          N/A            Image:         N/A
fffff78000000000: Unable to get shared data
Wait Start TickCount      2982         
Context Switch Count      40             IdealProcessor: 0             
ReadMemory error: Cannot get nt!KeMaximumIncrement value.
UserTime                  00:00:00.000
KernelTime                00:00:00.000
Win32 Start Address 0x00000000ffb7a9b4
Stack Init fffff88009033db0 Current fffff88009032bb0
Base fffff88009034000 Limit fffff8800902e000 Call 0
Priority 9 BasePriority 8 UnusualBoost 0 ForegroundBoost 0 IoPriority 2 PagePriority 5
fffff880`090339a8  fffff800`033d7b76 nt!ObOpenObjectByName+0x306
fffff880`09033a08  fffff800`033d3e2a nt!NtAllocateVirtualMemory+0x134a
fffff880`09033a78  fffff800`033d947c nt!IopCreateFile+0x2bc
fffff880`09033ab8  fffff800`030e61f8 nt!MmAccessFault+0x3d8
fffff880`09033b18  fffff800`033c3a84 nt!NtOpenFile+0x58
I wasn't able to find much conclusive information from the dump file, but I've managed to gather some further evidence to support the Stop 0xC9 by Driver Verifier, there is a few function calls related to I/O and Device Drivers.

Looking at your .Arn file, and the Drivers tab, I managed to find this:


Start Menu\Programs\DAEMON Tools Lite
Quote   Quote: Originally Posted by Arc View Post
Download SPTD standalone installer from, and execute the downloaded file as guided below :
  • Double click to open it.
  • Click this button only:
  • If it is grayed out, as in the picture, there is no more SPTD in your system, and you just close the window.
Daemon Tools uses a driver called sptd.sys and dtsoftbus01.sys, which is known to cause BSODs with Windows 7. It is recommend you remove this program, and use Windows own in-built features or ImgBurn.

Infrd960.sys seems to related to your IBM ServeRAID Controller Driver and dated as 06/06/2006, it's very unlikely to be compatible so I suggest removing the driver completely. Are you running a RAID configuration, I've noticed quite a few RAID drivers.

agrsm64.sys seems to be related to AgereSoftModem (part of LSI Logic) and unlikely to be compatible with Windows 7 since it is dated as 10/11/2008, I would either check for any updates or remove the driver completely.

adp94xx.sys related to Adaptec Windows SAS/SATA Storport Driver is dated as 05/12/2008, and again unlikely to be compatible with Windows 7, please check for updates or remove the driver completely from your system. Support Page - Adaptec - Technical Support

There's a few other drivers dated from 2009, but I would firstly check the HP Support Site for your model for any updates. Check for all the drivers apart from the Intel graphics.

My System SpecsSystem Spec
28 Jul 2013   #42
Roy Renard

Windows 7 Home Premium 64bit

Ok, so I uninstalled Daemon Tools and ran SPTD, but the Uninstalled button was already gray since the beginning, so I just closed it.
After this I went on to the HP Support Site and had my computer scanned in order to find driver updates, but the site said that there were no drivers or tools to update or install. Nonetheless, the site listed a group of drivers for my laptop's specific model and started to download and install as many of them as possible. Some of them (such as the Graphics drivers) prompted a window saying that I already had the newest version for that driver, so I just let them be.
Interestingly, during this process, my computer crashed twice, and a new minidump file was created, so I'm attaching it here just in case.
As for Infrd960.sys, I couldn't find it. I executed Autoruns once again and went to the Drivers tab in order to locate it, but couldn't find it at all. As for agrsm64.sys and adp94xx.sys, I did find them AT C:\Windows\System32\drivers, however, they are dated there as of 2009, so I'm unsure whether this changes anything about removing them.
I Googled for an update for agrsm64.sys, but could only find stuff saying that it is known to cause BSOD's and that I need to repair it, but the only way to do so is by downloading X or Y program that must be purchased in order to reapir the file (probably scams). In summary, I'm at a loss as to what to do with these drivers.
Also, I'm not really sure what a RAID configuration is and whether it's a good or bad thing... sorry.
Anyways, I'll continue installing the drivers from the HP Support Site and hope the problem gets better.
Edit: A new BSOD occurred just now by just being in the internet. I attached a zip file with both minidump files created today.
My System SpecsSystem Spec
29 Jul 2013   #43
x BlueRobot


If you don't know what RAID is, then your unlikely to have RAID and therefore you will not need those RAID drivers, but let's double check just in case:
  1. Start
  2. Right-Click Computer
  3. Manage
  4. Accept UAC Prompt
  5. Under Storage in the left pane, click Disk Management
Post a screenshot of your maximized Disk Management window - Screenshots and Files - Upload and Post in Seven Forums

BSOD Analysis:

BugCheck 1E, {ffffffffc000001d, fffff800030fe36d, 0, fffff8800935b300}

Probably caused by : memory_corruption
Usual causes:  Device driver, hardware, System service, compatibility, Remote control programs, memory, BIOS
0: kd> !error ffffffffc000001d
Error code: (NTSTATUS) 0xc000001d (3221225501) - {EXCEPTION}  Illegal Instruction  An attempt was made to execute an illegal instruction.
fffff8800935bb78 -- (.exr 0xfffff8800935bb78)
ExceptionAddress: 000000006d235409
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: 000000000000000c
Attempt to read from address 000000000000000c
0: kd> k
Child-SP          RetAddr           Call Site
fffff880`0935a8f8 fffff800`0310e728 nt!KeBugCheckEx
fffff880`0935a900 fffff800`030c3282 nt! ?? ::FNODOBFM::`string'+0x487ed
fffff880`0935afa0 fffff800`030c13df nt!KiExceptionDispatch+0xc2
fffff880`0935b180 fffff800`030fe36d nt!KiInvalidOpcodeFault+0x11f
fffff880`0935b310 fffff800`030fe48c nt!KiPreprocessFault+0xf9 
fffff880`0935b3a0 fffff800`030c3282 nt!KiDispatchException+0xf0
fffff880`0935ba40 fffff800`030c1dfa nt!KiExceptionDispatch+0xc2
fffff880`0935bc20 00000000`6d235409 nt!KiPageFault+0x23a
00000000`0530fa00 00000000`00000000 0x6d235409
KiInvalidOpcodeFault seems to be where the system has crashed, and it seems the reason why it crashed, was because something incorrectly used a Opcode instruction, which would explain the other illegal instruction error.

The problem is most likely to caused by drivers.

From the other BSOD, I managed to find one driver from the raw stack which may be causing problems:

0: kd> lmvm SynTP
start             end                 module name
fffff880`0565b000 fffff880`056ad000   SynTP    T (no symbols)           
    Loaded symbol image file: SynTP.sys
    Image path: SynTP.sys
    Image name: SynTP.sys
    Timestamp:        Fri Feb 05 02:45:26 2010 (4B6B8646)
    CheckSum:         00052589
    ImageSize:        00052000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Your Touchpad driver seems to be a possible cause, I would check for any updates from here - Drivers | Synaptics
My System SpecsSystem Spec

01 Aug 2013   #44
Roy Renard

Windows 7 Home Premium 64bit

Alright, sorry for the late reply; I have been busy with school.
I installed the updated Touchpad driver; however, I'm not really sure if everything's alright now. I'll be playing and doing things that caused crashes in order to see if the problem's solved.
Also, here is the screenshot of my Disk Management window.

Attachment 279226
My System SpecsSystem Spec
01 Aug 2013   #45
x BlueRobot


You do have RAID set up for some reason, hence the reason for the RAID drivers being on your system. There's no need for RAID with one physical hard drive.

I would convert it back to Basic - Convert a Dynamic Disk to a Basic Disk

Read all the steps within the tutorial very carefully, Option #1 and #2 will allow you to convert it back to Basic without losing any data, but a backup or image backup is advisable.
My System SpecsSystem Spec
06 Aug 2013   #46
Roy Renard

Windows 7 Home Premium 64bit

Again, sorry for late replays; school is taking a lot of my time (and things were working alright until now). My disk is converted back to Basic.
Also, got a new BSOD for the first time after updating the touchpad driver. Here's the SF file.
Thanks for your patience.
My System SpecsSystem Spec
07 Aug 2013   #47
x BlueRobot


Don't worry I understand :)

BugCheck 50, {fffff880096d8a04, 1, fffff8000333ec92, 0}

Could not read faulting driver name
Probably caused by : memory_corruption
Usual causes:  Defective hardware (particularly memory - but not just RAM), Faulty system service, Antivirus,  Device driver, NTFS corruption, BIOS
It's similar to Stop 0xA, there's no exact cause here, but I would remove those old RAID drivers from your system.

Here's the list -

Adaptec RAID Storport Driver	Adaptec, Inc.	c:\windows\system32\drivers\arc.sys	24/05/2007
Adaptec SAS RAID WS03 Driver	Adaptec, Inc.	c:\windows\system32\drivers\arcsas.sys	14/01/2009 
MEGASAS RAID Controller Driver for Windows 7\Server 2008 R2 for x64	LSI Corporation	c:\windows\system32\drivers\megasas.sys	18/05/2009
LSI MegaRAID Software RAID Driver	LSI Corporation, Inc.	c:\windows\system32\drivers\megasr.sys	18/05/2009 
IBM ServeRAID Controller Driver	IBM Corporation	c:\windows\system32\drivers\nfrd960.sys	06/06/2006 
SiS RAID Stor Miniport Driver	Silicon Integrated Systems Corp.	c:\windows\system32\drivers\sisraid2.sys	24/09/2008
VIA RAID DRIVER FOR AMD-X86-64	VIA Technologies Inc.,Ltd	c:\windows\system32\drivers\vsmraid.sys	30/01/2009
Check if the drivers appear in Device Manager - Using Device Manager to Uninstall Devices and Driver Packages (Windows Drivers)
My System SpecsSystem Spec
18 Sep 2013   #48
Roy Renard

Windows 7 Home Premium 64bit

Well, hello again. I didn't want to click the "Mark as Solved" button because I was afraid that the crashes would return eventually, seeing how persistent the problem had been.
Unfortunately, after a month of working flawlessly, my computer has started crashing yet again (while playing AoEII, as well). Crashes occurred about a week ago, but the system only created a Minidump file for September 14th. I got a couple crashes more today, but the Minidump folder didn't get any new files.
What might be the cause of such a persistent problem?
Any new help will be highly appreciated!
My System SpecsSystem Spec
20 Sep 2013   #49
x BlueRobot


Run Driver Verifier to scan for any corrupted drivers which may be causing problems, this program works by running various stress tests on drivers, in order to produce a BSOD which will locate the driver; run for least 24 hours:
information   Information

Select Individual Settings, and then enable all the options, apart from the Low Resources Simulation.
My System SpecsSystem Spec
28 Sep 2013   #50
Roy Renard

Windows 7 Home Premium 64bit

Alright, so I've been running Driver Verifier with the settings you specified for at least 3 days. After activating those settings and restarting my computer, Windows started up, but the PC immediately shut down when the desktop was being loaded. It did this for about two more times before it stayed on without interruption. Ever since then, no crashes, sudden restarts or BSOD's have happened, nor new files have been added to the Minidump folder, even when playing AoE II for the last couple of days.
I haven't deactivated Driver Verifier yet, so I'll post when a new crash/BSOD happens.
Thank you, nonetheless.
My System SpecsSystem Spec

 BSOD while playing Age of Empires II HD

Thread Tools

Similar help and support threads
Thread Forum
BSOD playing Age of Empires II HD, files attached
So in the past week I've been getting blue screens followed by a restart. From what I remember it happens when I'm playing AOE 2 HD (the Steam version) but it may have happened outside the game when doing other stuff. My computer then runs fine for another few hours or even a day. These are the...
BSOD Help and Support
BSOD playing Empires:Total War, error STOP: 0x00000F4
Hello, I have had a odd problem with my computer, until recently everything has been running fine for the last two years, until I decided to modify my version of Empires:Total War. I downloaded the modification (Darth Mod) and installed it, worked fine, however it suddenly crashed to desktop. I...
BSOD Help and Support
BSOD - page_fault_in_nonpaged_area (after installing Age Of Empires 2)
Hi, I seem to have encountered a problem after installing an old copy of Age of Empires 2. I now see a BSOD when running certain programs. The two different programs it has happened for are: Firefox - after typing in a URL, the BSOD appears VLC - When opening a file (only some - others work...
BSOD Help and Support
BSOD playing Age of Empires 3 online. Urgent Help
Today I faced a strange new pc has Core i3 2100 ,4gb RAM,Win 7 Ultimate,500gb Hdd, Intel Dh61WW mobo. Ok the problem goes as..I installed Age of Empires III online today. It said the game may have compatibility issues with Win 7. I decided to run it anyway. Worked fine on max settings....
BSOD Help and Support
Age of Empires not playing
My problem is that i can install AOE2, and the conquerers expansion without any difficulty, but when i hit play on the splash screen, the loading splash screen shows up for about 10 seconds, disappears, then nothing happens. i can hear the cd spinning and stuff happening inside my computer, but...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:26.
Twitter Facebook Google+