Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD on boot-up and shut-down.

23 Jun 2013   #1

Windows 7 Ultimate x64
BSOD on boot-up and shut-down.

Hi, all. I'm new to this place. Hope you can help me with this problem, as it's been perplexing.

Starting on the 11th of this month, I've had the occasional BSOD. Two of them occurred while the computer was shutting down, and two happened while the computer was booting up (right before the Windows boot-up screen).

Typically, rebooting the machine is enough to let me into Windows. I have yet to hit a brick wall that keeps me out of the machine, and I have yet to have it BSOD while I'm using the computer -- I can play Skyrim or Alan Wake or the Sims 3 for hours without incident -- but I'm getting worried as it has happened four times since the 11th of this month.

Here's my most recent crash report:

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.
Locale ID: 1033

Additional information about the problem:
BCCode: 1000007e
BCP3: FFFFF880031CB518
BCP4: FFFFF880031CAD70
OS Version: 6_1_7601
Service Pack: 1_0
Product: 256_1

Files that help describe the problem:

Read our privacy statement online:
Windows 7 Privacy Statement - Microsoft Windows

If the online privacy statement is not available, please read our privacy statement offline:
I've also attached in a RAR file the Minidump file listed above.

Any help would be greatly appreciated.

My System SpecsSystem Spec
24 Jun 2013   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Hi and welcome Timedye to seven forums

It seems that your EtronXHCI.sys - Etron USB 3.0 Extensible Host Controller Driver is the problem. Please try and update them to the latest version available, see if it stops the BSOD's.

Rt64win7.sys Thu Jan 13 17:57:19 2011 (4D2EE89F) - Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC
Driver Reference Table - Rt64win7.sys

EtronXHCI.sys Tue Jul 26 03:30:56 2011 (4E2DE090) - Etron USB 3.0 Extensible Host Controller Driver
Driver Reference Table - EtronXHCI.sys

EtronHub3.sys Tue Jul 26 03:30:59 2011 (4E2DE093) - Etron USB 3.0 Extensible Hub Driver
Driver Reference Table - EtronHub3.sys

Next time you get a BSOD, please GRAB ALL and upload the new zip to your next post.

Best Regards,

Loading User Symbols
*** WARNING: Unable to verify timestamp for EtronXHCI.sys
*** ERROR: Module load completed but symbols could not be loaded for EtronXHCI.sys
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 1000007E, {ffffffffc0000005, fffff880043dedb1, fffff880031cb518, fffff880031cad70}

Probably caused by : EtronXHCI.sys ( EtronXHCI+9db1 )

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Some common problems are exception code 0x80000003.  This means a hard
coded breakpoint or assertion was hit, but this system was booted
/NODEBUG.  This is not supposed to happen as developers should never have
hardcoded breakpoints in retail code, but ...
If this happens, make sure a debugger gets connected, and the
system is booted /DEBUG.  This will let us see why this breakpoint is
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff880043dedb1, The address that the exception occurred at
Arg3: fffff880031cb518, Exception Record Address
Arg4: fffff880031cad70, Context Record Address

Debugging Details:

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

fffff880`043dedb1 8b8174400000    mov     eax,dword ptr [rcx+4074h]

EXCEPTION_RECORD:  fffff880031cb518 -- (.exr 0xfffff880031cb518)
ExceptionAddress: fffff880043dedb1 (EtronXHCI+0x0000000000009db1)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: 0000000000004074
Attempt to read from address 0000000000004074

CONTEXT:  fffff880031cad70 -- (.cxr 0xfffff880031cad70)
rax=0000000000000001 rbx=fffffa8007fad000 rcx=0000000000000000
rdx=fffff88000fa7001 rsi=0000000000000002 rdi=fffffa8007f7a500
rip=fffff880043dedb1 rsp=fffff880031cb750 rbp=0000000000000000
 r8=0000000000000000  r9=0000000000000002 r10=0000000000000002
r11=0000000000000000 r12=fffffa8007f7a060 r13=0000000000000000
r14=fffff8a009b9b4e0 r15=0000000000000001
iopl=0         nv up ei pl zr na po nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010246
fffff880`043dedb1 8b8174400000    mov     eax,dword ptr [rcx+4074h] ds:002b:00000000`00004074=????????
Resetting default scope





ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  0000000000004074

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800032c7100
GetUlongFromAddress: unable to read from fffff800032c71c0
 0000000000004074 Nonpaged pool

fffff880`043dedb1 8b8174400000    mov     eax,dword ptr [rcx+4074h]


LAST_CONTROL_TRANSFER:  from fffffa8007fad000 to fffff880043dedb1

fffff880`031cb750 fffffa80`07fad000 : 00000000`00000002 fffffa80`07f7a060 fffffa80`07f7a1b0 fffffa80`07f7a1b0 : EtronXHCI+0x9db1
fffff880`031cb758 00000000`00000002 : fffffa80`07f7a060 fffffa80`07f7a1b0 fffffa80`07f7a1b0 fffffa80`07f7a478 : 0xfffffa80`07fad000
fffff880`031cb760 fffffa80`07f7a060 : fffffa80`07f7a1b0 fffffa80`07f7a1b0 fffffa80`07f7a478 fffffa80`07f7a060 : 0x2
fffff880`031cb768 fffffa80`07f7a1b0 : fffffa80`07f7a1b0 fffffa80`07f7a478 fffffa80`07f7a060 fffff880`043d6db6 : 0xfffffa80`07f7a060
fffff880`031cb770 fffffa80`07f7a1b0 : fffffa80`07f7a478 fffffa80`07f7a060 fffff880`043d6db6 fffffa80`00001b6f : 0xfffffa80`07f7a1b0
fffff880`031cb778 fffffa80`07f7a478 : fffffa80`07f7a060 fffff880`043d6db6 fffffa80`00001b6f fffff800`00007023 : 0xfffffa80`07f7a1b0
fffff880`031cb780 fffffa80`07f7a060 : fffff880`043d6db6 fffffa80`00001b6f fffff800`00007023 fffffa80`0c033001 : 0xfffffa80`07f7a478
fffff880`031cb788 fffff880`043d6db6 : fffffa80`00001b6f fffff800`00007023 fffffa80`0c033001 00000000`00000000 : 0xfffffa80`07f7a060
fffff880`031cb790 fffffa80`00001b6f : fffff800`00007023 fffffa80`0c033001 00000000`00000000 fffff880`02f64180 : EtronXHCI+0x1db6
fffff880`031cb798 fffff800`00007023 : fffffa80`0c033001 00000000`00000000 fffff880`02f64180 00000000`00000000 : 0xfffffa80`00001b6f
fffff880`031cb7a0 fffffa80`0c033001 : 00000000`00000000 fffff880`02f64180 00000000`00000000 00000000`00000000 : 0xfffff800`00007023
fffff880`031cb7a8 00000000`00000000 : fffff880`02f64180 00000000`00000000 00000000`00000000 00000000`00000000 : 0xfffffa80`0c033001



FOLLOWUP_NAME:  MachineOwner




STACK_COMMAND:  .cxr 0xfffff880031cad70 ; kb


BUCKET_ID:  X64_0x7E_EtronXHCI+9db1

Followup: MachineOwner

2: kd> lmvm EtronXHCI
start             end                 module name
fffff880`043d5000 fffff880`043e8500   EtronXHCI T (no symbols)           
    Loaded symbol image file: EtronXHCI.sys
    Image path: \SystemRoot\System32\Drivers\EtronXHCI.sys
    Image name: EtronXHCI.sys
    Timestamp:        Tue Jul 26 03:30:56 2011 (4E2DE090)
    CheckSum:         00020826
    ImageSize:        00013500
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
24 Jun 2013   #3

Windows 7 Ultimate x64

Thanks for the welcome, koolkat. :)

I'm installing the most recent GIGABYTE drivers for the USB 3.0 and Ethernet ports now, so hopefully that'll sort the problem out. If I get the BSOD again, I'll post back here (I'm downloading the tool to GRAB ALL as we speak).

Appreciate the help!
My System SpecsSystem Spec

15 Jul 2013   #4

Windows 7 Ultimate x64

Hello, all. Back again!

After following the steps you laid out for me last time, things seemed to clear up nicely. I haven't had the BSOD since, but now it seems to have cropped up again. About 15 minutes ago I was working on the computer and got the BSOD. It happened fast and out of sight, actually. I glanced out the window near my desk, and by the time I looked back the PC was rebooting. I only know it was a BSOD because I got a pop-up telling me as much after the reboot.

I've attached the GRAB ALL, as requested. Any help would be greatly appreciated. :)
My System SpecsSystem Spec
15 Jul 2013   #5

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

My System SpecsSystem Spec
17 Aug 2013   #6

Windows 7 Ultimate x64

Okay, I never got around to posting back because I had to move house, and we're still getting things settled -- I'm staying in temporary digs while our new house is being built, and that's taking longer than it should have, so my net access is limited.

I haven't had a BSOD since the last one I reported -- I'll try and get that report information for you when I have time, koolkat -- but shortly after getting the computer set up in our temporary digs, I began to experience frequent freezes and audio looping (where the sound loops into a buzzing). Sometimes the system will manage to stabilize and continue on its way, sometimes it has to be reset by holding the power button down.

This lock-up only seems to happen when I'm on the desktop or trying to browsing the internet. It never happens when I'm in a game or watching a video file, but it will happen when I'm just looking at icons on the desktop or when I'm using Firefox. Usually I have music playing on Winamp. The audio loop only seems to happen if the sound is outputting through my HDMI cable. If I'm listening to music through USB headphones, the music stops immediately.

During one of these lock ups, the screen turned pink, the color looked like lines running up the screen. On one occasion, the mouse turned into a cursor and the cursor was a weird rainbow color. These particular symptoms have only happened once each, they haven't occurred during any of the other lock ups.

So those are the symptoms I'm currently experiencing. Sometimes the computer locks up almost immediately after booting Windows, sometimes it takes hours (I used the computer from around midnight to 9AM without incident, and then it locked up). I've tried scrubbing and replacing video drivers, but that had no effect on the freezing. I also scanned my system for malware or viruses and found nothing.

So here's what I've tried in my search to figure out what in the hell has gone wrong: the first thing I did after fooling with drivers was run a scan of my HDD. I right clicked on the HDD and told it to scan for errors and bad sectors. The computer rebooted and started scanning, which took about four hours. The scan found no errors and no bad sectors.

I then moved on to the RAM. I'm running 2x4GB sticks of Corsair Vengeance. There was a mix up with my roommate's RAM while we were working on our PCs, and so I'm running different sticks from different kits, but they're the same brand and have identical specs (1600mhz, 1.50v, 9-9-9-24 timing). My former roommate is running the other two sticks from these kits in his PC, and he's had no problems whatsoever, so I don't think there's a compatibility issue (more on that later).

So it was at this point that I broke out memtest86+. The first time I ran the program, it found 18 errors within minutes (although none of them came up in red). Given what I've read about RAM errors (if you get even one, replace the RAM) I immediately stopped the test, powered down the computer, and stripped out one of the two DIMMs. I wanted to test them separately to see if one or both had errors.

I ran memtest on the first DIMM for 5 hours, did 5 passes, and found no errors. I removed the first DIMM, inserted the second DIMM, and ran the same 5 hour/5 pass test. No errors.

At this point, I was confused. I put both sticks back in the computer and began another test of both DIMMs together. At around the 8 hour mark, on the 5th pass, I found a single error.

Because I had found no errors on the sticks individually, I wondered if something might be wrong with one or more of the ports on my motherboard. I left the first stick in the port it was in (both sticks had shown clean in that port) and moved the second stick down to the port at the far end. I then ran memtest for a whopping 20 hours. 10 passes. Found zilch for errors.

Feeling stumped, I gave up on memtest and rebooted my computer. It took a little while, but eventually it froze up again. I decided to remove one of the DIMMs and see if that would solve the problem. While I waited for my next freeze, I downloaded Prime95 so that I could use the stress test feature to put my CPU through the ringer. The test I picked also stressed the RAM, so I thought it'd be a good way to kill two birds with one stone.

While running the stress test, the computer locked up. I turned it off and swapped the first DIMM for the second DIMM. When I rebooted, I got an odd message saying I'd had a boot failure due to overclocking. My CPU has not been overclocked, so I wasn't sure what the message was on about. All I could assume was that it was referring to my RAM: I had gone into the BIOS and manually set the RAM up, because the auto settings wanted to run my 1600mhz ram at 1333mhz, and the timing was all wrong (11-11-11-29 as opposed to 9-9-9-24). This had not been a problem previously, but I booted into the BIOS to reset it to AUTO, only to find it had already been reset to auto.

I tried rebooting and got the same message again, so I swapped the RAM again to see if the other DIMM would let me in. Same message again. The only way I ever got past it was by removing the battery on my motherboard to reset to CMOS. I put the second DIMM back in and the computer booted fine with the Default motherboard settings.

I then set about stress testing my CPU and RAM again with Prime95. I let it run for about an hour, with the CPU pushed all the way to 100%, and there were no errors and the system never crashed, so I assumed the first DIMM was faulty. I left the second DIMM in the machine, turned it off for a while to let it rest, and then proceeded to use the computer without incident from around midnight to 9AM, when it suddenly froze again. All I was doing was writing a post on a message board and listening to music, there was nothing processor intensive going on. Browsing the internet was pretty much all I did last night, without incident. I'm back to the other DIMM now, in a port on the board I haven't been using.

I'm stumped as to what to do next. It's hard for me to believe that two DIMMs from two different kits have suddenly gone bad -- the DIMM that was already in my machine prior to the mix-up has been working A-okay for over a year, but the machine locks up even when that's the only stick present. I would just swap RAM with my roommate and see what happens, but he's not living with me anymore and we're two far apart for that little experiment now.

The HDD appears to be fine, I can put ample amounts of stress and heat on the CPU without getting errors or locking the system... the RAM seems like the most likely culprit, but I'd hate to shell out $80 to replace it and have the issue continue. I'm not sure how to test things like the video card or the motherboard itself, but I'd like to rule them out before I start throwing money around.

Any advice? The biggest pain here is that, as far as I can tell, there are no error reports of any kind after these crashes.
My System SpecsSystem Spec

 BSOD on boot-up and shut-down.

Thread Tools

Similar help and support threads
Thread Forum
BSOD - Occurs during Shut Down Process. Shut Down hangs then crashes
Hey there, Lenovo E440 that ran excellent until recently. About a week or two ago I got an error message about a power surge on a USB port. Didn't really seem to effect much so I moved on. Lately, when shutting down, it hangs for a few minutes... just sitting at the final "Shutting Down"...
BSOD Help and Support
Random Shut Down, Won't Boot Sometimes
When I boot up my older PC it won't boot sometime and BSOD on me. I did a memory test and power test to see if they were the issues but all has pass. I attach my file as a zip and rar and like to see if anybody can fine other issues I can't. :/
BSOD Help and Support
BSOD on boot every time after I shut down, error 0x00000024
Hi everyone, I've had this problem for a while and it drives me nuts. Every time I shut down my computer it will crash the next time I power up and try to boot windows 7. I can go in and out of sleep or hibernate without issue but if I ever shut down my system it will BSOD during the next...
BSOD Help and Support
PC wont boot after being shut off
My PC froze so I was forced to shut off by holding power button for 8 seconds. When i tried to reboot I got some boot error. I took the drive out (Im assuming by now partition table is messed up so I want to load some partition recovery tool) and i put the drive in an enclosure and hooked it up...
BSOD Help and Support
Computer won't re-boot after shut down
I can get my computer booted only after clearing the bios with the jumper and renewing the BOS settings. Then when it is powered down it won't complete a bootup. It will POST and complete memory test but then won't seek the OS to boot Win 7. This has just started a few days after upgrading Vista to...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:16.
Twitter Facebook Google+