Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD, unable to determine exact cause

30 Jun 2013   #1

win7 prof 64bit
BSOD, unable to determine exact cause

Been receiving numerous BSOD for months. I never was able to determine the exact cause the first time. Most of the time the error occurs during a game such as Skyrim, Diablo 3. However, sometimes the error happened when watching videos on YouTube or even while idle.

Every time I thought I fixed it, I get a new one. Most of the time it was IRQ less than or equal. I swapped to an older card and it was less frequent, but still got them. Im back to the original card and still get the errors. Sometimes going days without errors, sometimes cant even go 20 minutes without one.

Im a bit lost in the dark on this one, documentation on the web point every direction, blaming video drivers, windows programs and even wireless adapters.

My System SpecsSystem Spec
30 Jun 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

The TP link network adapter is old.
fffff880`05e09000 fffff880`05fe7000   athurx     (deferred)             
    Image path: \SystemRoot\system32\DRIVERS\athurx.sys
    Image name: athurx.sys
    Timestamp:        Wed Apr 20 15:37:45 2011 (4DAEB071)
    CheckSum:         001E1C78
    ImageSize:        001DE000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Update it from Download - Welcome to TP-LINK , by matching your device number.

And, Disable USB Selective Suspensd too.
USB Selective Suspend - Turn On or Off

Let us know the results.
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {74, 2, 1, fffff88005672cec}

Probably caused by : usbohci.sys ( usbohci!OHCI_ProcessDoneIsoTd+30 )

Followup: MachineOwner

5: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 0000000000000074, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, value 0 = read operation, 1 = write operation
Arg4: fffff88005672cec, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff800030af100
GetUlongFromAddress: unable to read from fffff800030af1c0
 0000000000000074 Nonpaged pool


fffff880`05672cec 014674          add     dword ptr [rsi+74h],eax





TAG_NOT_DEFINED_c000000f:  FFFFF880030B7FB0

TRAP_FRAME:  fffff880030b0930 -- (.trap 0xfffff880030b0930)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=00000000ffffffff rbx=0000000000000000 rcx=fffffa8006aeb6a0
rdx=fffff88008678280 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88005672cec rsp=fffff880030b0ac0 rbp=fffffa8007822f06
 r8=000000004f444601  r9=fffff88008678280 r10=00000000ffffffff
r11=fffff880030b0b28 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na po cy
fffff880`05672cec 014674          add     dword ptr [rsi+74h],eax ds:00000000`00000074=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002e771a9 to fffff80002e77c00

fffff880`030b07e8 fffff800`02e771a9 : 00000000`0000000a 00000000`00000074 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`030b07f0 fffff800`02e75e20 : fffffa80`06a7a1a0 fffffa80`06a7a101 fffffa80`0708da00 00000000`00000000 : nt!KiBugCheckDispatch+0x69
fffff880`030b0930 fffff880`05672cec : fffffa80`0529d840 00000000`00000001 fffffa80`06a7a101 fffff880`053bdea0 : nt!KiPageFault+0x260
fffff880`030b0ac0 fffff880`05672f7d : 00000000`00000004 fffff880`08678080 fffffa80`06aea101 fffffa80`056fa648 : usbohci!OHCI_ProcessDoneIsoTd+0x30
fffff880`030b0b30 fffff880`05675744 : fffffa80`056fa648 fffffa80`056fa400 fffffa80`06aea1a0 00000000`ffffff02 : usbohci!OHCI_PollIsoEndpoint+0x101
fffff880`030b0b80 fffff880`05391e8b : 00000000`00000002 fffffa80`056fa400 fffffa80`06aea1a0 00000000`00000000 : usbohci!OHCI_PollEndpoint+0x4c
fffff880`030b0bb0 fffff880`053969d1 : 00000000`00000040 00000000`00000004 fffffa80`056fa400 fffffa80`06aea050 : USBPORT!MPf_PollEndpoint+0x9b
fffff880`030b0be0 fffff880`053a2077 : fffffa80`06aea1a0 00000000`00000040 fffffa80`0000000e 00000000`00000000 : USBPORT!USBPORT_iSetGlobalEndpointStateTx+0x7c1
fffff880`030b0c40 fffff880`05392f89 : fffffa80`06aea050 00000000`00000000 fffffa80`06aeaa02 fffffa80`06aeaa18 : USBPORT!USBPORT_Core_UsbHcIntDpc_Worker+0x1c3
fffff880`030b0ca0 fffff800`02e822fc : fffff880`03088180 fffffa80`06aeaa18 fffffa80`06aeaa30 00000000`00000000 : USBPORT!USBPORT_Xdpc_Worker+0x1d9
fffff880`030b0cd0 fffff800`02e6f90a : fffff880`03088180 fffff880`03093040 00000000`00000000 fffff880`05392db0 : nt!KiRetireDpcList+0x1bc
fffff880`030b0d80 00000000`00000000 : fffff880`030b1000 fffff880`030ab000 fffff880`030b0d40 00000000`00000000 : nt!KiIdleLoop+0x5a


fffff880`05672cec 014674          add     dword ptr [rsi+74h],eax


SYMBOL_NAME:  usbohci!OHCI_ProcessDoneIsoTd+30

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: usbohci

IMAGE_NAME:  usbohci.sys


FAILURE_BUCKET_ID:  X64_0xD1_usbohci!OHCI_ProcessDoneIsoTd+30

BUCKET_ID:  X64_0xD1_usbohci!OHCI_ProcessDoneIsoTd+30

Followup: MachineOwner

5: kd> lmvm usbohci
start             end                 module name
fffff880`05671000 fffff880`0567c000   usbohci    (pdb symbols)          c:\symbols\usbohci.pdb\45ADE9C11E264B08BFCF9E0A1B4D27C01\usbohci.pdb
    Loaded symbol image file: usbohci.sys
    Mapped memory image file: c:\symbols\usbohci.sys\4D8C0BFFb000\usbohci.sys
    Image path: \SystemRoot\system32\DRIVERS\usbohci.sys
    Image name: usbohci.sys
    Timestamp:        Fri Mar 25 08:59:03 2011 (4D8C0BFF)
    CheckSum:         00008443
    ImageSize:        0000B000
    File version:     6.1.7601.17586
    Product version:  6.1.7601.17586
    File flags:       0 (Mask 3F)
    File OS:          40004 NT Win32
    File type:        2.0 Dll
    File date:        00000000.00000000
    Translations:     0409.04b0
    CompanyName:      Microsoft Corporation
    ProductName:      Microsoft® Windows® Operating System
    InternalName:     USBOHCI.sys
    OriginalFilename: USBOHCI.sys
    ProductVersion:   6.1.7601.17586
    FileVersion:      6.1.7601.17586 (win7sp1_gdr.110324-1501)
    FileDescription:  OHCI USB Miniport Driver
    LegalCopyright:   © Microsoft Corporation. All rights reserved.
My System SpecsSystem Spec
04 Jul 2013   #3

win7 prof 64bit

No new drivers avail for tp link, I just got in my new adapter today and installed. So I will post back if BSOD happens again
My System SpecsSystem Spec

04 Jul 2013   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Good luck :)
Let us know how the computer is working with the new adapter?
My System SpecsSystem Spec
17 Aug 2013   #5

win7 prof 64bit

Tried 2 new devices for up to 300mbs. I cant seem to find one that has any driver update since 2011.

The latest one doesn't crash as often and connection strength is great. My only alternative I can think of is to switched to a wired connection, but I cant at the moment.
My System SpecsSystem Spec
18 Aug 2013   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

I think you are right.

The driver is developed by Atheros, but the device is sold by TP Link. So nobody have the updates.
One more thing you may do ... to get a new adapter, which is made and marketed by the same vendor and so updates will be available over a reasonably long time.
My System SpecsSystem Spec
06 Sep 2013   #7

win7 prof 64bit

Went completely away from wireless this time, even to the point of disabling window's application for controlling the device.
I went to a wired connection and no bsod for about a week. Just last night got 2 more of the same crash. uploaded my updated logs including the two new crashes.
My System SpecsSystem Spec
06 Sep 2013   #8

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Some problem with the USB drivers. Upload the list of all the third party drivers Using NirSoft DriverView :
  • Download and execute Driverview
  • View > Hide Microsoft Drivers
  • Edit > Select all
  • File > Save Selected Items
  • In the Save dialog, Set the path to desktop, Put "Driverview" in the name field, and save.
  • Zip the .txt file and upload it.
My System SpecsSystem Spec
07 Sep 2013   #9

win7 prof 64bit

ok here it is
My System SpecsSystem Spec
07 Sep 2013   #10

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Update the AMD chipset driver for Windows 7. AMD Chipset Drivers
This package is for motherboards with 700 series or newer AMD chipsets, and includes:
AMD Chipset Drivers
AMD USB 3.0 Driver
My System SpecsSystem Spec

 BSOD, unable to determine exact cause

Thread Tools

Similar help and support threads
Thread Forum
WEI Unable to determine memory performance Error
W7X64 Pro ASUS X99-DELUXE CPU5960X DDR4 Crossair 2800Mhz GTX750Ti/K5000/K20 M.2 Plextor 256GB Extended Drive System C: + Xp941 System C: 512 GB WD Black2TB X3 XT750GB X2 When I run Windows performance Index
Performance & Maintenance
Strange BSODs, Unable to Determine Cause Alone
Occasionally, my entire system will just hang and either be forced to restart, or, very rarely, it will be able to regain control and continue working. I've ran memtest and memtestx86 to determine if the cause is my ram, but both tests showed the ram is working fine. The cause could be my GPU, an...
BSOD Help and Support
BSOD Unable to determine origin
Heya! I seem to be getting the BSOD when playing games, most recently during a game of Dota2. When the BSOD does occur my computer hangs and a weird, electronic - it's hard to describe - whining sound comes through the speakers. I've run the SF_Diagnostic_Tool.exe as per the...
BSOD Help and Support
Unable to Determine BSOD Cause. Occurs Randomly
I built this computer about a year ago. Things were running smooth up until recently. I m usually pretty good at figuring out what is causing Errors on my computers but I cannot figure out what is causing this one. I do see kernel Errors in the event log but that is only about a bug check after it...
BSOD Help and Support
"Setup was unable to determine...BitLocker"
While attempting to do an upgrade from Vista Home Premium 64 bit to Windows 7 Home Premium 64 bit I get the following message; "Setup was unable to determine if BitLocker Drive Encryption is in use." The only option then is to cancel the upgrade. I've tried installing 3 times now with the same...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:25.
Twitter Facebook Google+