Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD running Plex Media Server, now NIC not working and locking up

10 Jul 2013   #1

Windows 7 Ultimate x64
BSOD running Plex Media Server, now NIC not working and locking up

OK, I've been doing a fresh install of Windows 7 x64 and had almost finished installing all the software, when I found it would BSOD whenever I tried to run Plex Media Server, which scans certain folders to build a media database. Running defrag didn't cause any problems, so it didn't seem to be an issue with accessing the disk as such.

I posted the dump from that BSOD at the Plex forum and someone looked at it for me and advised:

This is memory corruption in kernel mode. Nothing to do with Plex.

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is
caused by drivers that have corrupted the system pool.  Run the driver
verifier against any new (or suspect) drivers, and if that doesn't turn up
the culprit, then use gflags to enable special pool.The crash appears to be a null dereference, which suggest a software bug rather than bad memory. But I'd suggest running memtest anyway.
fffff800`033c2b05 4c395808        cmp     qword ptr [rax+8],r11




TRAP_FRAME:  fffff880031857d0 -- (.trap 0xfffff880031857d0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=fffff8000341da50
rdx=fffff88009841450 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800033c2b05 rsp=fffff88003185960 rbp=0000000000000000
 r8=0000000000000000  r9=fffff88009841c90 r10=0000000000000001
r11=fffff88009841ca0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz ac po cy
fffff800`033c2b05 4c395808        cmp     qword ptr [rax+8],r11 ds:00000000`00000008=????????????????

Unfortunately, these tend to be fairly hard to track back to a specific driver. You can use the driver verifier to pinpoint the issue further (at the risk of exposing new issues). My general suggestion is to revert to inbox or WU drivers, as those tend to be more tested/stable.
This is the 063013-36535-01.dmp in the attached zip.

Since then, I disabled a BIOS option "SATA IDE Combined Mode". I have no idea what it's for but after disabling it, I didn't get any more BSOD when running Plex, although it did crash.

Everything was looking up until last night, when the onboard NIC stopped working. It still showed as OK in Device Manager but just insisted that the "Network Cable Disconnected". I first had the same problem a few months ago when I plugged in a CF Card IDE adapter. I have no idea why plugging something into the IDE port would affect the NIC but it did and started working again as soon as I disconnected the adapter.

Yesterday, I'd connected up an IDE HDD and ODD (actually I only had power to the ODD) but the NIC didn't stop working until several hours later. I disconnected the IDE cable from the motherboard but this time it didn't get the NIC working again.

This morning I ran a LAN test from the BIOS which confirmed the cable was fine. I also disabled the "Aggressive Link Power Management" option in the BIOS in case that was causing the NIC problem. Then I booted into a Win 7 x86 VHD I use for diagnostic purposes. After installing the NIC driver, which I had stored on the HDD "AR813x_AR815x_v2.1.0.14_WHQL (Ethernet)", it worked fine in that. So I rebooted into my normal Win7 x64 install but it seems to have got worse overnight, whilst the PC was off! Now, although the mouse pointer still moves, I can't click on anything, such as Start or the notification tray, which I normally can and the system is basically frozen. On my second boot, the whole thing, including the mouse pointer froze up.

So I rebooted into safe-mode from where I'm typing this, obviously with a working NIC. I'm really hoping it's a driver/software thing that can be fixed as I've put a lot of time into setting up this system for my brother and it's getting hard these days to find another board that has the required onboard VGA/DVI, adequate PCI slots, IDE connector, etc.

My System SpecsSystem Spec
10 Jul 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hello doveman007.

First of all, I would suggest you to uninstall SoftPerfect Virtual Disk.

Name SoftPerfect Virtual Bus
Manufacturer KEG
Status OK
Driver c:\windows\system32\drivers\spvdbus.sys (, 132.99 KB (136,184 bytes), 28/06/2013 21:52)

Then, depending on the situation, we will decide our further steps.

Let us know the situation after uninstalling it.

* Edit: The network problem ... that's common with Comodo and networx installed. Uninstall networx. Uninstall Comodo, too. Use Microsoft Security Essentials as your antivirus with windows inbuilt firewall, and free MBAM as the on demand scanner.

Download, install and update those, and then run full system scans with both of them, one by one.
*** WARNING: Unable to verify timestamp for spvve.sys
*** ERROR: Module load completed but symbols could not be loaded for spvve.sys
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 1000007E, {ffffffffc0000005, fffff800033de308, fffff880009a9098, fffff880009a88f0}

Probably caused by : spvve.sys ( spvve+1b6ca )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Some common problems are exception code 0x80000003.  This means a hard
coded breakpoint or assertion was hit, but this system was booted
/NODEBUG.  This is not supposed to happen as developers should never have
hardcoded breakpoints in retail code, but ...
If this happens, make sure a debugger gets connected, and the
system is booted /DEBUG.  This will let us see why this breakpoint is
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff800033de308, The address that the exception occurred at
Arg3: fffff880009a9098, Exception Record Address
Arg4: fffff880009a88f0, Context Record Address

Debugging Details:

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

fffff800`033de308 488b4cc270      mov     rcx,qword ptr [rdx+rax*8+70h]

EXCEPTION_RECORD:  fffff880009a9098 -- (.exr 0xfffff880009a9098)
ExceptionAddress: fffff800033de308 (nt!IopPerfCompleteRequest+0x0000000000000058)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff

CONTEXT:  fffff880009a88f0 -- (.cxr 0xfffff880009a88f0)
rax=0000000000000000 rbx=fffffa8006dabc88 rcx=0000000000000000
rdx=00670061006e0061 rsi=fffff880009a9400 rdi=fffffa8006dabb70
rip=fffff800033de308 rsp=fffff880009a92d0 rbp=0000000000000000
 r8=0000000000000000  r9=fffffa80072ed000 r10=0000000000401802
r11=fffff880009a93a0 r12=0000000000000001 r13=ffffffff800000fc
r14=fffffa801b57c870 r15=000000000000001c
iopl=0         nv up ei ng nz ac pe cy
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010293
fffff800`033de308 488b4cc270      mov     rcx,qword ptr [rdx+rax*8+70h] ds:002b:00670061`006e00d1=????????????????
Resetting default scope





ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  ffffffffffffffff

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80003512100
GetUlongFromAddress: unable to read from fffff800035121c0

fffff880`02c426ca ??              ???


LAST_CONTROL_TRANSFER:  from fffff88002c426ca to fffff800033de308

fffff880`009a92d0 fffff880`02c426ca : fffffa80`1b5997f0 00000000`00000000 fffff880`009a9450 20206f49`00000001 : nt!IopPerfCompleteRequest+0x58
fffff880`009a9380 fffffa80`1b5997f0 : 00000000`00000000 fffff880`009a9450 20206f49`00000001 00000000`00000000 : spvve+0x1b6ca
fffff880`009a9388 00000000`00000000 : fffff880`009a9450 20206f49`00000001 00000000`00000000 fffff880`02c421d6 : 0xfffffa80`1b5997f0


SYMBOL_NAME:  spvve+1b6ca

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  spvve.sys


STACK_COMMAND:  .cxr 0xfffff880009a88f0 ; kb

FAILURE_BUCKET_ID:  X64_0x7E_spvve+1b6ca

BUCKET_ID:  X64_0x7E_spvve+1b6ca

Followup: MachineOwner

0: kd> lmvm spvve
start             end                 module name
fffff880`02c27000 fffff880`02c90000   spvve    T (no symbols)           
    Loaded symbol image file: spvve.sys
    Image path: \??\C:\Program Files\SoftPerfect RAM Disk\spvve.sys
    Image name: spvve.sys
    Timestamp:        Fri May 31 10:15:01 2013 (51A82ACD)
    CheckSum:         0006FFD2
    ImageSize:        00069000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
0: kd> lmvm spvdbus
start             end                 module name
fffff880`03f60000 fffff880`03f85000   spvdbus    (deferred)             
    Image path: \SystemRoot\system32\DRIVERS\spvdbus.sys
    Image name: spvdbus.sys
    Timestamp:        Fri May 31 10:15:00 2013 (51A82ACC)
    CheckSum:         00028B1A
    ImageSize:        00025000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
10 Jul 2013   #3

Windows 7 Ultimate x64

Hi Arc

Thanks for your help.

I booted into Safe Mode and uninstalled SoftPerfect and Networx. I couldn't uninstall Comodo as it requires the MSI installer which is not available in Safe Mode. After that, I was able to boot normally and am typing this from there.

I wonder if disabling that "Aggressive Link Power Management" BIOS option confused Windows and caused it to start locking up and maybe it's adjusted now. Anyway, someone has advised me that he's had nothing but severe problems with that option enabled and disabling it is one of the first things he does, so I think it's best I leave it disabled, even though I'm not sure what it does. I wonder if it's connected to the option in Windows Power Schemes "PCI Express - Link State Power Management" which defaults to "Moderate Power Savings". This can be changed to Off but I'm not sure if having that BIOS option disabled makes this setting irrelevant anyway.

I need to keep Comodo really, as whilst far from perfect in the way it adds rules to the top, rather than the bottom of the list, it's the only decent free firewall I've found. I find Windows Firewall totally non-user friendly and I don't think it even gives alerts for outgoing connections. I'll uninstall it for now of course though if you need me to before you can help me diagnose my problems.

I really don't like MSE either I'm afraid. I can't remember exactly why but I know I've tried it and found a few things about it rather annoying. I could go back to Avira antivir which is what I was using before Avast was recommended to me but for now, I'll do without an antivirus whilst we try and sort things out.

I wanted to use Networx as my brother has a monthly download limit so it would have been useful to him to keep track of his usage but if it causes problems he'll just have to do without it.

I'll need some RAMDisk on there, mainly for MediaPortal as it constantly creates Timeshifting files whilst watching TV and I don't want them on the HDD to reduce wear and also keep the noise down. Softperfect benchmarks a lot faster but I could use the AMD RAMDisk instead, which is just a branded version of DataRAM Ramdisk RAMDisk - Software - Server Memory Products & Services - Dataram which allows larger RAMDisks than the freeware product. I've used that before (and still do on another PC) without any problems (not that SoftPerfect has caused me any problems on my other PC). Anyway, I'll leave that off for now as well.

I'm doing the MBAM scan now. Please let me know if you need me to do the MSE scan, even if I won't be keeping it installed once we've finished.
My System SpecsSystem Spec

10 Jul 2013   #4

Windows 7 Ultimate x64

Here's the MBAM scan:

Malwarebytes Anti-Malware

Database version: v2013.07.10.07

Windows 7 Service Pack 1 x64 NTFS
Internet Explorer 10.0.9200.16618
Steve :: STE-PC [administrator]

10/07/2013 20:52:51
MBAM-log-2013-07-10 (21-42-17).txt

Scan type: Full scan (C:\|D:\|)
Scan options enabled: Memory | Startup | Registry | File System | Heuristics/Extra | Heuristics/Shuriken | PUP | PUM
Scan options disabled: P2P
Objects scanned: 438812
Time elapsed: 44 minute(s), 11 second(s)

Memory Processes Detected: 0
(No malicious items detected)

Memory Modules Detected: 0
(No malicious items detected)

Registry Keys Detected: 0
(No malicious items detected)

Registry Values Detected: 0
(No malicious items detected)

Registry Data Items Detected: 0
(No malicious items detected)

Folders Detected: 0
(No malicious items detected)

Files Detected: 5
C:\ProgramData\Team MediaPortal\MediaPortal\Installer\V2\9b9bc24e-69ca-4abc-8810-f8f95bd4bbe6\\9b9bc24e-69ca-4abc-8810-f8f95bd4bbe6.mpe2 (Trojan.Clicker.M) -> No action taken.
C:\ProgramData\Team MediaPortal\MediaPortal\Installer\V2\9b9bc24e-69ca-4abc-8810-f8f95bd4bbe6\\9b9bc24e-69ca-4abc-8810-f8f95bd4bbe6.mpe2 (Trojan.Clicker.M) -> No action taken.
D:\$RECYCLE.BIN\S-1-5-21-1074606757-3784109166-4096876264-1003\$RU1IGBJ.dll (Malware.Packer.Gen) -> No action taken.
D:\$RECYCLE.BIN\S-1-5-21-1074606757-3784109166-4096876264-1003\$RLIU599\StartupRun.exe (PUP.StartUpManager) -> No action taken.
D:\$RECYCLE.BIN\S-1-5-21-4142153632-2294863933-3660688552-1000\$RH4H5G3.dll (Trojan.Clicker.M) -> No action taken.

I'd be surprised if the MediaPortal files aren't false positives and I probably shouldn't remove them in case they're needed for something (I'll ask in the MediaPortal forum about them). I've removed the other files from the Recycle Bin though.
My System SpecsSystem Spec
10 Jul 2013   #5

Windows 7 Ultimate x64

I've noticed I haven't installed the AMD Chipset drivers yet, so maybe I should do that? I've got the 13.1 Legacy graphics card drivers installed (for my onboard HD4250) but I guess I should install the chipset drivers for the AMD SATA driver (currently have the "Standard AHCI 1.0 Serial ATA Controller" installed.

I checked the installed drivers for my other devices and found there's some updates available

SATA3 - 2 x SATA3 6.0 Gb/s connectors by ASMedia ASM1061, support NCQ, AHCI and Hot Plug functions
Installed v1.3.9.0 (17/09/2012), latest (04/07/2013)

USB 3.0 - 2 x USB 3.0 ports by ASMedia ASM1042, support USB 1.0/2.0/3.0 up to 5Gb/s
Installed v1.16.2.0 (20/08/2012) latest (06/03/2013)

USB3.0 Firmware (not sure of installed version), latest version 120816-02-02-06D (V3) (16/04/2013) (Origine Asus)
ASMEDIA drivers & firmwares

LAN - PCIE x1 Gigabit LAN 10/100/1000 Mb/s - Atheros AR8151
Installed v2.1.0.13 (14/12/2012), latest v2.1.0.15
Latest Qualcomm Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20) Driver...

I won't install anything until you ask me to though :)

EDIT: By the way, which dump was that BSOD analysis you did from. Was it the 063013-36535-01.dmp associated with the first BSOD I had, when launching Plex or another one? As it refers to the SoftPerfect driver, I feel I should inform them about it in case there's anything they need to do to avoid this happening in future, so the more information I can give them about the circumstances in which it happened the better.
My System SpecsSystem Spec
10 Jul 2013   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Let us know how it is running after following the suggestions. If there are further BSODs, upload the dumps as per BSOD posting instruction.

When the situation is stable, any question is welcome ... but before that, the single point objective is to fix the issue.

Apparently the start blockage was caused by the fake SCSI adapter installed by SoftPerfect. Its the common nature of those programs.

I usually check the latest ones, did the same here too.
My System SpecsSystem Spec
11 Jul 2013   #7

Windows 7 Ultimate x64

Thanks. It seems to be OK at the moment.

I uninstalled Comodo for now, partly to see if it was causing the high latency issues. It wasn't but that's another issue.

I guess I'll try running Plex again and see if it works OK now. If so, I'll install the AMD Chipset drivers and then maybe update the others. Then I'll have to try plugging in the IDE devices again and see if it behaves itself.

I reported the issue to SoftPerfect and will send them the last dump if requested.
My System SpecsSystem Spec
11 Jul 2013   #8

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

About SoftPerfect, it is not present in the dump. Nobody can say it with certainty seeing those that it is SoftPerfect that is causing the issue. But you can see the difference having softperfect uninstalled.

It is the nature of the program that those programs (all of them of this type) are problematic in the same way.
My System SpecsSystem Spec
11 Jul 2013   #9

Windows 7 Ultimate x64

Sorry, I thought I saw references to spvve.sys if not spvdbus.sys in the dump. Did I misunderstand?
My System SpecsSystem Spec
11 Jul 2013   #10

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

I havent got a fulproof that spvve.sys is an element of SoftPerfect; and that driver was not found within the system at verification other than the dumps.

I just conclude by the similarity of name and the exactly same driver date. From my part, it was an attempt to make a decision; when I know it that all the virtual CD emaluator programs does some mishap during boot up.

spvdbus.sys is present in the system, but never pointed out in the dumps as a failing element. I just checked the date of it, to draw the inference.

If you have the surity that it is the element of SoftPerfect, it gives the proof.

BTW, how the system is running? Any more issues?
My System SpecsSystem Spec

 BSOD running Plex Media Server, now NIC not working and locking up

Thread Tools

Similar help and support threads
Thread Forum
BSODs at random, generally with Plex Media Server running
My hypothesis is that the BSODs I've been getting have something to do with Plex. They started about a month after I installed Plex, and have been happening irregularly since then. Here's the list of BSODs from the Event Viewer (if that isn't in the thing I uploaded, very nifty tool btw). ...
BSOD Help and Support
Plex Media Server port forwarding issue
Hi everyone dont really know staff which section this would go into, so I'm sorry if I posted in the wrong place. I am having so much problems trying to connect the Plex Media Server to my PC for my remote access. I've tried opening up a ports through my router and still no avail. I...
Network & Sharing
BSOD While Running Plex Media Server
I just built a media server and after I installed Plex Media Server, the system will either freeze or goto BSOD sometimes within minutes and other times after a few hours (idle or in use) if Plex Media Server is running. I exited out of Plex Media Server, ran Prime95 for 12 hours and no problems. ...
BSOD Help and Support
BSOD when downloading torrents, and running Plex
I have been experiencing some BSOD as I am downloading torrents on my laptop that is "running" as a media server for Plex. I tried analyzing the .dmp files, but I am not too knowledgeable, so I'm just going to upload them here, hopefully someone can help me figure it out. These are all .dmps from...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:03.
Twitter Facebook