Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win7 x64 Bluescreen when inserting Lexar JD FireFly 8gb

18 Oct 2009   #1

Windows 7 x64 RTM
Win7 x64 Bluescreen when inserting Lexar JD FireFly 8gb

Hi all,

My usually stable x64 RTM install , bluescreens whenever i insert my Lexar JD FireFly 8gb USB stick. This stick works in other systems and OSes without issue. This stick also works under Win7 x86 7100 build, in my other PC (Asus). My x64 RTM build is on a GA-EX58 UD5 / i7 920 system.

If i boot the system with the USB aready inserted, all seems fine, it is only when i insert USB into the already running OS. I tried a reformat of the USB, in the EX58 , which seemed to cure the problem for a short while, but it happend again, yesterday. Other brand USB sticks and USB HDD's i have tried, have not exhibited this issue.

Any suggestions on further troubleshooting, or should i cut my losses and purchase another brand USB stick?

My System SpecsSystem Spec
18 Oct 2009   #2

64-bit Windows 8.1 Pro

Check your Device Manager and make sure that all of your USB entries have the appropriate drivers installed.. if any have the dreaded yellow triangle, update the driver....
My System SpecsSystem Spec
18 Oct 2009   #3
Microsoft MVP


Please zip up the contents of the C:\Windows\Minidump directory and upload/attach the .zip file with your next post.
My System SpecsSystem Spec

21 Oct 2009   #4

Windows 7 x64 RTM

Sorry, been away from PC for a day or two..

Minidump and BSOD attached.
Regards Gary
My System SpecsSystem Spec
21 Oct 2009   #5


Update or remove this (Acronis?) driver and the crashes will very probably stop:

Image name: tdrpm251.sys
Timestamp: Fri Jul 31 23:59:53 2009 (4A72F8D9)
My System SpecsSystem Spec
22 Oct 2009   #6

Windows 7 x64 RTM

Something wrong with my version of acronis ?
My System SpecsSystem Spec
22 Oct 2009   #7


Quote   Quote: Originally Posted by garfin View Post
Something wrong with my version of acronis ?
"Wrong" is a moral judgement. In BSOD-land we don't do morals or judgements - only "likely crash causes" :)

Here's the stack of the offending thread:

Child-SP RetAddr Call Site
fffff880`081efd28 fffff800`0290b1e4 nt!KeBugCheckEx
fffff880`081efd30 fffff800`02889fee nt! ?? ::FNODOBFM::`string'+0x42907
fffff880`081efe90 fffff800`02b6efb9 nt!KiPageFault+0x16e
fffff880`081f0020 fffff800`02b700ba nt!ObpQueryNameString+0x51
fffff880`081f0120 fffff880`01cd20c8 nt!ObQueryNameString+0xe
fffff880`081f0160 fffff880`00000009 tdrpm251+0x4c0c8
fffff880`081f0168 00000000`00000001 0xfffff880`00000009
fffff880`081f0170 00000000`00000001 0x1
fffff880`081f0178 00000000`00000000 0x1

The tdrpm251 driver was attempting to parse the name of some object, but it apparently passed in a bad buffer to the Object Manager (Ob*) routines. The version of tdrpm251 that's on your machine is the one whose timestamp I've already posted. Perhaps there's an updated build by now.

Since you can readily reproduce the crash, it ought to be relatively straightforward to test whether removing Acronis does the trick. If not, please upload more minidumps.
My System SpecsSystem Spec

 Win7 x64 Bluescreen when inserting Lexar JD FireFly 8gb

Thread Tools

Similar help and support threads
Thread Forum
Lexar 3.0 usb device
WpdBusEnumRoot\UMB\2&37c186b&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_LEXAR&PROD_CF__USB_3_0_READ&REV_0545#000000003455&0# windows seems to be asking for a driver, but the manufacturer dosn't supply one, what can I do to get this warning out of event viewer.
Can a Lexar Media 64 GB SDXC Flash Memory Card LSD64GCRBNA133
be used to replace or backup the 64 gb SSD that contains my operating system? This is what I currently have: TOSHIBA Qosmio X505-Q898 Windows 7 Home Premium x64 Service Pack 1 Thanks in advance for any answers. Best regards, boidsonly
Hardware & Devices
no windows 7 'firefly' boot animation
hey! i have a problem that started happening about 2 days ago, when i boot windows 7 (ultimate x64) i dont get the boot animation,instead i get 8 blue dots in the top left corner of my screen,and then it boots normally,i can live with it if it cant be fixed,but if it can i would rly like to fix...
General Discussion
Lexar Card Reader (recently) not listed as Drive in Explorer
I have a Lexan dual-slot card reader that I use for downloading my photo's to my computer. I've had this for over a year and since I installed it, I would always see the drive letters listed in Explorer. Recently, I tried to download some pictures and when I went to click on the drive letter to...
Hardware & Devices
Win7 Ultimate BSOD when inserting USB Drive
It doesnt happen everytime, but most times. Whether powered by battery or AC. See attached files. Is Windows 7 . . . - x86 (32-bit) or x64 ? 32 - the original installed OS on the system? Upgrade from Vista - an OEM or full retail version? Retail - OEM = came pre-installed on system. No...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App