Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Damaged/unsigned AHCIX64S.SYS driver after unistalling AMD Catalyst

31 Jul 2013   #1

Windows 7 Home Premium 64 bit
Damaged/unsigned AHCIX64S.SYS driver after unistalling AMD Catalyst

Hi there,

I will keep things short first, if anybody per chance knows this problem right from the start and how to solve it quickly. If u need more details on what I have tried so far or more details about my system. Just ask then i will provide all info I have. But I don't want that you read until you die...

Well it ain't a bluescreen but a Windows Boot Manager Error message during boot up of my Windows 7 64 bit Home Premium:

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:

1 Insert cour Windows istallation disc ... blah
2 blabla
3 blabla -> "Repair your computer"

(Now the important part)

File: \ Windows \ system32 \ DRIVERS \ ahcix64s.sys

Status: 0xc0000428

Info: Windows can not verify the digital signature for this file.

This came directly after a reboot which I had to make after using the AMD Catalyst removal tool to remove my AMD Catalyst drivers 11.2 to install Version 13.4 because I couldnt uninstall via "Software" or reinstall the new drivers simply. So basically what happened is that the removal tool removed more than only my graphic card drivers. Safe mode wont work, its a more fundamental problem i suppose.
If I chose to "Disable Driver Signature Enforcement" via F8 Boot menu then there indeed is a Blue Screen
with Error code 0x0000007B (INACCESSIBLE BOOT DEVICE) which again points to the fact that the HD/RAID/AHCI drivers have problems initialising because they have been removed/manipulated by the Catalyst Removal tool.

I tried the Windows Recovery Automatic Repair tool but it wouldn't find my Windows installation.

I have a RAID0 on my system HD for which I always need to preload (F6) the RAID drivers before I install W7 on my computer, one time only of course. So in the Windows Recovery mode there is an option to "Load drivers" if the HD with the system is not found. I did download the drivers again from MSI and burnt them on CD (I didnt find my old one). I loaded the drivers and then he acutally FOUND my partitions and i could access the filesystem at the W7 Recovery Environment (Command Prompt i.e., or via "Open File" dialogue when trying to load more drivers). I retried the automatic repair procedure but it again failed with a "Bad driver" error in the detailed error description.

A possibilty would be of course to install W7 again with preloading the drivers and have my old Windows moved to a folder "windows.old". I started the setup routine and preloaded the driver, he found my partitions and even found the Windows installation. But I dont want to do this because it means I lose all my settings and profile information which is in my case very much work to resetup.

Do you know of any simple possibility to repair the AHCI driver without being able to login.
Or how to install it if I have the .inf file and the sys file and all the media needed. Can I inject this somehow? Do I need to offline edit the registry for this? Is there a possibility including a Linux Boot Disc?

I mean there has to be a simple trick to repair this because it even has access to the HD because I have the possibiliy to go to the F8 menu and chose "Safe mode" for example. Then during the "Loaded driver: xxx.sys" listing it will move through many drivers and show them as loaded. Then hangs and gives the initially stated error message. It's of course the same error I get when i try to start windows normally.
Only then I can even see the W7 logo screen (Starting windows) until the error appears.

Please help me I am so desperate.


EDIT: report from removal tool attatched. open to see the successfully deleted modules.
i dont know WHICH of them is responsible for the shit now...

My System SpecsSystem Spec
31 Jul 2013   #2
x BlueRobot


ahcix64s.sys is for your RAID controller, you could try downloading the driver from here - AMD Support Search

This may work - SATA Drivers - Load in Windows Recovery Options or SATA Driver - Load in Windows 7 or Vista Setup

Otherwise, I would attempt booting into your system with and recovering all your important data and files, and then attempting a clean install with Clean Install Windows 7
My System SpecsSystem Spec
31 Jul 2013   #3

Windows 7 Home Premium 64 bit


Thank you, first of all.

As written in the text, I did already download the newest ahci drivers and loaded 'em like in your tutorial.
This didnt work. And a new installation was not out of question but I couldn't simply accept the fact that because
of one single uninstalled AHCI driver my comp wouldnt boot up anymore.

So i fizzled around a bit and finally got a solution which I want to share for those who may encounter the same problem
when using this beastly tool of AMD to uninstall their Catalyst (NEVER DO USE THIS...I now found out there are way better 3rd party removal tools for graphic card drivers than this 2MB piece of crap...).


I also had to xcopy the driver files from the CD which I burnt before with the fresh drivers on it. I copied them in the Windows\System32\Drivers folder and overwrote the old (actually it was the same file size and date but still...)
This alone would not do it.
So afterwards I had to disable the digital signature check in addition to that. And still it was not enough.
Finally I did xcopy the old registry files (1 week old) from \Windows\System32\Config\RegBack and overwrote the originals.

These 3 steps were the solution to my problem. I could logon normally and just had to install the fresh graphic card drivers and I also reinstalled my AMD chipset drivers just to make sure everything is installed and up to date again.

My System SpecsSystem Spec

01 Aug 2013   #4
x BlueRobot


Glad you were able to solve your problem :)

I always recommend Driver Sweeper for removing old drivers.
My System SpecsSystem Spec

 Damaged/unsigned AHCIX64S.SYS driver after unistalling AMD Catalyst

Thread Tools

Similar help and support threads
Thread Forum
Unsigned Driver Error... how do i fix it?
I'm using a PC running Windows 7 Professional x64. I tried to install the dongle & software for a Kensington Expert Wireless Trackball and got a "Unsigned Driver Error" message from Windows. Is there a workaround for this? (Kensington tells me it's a Windows issue) I'm not very computer savvy...
Using an unsigned driver in Win 7 x64. Can I sign the driver myself?
I have a program that has a driver for Windows 7 x64. For various reasons this driver is unsigned. I know the manufacturer and it's safe. I know that I can put computers into test mode to load the unsigned driver but I'm concerned that mode allows any other unsigned driver to load. Is there a...
some my icons are damaged after unistalling MY COLORS theme
guyz its seems that some of my windows 7 default icons are damaged after i unistalled the MY COLORS theme by Stardock..:confused:...the icons of my hard disk are showing a red cross mark and me shortcut icon now looks horrible......someone pleazzz help mee
Themes and Styles
Problem with unsigned driver I can't fix
Hello, I'm running Windows 7 x64 since October without any problems. Yesterday I had to change the CPU cooler (and I cleared the CMOS) I found out that my TV tuner (twinhan DVB-T) drivers weren't installed anymore. I don't know if those two actions are linked somehow cause I had a system update...
Problem installing unsigned driver!!
I'm trying to install a BTTrace device driver for a wireless/bluetooth led on my Shuttle case. the problem i have is that the 64bit driver was built for xp 64, and therefore is not signed for windows 7. I have tried installing the driver in xp compatibility mode, but i get a message saying that the...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:03.
Twitter Facebook Google+