Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD 0x9F for a while and now started 0x1E at startup

03 Aug 2013   #1

Windows 7 Pro - 64-bit
BSOD 0x9F for a while and now started 0x1E at startup


I have been getting random 0x9F BSODs for a while now. I believe that it happens when the PC is waking up or when going to sleep. I have been unable to trace the cause of the fault. I understand that this is usually caused by a bad driver. The BSOD screen itself does not say which driver is causing it. I have not installed any new hardware or anything recently, so I have no clue what may be causing it.

To make things worse, today I have also started getting 0x1E BSOD. This happens as soon as I log in into Windows 7. Luckily, I can boot into safe mode. I am in safe mode right now! I understand that a 1E error is also related to driver issues. I'm assuming these two faults are related, and something is getting worse on my PC. Please see the attached SF Zip file (GREAT tool, btw!).

Thanks for your help in advance.

My System SpecsSystem Spec
03 Aug 2013   #2
x BlueRobot


BugCheck 9F, {3, fffffa8004737a10, fffff80004c61518, fffffa8005f339d0}

Probably caused by : pci.sys
This bugcheck indicates that a Device Object has been holding a IRP for too long, causing the a timeout.

0: kd> !irp fffffa8005f339d0
Irp is active with 3 stacks 2 is current (= 0xfffffa8005f33ae8)
 No Mdl: No System Buffer: Thread 00000000:  Irp stack trace.  
     cmd  flg cl Device   File     Completion-Context
 [  0, 0]   0  0 00000000 00000000 00000000-00000000    

			Args: 00000000 00000000 00000000 00000000
>[ 16, 2]   0 e1 fffffa8005428050 00000000 fffff800032ce200-fffffa8007ede280 Success Error Cancel pending
	      Unable to load image \SystemRoot\system32\DRIVERS\Rt64win7.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for Rt64win7.sys
*** ERROR: Module load completed but symbols could not be loaded for Rt64win7.sys
 \Driver\RTL8167	nt!PopSystemIrpCompletion
			Args: 00015400 00000000 00000005 00000003
 [  0, 0]   0  0 00000000 00000000 00000000-fffffa8007ede280    

			Args: 00000000 00000000 00000000 00000000
Okay, we can from the Major Function code of the current IRP, that the nature of the IRP is power transition related, hence why the bugcheck occurs when the computer is going to sleep or waking up. The IRP is currently being held by your network adapter driver.

0: kd> lmvm Rt64win7
start             end                 module name
fffff880`0346a000 fffff880`034a8000   Rt64win7 T (no symbols)           
    Loaded symbol image file: Rt64win7.sys
    Image path: \SystemRoot\system32\DRIVERS\Rt64win7.sys
    Image name: Rt64win7.sys
    Timestamp:        Thu Jul 30 12:58:43 2009 (4A718AF3)
    CheckSum:         000460F2
    ImageSize:        0003E000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Please check for any updates for your Realtek RTL8168D/8111D driver from here - Realtek

0: kd> !devobj fffffa8004737a10
Device object (fffffa8004737a10) is for:
 Cannot read info offset from nt!ObpInfoMaskToOffset
 \Driver\pci DriverObject fffffa8003cb9500
Current Irp 00000000 RefCount 0 Type 00000022 Flags 00001040
DevExt fffffa8004737b60 DevObjExt fffffa8004737f88 DevNode fffffa80047356e0 
ExtensionFlags (0x00000800)  DOE_DEFAULT_SD_PRESENT
Characteristics (0x00000100)  FILE_DEVICE_SECURE_OPEN
AttachedDevice (Upper) fffffa8005428050 \Driver\RTL8167
Device queue is not busy.
0: kd> vertarget
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.18113.amd64fre.win7sp1_gdr.130318-1533
Machine Name:
Kernel base = 0xfffff800`0300c000 PsLoadedModuleList = 0xfffff800`0324f670
Debug session time: Fri Aug  2 16:14:22.140 2013 (UTC + 1:00)
System Uptime: 8 days 21:55:39.687
You have Windows 7, yet your System Specifications say Vista, I would change that so you don't confuse other people.
My System SpecsSystem Spec
03 Aug 2013   #3

Windows 7 Pro - 64-bit

Thanks for your very quick response. I have updated my Realtek network driver. There was a new release just two days ago! However, after restarting the PC, I still got the 0x1E BSOD. I have reverted back to safe mode. Please see the latest dump file at 3:20pm in the attached zip file.

I have changed my System Spec to Windows 7. It was Vista from when I signed up here 2 years ago. :)
My System SpecsSystem Spec

03 Aug 2013   #4
x BlueRobot


BugCheck 1E, {ffffffffc0000005, fffff8000336371b, 0, c}

Probably caused by : ntkrnlmp.exe ( nt!CmpMarkValueDataDirty+1b )
Usual causes:  Device driver, hardware, System service, compatibility, Remote control programs, memory, BIOS
0: kd> !error ffffffffc0000005
Error code: (NTSTATUS) 0xc0000005 (3221225477) - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.
It seems like device drivers accessing invalid memory addresses.

0: kd> lmvm klif
start             end                 module name
fffff880`02000000 fffff880`020a5000   klif     T (no symbols)           
    Loaded symbol image file: klif.sys
    Image path: klif.sys
    Image name: klif.sys
    Timestamp:        Tue Mar 26 15:07:33 2013 (5151B9B5)
    CheckSum:         000A60C2
    ImageSize:        000A5000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Kaspersky Internet Security seems to be causing problems, please remove the program completely with the Kaspersky Removal Tool, and then install and run full scans with these free and proven alternatives which work best with Windows 7, due to their compatibility and lightweight nature on system resources.

Install and perform full scans with:
information   Information
Remember to install the free version of Malwarebytes not the free trail; untick the free trial box during installation. MSE is the most lightweight and compatible with the Windows 7 operating system

You can also view this thread for a complete free and lightweight security protection combination:
My System SpecsSystem Spec
03 Aug 2013   #5

Windows 7 Pro - 64-bit

I uninstalled Kaspersky as suggested and that has fixed the 0x1E BSOD. I think that Kaspersky was somehow corrupted when the last 0x9F BSOD occurred.

Anyways, now I have to just wait and see if I still get a 0x9F BSOD! As the fault occurs at random, I don't think there is anything I can do to force it. Let's hope that updating the netgear driver has fixed the issue.

Thanks for your invaluable time. Very highly appreciated. Top marks!
My System SpecsSystem Spec
04 Aug 2013   #6
x BlueRobot


Glad to be able to help, leave the thread open for about a week :)
My System SpecsSystem Spec

 BSOD 0x9F for a while and now started 0x1E at startup

Thread Tools

Similar help and support threads
Thread Forum
BSOD 0x1E at startup, no minidumps
Hello, I got a BSOD yesterday while working and listening to some music, but was able to restart the computer afterwards (in normal Windows mode). Today, I got a BSOD at startup, and restarting didn't help (getting BSOD every time). I can boot in Safe Mode, though. The BSOD message is as...
BSOD Help and Support
BSOD always on startup, started out with PAGE_FAULT_IN_NONPAGED_AREA
Just as I started up my PC this morning, It went normally until it we went into the Windows in starting screen, in which the computer flickers a bit and the BSOD shows up and said PAGE_FAULT_IN_NONPAGED_AREA. I tried doing safe mode and system restore but the blue screen still showed up, then...
BSOD Help and Support
Started getting different BSOD on Startup without doing anything
Hi all I have recently started to get regular BSOD when i start my PC for the 1st time on a day. I decided to install a fresh windows 7 on my spare HDD just to eliminate any potential driver update errors or programs that may cause BSOD. It seems to only be on a fresh startup for the day...
BSOD Help and Support
BSOD Started When Playing Skyrim, now on startup.
I was playing Skyrim when it first blue screened. Soon after, it blue screened when browsing. Now, it is blue screening over and over again on start up. Any help would be awesome, thanks. -------------- Problem signature: Problem Event Name: BlueScreen OS Version: ...
BSOD Help and Support
0X9F with pci.sys BSOD
Been getting BSOD on reboot. It's always a 0X9F and reading the dump it just says PCI.sys is the problem and that's where I get lost. Used the great SF Diagnostic Tool by Capt. Jack (thx Jack!) Attached are the files collected by SF Diagnostic Tool.
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:54.
Twitter Facebook