Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD "NDIS.sys" IRQL_NOT_LESS_OR_EQUAL > MS Virtual Wifi Miniport

08 Sep 2013   #1

Windows 7 Ultimate 32bit
BSOD "NDIS.sys" IRQL_NOT_LESS_OR_EQUAL > MS Virtual Wifi Miniport

Hi, I'm hoping someone can help me with a recent problem I ran into. My wifi router broke down and I thought as a workaround, use my laptop as a temporary wifi hotspot until I can purchase a new one. I was able to share my LAN connection but cannot pass the Internet access thru my ad-hoc. I found out that I need to enable the MS Virtual Wifi Miniport to be able to accomplish that. The BSOD happened right after enabling that adapter. I tried rebooting into safe mode where I disabled both my wifi adapter and the miniport. Re-installed the wifi adapter but BSOD recurred when I try to enable the miniport. Any suggestions?

EDIT: I have posted an updated file. Apparently, the process took some time and not all files were present upon posting. My bad.

My System SpecsSystem Spec
08 Sep 2013   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Please provide all the files following this tutorial so we can provide a complete analysis: Blue Screen of Death Posting Instructions
My System SpecsSystem Spec
09 Sep 2013   #3

Windows 7 Ultimate 32bit

updated my first post with the new file :)
My System SpecsSystem Spec

09 Sep 2013   #4

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Please open an elevated (Run as administrator) Command Prompt and type (or copy/paste) "systeminfo.exe >%USERPROFILE%\Desktop\systeminfo.txt" (without the quotes) and press Enter. Then navigate to Desktop to retrieve the syteminfo.txt file. If you have difficulties with making this work, please post back. Then zip up the .txt file and upload/attach the .zip file with your next post.
My System SpecsSystem Spec
09 Sep 2013   #5

Windows 7 Ultimate 32bit

Here you go
My System SpecsSystem Spec
09 Sep 2013   #6

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Reduce the start-up items, Antivirus software is basically whats required.------------------------
Start Menu\Programs\Alcohol 52%	Public:Start Menu\Programs\Alcohol 52%	Public
Daemon Tools (also Alcohol % software) are known to cause BSOD's on some Win7 systems (mostly due to the sptd.sys driver, although we have seen dtsoftbus01.sys blamed on several occasions). Please uninstall Daemon Tools.As an alternative: ------------------------
Make scans with these tools -------------------------
Run the System File Checker that scans the of all protected Windows 7 system files and replaces incorrect corrupted, changed/modified, or damaged versions with the correct versions if possible:
  • Click on the
  • Type CMD on Search
  • Left click and Run as Administrator
  • Type SFC /scannow - read here
Run Disk Check on your Hard Drive for file system errors and bad sectors on it - read here
Remove and Replace your existing antivirus with Microsoft Security Essentials & the Free version of Malwarebytes, update and make full scans separately:
Note   Note
Do not start the trial version of MalwareBytes
You may also take a look at:------------------------
Install all updates including Service Pack 1:------------------------
Upload a screenshot using:Test your Hard Drive(s) by running:Atheros Driver
If its wireless, match your device from here:
ATHEROS Wireless drivers for Windows

If its not a wireless, match your device from here:
ATHEROS Network drivers for Windows

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {4, 2, 0, 8bd6db02}

Unable to load image \SystemRoot\system32\DRIVERS\athr.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for athr.sys
*** ERROR: Module load completed but symbols could not be loaded for athr.sys
Probably caused by : athr.sys ( athr+212e1 )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 00000004, memory referenced
Arg2: 00000002, IRQL
Arg3: 00000000, value 0 = read operation, 1 = write operation
Arg4: 8bd6db02, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from 837b5718
Unable to read MiSystemVaType memory at 83795160


8bd6db02 8b4b04          mov     ecx,dword ptr [ebx+4]





TRAP_FRAME:  b45ebba8 -- (.trap 0xffffffffb45ebba8)
ErrCode = 00000000
eax=00000000 ebx=00000000 ecx=8bd79970 edx=86950020 esi=870c5028 edi=8bd79970
eip=8bd6db02 esp=b45ebc1c ebp=b45ebc28 iopl=0         nv up ei ng nz na po nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010282
8bd6db02 8b4b04          mov     ecx,dword ptr [ebx+4] ds:0023:00000004=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from 8bd6db02 to 8369382b

b45ebba8 8bd6db02 badb0d00 86950020 b45ebbc4 nt!KiTrap0E+0x2cf
b45ebc28 97e3f2e1 00000000 b45ebc40 97e3f2bf ndis!NdisFreeTimerObject+0x18
WARNING: Stack unwind information not available. Following frames may be wrong.
b45ebc34 97e3f2bf 86950210 b45ebc4c 97e44f0c athr+0x212e1
b45ebc40 97e44f0c 86950020 b45ebc64 97e44ebf athr+0x212bf
b45ebc4c 97e44ebf 86950020 c000009a 86950020 athr+0x26f0c
b45ebc64 97e3682e 87695408 b45ebc78 00000001 athr+0x26ebf
b45ebc84 97e2f313 87695408 00000001 b45ebc9c athr+0x1882e
b45ebcc4 97e2f1e8 87695408 8dd2b38c 87695408 athr+0x11313
b45ebcdc 8bd3830a 87695408 873b5a70 b45ebd00 athr+0x111e8
b45ebcec 8386d7fd 870c5028 873b5a70 88749698 ndis!ndisDispatchIoWorkItem+0xf
b45ebd00 836baf3b 86fe51e0 00000000 88749698 nt!IopProcessWorkItem+0x23
b45ebd50 8385b6bb 80000000 936f114f 00000000 nt!ExpWorkerThread+0x10d
b45ebd90 8370d0f9 836bae2e 80000000 00000000 nt!PspSystemThreadStartup+0x9e
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x19


97e3f2e1 ??              ???


SYMBOL_NAME:  athr+212e1

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  athr.sys


FAILURE_BUCKET_ID:  0xD1_athr+212e1

BUCKET_ID:  0xD1_athr+212e1

Followup: MachineOwner

0: kd> lmvm athr
start    end        module name
97e1e000 97f42000   athr     T (no symbols)           
    Loaded symbol image file: athr.sys
    Image path: \SystemRoot\system32\DRIVERS\athr.sys
    Image name: athr.sys
    Timestamp:        Tue Aug 11 07:14:25 2009 (4A80C5F1)
    CheckSum:         0012F46C
    ImageSize:        00124000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Post back with results.
My System SpecsSystem Spec
09 Sep 2013   #7

Windows 7 Ultimate 32bit

Thanks! Looks like a lot, but I'll post here with updates once I manage to get everything done
My System SpecsSystem Spec
09 Sep 2013   #8

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Take your time. No hurries.
My System SpecsSystem Spec
10 Sep 2013   #9

Windows 7 Ultimate 32bit

The driver update nailed it. Many thanks for your help!
My System SpecsSystem Spec
10 Sep 2013   #10

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

You're welcome. Be sure to complete the remaining steps also.
They will help improve the state of your PC.
My System SpecsSystem Spec

 BSOD "NDIS.sys" IRQL_NOT_LESS_OR_EQUAL > MS Virtual Wifi Miniport

Thread Tools

Similar help and support threads
Thread Forum
"Microsoft Virtual WiFi Miniport Adapter" is missing
I used to see Wireless Connection 2 (Microsoft Virtual WiFi Miniport Adapter), but now it has disappeared. I have tried netsh wlan set hostednetwork mode=allow ssid=<name of network> key=<password>. However, this hasn't brought back the connection in "Network Connections". How can I get it...
Network & Sharing
BSOD Asus Aspire 5332 NDIS.sys "driver_irql_not_less_or_equal"
Hello clever people, hopefully you can help me. My Asus Aspire 5332 Windows 7 x64 is blue screening each time Windows starts in normal mode. It starts in safe mode Ok but does not in normal mode. I have tried system restores to an older point in time but this hasnt resolved my issue. No...
BSOD Help and Support
Virtual WiFi Miniport - Disapear!
My "Microsoft Virtual WiFi Miniport adapter" has disapeared. How do I activate it again?
Network & Sharing
BSOD while reinstalling Virtual WiFi Miniport Adapter Driver
Pretty much what it says on the tin. I try to install the MS Virtual WiFi Miniport Adapter driver, the laptop crashes halfway through installation. Same happens when I have Windows download the driver fresh from MS. Windows 7 Starter 32 bit Originally installed OEM Machine and installation...
BSOD Help and Support
Virtual WiFi Miniport Adapter
Using Windows 7, my wireless works great in the vicinity of the router, but slows down and will not load some sites when 30+ feet away from the router. The signal strength is excellent. Any ideas?
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:13.
Twitter Facebook