Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD Bad Pool Caller when rebooting

09 Sep 2013   #1

Windows 7 Professional 64-bit
BSOD Bad Pool Caller when rebooting


I have recently setup new pc's for our programming staff. The pc's are HP 8300 Elite convertible minitower. 32GB of memory 500GB hard drives RAID 1 configuration, Nvidia 8400 GS. They are all setup with identical software and drivers, etc. out of 11 pc's 3 of them after a month of use get the Bad Pool Caller when rebooting the pc. all of them appear be be the same error. I am unable to use the SF diagnostic tool. So I will post the error what who crashed says.
Along with several of the mini dump files. The Bad Pool Caller is the most common error but I have also received Driver corrupted Expool. Any help troubleshooting these errors would be appreciated. Thanks Drew..

Crash dump directory: C:\Windows\Minidump

Crash dumps are enabled on your computer.

On Tue 9/3/2013 8:01:07 PM GMT your computer crashed
crash dump file: C:\Windows\memory.dmp
This was probably caused by the following module: ntoskrnl.exe (nt+0x75B80)
Bugcheck code: 0xC2 (0x99, 0xFFFFFA801EE48E70, 0x0, 0x0)
file path: C:\Windows\system32\ntoskrnl.exe
product: Microsoft® Windows® Operating System
company: Microsoft Corporation
description: NT Kernel & System
Bug check description: This indicates that the current thread is making a bad pool request.
This appears to be a typical software driver bug and is not likely to be caused by a hardware problem.
The crash took place in the Windows kernel. Possibly this problem is caused by another driver that cannot be identified at this time.

My System SpecsSystem Spec
09 Sep 2013   #2
x BlueRobot


Why weren't you able to use the SF_Diagnostic Tool?
My System SpecsSystem Spec
09 Sep 2013   #3

Windows 7 Professional 64-bit

Quote   Quote: Originally Posted by x BlueRobot View Post
Why weren't you able to use the SF_Diagnostic Tool?
I get an error saying unable to create folder when selecting grab all. I think it's the Symantec endpoint may be blocking it. Our network engineer has it set so I can't disable endpoint.
My System SpecsSystem Spec

09 Sep 2013   #4
x BlueRobot


Okay, we can gather the files manually, I'll post the instructions for the main two first:


Please go to this folder (see below), and then check for any dump files, if so please place them into a zipped folder and then attach in your next post.


Type: msinfo32
File, Save
Place in the same zipped folder, and then upload in your next post.

Screenshots and Files - Upload and Post in Seven Forums
My System SpecsSystem Spec
09 Sep 2013   #5

Windows 7 Professional 64-bit

File Uploaded.
My System SpecsSystem Spec
10 Sep 2013   #6
x BlueRobot


BugCheck C2, {99, fffffa801ee48e70, 0, 0}

Probably caused by : memory_corruption ( nt!MiUnmapViewOfSection+295 )
Usual causes:  Device driver, Memory
This bugcheck indicates that the thread has attempted to free a pool page with a invalid memory address; the pool header could be corrupt too for the driver which exists within the page.

3: kd> !pool fffffa801ee48e70
Pool page fffffa801ee48e70 region is Nonpaged pool
 fffffa801ee48000 size:  210 previous size:    0  (Allocated)  ALPC (Protected)
 fffffa801ee48210 size:   30 previous size:  210  (Allocated)  ReSe
 fffffa801ee48240 size:   80 previous size:   30  (Free )  SeTl
 fffffa801ee482c0 size:   c0 previous size:   80  (Free )  EtwR (Protected)
 fffffa801ee48380 size:   20 previous size:   c0  (Allocated)  I200
 fffffa801ee483a0 size:   a0 previous size:   20  (Free )  Even (Protected)
 fffffa801ee48440 size:  1c0 previous size:   a0  (Free )  EtwG
 fffffa801ee48600 size:   10 previous size:  1c0  (Free)       CcSc
 fffffa801ee48610 size:   c0 previous size:   10  (Allocated)  EtwR (Protected)
 fffffa801ee486d0 size:   c0 previous size:   c0  (Allocated)  EtwR (Protected)
 fffffa801ee48790 size:   e0 previous size:   c0  (Allocated)  SASC
 fffffa801ee48870 size:   30 previous size:   e0  (Allocated)  ReEv
 fffffa801ee488a0 size:  100 previous size:   30  (Allocated)  Ntfx
 fffffa801ee489a0 size:   80 previous size:  100  (Free )  Sema (Protected)
 fffffa801ee48a20 size:   50 previous size:   80  (Allocated)  ViMm
 fffffa801ee48a70 size:   e0 previous size:   50  (Allocated)  IoCo (Protected)
 fffffa801ee48b50 size:  1e0 previous size:   e0  (Allocated)  MmCi
 fffffa801ee48d30 size:  130 previous size:  1e0  (Allocated)  IE1Q
3: kd> !poolval fffffa801ee48000
Pool page fffffa801ee48000 region is Nonpaged pool

Validating Pool headers for pool page: fffffa801ee48000

Pool page [ fffffa801ee48000 ] is __inVALID.

Analyzing linked list...
[ fffffa801ee48d30 --> fffffa801ee48ef0 (size = 0x1c0 bytes)]: Corrupt region

Scanning for single bit errors...

None found
3: kd> dt nt!_POOL_HEADER fffffa801ee48d30
   +0x000 PreviousSize     : 0y00011110 (0x1e)
   +0x000 PoolIndex        : 0y00000000 (0)
   +0x000 BlockSize        : 0y00010011 (0x13)
   +0x000 PoolType         : 0y00000010 (0x2)
   +0x000 Ulong1           : 0x213001e
   +0x004 PoolTag          : 0x51314549
   +0x008 ProcessBilled    : (null) 
   +0x008 AllocatorBackTraceIndex : 0
   +0x00a PoolTagHash      : 0
3: kd> dt nt!_POOL_HEADER fffffa801ee48ef0
   +0x000 PreviousSize     : 0y00001001 (0x9)
   +0x000 PoolIndex        : 0y00000000 (0)
   +0x000 BlockSize        : 0y00000001 (0x1)
   +0x000 PoolType         : 0y00000000 (0)
   +0x000 Ulong1           : 0x10009
   +0x004 PoolTag          : 0xee657645
   +0x008 ProcessBilled    : (null) 
   +0x008 AllocatorBackTraceIndex : 0
   +0x00a PoolTagHash      : 0
Run Driver Verifier to scan for any corrupted drivers which may be causing problems, this program works by running various stress tests on drivers, in order to produce a BSOD which will locate the driver; run for least 24 hours:
information   Information

Select the Individual Settings option, and check all the boxes (especially Special Pool) apart from the Low Resources Simulation option.
My System SpecsSystem Spec
10 Sep 2013   #7

Windows 7 Professional 64-bit

OK I will give that a try. I will have to wait until this weekend to run it. I will report back on Monday.

My System SpecsSystem Spec
10 Sep 2013   #8
x BlueRobot


Okay thanks :)
My System SpecsSystem Spec

 BSOD Bad Pool Caller when rebooting

Thread Tools

Similar help and support threads
Thread Forum
BSOD on Steam Update, Bad Pool Caller or Bad Pool Header, no dmp files
Good day all, I hope someone can help me with a consistent BSOD problem I've had today. Every time my Steam client starts up and attempts to download its latest update, I get a BSOD with a Bad Pool Caller (one time out of about a dozen crashes it was Bad Pool Header instead). I have tried the...
BSOD Help and Support
BSOD Bad pool caller
Had a couple BSOD recently. i suspect it may have something to do with my native instruments audio interface but am not sure. BCCode: c2 BCP1: 0000000000000007 BCP2: 0000000000001097 BCP3: 0000000000008003 BCP4: FFFFF8800681508C OS Version: 6_1_7600 Service...
BSOD Help and Support
BSOD (ks.sys bad pool caller)
Hello everybody! I have a small problem, well i think it´s a small one. My computer sometimes crashes, I will atach the dump file. Otherwise, it runs perfectly, except few crashes in almost 10 months. It used to happen every three or four months one crash, and it didn´t bother me that much, but now...
BSOD Help and Support
BSOD Bad Pool Caller
Hello all, Recently built a computer. I was just watching a video and I got my first ever BSOD with the error 'Bad Pool Caller'. I've rebooted OK however it would appear the computer is notably slower at the moment. I've googled around and I can see theres various causes for this error so any...
BSOD Bad Pool Caller
Hi I have just built a new computer with the following specs: Gigabyte GA-MA790XT-UD4P 790X Socket AM3 DDR3 Corsair 650W TX Series PSU Western Digital WD5000AAKS 500GB

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:16.
Twitter Facebook Google+