Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Weird boot problem in Windows 7

13 Sep 2013   #11

32 bit Windows 7

Quote   Quote: Originally Posted by SIW2 View Post
SIW2 is there any chance I could delete my partition/files using those commands
The first two commands give me the same error which doesn't show up in google exactly the same:
bfsvc could not open the bcd template store status = [c000000f ]

The third command says I cannot update the boot code of partition D because it cannot be locked. Access is denied.
There was a drive lock enabled feature enabled. It is HP 625 and it said that it needs password after each restart yet it wasn't asking for one so I didn't expect such an issue.

BTW I don't have the "boot" folder in my system drive D:\ which I think is important to boot Windows normally!

BTW the BSOD could be happening because of my msahci.sys driver not being suitable for the system but I've taken it straight from the reserve drivers folder. But even then this driver isn't required for booting from Safe Mode which doesn't work (it restarts automatically).

G:\boot\bootsect /nt60 D:
g is my dvd drive (Windows 7 install cd)
d is my hdd windows partition
this command says it is all successfully completed.
But if I type it like this

G:\boot\bootsect /nt60 all
it gives the access is denied error on D: drive only. All other seem to be okay.
The hdd has 4 total partitions.

G:\boot\bootsect /nt60 all /force
This fixed the last access is denied error :).
I used
detail disk
and it shows boot disk: no
4 volumes which doesn't have anything on Info. The system(active/boot partition is for some reason NTFS and D drive doesn't have a label).
The 100 mb partition is as follows:
Partition 0 Type : 07 Hidden: No Active: Yes

From this article How can I check that I am using MSAHCI? - The Corsair Support Forums
it seems msahci is a driver for SSD and I think it loads even in safe mode. Safe mode does give bsod but it restarts immediately. Maybe I should try repairs with ahci disabled from bios. I tried 2 different installation medias. The screen where I select which operation system to repair doesn't show is the OS version 32 or 64 bits which is a problem because I am also not sure since I cannot enter it . Yet the disk I use has both versions I am 100% sure because I used it a lot.

I've removed the drive from the notebook and put it right in my PC Win 7 Ultimate x64 and it still gave me the very same error with the big sfc command:
"G:\>sfc /scannow

Beginning system scan. This process will take

Another servicing or repair operation is curre
Wait for this to finish and run sfc again."
"G:\Windows\System32>sfc /scannow /offbootdir=F:\ /offwindir=G:\Windows
Beginning system scan. This process will take some time.
Windows Resource Protection could not perform the requested operation."
This time f is boot drive and g is windows drive.
Now chkdsk won't run on the windows drive:
An unspecified error occurred (766f6c756d652e63 3f1).

This must be a TOP 10 of the ridiculous amount of weird problems happening in a row for a single operating system in the world! Chkdsk runs fine with the DVD. But what if it really doesn't check D: drive although I am in it and rather checks X: drive for some stupid reason. Although it is checking the drive very slowly which is appropriate.

I've scanned with NOD32 latest version the whole disk and the boot disk because NOD32 is very good at detecting and removing MBR viruses but it didn't found anything serious. Now we need to concentrate on what could cause BSOD 0x0000007B and is not chkdsk and bad sectors related.
How can I make the OS to make memory dump files? There is no minidump folder in Windows\ now.

I've replaced msahci.sys with the same file but from my PC (which is 64 bits )and now it doesn't give BSOD but it is back to "Loading setup files" or something (automatic system recovery) which returns me again to the same screen to choose repair or start windows normally.
I am back to the BSOD with restoring the original msahci.sys from the driverepository (reserved backup folder for drivers) so I think I just need the correct msahci.sys driver.

The russians have typed a lot about this exact BSOD 0x0000007B (0х80D86B58, 0xc0000034, 0x00000000, 0x000000000) and it seems that the ahci driver msahci.sys (or some other driver) could be DISABLED for some stupid reason from the registry in the OS.
BSOD 0x0000007B
Check the big comment of mAlexey1978
A new error finally.
intelide.sys 0xc000000f missing or corrupt.
It gave me random drivers missing so I replaced them all from the DVD X:\Windows\System32\Drivers folder and again I've got the BSOD just like not having ahci drivers for the disk. Maybe I should download them straight from HP then.
Just to recap I couldn't start sfc on the system drive even once!!! It checks X: drive just not saying it...
Although all the partitions are visible in order to make a new installation I need the ahci drivers which is very rare occurance. I've placed the ahci driver inside my USB thumb drive and it still says that there are no new devices detected (what it needs to detect if I see all the drives I dunno).
With disabled AHCI it still wants some driver!!! In the very same menu as soon as I put an installation dvd media it started okay (without restarting) without using the USB drive. Just installing from the dvd and didn't wanting an ahci driver. Maybe it is a rare drive letter issue and I say rare because I've installed it a dozens of times with the same usb pen drive.

My System SpecsSystem Spec
16 Sep 2013   #12
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

The c000000f error from the bcd template thing is telling you that the file does not exist. Again, a filesystem issue. The issue with the 0x7B and the c00000034 (object name not found) is not specific to the AHCI driver not being present. However, it can cause it when Windows is set to run on AHCI while the system BIOS has the SATA mode set to IDE, or vice versa. They both must be the same: either BIOS has to be in IDE and msahci not loaded; or BIOS has to be set to RAID or AHCI and Windows set to load msahci.

The boot folder should be in your boot partition, which isn't always your system partition. So if the first partition in the system has boot folder but you have Windows on another partition, then that's ok as long as the one with the boot folder is the one that the system starts up on and it redirects everything to Windows on the other partition. So is the boot folder on your C: partition instead of your D:?

As for SFC still giving grief, when you start into the recovery environment and you select the Windows partition you are trying to work on, does it actually prompt you for an administrative password? It sounds an awful lot like you're getting access denied issues because you haven't entered proper administrative login credentials for that Windows installation, and so the recovery commands are having difficulties working because of it. Make sure you're working with the proper credentials.

You can try to tinker with the msahci or IDE/AHCI SATA mode to see if that'll get a fix in, but TBH, if that fails, I really think that your partitions and Windows installation has somehow reached a level of corruption where manual fixing is going to be extensive and requires advanced filesystem knowledge to work on to repair it. It sounds like it'll just be better to deal with a clean Windows install. It's a last ditch option, but considering the extensive work already put into this and the time it's already taken to revive it, it starts sounding more and more like the better option. Just backup your files to another drive and then reinstall Windows, making sure to remove all partitions on that drive first and recreating new ones.
My System SpecsSystem Spec
18 Sep 2013   #13

32 bit Windows 7

It didn't asked me for credentials a single time. Also I need administrator access to run chkdsk /R command too but it never asked me anything.
I've solved the problem with new installation sadly. I wanted to fix it for my own knowledge/experience but in the end it doesn't really matter that much. Thanks again for the help.
My System SpecsSystem Spec

18 Sep 2013   #14
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

I know the determination - believe me I've been there - but there are some issues that go beyond even advanced technical support experience and enters the realm of deep hardware internal diagnostics and other stuff reserved only for highest echelons of computer prowess, such as escalation engineers and filesystem developers. Even then it may be a case where someone of that expertise would discover the exact problem, but say it's unrecoverable and the only means of fixing would be to backup and replace.

I'm not the brightest bulb when it comes to this stuff, but I am aware of being a bit more advanced than the average PC technician, yet I know well I'm better off not tinkering with stuff far beyond my skill level. I wouldn't want to waste time and effort to learn how to reconstruct a partition table manually when I can just backup and reinstall. There's a time and place for learning that stuff, but it ain't going to be through a need-to basis - you can't be a guru in a couple days with this kind of stuff.

Sorry that we couldn't help you further on the matter. However, given that the new installation seems to work, it does appear that we were at least close -if not dead on - in our evaluation that the MBR/partition table was broken, and that no manner of software nor manual editing is going to fix it. Best thing I would do after that would be to try and evaluate what could've done it - an infection? Hard drive failure? Not just anything can corrupt an MBR/partition, so you'll want to got through the possibilities of what could've done it then prepare accordingly. If it's something like a hard drive or disk controller having issues, then no manner of reinstalling is going to fix it. You'll want to see what you can do about finding the root of the problem, and if you can't, just shrug it off and move on.
My System SpecsSystem Spec
23 Sep 2013   #15

32 bit Windows 7

Thanks for the nice comment Vir Gnarus. I guess the problem is maybe a not common version (or modified somehow) of Windows 7 being installed prior to the problem. It's possible that the installation could've been made using an image made with the sysprep command for fast Windows 7 deployment. Couldn't find viruses with two good AV softwares so I guess damaged Windows from updating or MBR/Boot issue. The way how it always started Automatic Startup Recovery was very weird and I am sure it wasn't caused by a damaged keyboard . The people who were using the notebook didn't had much knowledge so they could've erased some drivers/boot files without telling me lmao ;D. Now the question is should I mark the thread as "Solved" although new installation is not so good solving in some cases.
My System SpecsSystem Spec

 Weird boot problem in Windows 7

Thread Tools

Similar help and support threads
Thread Forum
Slow/Weird boot problem
Spec - Asus z97-ar / intel i5 4690k / 16GB / GTX 660 / Crucial mx100 512gb SSD It takes very slow for my PC to get to the desktop ( about 40 seconds ) and i have no clue what the problem is. Two things usually happen which ill explain below 90 % of the time my pc will start up and the screen...
General Discussion
Weird 'reboot and select proper boot device' problem!!!
I know that this may sound like a common problem but after searching the forums and on google I can't find anyone with this particular problem. My PC is a custom build that I built a couple of months ago and has been running without problems until now. Here is the spec of the PC: Windows 7...
BSOD Help and Support
Weird boot problem after rescue CD boot fix
Hello. Just like the title says. I installed linux and grub, which kinda screwed up my windows boot. Long story short, i used rescue CD to do the fixboot => fixmbr => rebuild bcd. After that i wanted to install linux again, but none of my flash drives are recongnized as being bootable. I tried a...
General Discussion
Weird Windows 7/Windows 8 Dual Boot problem
So I have Windows 7 on an SSD that is Disk 0. I decided to make a dual boot with Windows 8 for Hyper V because I have a class where I need to setup VM's with it (but thats not the point). Anyway, I wiped my secondary hard drive (Western Digital 300gb HDD) and created a partition to load Windows...
Installation & Setup
weird video problem on boot-up
I have a very unusual problem: Sometimes, when booting, the monitor only shows a blinking cursor in the top-left corner. No POST, nothing else. The weird thing is that the system appears to be booting quite normally, as sometimes, if I wait long enough (1-2 minutes tops) I can hear the startup...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:16.
Twitter Facebook