Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD Wdf01000.sys

01 Oct 2013   #1

Windows 7 Proffesional 64bit
BSOD Wdf01000.sys

Hello, just got a bluescreen and i couldnt get back into windows untill i removed one of my RAM`s. I tryed the startup repair system restore before doing that but i was getting bluescreen everytime before or after windows was loading. Tho i only see only one event, the others might have been lost because of system restore, im not sure. Im posting my sf diagnostic tool files for someone to tell me more about this.

My System SpecsSystem Spec
01 Oct 2013   #2
x BlueRobot


Any feedback here?

BSOD L1C62x64.sys
My System SpecsSystem Spec
01 Oct 2013   #3

Windows 7 Proffesional 64bit

Well after doing a clean reinstall of the windows those old bsod stoped.
My System SpecsSystem Spec

02 Oct 2013   #4
x BlueRobot


Could you please mark the old thread as solved then?
My System SpecsSystem Spec
02 Oct 2013   #5
x BlueRobot


BugCheck 1000007E, {ffffffffc0000005, fffff88000e80000, fffff88002124318, fffff88002123b70}

Probably caused by : memory_corruption
Usual causes:  Insufficient disk space, Device driver, Video card, BIOS, Breakpoint with no debugger attached, Hardware incompatibility, Faulty system service, Memory, 3rd party remote control
!chkimg -lo 50 -db !Wdf01000
8 errors : !Wdf01000 (fffff88000e80003-fffff88000e8003b)
fffff88000e80000  48  83  64 *06  50  00  48  8b  69  10  0f *9f  f2  1f  49  8b H.d.P.H.i.....I.
fffff88000e80010  f0  48  8b *f8  83  fa  01  0f  84  a3  01 *23  00  4d  85  c0 .H.........#.M..
fffff88000e80020  75  6a  83 *fc  04  74  65  44  38  85  0c *06  00  00  74  1e uj...teD8.....t.
fffff88000e80030  45  8d  48 *28  48  8d  35  f5  73  04  00 *96  05  45  8d  41 E.H(H.5.s....E.A
!chkimg -lo 50 -d -db !Wdf01000
    fffff88000e80003 - Wdf01000!FxFileObject::_DestroyFileObject+f
	[ 24:06 ]
    fffff88000e8000b - Wdf01000!FxFileObject::_DestroyFileObject+17 (+0x08)
	[ ba:9f ]
    fffff88000e80013 - Wdf01000!FxFileObject::_DestroyFileObject+1f (+0x08)
	[ d9:f8 ]
    fffff88000e8001b - Wdf01000!FxFileObject::_DestroyFileObject+27 (+0x08)
	[ 00:23 ]
    fffff88000e80023 - Wdf01000!FxFileObject::_DestroyFileObject+2f (+0x08)
	[ fa:fc ]
    fffff88000e8002b - Wdf01000!FxFileObject::_DestroyFileObject+37 (+0x08)
	[ 01:06 ]
    fffff88000e80033 - Wdf01000!FxFileObject::_DestroyFileObject+3f (+0x08)
	[ 0b:28 ]
    fffff88000e8003b - Wdf01000!FxFileObject::_DestroyFileObject+47 (+0x08)
	[ b2:96 ]
8 errors : !Wdf01000 (fffff88000e80003-fffff88000e8003b)
fffff88000e80000  48  83  64 *06  50  00  48  8b  69  10  0f *9f  f2  1f  49  8b H.d.P.H.i.....I.
fffff88000e80010  f0  48  8b *f8  83  fa  01  0f  84  a3  01 *23  00  4d  85  c0 .H.........#.M..
fffff88000e80020  75  6a  83 *fc  04  74  65  44  38  85  0c *06  00  00  74  1e uj...teD8.....t.
fffff88000e80030  45  8d  48 *28  48  8d  35  f5  73  04  00 *96  05  45  8d  41 E.H(H.5.s....E.A
fffff88002124318 -- (.exr 0xfffff88002124318)
ExceptionAddress: fffff88000e80000 (Wdf01000!FxFileObject::_DestroyFileObject+0x000000000000000c)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000001
   Parameter[1]: 0000057ff843a3a8
Attempt to write to address 0000057ff843a3a8
Okay, the image seems to be corrupt, and the reason being so, is because a stride (I'm assuming it means in terms of a array), being the number of bytes until the next or previous element within an array, doesn't quite add up and has crashed the system.

1: kd> !dpx
Start memory scan  : 0xfffff88002124550 ($csp)
End memory scan    : 0xfffff88002125000 (Stack Base)

               rcx : 0xfffffa8007a50810 :  dt Wdf01000!FxDevice
               rbx : 0xfffffa8007a4f180 :  dt Wdf01000!FxPkgGeneral
0xfffff88002124598 : 0xfffff88000e85a9f : Wdf01000!FxPkgGeneral::OnClose+0xd3
0xfffff880021245a0 : 0xfffffa8007a4f180 :  dt Wdf01000!FxPkgGeneral
0xfffff880021245b0 : 0xfffffa8007a4f180 :  dt Wdf01000!FxPkgGeneral
0xfffff880021245e8 : 0xfffffa8007a4f180 :  dt Wdf01000!FxPkgGeneral
0xfffff880021245f8 : 0xfffff88000e852cf : Wdf01000!FxPkgGeneral::Dispatch+0x14f
0xfffff88002124618 : 0xfffffa8007a4faf0 :  dt Wdf01000!FxIoQueue
0xfffff88002124658 : 0xfffff88000e79245 : Wdf01000!FxDevice::Dispatch+0xa9
0xfffff88002124688 : 0xfffff800025cd22e : nt!IopDeleteFile+0x11e
0xfffff880021246e8 : 0xfffff88000e14f10 : mountmgr!MountMgrSendDeviceControl+0xbc
0xfffff88002124718 : 0xfffff800022d7e54 : nt!ObfDereferenceObject+0xd4
0xfffff88002124768 : 0xfffff88000e04110 : mountmgr!WPP_GLOBAL_Control
0xfffff88002124778 : 0xfffff88000e06d9d : mountmgr!QueryDeviceInformation+0x539
0xfffff880021247f8 : 0xfffff88000e0dd83 : mountmgr!MountMgrMountedDeviceArrival+0x1fb
0xfffff88002124840 : 0x0000000000010008 :  Trap @ fffff88002124840
0xfffff88002124848 : 0xfffff88000e0f180 : mountmgr!MountMgrMountedDeviceNotification
0xfffff88002124890 : 0xfffff88000e0f180 : mountmgr!MountMgrMountedDeviceNotification
0xfffff88002124910 : 0xfffff88000e0f180 : mountmgr!MountMgrMountedDeviceNotification
0xfffff88002124968 : 0xfffff88000fc23cf : volmgr!IsEqualGUID+0xf
0xfffff88002124980 : 0xfffff8000279d7d0 : nt!PnpDeviceClassNotifyList+0xb0
0xfffff880021249a8 : 0xfffff88000e0f1f5 : mountmgr!MountMgrMountedDeviceNotification+0x75
0xfffff880021249d8 : 0xfffff8000253c77c : nt!PnpNotifyDriverCallback+0x5c
0xfffff88002124a10 : 0xfffffa8006734c58 : 0xfffff800024742e0 : nt!ExWorkerQueue+0x60
0xfffff88002124a18 : 0xfffff800022c45d2 : nt!KiCommitThreadWait+0x1d2
0xfffff88002124a50 : 0xfffff8000279d7d0 : nt!PnpDeviceClassNotifyList+0xb0
0xfffff88002124a68 : 0xfffff80002710838 : nt!PnpNotifyDeviceClassChange+0x188
0xfffff88002124b38 : 0xfffff8000253b868 : nt!PnpDeviceEventWorker
0xfffff88002124b68 : 0xfffff800022d8261 : nt!ExpWorkerThread+0x111
0xfffff88002124b70 : 0xfffff8000253b868 : nt!PnpDeviceEventWorker
0xfffff88002124b80 : 0xfffff800024742d8 : nt!ExWorkerQueue+0x58
0xfffff88002124be0 : 0xfffff800022d8150 : nt!ExpWorkerThread
0xfffff88002124bf8 : 0xfffff8000256cbae : nt!PspSystemThreadStartup+0x5a
0xfffff88002124c38 : 0xfffff800022bf8c6 : nt!KxStartSystemThread+0x16
Scan for any missing, modified or corrupted protected Windows files with:Run Memtest86+ for least 9-10 passes, and preferably overnight as it can take a while to fully complete.

Test each RAM stick individually, if an error is found then move the same RAM stick into the next DIMM slot and test again, if errors are found for the same RAM stick in every available slot then you have a faulty RAM module. On the other hand, if no errors are found in the next slot or the other slots for the same RAM module, then you have a faulty DIMM slot.

Test each RAM stick and every motherboard DIMM slot available.

Quote   Quote: Originally Posted by Arc View Post
It is a RAM, a bad RAM.

But if you have got a result like that:
It is a motherboard issue. The particular slot is bad.
My System SpecsSystem Spec
03 Oct 2013   #6

Windows 7 Proffesional 64bit

I did test the ram sticks, no matter where i put one of them i allways get bluescreen before windows starts so i guess that makes means that stick is the fault. Now im running with only one stick.
My System SpecsSystem Spec
04 Oct 2013   #7
x BlueRobot


Did you get any errors running MemTest86+? Using one stick, change it to a different slot, and then see if it crashes, hopefully you will be able to see if the RAM stick(s) are faulty or a motherboard DIMM slot is faulty.
My System SpecsSystem Spec

 BSOD Wdf01000.sys

Thread Tools

Similar help and support threads
Thread Forum
BSOD with wdf01000.sys driver
I'm getting random crashes on my laptop Toshiba Portege R830 3G. I'm sure it's a driver issue but can't find which one. wdf01000.sys is the error I'm getting now. I used to get KeyAgent.sys and another one phx....?? which I've since removed.
BSOD Help and Support
BSOD with Wdf01000.sys at every boot
Hello, i used on my comp Advanced system care (i'm trying to install almost none unneccessary programs on my workcomp, but my mom used ASC and it worked fine with her so i stupidly thought it will be ok with me too :) ). What it done was, that it updated drivers. That was my intention anyway,...
BSOD Help and Support
BSOD WDF01000.sys
I have attached a zip of my minidump folder. Getting random BSOD's. Appears to happen when PC is sitting idle for the most part. Started shortly after Win 7 Pro 64-bit install. This is from an HP 6560b laptop. It seemed that windbg only shows wdf01000.sys as the problem, but I'm not sure if my...
BSOD Help and Support
BSOD, Driver Wdf01000.sys
Trying to help my father-in-law who is getting a BSOD on his very new laptop. We've barely used the thing, so I'm not getting it. Attached is the SF dump file info. I am intermediate level computer knowledge, so bear with me. It starts in safe mode. Thanks for any help.
BSOD Help and Support
BSOD wdf01000.sys happens 2 - 3 times a day
Any help on this would be much appreciated. Thanks in advance. Is Windows 7 -X86 -Original OS -OEM - hardware about 1 year old
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:15.
Twitter Facebook Google+