Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD during startup, "BAD_POOL_HEADER".

08 Oct 2013   #1

Windows 7 Home Premium 64bit
BSOD during startup, "BAD_POOL_HEADER".

I recently reinstalled windows for the first time since I bought this computer from it's previous owner. I installed a legitimate version of Home Premium, instead of the pirated Ultimate version that was on it before. I also installed it to a different hard drive.

Now I get a BSOD almost every time that I start up. It happens during boot, before the login screen. Says "BAD_POOL_HEADER". I'm on Windows 7 Home Premium 32bit. I've already updated graphics drivers to the latest version. Minidumps and other relevant files are attached. Thank you for your time

My System SpecsSystem Spec
08 Oct 2013   #2
x BlueRobot


BugCheck 19, {20, 86629000, 86629180, 18300000}

Probably caused by : ndisuio.sys ( ndisuio!NdisuioIoControl+211 )
1: kd> dt nt!_POOL_HEADER 86629000
   +0x000 PreviousSize     : 0y000000000 (0)
   +0x000 PoolIndex        : 0y0000000 (0)
   +0x002 BlockSize        : 0y000110000 (0x30)
   +0x002 PoolType         : 0y0001100 (0xc)
   +0x000 Ulong1           : 0x18300000
   +0x004 PoolTag          : 0x20206f49
   +0x004 AllocatorBackTraceIndex : 0x6f49
   +0x006 PoolTagHash      : 0x2020
1: kd> dt nt!_POOL_HEADER  86629180
   +0x000 PreviousSize     : 0y000000110 (0x6)
   +0x000 PoolIndex        : 0y0000000 (0)
   +0x002 BlockSize        : 0y001010000 (0x50)
   +0x002 PoolType         : 0y1111001 (0x79)
   +0x000 Ulong1           : 0xf2500006
   +0x004 PoolTag          : 0x10010004
   +0x004 AllocatorBackTraceIndex : 4
   +0x006 PoolTagHash      : 0x1001
There seems to be a corrupt pool header, which is usually related to drivers causing buffer overflows.

Are you able to boot into the computer at all?
My System SpecsSystem Spec
08 Oct 2013   #3

Windows 10

Hello and welcome to SF :) .

Your bugchecks appear to be caused by a very old WLAN driver.

The pool is already corrupt at the time of the current request.
This may or may not be due to the caller.
The internal pool links must be walked to figure out a possible cause of
the problem, and then special pool applied to the suspect tags or the driver
verifier to a suspect driver.
Arg1: 00000020, a pool block header size is corrupt.
Arg2: 86629000, The pool entry we were looking for within the page.
Arg3: 86629180, The next pool entry.
Arg4: 18300000, (reserved)
We see a usermode program calling into the kernel and using ndisuio
91a0bb50 82a820d1 86629008 00000000 a28ca68a nt!ExFreePoolWithTag+0x1b1
91a0bb9c 82a79b9f 018ad7d0 91a0bbe4 91a0bbdc nt!IopCompleteRequest+0xe6
91a0bbe8 97b7231f 866796f0 866264f0 00000000 nt!IopfCompleteRequest+0x3b4
91a0bbfc 82a385be 00000104 878ad790 878ad790 ndisuio!NdisuioIoControl+0x211
91a0bc14 82c2bb09 866796f0 878ad790 878ad800 nt!IofCallDriver+0x63
91a0bc34 82c2ecdb 866264f0 866796f0 00000000 nt!IopSynchronousServiceTail+0x1f8
91a0bcd0 82c7561b 866264f0 878ad790 00000000 nt!IopXxxControlFile+0x6aa
91a0bd04 82a3f27a 000004f8 00000000 00000000 nt!NtDeviceIoControlFile+0x2a
91a0bd04 770a7094 000004f8 00000000 00000000 nt!KiFastCallEntry+0x12a
WARNING: Frame IP not in any known module. Following frames may be wrong.
007df57c 00000000 00000000 00000000 00000000 0x770a7094
The raw stack doesn't reveal anything concrete as well, but by association of ndisuio (NDIS-uIO)
we can look at the active network related drivers.

This USB adapter is active:
Product Type    ZyXEL G-202 Wireless USB Adapter
Using this driver:
Driver    c:\windows\system32\drivers\wlangzxp.sys (
The driver is as I said is very old!
lmvm wlangzxp
start    end        module name
97a1f000 97ad2800   WlanGZXP   (deferred)             
    Image path: \SystemRoot\system32\DRIVERS\WlanGZXP.sys
    Image name: WlanGZXP.sys
    Timestamp:        Tue Sep 23 06:13:41 2008
I'm assuming you're able to boot into the PC long enough for you to post
this thread, please use that time to update the driver.
My System SpecsSystem Spec

08 Oct 2013   #4

Windows 7 Home Premium 64bit

Yes, I'm using it right now. If I restart it enough times, it eventually will get to the login screen and work perfectly after that. Also, if it helps at all, it boots up every single time if I use safe mode.
My System SpecsSystem Spec
08 Oct 2013   #5

Windows 7 Home Premium 64bit

I might be screwed then. Those drivers are actually the newest ones on the website. I bought that wifi adapter somewhere around 2004. It worked fine on my last windows 7 install. They are said to be compatible with 7 on the website.

EDIT: It looks like Zyxel has multiple driver pages. The last one I looked at only had the 2008 drivers. I will update those and report back if I have problems. Thanks!
My System SpecsSystem Spec
08 Oct 2013   #6

Windows 7 Home Premium 64bit

Ok, Zyxel is doing something stupid. I downloaded what were labeled as the 2010 drivers, but windows told me that those weren't any more current than what I already had (2008).

So, out of curiosity, I read the .inf file in the new drivers I downloaded. They appear to actually be the same driver version I already have, from 2008.

WTF Zyxel? Is this some kind of joke?
My System SpecsSystem Spec
08 Oct 2013   #7

Windows 10

When you do please post a new instance of the MSINFO32 file :) .

Start> Run> Type MSINFO32 then hit [Enter].
In MSINFO32 go to, File> Save> name it your user-name and upload.
My System SpecsSystem Spec
08 Oct 2013   #8

Windows 7 Home Premium 64bit

I can't update my drivers, windows won't let me since the drivers I just downloaded seem to be identical to what I already have, despite being labeled differently on the manufacturers website. I've attached a new MSINFO32 anyways.
My System SpecsSystem Spec
08 Oct 2013   #9
x BlueRobot


Have you checked for Realtek driver updates?

Realtek RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)

Support Page - Realtek
My System SpecsSystem Spec
08 Oct 2013   #10

Windows 7 Home Premium 64bit

I updated Realtek drivers to the latest version, but to no avail. I'm going to assume that it is the WiFi adapter's fault.

I've already purchased a new Ethernet cable to run wired internet to this PC, something I've been planning to do for a long time now. I'll just deal with the errors until I can uninstall that driver and throw that aging adapter out. I'll come back here if the problem persists after I remove the driver. Thanks everybody for your help!
My System SpecsSystem Spec

 BSOD during startup, "BAD_POOL_HEADER".

Thread Tools

Similar help and support threads
Thread Forum
"BAD_POOL_HEADER" BSOD after rebooting and logging in
Hello, Yesterday my computer was working fine. Finished using it, shut it down. Don't remember installing anything between the last boot and the most recent other than a Steam game. Now, today, after booting up, the computer worked fine for a few seconds after logging in to a user, before...
BSOD Help and Support
Stuck on "Start Windows normally" and "Launch startup repair"
I am stuck on "Start Windows normally" and "Launch startup repair" When I choose "Start Windows Normally",it gives me blue screen with the following error:Unmountable_Boot_Volume.On "Launch startup repair" I am stuck on the Windows 7 wallpaper with cursor and can't even open Cmd trough...
General Discussion
BSOD every few hours: mostly "STOP: 0x00000F4", "c00021a" & "c0000135"
Hi everyone! Yesterday my HP laptop (Windows 7) started getting BSOD with various types of errors (mostly "STOP: 0x00000F4", "STOP: 0x0000007A", "c00021a" and one "missing %hs, c0000135"). Most of the time it restarts without any issues and works fine right after the BSOD and then an hour or two...
BSOD Help and Support
BSOD after Log-in, "BAD_POOL_HEADER", STOP: 0x00000019
I had my laptop disconnected from AC power, totally off, and it had worked perfectly so far. I haven't had any problems, except for a few Trojans/rootkits long ago, and I have only gotten one BSOD plus this one. I turn my laptop on, connect it to AC power, and after having logged in, I initiated...
BSOD Help and Support
Laptop endless spinning / BSOD on start up - BAD_POOL_HEADER "<3"
Hello Sevenforum! I am in dire need of your help! I seem to be in a pinch..! Was working on a presentation on the laptop and had Firefox, Dropbox and Word opened when suddenly Word when "Not responding", switches to Firefox and surf for a bit when that and Dropbox turns "Not Responding" and...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:46.
Twitter Facebook Google+