Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD when trying to update Video Card Drivers

14 Oct 2013   #1

Windows 7 Home Premium 64bit
BSOD when trying to update Video Card Drivers

Hello. I'm not sure if this belongs here or somewhere else. I am trying to update my video card drivers, but I get a BSOD when I try to do it. My ZIP file contains three crashes, and all three of them have different error codes. The last one (in August) might not be relevant, but the two in October both are.

My suspicion is that there is a problem in the registry involving the video card drivers, but I don't know how I'd go about fixing this.

Edit: I ran Memtest86 on my computer recently and there was not a problem involving my RAM.

My System SpecsSystem Spec
14 Oct 2013   #2
x BlueRobot


BugCheck CA, {b, fffffa8007ac7080, 1, 0}

Probably caused by : pci.sys
0: kd> !drvobj fffffa80076595a0 f
fffff8000348c010: Unable to get value of ObpRootDirectoryObject
fffff8000348c010: Unable to get value of ObpRootDirectoryObject
Driver object (fffffa80076595a0) is for:
Driver Extension List: (id , addr)

Device Object list:
fffffa8007ac6a10: Could not read device object

DriverEntry:   fffff88000f601a0	pci!GsDriverEntry
DriverStartIo: 00000000	
DriverUnload:  fffff88000f5526c	pci!PciDriverUnload
AddDevice:     00000000	

Dispatch routines:
[00] IRP_MJ_CREATE                      fffff800032c0b00	nt!IopInvalidDeviceRequest
[01] IRP_MJ_CREATE_NAMED_PIPE           fffff800032c0b00	nt!IopInvalidDeviceRequest
[02] IRP_MJ_CLOSE                       fffff800032c0b00	nt!IopInvalidDeviceRequest
[03] IRP_MJ_READ                        fffff800032c0b00	nt!IopInvalidDeviceRequest
[04] IRP_MJ_WRITE                       fffff800032c0b00	nt!IopInvalidDeviceRequest
[05] IRP_MJ_QUERY_INFORMATION           fffff800032c0b00	nt!IopInvalidDeviceRequest
[06] IRP_MJ_SET_INFORMATION             fffff800032c0b00	nt!IopInvalidDeviceRequest
[07] IRP_MJ_QUERY_EA                    fffff800032c0b00	nt!IopInvalidDeviceRequest
[08] IRP_MJ_SET_EA                      fffff800032c0b00	nt!IopInvalidDeviceRequest
[09] IRP_MJ_FLUSH_BUFFERS               fffff800032c0b00	nt!IopInvalidDeviceRequest
[0a] IRP_MJ_QUERY_VOLUME_INFORMATION    fffff800032c0b00	nt!IopInvalidDeviceRequest
[0b] IRP_MJ_SET_VOLUME_INFORMATION      fffff800032c0b00	nt!IopInvalidDeviceRequest
[0c] IRP_MJ_DIRECTORY_CONTROL           fffff800032c0b00	nt!IopInvalidDeviceRequest
[0d] IRP_MJ_FILE_SYSTEM_CONTROL         fffff800032c0b00	nt!IopInvalidDeviceRequest
[0e] IRP_MJ_DEVICE_CONTROL              fffff88000f50748	pci!PciDispatchDeviceControl
[0f] IRP_MJ_INTERNAL_DEVICE_CONTROL     fffff800032c0b00	nt!IopInvalidDeviceRequest
[10] IRP_MJ_SHUTDOWN                    fffff800032c0b00	nt!IopInvalidDeviceRequest
[11] IRP_MJ_LOCK_CONTROL                fffff800032c0b00	nt!IopInvalidDeviceRequest
[12] IRP_MJ_CLEANUP                     fffff800032c0b00	nt!IopInvalidDeviceRequest
[13] IRP_MJ_CREATE_MAILSLOT             fffff800032c0b00	nt!IopInvalidDeviceRequest
[14] IRP_MJ_QUERY_SECURITY              fffff800032c0b00	nt!IopInvalidDeviceRequest
[15] IRP_MJ_SET_SECURITY                fffff800032c0b00	nt!IopInvalidDeviceRequest
[16] IRP_MJ_POWER                       fffff88000f36908	pci!PciDispatchPnpPower
[17] IRP_MJ_SYSTEM_CONTROL              fffff88000f506e4	pci!PciDispatchSystemControl
[18] IRP_MJ_DEVICE_CHANGE               fffff800032c0b00	nt!IopInvalidDeviceRequest
[19] IRP_MJ_QUERY_QUOTA                 fffff800032c0b00	nt!IopInvalidDeviceRequest
[1a] IRP_MJ_SET_QUOTA                   fffff800032c0b00	nt!IopInvalidDeviceRequest
[1b] IRP_MJ_PNP                         fffff88000f36908	pci!PciDispatchPnpPower
There seems to be a problem with the PnP Manager or at least the drivers for the device, and how they are handling certain IRPs. The IRP seems most likely related to the _MJ_PNP Major Function code; IRP_MN_QUERY_DEVICE_RELATIONS seems to be the specific Minor Function code where the problem might have happened. I'm also guessing that a routine was used which took a device object as a parameter, before the a device node was created within the device tree by the PnP Manager for the associated device object.

0: kd> !stack
Call Stack : 9 frames
## Stack-Pointer    Return-Address   Call-Site       
00 fffff88002ffda18 fffff8000371cf65 nt!KeBugCheckEx+0 
01 fffff88002ffda20 fffff8000371d669 nt!PnpProcessRelation+695 
02 fffff88002ffda90 fffff80003758915 nt!PnpBuildRemovalRelationList+69 
03 fffff88002ffdae0 fffff8000375987c nt!PnpProcessQueryRemoveAndEject+325 
04 fffff88002ffdc20 fffff80003642a1e nt!PnpProcessTargetDeviceEvent+4c 
05 fffff88002ffdc50 fffff800032e5261 nt!PnpDeviceEventWorker+fa1b6 (perf)
06 fffff88002ffdcb0 fffff80003579bae nt!ExpWorkerThread+111 
07 fffff88002ffdd40 fffff800032cc8c6 nt!PspSystemThreadStartup+5a 
08 fffff88002ffdd80 0000000000000000 nt!KxStartSystemThread+16
A different stack trace from a Stop 0xE4 dump file revealed this:

0: kd> k
 # Child-SP          RetAddr           Call Site
00 fffff880`02fda748 fffff800`032417ea nt!KeBugCheckEx
01 fffff880`02fda750 fffff880`010e457e nt! ?? ::FNODOBFM::`string'+0x1032a
02 fffff880`02fda790 fffff880`010e3ada PCIIDEX!ControllerQueryDeviceRelations+0x52
03 fffff880`02fda7c0 fffff800`036474ae PCIIDEX!PciIdeDispatchPnp+0x22
04 fffff880`02fda7f0 fffff800`0364781a nt!PnpAsynchronousCall+0xce
05 fffff880`02fda830 fffff800`03649b67 nt!PnpQueryDeviceRelations+0xfa
06 fffff880`02fda8f0 fffff800`0367a15c nt!PipEnumerateDevice+0x117
07 fffff880`02fda950 fffff800`0367a768 nt!PipProcessDevNodeTree+0x21c
08 fffff880`02fdabc0 fffff800`0338d817 nt!PiProcessReenumeration+0x98
09 fffff880`02fdac10 fffff800`03294261 nt!PnpDeviceActionWorker+0x327
0a fffff880`02fdacb0 fffff800`03528bae nt!ExpWorkerThread+0x111
0b fffff880`02fdad40 fffff800`0327b8c6 nt!PspSystemThreadStartup+0x5a
0c fffff880`02fdad80 00000000`00000000 nt!KxStartSystemThread+0x16

Start Menu\Programs\Driver Fusion
These driver update and installation programs usually install incorrect and unstable drivers, please remove the program completely, and only install device drivers from your model support page or the hardware vendor.

Run Driver Verifier to scan for any corrupted drivers which may be causing problems, this program works by running various stress tests on drivers, in order to produce a BSOD which will locate the driver; run for least 24 hours:
information   Information
My System SpecsSystem Spec
14 Oct 2013   #3

Windows 7 Home Premium 64bit

I tried running Driver Verifier but my computer would not start up when it was activated. The Windows 7 splash would come up but when it should have gone to the desktop, the screen remained black. Is this normal?
My System SpecsSystem Spec

18 Oct 2013   #4
x BlueRobot


Sorry for my absence, I've been ill most of this week.

It is in a way, but it should boot normally into Windows. Have you disabled it now?

I would suggest reinstalling your drivers from the manufacturer's support page.
My System SpecsSystem Spec
18 Oct 2013   #5

Windows 7 Home Premium 64bit

I'm going to try to get driver verifier to work when I have time for it.

I can't reinstall or upgrade the drivers because that is what causes the BSOD. It 's like as soon as the install program tries to read the current version of driver installed, it crashes the computer.

I'll update the thread if I get something from driver verifier.
My System SpecsSystem Spec
19 Oct 2013   #6
x BlueRobot


Okay, and have you tried installing the drivers manually?
My System SpecsSystem Spec
21 Oct 2013   #7

Windows 7 Home Premium 64bit

No I haven't. I haven't heard of this before. I'll try it.
My System SpecsSystem Spec
22 Oct 2013   #8
x BlueRobot


Okay, please post an update when finished.
My System SpecsSystem Spec

 BSOD when trying to update Video Card Drivers

Thread Tools

Similar help and support threads
Thread Forum
BSOD after updating Video Card drivers. BSOD continued after reformat.
Just started playing Fortnite: Battle Royale and had a message consistently pop up upon launch of the game, saying that my drivers were old and that I should upgrade (they hadn't been updated since 2015). Since then, I've been repeatedly hit with multiple BSODs. It's my first time dealing with it...
BSOD Help and Support
ati video card drivers
amd display driver driver install: the driver package does not specify a hardware identifier sorry if this thread is already here somewhere i got this error after i uninstall all the amd that i was told to do not the only thing that want install is my video card update/driver i have a 32bit system...
Graphic Cards
dxgmms1.sys BSOD, can't uninstall video card drivers
I'm using a i5-750, evga P55 classified and 4gb of team xtreem ram. recently I've been getting BSOD when playing games, caused by this file according to bluescreenview. I uninstalled the video card drivers but when I rebooted, for some reason I still have catalyst 12.1 and there doesn't seem to be...
BSOD Help and Support
Cannot recover video card & sound card drivers after crash
Hello, I'm going to try to give as much detail as possible but I didn't write down any of the errors unfortunately. I had a freeze on my computer as I was switching my sound card (a pretty old sound blaster live gamer) from entertainment mode to game mode. I had to reboot as nothing else was...
BSOD Help and Support
BSOD cannot update gfx card drivers :/
ok over the past month or so I have been trying to solve a problem with my win7 installation (build 7232.0.1md64fre.winmain.0980610-1900) after a fresh install I had to find the smu drivers for my biostar MB and windows installed it's own video driver dated april 09. the gfx card is...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:44.
Twitter Facebook Google+