iastora.sys BSOD on HP ultrabook - can't even boot into windows

Page 2 of 2 FirstFirst 12

  1. Posts : 12
    Windows 7 Ultimate x64
    Thread Starter

    UPDATE: using this tutorial Recover files from Windows hard disk using Puppy Linux | www.winhelp.us

    In puppy linux I see all my partitions. I can mount them. Is there anything I can do from here?

    Obviously I can back up my data, which is awesome. But can I actually fix the iastor thing from here?
      My Computer

  2. Posts : 12
    Windows 7 Ultimate x64
    Thread Starter

    I downloaded the latest iastora.sys and iastorf.sys onto a flash drive. Accessing my drivers folder through puppy linux, I was able to rename the old iastora.sys and iastorf.sys and drag the new ones into there. I shut down and attempted to boot windows again. This time, instead of a BSOD after the "Starting Windows" Animation screen, it goes into system recovery options (even when I select "Start Windows Normally"). Is this good progress?
      My Computer

  3. Arc
    Posts : 35,373
    Microsoft Windows 10 Pro Insider Preview 64-bit

    You are trying really hard.

    Well done with Puppy Linux.

    But what we need here is to disable the IRST in the BIOS.

    I am asking for some help form the hardware experts who can guide you through it. In between, you please let us know the model number of your laptop, which will help us to help you about the BIOS configuration.
      My Computer

  4. Posts : 12
    Windows 7 Ultimate x64
    Thread Starter


    I have an HP ENVY 4-1043cl. The bios is InsydeH20 revision 3.7 F.02

    Now that I have the data I needed, my primary goal is to do a fresh clean install of W7 without using the rapid storage stuff.

    I really appreciate all your help
      My Computer

  5. Posts : 17,545
    Windows 10 Pro x64 EN-GB

    If you do a clean install (valid original Microsoft install media, not HP recovery media), the Intel Rapid Storage will not be automatically installed on your system but have to be instead downloaded and installed from HP support pages. If it is installed, you can uninstall it easily from Control Panel > Programs and Features.

      My Computer

  6. Posts : 12
    Windows 7 Ultimate x64
    Thread Starter

    Thanks Kari. Once I get my BIOS figured out, i'll do a clean install
      My Computer

  7. Posts : 12
    Windows 7 Ultimate x64
    Thread Starter

    I found this topic Access HP Envy 14 F.23 BIOS Advanced Options

    I tried that with my bios in all different combinations and it simply doesn't work.

    I checked HP website to see if there is a newer bios for my laptop. There is! and it is version F.23, the same version people have success with accessing advanced settings

    HP Notebook System BIOS Update (Intel Processors) - HP ENVY Ultrabook 4-1043cl | HP® Support

    Now I need to figure out how to install from outside of windows
      My Computer

  8. Posts : 5,605
    Originally Win 7 Hm Prem x64 Ver 6.1.7600 Build 7601-SP1 | Upgraded to Windows 10 December 14, 2019

    fut832 said:
    Now I need to figure out how to install from outside of windows
    Will this help? How to Flash BIOS if you cannot start Windows - HP Support Forum - 436381, when you click on "Go to Solution" you arrive here on the second page: Re: How to Flash BIOS if you cannot start Windows - Page 2 - HP Support Forum - 436381
      My Computer

  9. Posts : 12
    Windows 7 Ultimate x64
    Thread Starter

    I think I'm gonna give this a try HP Insyde BIOS recovery steps.
      My Computer

  10. Posts : 1
    Windows 8 x64

    i'm not sure if this post is still active but i'm having similar problems with the bsod and iastora.sys error message. i'd like to get my files off the computer to format it with the installation cds. i followed the puppy linux instructions but once puppy linux loads i only get a screen with a message saying that it is
    loading drivers needed to access disk drives....done
    searching puppy files in computer disk drives...
    searching deeper, sub-sub-folders in partitions... lupu_528.sfs not found. dropping out into initial ramdiskconsole...
    /bin/sh: can't access tty; job control turned off

    i tried putting drivers on the usb disk but i get the same message. i'd really appreciate help with this. thanks!
      My Computer

Page 2 of 2 FirstFirst 12

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 20:12.
Find Us