Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD BCCode: a

14 Nov 2013   #1

Windows 7 Professional x64
BSOD BCCode: a

This is my first post and is actually the first time I couldn't figure out why i'm getting a BSOD. It happens when i'm not looking and sometimes windows fails to boot all together and I suspect these issues are tied together. I'm hoping you guys can help me out

My System SpecsSystem Spec
15 Nov 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hi Bxsteez.

Make it sure that the Corsair Force GS SSD is running with the up-to-date firmware. They does it via their forum ... SSD Firmware Update - The Corsair Support Forums.

Get rid of intel rapid storage. First uninstall it from Control Panel > Programs and Features. Then Uninstall the driver from device manager.
  1. Right click on "my computer" icon and click "manage" on the context menu.
  2. It will open the "computer management" window.
  3. Select "Device Manager" in the left pane, It will list all the existing devices up.
  4. Expand "IDE ATA/ATAPI controllers" by clicking on the triangle in front of it.
  5. Select one Intel device item under it, right click, uninstall.
  6. Continue the process for all Intel items under "IDE ATA/ATAPI controllers"
  7. Now restart the computer. At restart, windows will auto configure the appropriate native system driver.
Free up the startup. Windows does not need any other program to auto start with it, but the auto start programs often conflicts and causes various problems including BSODs.
  1. Click on the Start button
  2. Type “msconfig (without quotes), click the resulting link. It will open the System Configuration window.
  3. Select the “Startup” tab.
  4. Deselect all items other than the antivirus.
  5. Apply > OK
  6. Accept then restart.
Update Asmedia 106x SATA Controller from Station-Drivers - Asmedia drivers.

Uninstall the following Asrock bloatware junks:
  • Start Menu\Programs\ASRock Utility
  • Start Menu\Programs\ASRock Utility\A-Tuning
  • Start Menu\Programs\ASRock Utility\AsrAppCharger
  • Start Menu\Programs\ASRock Utility\HDMISwitch
I'd recommend you to Clean Up Factory Bloatware, with a special reference to Point #13
13. Consider a Clean Reinstall - Factory OEM Windows 7 which is often better than getting a new computer considering how pre-installed bloatware can corrupt Windows 7 even if it's completely cleaned up.
Test your RAM modules for possible errors.
How to Test and Diagnose RAM Issues with Memtest86+
Run memtest for at least 8 passes, preferably overnight.
If it start showing errors/red lines, stop testing. A single error is enough to determine that something is going bad there.

Let us know the results.
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck A, {8, 2, 1, fffff800030eb227}

Probably caused by : ntkrnlmp.exe ( nt!KeReleaseSemaphore+137 )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: 0000000000000008, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff800030eb227, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff80003307100
GetUlongFromAddress: unable to read from fffff800033071c0
 0000000000000008 Nonpaged pool


fffff800`030eb227 48894108        mov     qword ptr [rcx+8],rax




PROCESS_NAME:  SetPoint.exe

TRAP_FRAME:  fffff8800a4585d0 -- (.trap 0xfffff8800a4585d0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffffa800bb05700 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800030eb227 rsp=fffff8800a458760 rbp=fffffa8006e191e8
 r8=0000000000000000  r9=0000000000000001 r10=0000000000000000
r11=fffff8800a4588c0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na pe nc
fffff800`030eb227 48894108        mov     qword ptr [rcx+8],rax ds:00000000`00000008=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800030cf169 to fffff800030cfbc0

fffff880`0a458488 fffff800`030cf169 : 00000000`0000000a 00000000`00000008 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`0a458490 fffff800`030cdde0 : 00000000`00000000 00000000`00000000 00000000`00000000 fffffa80`06e191e0 : nt!KiBugCheckDispatch+0x69
fffff880`0a4585d0 fffff800`030eb227 : 00000000`00000000 fffffa80`09399430 00000000`00000000 fffffa80`09399538 : nt!KiPageFault+0x260
fffff880`0a458760 fffff800`03130382 : 00000000`00000000 fffffa80`00000001 00000000`00000000 00000000`00000001 : nt!KeReleaseSemaphore+0x137
fffff880`0a4587e0 fffff800`033e0d66 : 00000000`00580030 fffffa80`0a714c28 00000000`00000001 00000000`00000000 : nt! ?? ::FNODOBFM::`string'+0x206d7
fffff880`0a458890 fffff800`033e0460 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!AlpcpReceiveSynchronousReply+0x46
fffff880`0a4588f0 fffff800`033e451d : fffffa80`0a7cfb00 00000000`00020000 00000000`002e2000 00000000`00000000 : nt!AlpcpProcessSynchronousRequest+0x33d
fffff880`0a458a30 fffff800`033e45f6 : fffff900`c0643300 00000000`00000001 fffffa80`06799080 fffff800`03380001 : nt!LpcpRequestWaitReplyPort+0x9c
fffff880`0a458a90 fffff800`030cee53 : fffffa80`0a714860 fffff880`0a458b60 00000000`03d1f988 fffffa80`0a7cfb00 : nt!NtRequestWaitReplyPort+0x76
fffff880`0a458ae0 00000000`76d014da : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`03d1f798 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x76d014da


fffff800`030eb227 48894108        mov     qword ptr [rcx+8],rax


SYMBOL_NAME:  nt!KeReleaseSemaphore+137

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  ntkrnlmp.exe


FAILURE_BUCKET_ID:  X64_0xA_nt!KeReleaseSemaphore+137

BUCKET_ID:  X64_0xA_nt!KeReleaseSemaphore+137

Followup: MachineOwner
My System SpecsSystem Spec
17 Nov 2013   #3

Windows 7 Professional x64

I tried all of these fixes and I'm not seeing the BSOD anymore but now when i return from sleep the computer goes right back to sleep. I'm not even remotely sure how to fix that
My System SpecsSystem Spec

17 Nov 2013   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

If the BSODs are over and only some issue with sleep is there, I would suggest you to close this thread for now and start a new thread in General Discussion - Windows 7 Help Forums for the sleep issue.
My System SpecsSystem Spec

 BSOD BCCode: a

Thread Tools

Similar help and support threads
Thread Forum
three different BSOD during 2 nights bccode 1A and bccode 24 and D1
play computer games during day and sleeping at night. forget to windows key + L during the night so that the system doesnt get that affected by errors and programs. what do i need to do? i downloaded the sf diagnostic tool and grab all function. where do i post it?
BSOD Help and Support
BSOD:: BCCode: 116; BCCode: f4 (mostly f4)
Hard drive failed in late October, replaced with SSD. Started getting BSOD whenever doing anything graphical (flash in a web browser, or a game) in November. Tried Driver Fusion (|MG| Driver Fusion (Driver Sweeper) 1.4.0 Download) and installiing older NVIDIA drivers, this reduced the...
BSOD Help and Support
BSOD during high bandwith situations. Bccode a, bccode b1.
I've completely reinstalled my system from the ground up twice over this last weekend. Still gettin the BSOD's at least daily. Here's a zip of the latest dump. It seems to really only BS when I'm running high bandwith/ memory. I.E. videogames/teamspeak/Pandora simultaneously My system is an ...
BSOD Help and Support
Frequent/randon BSODs. once BCCode =3b, once BCCode =1e,
Frequent and randon BSODs. once BCCode =3b, once BCCode =1e, others unknown. Dell precision 380 w/ 4GB. Upgraded OS to WIN 7 Premiun Home 64 bit in June 2012 (from XP Pro). WIN 7 Premium Home Family Pack (upgrade). Using Windows Security Essentials. Have scanned frequently. Also downloaded and...
BSOD Help and Support
BSOD from new memory card, BCCode:d1 & BCCode:fc
x64 full retail around 4 year old comp The memory I use on my PC is: "Corsair TWIN2X4096-8500C5D Dominator 4GB 2 X 2GB PC2-8500 1066MHz 240-Pin DDR2 CL5 Dual Channel Desktop Memory" Wanting more memory I decided to to place: "OCZ DDR2 PC2-8500 Platinum 4GB Edition Dual Channel *EOL" ...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:38.
Twitter Facebook Google+