Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: RAID Changed, Windows 7 Won't Boot (BSOD)

29 Nov 2013   #1

Windows 7 64bit
RAID Changed, Windows 7 Won't Boot (BSOD)

Ok, so Bare with me while I explain the problem.

A few days back, my computer would not post on boot. For some reason, no signal would go to the monitor. After reading a considerable amount on the subject online, I tried various hardware swaps (ram, video card, remove optical drives to try and ascertain the problem. Everyone suggested updating the bios. After leaving the computer unplugged for some time, It finally showed me the bios. After booting into windows, several problems would occur, such as the keyboard and mouse not working. Several reboots later and they worked fine. I flashed the bios, and the computer started up perfectly normally. However, during the flash, it gave me the message that it completely cleared the cmos. I noticed that the device initiation looked different in the bios. I couldn't tell if it was due to the updated BIOS version, or if a configuration setting was different (since the cmos was cleared). When windows was booting it was taking far longer than normal. Once loaded, the first thing it showed me was that it was installing new drivers, including an IDE controller driver. Confusing, since Windows had not installed this driver before in the 3 years I had owned the computer, and no new hardware has ever been added. During the driver install, it informed me that One of my hard drives was ready to use, but the other required a restart to complete. This was confusing to me, as they function as a single drive in RAID 1 configuration. Well, It restarted the computer, and windows refuses to boot. The windows 7 graphic starts, and then is interrupted by a BSOD flash, and then my computer reboots. The BSOD is so quick, I don't get to see the error.

This computer was custom built for me by a company, and I never had much of a need to go into the BIOS. Unfortunately, this means that I wasn't familiar with how the raid setup was done within my bios. So when the CMOS cleared, I lost that configuration. My Options are IDE, RAID, or AHCI. After the cmos wipe, it was set to IDE. I tried changing it to RAID, and the same problem occurs. I tried changing it to AHCI, and the windows graphic goes farther, but then the same BSOD.

The system will not boot into safe mode.

At one point i got the system to boot using last known good configuration, but when It loaded, I kept getting errors informing me that various files were corrupt. And the system had to be rebooted. Now, when I try to boot using last known good configuration, it will not boot. And it also tells me it needs to run check disk.

So, What do you guys suggest. Is there any way for me to ascertain what the setting was originally on my BIOS? Does it sound like this was the problem? What should I do. I do have an older system image to restore, but if it is a RAID setting, the restored drive will have the same problems, correct? I attempted a system repair, which didn't work, is this hurting the system for if/when I fix the issue?

My System SpecsSystem Spec
30 Nov 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Your issue is that the computer is now on the storage controller mode which is different from that one which was in use during installation.

This computer is a custom build, and custom installed. The OS was installed with RAID as the storage controller mode. Now, the BIOS got reverted back to defaults, and the RAID options got disabled. Either you have to get those settings back (most probably those are available in the advanced BIOS setup options, but every BIOS is different, so it cannot be told specifically. Also, various RAID works differently, like Intel, Marvell or JMicron).

If you can search for those options and revert them back, the computer will boot up.

If you cannot, it will not boot at all. No other fix will work.

So, if you cannot, forget the RAID, if RAID is not a must for you. RAID is always problematic.

Set the storage controllers to AHCI, and perform a clean reinstall.
My System SpecsSystem Spec

 RAID Changed, Windows 7 Won't Boot (BSOD)

Thread Tools

Similar help and support threads
Thread Forum
AMD Raid 1 disks changed to not initialized
My computer has 5 disks and was set to duel boot several Win7 vhd. 2 of the disks were run in RAID 1 for store data. Yesterday, one of the Win7 had those 2 disks changed to not initialized. But all the other Win7 can see those 2 disks (1 volume as RAID 1) showed Online and Healthy. I thought...
Hardware & Devices
BSOD on boot, RAID 0, Stock clocks
I7-950 HD6970 6GB corsair XMS 3 1600MHz @1066 DRIVES- OS- 2 x corsair force 3 60gb SSD running RAID 0 on Sata 2 ports SEPARATE to OS drives- 2 x corsair 60gb in RAID 0 1x WD 320gb 1x WD 1TB Cooler master silent pro 850
BSOD Help and Support
NTFS automatically changed to RAID?
Hi all, I am hoping someone can help as I just cannot figure it out and I have searched high and low on the internet and cannot find the answer. New PC built from a bare bones machine 4344g.html and a 2tb drive ...
Hardware & Devices
Common BSOD/changed boot disk
I've been running Win7 x64 for months,and the only problem I get is that after a few months, it just goes belly up and i get a BSOD, just today it happened again, no hardware chages, no software changes, it was working fine when I turned it off lastnight. The only way I fixed it today was i...
Performance & Maintenance
Cannot boot from non-RAID image restored to RAID SSD
OK, I was using one Vertex 120 as my Windows 7 C: drive and bought another to take advantage of RAID0 performance. Did a system image backup of the C: drive to my 1TB D: drive, installed the 2nd Vertex 120 (both are FW 1.5), enabled RAID in BIOS and created a RAID0 in the Intel RAID launch...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:26.
Twitter Facebook Google+