Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Driver error possibly preventing proper sleep and shut down

21 Dec 2013   #1

Windows 7 Home Premium x64
Driver error possibly preventing proper sleep and shut down

Just recently I started having an issue where I would come back and my computer would be off, when I had left it on, so I am assuming that when I leave for a long enough time it attempts to enter sleep mode, somehow fails and shuts down, because then I get a "windows failed to shut down properly" message. I have also been having issues with restart not actually restarting, and getting stuck on "Shutting Down Windows". I also have had that happen when I give the Shut down command. I'd rather not shut off my computer improperly all the time, and when I start it up it says that windows recovered from an unexpected shutdown, and gives similar error codes to the ones found below (I think, I can't quite remember).

I looked around a bit regarding the error code that I was getting, which seemed to point me to use driver verifier on all my non-Microsoft signed drivers. So I did that and it bluescreened on startup, after displaying the starting windows screen.

It did the same thing 2 or 3 times in a row before I decided to go into the Startup Recovery and attempt repairs, which failed, giving the root cause:

"Unknown Bugcheck: Bugcheck c9. Parameters = 0x23e, 0xfffff88004250324, 0xfffff98006142ee0, 0x0."

I then restarted again and allowed the Startup Recovery to recover using the backup, which seems to have recovered completely without losing any of my recent data. I haven't yet turned off my computer to see if the problem persists but I don't see why this backup would have fixed it, and I wanted to put up this post just in case it has more issues.

Edit: I just shut down my computer to see what happened and it didn't get stuck on "Shutting down..." but it went black but the computer was still running and the lights were on to denote that, so something must be going on there... so I just manually turned it off and then when I turned it back on I received no "windows has recovered from an unexpected shutdown" or anything like that.

Any help would be appreciated, thanks! (Also this is my first time using the SF Diagnostic Tool so if I missed anything please let me know)

My System SpecsSystem Spec
22 Dec 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Disable Driver Verifier at first. If you cannot, boot into System Recovery Options and opt for a System Restore. For such hazards, you are not supposed to enable DV at your own. You did not need to enable DV here.

Anyway .........

The DV enabled BSOD indicates to Daemon Tools.
BugCheck C9, {23e, fffff880042f8324, fffff98005982ee0, 0}

*** WARNING: Unable to verify timestamp for dtsoftbus01.sys
*** ERROR: Module load completed but symbols could not be loaded for dtsoftbus01.sys
Probably caused by : dtsoftbus01.sys ( dtsoftbus01+1324 )

Followup: MachineOwner
Daemon Tools, Alcohol 120% and Power Archiver Pro uses SCSI Pass Through Direct (SPTD), which is a well known BSOD causer. Uninstall Daemon Tools at first. Then download SPTD standalone installer from, and execute the downloaded file as guided below :
  • Double click to open it.
  • Click this button only:
  • If it is grayed out, as in the picture, there is no more SPTD in your system, and you just close the window.
The Non-DV enabled BSODs are indicating to NETGEAR WNA3100 N300 Wireless USB Adapter.
BugCheck 1000009F, {4, 258, fffffa8003fefb50, fffff800048fb3d0}

*** WARNING: Unable to verify timestamp for bcmwlhigh664.sys
*** ERROR: Module load completed but symbols could not be loaded for bcmwlhigh664.sys
Implicit thread is now fffffa80`03fefb50
*** WARNING: Unable to verify timestamp for win32k.sys
*** ERROR: Module load completed but symbols could not be loaded for win32k.sys
Probably caused by : bcmwlhigh664.sys ( bcmwlhigh664+b866 )

Followup: MachineOwner
And the driver is old.

fffff880`0968d000 fffff880`097c4000   bcmwlhigh664 T (no symbols)           
    Loaded symbol image file: bcmwlhigh664.sys
    Image path: \SystemRoot\system32\DRIVERS\bcmwlhigh664.sys
    Image name: bcmwlhigh664.sys
    Timestamp:        Tue Apr 19 12:43:08 2011 (4DAD3604)
    CheckSum:         00137E7A
    ImageSize:        00137000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Try to update the driver from

Let us know the results.
My System SpecsSystem Spec
24 Dec 2013   #3

Windows 7 Home Premium x64

Hey, so I did both of the fixes you suggested, first uninstalling Daemon Tools and then running the remover, which said it was already removed so I just left it at that. I also uninstalled my wifi network adapter's driver and reinstalled the newer version, which was available. I am still having a strange problem with my computer shutting down properly or entering sleep mode.

Here's the relevant information:

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.
Locale ID: 1033

Additional information about the problem:
BCCode: 9f
BCP1: 0000000000000003
BCP2: FFFFFA8004075A10
BCP3: FFFFF800048F7748
BCP4: FFFFFA8006A99C10
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1

Files that help describe the problem:

I have zipped up these two files and attached them for troubleshooting. The error seems to have occurred as the computer attempted to enter sleep mode after I had gone to sleep. The computer also always crashes whenever I tell the computer to shut down, getting frozen after the screen turns black - I can hear the fans are still running and the lights are on, and I have to turn it off manually.

Help would be appreciated. Thanks!
My System SpecsSystem Spec

25 Dec 2013   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Update your ATI/AMD display driver to teh latest WHQL.
You can get it from the link in our forum, Latest AMD Catalyst Video Driver for Windows 7, or you may go to AMD Graphics Driver and Software and opt for Automatically Detect and Install the appropriate driver for your card.

During installation, you may opt for advanced installation, and install the display driver only, not the Catalyst Control Center.

Do you have a dual graphics GPU?
My System SpecsSystem Spec
25 Dec 2013   #5

Windows 7 Home Premium x64

Yes I do, I have 2 7850's currently CrossFire'd together, would that change your suggestions?

I don't know if this matters either but the cards have separate manufacturers, I figured that shouldn't matter though..
My System SpecsSystem Spec
26 Dec 2013   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

No, having multiple GPU does not change the suggestion to update the outdated driver, but increases the chance to have a stop 0x9F.
My System SpecsSystem Spec
26 Dec 2013   #7

Windows 7 Home Premium x64

Okay, well, I for the first time came back to my computer today after updating my graphics drivers and the stop 0x9F was nowhere to be found and it came back from sleep nicely.

I am a bit curious though, mind explaining how an outdated graphics card driver interferes with something that seems to irrelevant to display? (not shutting down all the way, not going to sleep properly, etc)

I'm going to mark this as solved, so thanks a lot for all your assistance!
My System SpecsSystem Spec
27 Dec 2013   #8

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Graphics cards are display devices for sure, but it is a PnP device at the end of the day. Any PnP device may face a stop 0x9F during the power transitions. It is not irrelevant at all.

Anyway, let us know for any further issue.
My System SpecsSystem Spec

 Driver error possibly preventing proper sleep and shut down

Thread Tools

Similar help and support threads
Thread Forum
Samsung 840 EVO preventing sleep
I just purchased this SSD to replace the 830. The 830 allowed sleep, but this one will not. I have the same settings I had for the 830 in power options If I click Start and sleep, it will not sleep. I called Samsung and they said I should just turn comp off, but that does not solve the...
Hardware & Devices
Ad preventing screen shut off?
Are animated ads supposed to prevent the display from turning off? I was idle for 20 minutes but the screen will not turn off. I will try a antivirus check later.
General Discussion
BSOD (random) possibly after computer when to sleep, error 0x0000000A
I've seen random BSOD. 0) I run Windows memory test again and no errors found 1) First I suspected of eSata interface, but this was a guess, there was not really any proof 2) I suspected of a SW called MagicISO because I saw some reports about BSOD (but a guess again) 3) Then I suspected of...
BSOD Help and Support
What preventing my pc from Sleep/hibernate
My lap is lenovo y580 and i'm struggling how to solve the problem. I allways gettin' BsOD when pc trying to go sleep or hibernate. Win 7 x64. I've tried to reinstall lenovo energy managment but same thing. Any help appreciated. Thanks in advice.
General Discussion
Motherboard preventing manual sleep
I posted a thread a while ago, and I thought something was preventing my computer from sleeping (Mouse or keyboard), but I have tried the lastwake command and it will say my keyboard at first, but keeps coming up with something else that awakened it my computer from sleep (As I disable all the...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:27.
Twitter Facebook Google+