Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD: IRQL Not Less or Equal, newly built computer

24 Dec 2013   #1

Windows 7 Ultimate x64
BSOD: IRQL Not Less or Equal, newly built computer

Hi there! I'm hoping to find out the origin of the issues I've been having with my new PC. I recently put it together; the configuration is in my profile. I have had a number of blue screens over the last few days, all with the IRQL_NOT_LESS_OR_EQUAL message.

I know that I have had World of Warcraft running when most of them have occurred, but I can't say with certainty that it was running for each and every occasion. I've uploaded my SF Diagnostic Folder. Hopefully, this is enough information to find a solution.

Thank you in advance!

My System SpecsSystem Spec
24 Dec 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hi Pyrillia.

How old your Razor products are? Can you identify any time relation between the usage of Razor and the occurrence of the BSODs?

Update the Etron USB 3.0 driver ver: from ASRock > 970 Pro3 R2.0. If still it is the same, remove razor stuff, at least as a test.

Also update the network driver from Realtek. Get the Win7 and WinServer 2008 R2 Driver (first one of the list), follow Driver Install - Device Manager to install it.

Let us know the results.
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck A, {80038000020, 2, 0, fffff80002e758d2}

*** WARNING: Unable to verify timestamp for rzudd.sys
*** ERROR: Module load completed but symbols could not be loaded for rzudd.sys
Probably caused by : kbdclass.sys ( kbdclass!KeyboardClassServiceCallback+47e )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: 0000080038000020, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff80002e758d2, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800030bb100
GetUlongFromAddress: unable to read from fffff800030bb1c0
 0000080038000020 Nonpaged pool


fffff800`02e758d2 4c396220        cmp     qword ptr [rdx+20h],r12





TAG_NOT_DEFINED_c000000f:  FFFFF88002F22FB0

TRAP_FRAME:  fffff88002f1ac30 -- (.trap 0xfffff88002f1ac30)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=fffffa800987fba0
rdx=0000080038000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80002e758d2 rsp=fffff88002f1adc0 rbp=fffff880009ec180
 r8=0000000000000000  r9=fffffa800987fba0 r10=0000000000000000
r11=fffff88002f1af02 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na po cy
fffff800`02e758d2 4c396220        cmp     qword ptr [rdx+20h],r12 ds:00000800`38000020=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002e83169 to fffff80002e83bc0

fffff880`02f1aae8 fffff800`02e83169 : 00000000`0000000a 00000800`38000020 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`02f1aaf0 fffff800`02e81de0 : 00000000`00000000 00000000`00000002 fffff880`02f1ac70 fffffa80`0987fb50 : nt!KiBugCheckDispatch+0x69
fffff880`02f1ac30 fffff800`02e758d2 : 0000057f`f71b6b08 00000000`00000198 0000057f`f64d2a78 0000057f`f822a998 : nt!KiPageFault+0x260
fffff880`02f1adc0 fffff800`02e646a4 : fffffa80`0987fb50 00000000`00000002 00000000`00000000 fffffa80`0a7cd088 : nt!KiInsertQueueApc+0x322
fffff880`02f1adf0 fffff800`02e87df3 : fffffa80`07ccc8a0 00000000`a000000c 00000000`00000000 fffff880`02f1b010 : nt!KeInsertQueueApc+0x80
fffff880`02f1ae50 fffff880`05863e0e : 00000000`00000004 fffffa80`07eafe06 fffffa80`07eafe30 00000000`00000000 : nt!IopfCompleteRequest+0xb63
fffff880`02f1af40 fffff880`06fb0d52 : fffffa80`09d5d4f0 fffff880`02f1b01c fffff880`02f1b230 fffff880`02f1b230 : kbdclass!KeyboardClassServiceCallback+0x47e
fffff880`02f1afc0 fffffa80`09d5d4f0 : fffff880`02f1b01c fffff880`02f1b230 fffff880`02f1b230 fffff880`02f1b010 : rzudd+0x15d52
fffff880`02f1afc8 fffff880`02f1b01c : fffff880`02f1b230 fffff880`02f1b230 fffff880`02f1b010 fffff880`06fb0fe0 : 0xfffffa80`09d5d4f0
fffff880`02f1afd0 fffff880`02f1b230 : fffff880`02f1b230 fffff880`02f1b010 fffff880`06fb0fe0 00000000`00000001 : 0xfffff880`02f1b01c
fffff880`02f1afd8 fffff880`02f1b230 : fffff880`02f1b010 fffff880`06fb0fe0 00000000`00000001 fffff880`02f1b230 : 0xfffff880`02f1b230
fffff880`02f1afe0 fffff880`02f1b010 : fffff880`06fb0fe0 00000000`00000001 fffff880`02f1b230 00000000`00000001 : 0xfffff880`02f1b230
fffff880`02f1afe8 fffff880`06fb0fe0 : 00000000`00000001 fffff880`02f1b230 00000000`00000001 fffffa80`088c0010 : 0xfffff880`02f1b010
fffff880`02f1aff0 00000000`00000001 : fffff880`02f1b230 00000000`00000001 fffffa80`088c0010 00000002`00510005 : rzudd+0x15fe0
fffff880`02f1aff8 fffff880`02f1b230 : 00000000`00000001 fffffa80`088c0010 00000002`00510005 00000000`00000000 : 0x1
fffff880`02f1b000 00000000`00000001 : fffffa80`088c0010 00000002`00510005 00000000`00000000 00000000`00000000 : 0xfffff880`02f1b230
fffff880`02f1b008 fffffa80`088c0010 : 00000002`00510005 00000000`00000000 00000000`00000000 00000000`00000000 : 0x1
fffff880`02f1b010 00000002`00510005 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0xfffffa80`088c0010
fffff880`02f1b018 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x00000002`00510005


fffff880`05863e0e 488d4e20        lea     rcx,[rsi+20h]


SYMBOL_NAME:  kbdclass!KeyboardClassServiceCallback+47e

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: kbdclass

IMAGE_NAME:  kbdclass.sys


FAILURE_BUCKET_ID:  X64_0xA_kbdclass!KeyboardClassServiceCallback+47e

BUCKET_ID:  X64_0xA_kbdclass!KeyboardClassServiceCallback+47e

Followup: MachineOwner

1: kd> lmvm rzudd
start             end                 module name
fffff880`06f9b000 fffff880`06fc3000   rzudd    T (no symbols)           
    Loaded symbol image file: rzudd.sys
    Image path: \SystemRoot\system32\DRIVERS\rzudd.sys
    Image name: rzudd.sys
    Timestamp:        Fri Nov 15 12:04:51 2013 (5285C08B)
    CheckSum:         0002F832
    ImageSize:        00028000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
24 Dec 2013   #3

Windows 7 Ultimate x64

Hi there, Arc!

The Razer products are a bit over a year old. I purchased each one of them in the middle of September, last year. I had noticed that the keyboard was having an issue where the enter key was becoming stuck in use, whenever I brought my computer out of sleep mode, but I have not had that problem in the last two days since installing the most recent firmware update.

I went ahead and updated the Etron USB 3.0 driver, as well as the network driver. I will continue using my computer as I normally would and will check back in within the next day or two, to report back if the BSODs are still occurring or not. Hopefully, it was just the drivers. That would be a big relief!

Thank you!
My System SpecsSystem Spec

24 Dec 2013   #4

Windows 7 Ultimate x64

Well, that was fast.

Got another BSOD within about 45 minutes of updating all of those drivers. Different message this time, though. Nothing regarding IRQL_NOT_LESS_OR_EQUAL.

Here's my latest SF Diagnostic Folder.

Edit: A couple more for my trouble. Uploaded another folder. These two latest BSODs stated that a "clock interrupt was not received on a secondary processor."
My System SpecsSystem Spec
25 Dec 2013   #5

Windows 7 Ultimate x64

Any more help I could get with this would be greatly appreciated. I'm starting to get BSODs within 5 or 10 minutes of restarting, now.
My System SpecsSystem Spec
26 Dec 2013   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

The latest BSOD is CLOCK_WATCHDOG_TIMEOUT, BugCheck 101. Usually these BSODs are clueless, and anything of the entire computing environment can cause it.

First let us concentrate on the storage section.
fffff880`094f3c48 fffff800`02edda4a nt!KeBugCheckEx
fffff880`094f3c50 fffff800`02e906f7 nt! ?? ::FNODOBFM::`string'+0x4e3e
fffff880`094f3ce0 fffff800`03400895 nt!KeUpdateSystemTime+0x377
fffff880`094f3de0 fffff800`02e83113 hal!HalpHpetClockInterrupt+0x8d
fffff880`094f3e10 fffff800`02e8b9ee nt!KiInterruptDispatchNoLock+0x163
fffff880`094f3fa0 fffff800`02eca95c nt!KeFlushMultipleRangeTb+0x25e
fffff880`094f4070 fffff880`0126d69c nt!MmSetAddressRangeModified+0x2b0
fffff880`094f4170 fffff880`01318dfb Ntfs!LfsFlushLfcb+0x5d8
fffff880`094f42f0 fffff880`0131b35c Ntfs!LfsFlushToLsnPriv+0x143
fffff880`094f4380 fffff880`01318997 Ntfs!LfsWriteLfsRestart+0xf0
fffff880`094f43c0 fffff880`0131737b Ntfs!LfsWriteRestartArea+0x143
fffff880`094f4450 fffff880`0131a68f Ntfs!NtfsCheckpointVolume+0xa97
fffff880`094f4850 fffff880`0131903f Ntfs!NtfsCheckpointAllVolumesWorker+0x4b
fffff880`094f48a0 fffff880`0131b144 Ntfs!NtfsForEachVcb+0x167
fffff880`094f4940 fffff800`02e90261 Ntfs!NtfsCheckpointAllVolumes+0xb8
fffff880`094f4b70 fffff800`031232ea nt!ExpWorkerThread+0x111
fffff880`094f4c00 00000000`00000000 nt!PspSystemThreadStartup+0x5a
Test both your HDDs: SeaTools for DOS and Windows - How to Use

Plus, the storage controller is old.
fffff880`00dcc000 fffff880`00de4000   amd_sata   (deferred)             
    Image path: \SystemRoot\system32\DRIVERS\amd_sata.sys
    Image name: amd_sata.sys
    Timestamp:        Tue Dec 13 02:22:00 2011 (4EE66970)
    CheckSum:         000173E9
    ImageSize:        00018000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
It is a part of the chipset. Download and install AMD all in 1 driver ver:12.3 from ASRock > 970 Pro3 R2.0

Let us know the results.
My System SpecsSystem Spec
26 Dec 2013   #7

Windows 7 Ultimate x64

Thank you again for the response!

I went ahead and downloaded the latest AMD all in 1 driver. I also ran SeaTools on both HDDs and they each came up as passing, after the short generic tests. Should I run the long generic tests, as well, or move on to testing something else?
My System SpecsSystem Spec
26 Dec 2013   #8

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

If short generic test passed, stop here.

Test your RAM modules for possible errors.
How to Test and Diagnose RAM Issues with Memtest86+
Run memtest for at least 8 passes, preferably overnight.
If it start showing errors/red lines, stop testing. A single error is enough to determine that something is going bad there.

Stress test the Graphics Card using Furmark.
Video Card - Stress Test with Furmark

Stress test the CPU.
Hardware - Stress Test With Prime95

Are you overclocking? As you are getting BSODs, you should stop overclocking and run all the hardware components like CPU, GPU and RAM to their default settings. Also set the BIOS to default, too.
How To Clear CMOS (Reset BIOS)

Check if the Power Supply Unit (PSU) supplying adequate power to the computer or not.
eXtreme Power Supply Calculator
Also let us know the the wattage of the CPU.

Is the computer hot? Report us the heat of the computer after a couple of hours of your normal usage. Upload a screenshot of the summery tab of Speccy. Alternatively, you can publish a Speccy snapshot too: Speccy - Publish Snapshot of your System Specs .

Let us know the results, also post if any further BSODs are there.
My System SpecsSystem Spec
27 Dec 2013   #9

Windows 7 Ultimate x64

Alright. I ran Prime95 last night, for a little over two hours. Everything appeared fine; the process was still running when I checked on it again and there were no errors.

The Power Supply Calculator put me at needing a little over 300 watts for what I'm running. My current power supply is 600 watts.

I've made sure that overclocking hasn't been enabled. I don't believe I've touched it since putting the computer together, but I did double check to make sure it wasn't enabled.

I ran Memtest86+ overnight, and then some. It took about 17 hours for eight full passes, but there wasn't a single error once that was through.

This is a screenshot of Speccy, after about 1 1/2 hours of normal usage: It doesn't seem like anything is running too hot.

While running Furmark, I did notice what could possibly be artifacts, but I'm not entirely sure. There would be a white, pixelated line popping up every so often, but that was it.

In-between the tests, I had three more BSODs pop up last night. The new diagnostic folder is uploaded.
My System SpecsSystem Spec
28 Dec 2013   #10

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Enable Driver Verifier to monitor the drivers.
Driver Verifier - Enable and Disable
Run Driver Verifier for 24 hours or the occurrence of the next crash, whichever is earlier.

information   Information
Why Driver Verifier:
It puts a stress on the drivers, ans so it makes the unstable drivers crash. Hopefully the driver that crashes is recorded in the memory dump.

How Can we know that DV is enabled:
It will make the system bit of slow, laggy.

warning   Warning
Before enabling DV, make it sure that you have earlier System restore points made in your computer. You can check it easily by using CCleaner looking at Tools > System Restore.

If there is no points, make a System Restore Point manually before enabling DV.

Tip   Tip

Let us know the results, with the subsequent crash dumps, if any.
My System SpecsSystem Spec

 BSOD: IRQL Not Less or Equal, newly built computer

Thread Tools

Similar help and support threads
Thread Forum
Newly built computer BSOD 000000f4
Hi all, Built a new computer yesterday. Been having a lot of BSOD problems. Dump files are attached. What I've tried so far: - Full re-install of Windows (twice) - Replaced SATA cable on hard drive (seemed to work, gave me 2 hours without BSOD before they started coming back). - Ran...
BSOD Help and Support
BSOD in Newly built computer BCCode: 50
Background : I had my custom computer build for me, the parts are Processor - Intels i3 3220 3.3ghz Motherboard - MSI Z77A-G41 Graphics Card - MSI Radeon 7770 Harddrive - Seagate Barracuda 7200 RPM 1TB 64mb cache RAM - 2 x 4 GB Ballistics Memory Sticks DVD CD 24/XX - optical drive...
BSOD Help and Support
BSOD 0x0000003B on newly built Computer.
I revived a BSOD error 0x0000003B while the computer was at idle. The computer was at idle. I think I uploaded the dump file correctly. I am new here. Thanks for your time in advance. jtn0123
BSOD Help and Support
BSOD on newly built computer
My computer has been getting the BSOD with normal use. It's a brand new computer that I assembled myself. The only parts that aren't new are the three internal hard drives, which were salvaged from an older machine. Appreciate any help, thanks in advance!
BSOD Help and Support
Newly built computer with BSOD, please help!
Hey everybody, I've been putting together a new computer for the past 2 weeks, and I've been getting the BSOD and I don't know why. It might be because of the cpu cooling or memory or the psu. I've changed the psu from 600w to 800w but I'm still getting the bs. I'm currently using the stock...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:06.
Twitter Facebook Google+