Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD while boot - DRIVER_IRQL_NOT_LESS_EQUAL - ndis.sys

30 Dec 2013   #1

Wiindows 7 Professional 64Bit
BSOD while boot - DRIVER_IRQL_NOT_LESS_EQUAL - ndis.sys

Hi Everyone,

I'm at the end of my (somewhat limited) knowledge.

I tried to fix my dads computer today and uninstalled some useless junk he picked up on the way (mostly the great toolbar and the free McAfee AV).

Idk what happened but after a restart I only get BSODs just shy of the login screen.
After some to and from I was no finally able to reach the basic secure mode to retrieve the minidump but that's about it

I hope someone can help. My dad needs his computer and my only other idea would be to extract his data and re-install Windows

BSOD minidump:

My System SpecsSystem Spec
30 Dec 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Upload your MSINFO32.nfo file.
  1. Click on the start button
  2. Type "msinfo32" (without quotes) in the search bar of the start menu, click the resulting link. It will open the System Information window.
  3. File>Save. In the "File Name" filed, put "MSINFO32" (without Quote), give the save location to desktop, and click the "save" button.
  4. Give the time for processing, it will save a .nfo file on your desktop.
  5. Zip it, and upload it following the instruction.
It is needed to see to suggest the appropriate driver.
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {10, 2, 0, fffff88001511566}

Unable to load image \SystemRoot\system32\DRIVERS\athrx.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for athrx.sys
*** ERROR: Module load completed but symbols could not be loaded for athrx.sys
Probably caused by : athrx.sys ( athrx+4c0c7 )

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 0000000000000010, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff88001511566, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff8000350f100


fffff880`01511566 488b5310        mov     rdx,qword ptr [rbx+10h]




TRAP_FRAME:  fffff8800319a8a0 -- (.trap 0xfffff8800319a8a0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=fffff88001547ac8
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88001511566 rsp=fffff8800319aa30 rbp=fffff8000347d280
 r8=0000000000011120  r9=0000000000000000 r10=fffff80003262000
r11=fffffa8005c34030 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na pe nc
fffff880`01511566 488b5310        mov     rdx,qword ptr [rbx+10h] ds:5040:00000000`00000010=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800032d7169 to fffff800032d7bc0

fffff880`0319a758 fffff800`032d7169 : 00000000`0000000a 00000000`00000010 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`0319a760 fffff800`032d5de0 : fffff880`00000000 00000000`00000801 fffffa80`05c45bb0 00000000`00000000 : nt!KiBugCheckDispatch+0x69
fffff880`0319a8a0 fffff880`01511566 : fffffa80`033e0b50 fffff880`04518c56 fffffa80`05c35448 00000000`00000000 : nt!KiPageFault+0x260
fffff880`0319aa30 fffff880`044a50c7 : fffffa80`05c35448 fffff880`0449d81f fffff880`0459d140 fffff880`0459d130 : ndis!NdisFreeTimerObject+0x16
fffff880`0319aa60 fffffa80`05c35448 : fffff880`0449d81f fffff880`0459d140 fffff880`0459d130 00000000`00011120 : athrx+0x4c0c7
fffff880`0319aa68 fffff880`0449d81f : fffff880`0459d140 fffff880`0459d130 00000000`00011120 fffff880`04487933 : 0xfffffa80`05c35448
fffff880`0319aa70 fffff880`0459d140 : fffff880`0459d130 00000000`00011120 fffff880`04487933 fffffa80`05c342c8 : athrx+0x4481f
fffff880`0319aa78 fffff880`0459d130 : 00000000`00011120 fffff880`04487933 fffffa80`05c342c8 fffffa80`05130000 : athrx+0x144140
fffff880`0319aa80 00000000`00011120 : fffff880`04487933 fffffa80`05c342c8 fffffa80`05130000 fffffa80`04cf8050 : athrx+0x144130
fffff880`0319aa88 fffff880`04487933 : fffffa80`05c342c8 fffffa80`05130000 fffffa80`04cf8050 fffff880`0448acf8 : 0x11120
fffff880`0319aa90 fffffa80`05c342c8 : fffffa80`05130000 fffffa80`04cf8050 fffff880`0448acf8 fffffa80`05130030 : athrx+0x2e933
fffff880`0319aa98 fffffa80`05130000 : fffffa80`04cf8050 fffff880`0448acf8 fffffa80`05130030 fffff880`0448a549 : 0xfffffa80`05c342c8
fffff880`0319aaa0 fffffa80`04cf8050 : fffff880`0448acf8 fffffa80`05130030 fffff880`0448a549 fffffa80`05c34030 : 0xfffffa80`05130000
fffff880`0319aaa8 fffff880`0448acf8 : fffffa80`05130030 fffff880`0448a549 fffffa80`05c34030 00000000`00000000 : 0xfffffa80`04cf8050
fffff880`0319aab0 fffffa80`05130030 : fffff880`0448a549 fffffa80`05c34030 00000000`00000000 00000000`00000000 : athrx+0x31cf8
fffff880`0319aab8 fffff880`0448a549 : fffffa80`05c34030 00000000`00000000 00000000`00000000 fffffa80`05c34000 : 0xfffffa80`05130030
fffff880`0319aac0 fffffa80`05c34030 : 00000000`00000000 00000000`00000000 fffffa80`05c34000 00000000`00000000 : athrx+0x31549
fffff880`0319aac8 00000000`00000000 : 00000000`00000000 fffffa80`05c34000 00000000`00000000 fffff880`0448a4e9 : 0xfffffa80`05c34030


fffff880`044a50c7 ??              ???


SYMBOL_NAME:  athrx+4c0c7

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  athrx.sys


FAILURE_BUCKET_ID:  X64_0xD1_athrx+4c0c7

BUCKET_ID:  X64_0xD1_athrx+4c0c7

Followup: MachineOwner

2: kd> lmvm athrx
start             end                 module name
fffff880`04459000 fffff880`045c8000   athrx    T (no symbols)           
    Loaded symbol image file: athrx.sys
    Image path: \SystemRoot\system32\DRIVERS\athrx.sys
    Image name: athrx.sys
    Timestamp:        Thu Jul 09 06:19:13 2009 (4A553E89)
    CheckSum:         0016D79F
    ImageSize:        0016F000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
30 Dec 2013   #3

Wiindows 7 Professional 64Bit

Thank you so much for the very quick reply.

Here is the .nfo you requested:
My System SpecsSystem Spec

30 Dec 2013   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

The device is D-Link AirPlus DWL-G520 Wireless PCI Adapter(rev.B)

No feasible update is there with D-Link: D-Link Technical Support
Attachment 299461
But You may get it from Atheros: Drivers for Atheros AR9285 and Windows 7
Attachment 299464
So it seems to be the appropriate one.
  • Version:
  • Release: 2013-07-02
Install it by following Driver Install - Device Manager

Let us know the results.
My System SpecsSystem Spec
30 Dec 2013   #5

Wiindows 7 Professional 64Bit


Boot did take pretty long (its not really a fast computer to begin with) but it is running smoothly for now.
I will monitor it further and will come back to this thread if anything should change.

Thank you so very much for your expertise and quick help.

My System SpecsSystem Spec
30 Dec 2013   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Quote   Quote: Originally Posted by longfellow01 View Post
Boot did take pretty long (its not really a fast computer to begin with)
That's not fair.

Free up the startup. Windows does not need any other program to auto start with it, but the auto start programs often conflicts and causes various problems including BSODs.
  1. Click on the Start button
  2. Type “msconfig (without quotes), click the resulting link. It will open the System Configuration window.
  3. Select the “Startup” tab.
  4. Deselect all items other than the antivirus, Microsoft Security Client; MSC.
  5. Apply > OK
  6. Accept then restart.
Now take a restart as a test. Does it improve the booting process anyhow?
My System SpecsSystem Spec

 BSOD while boot - DRIVER_IRQL_NOT_LESS_EQUAL - ndis.sys

Thread Tools

Similar help and support threads
Thread Forum
Ndis.sys is corrupted or missing, can't boot windows at all
i tried everything I can find. The bootrec in command prompt, chkdsk, startup repair, no system restore possible, safe mode Dosent work. Please help I try to start windows and I get the following picture everytime.
General Discussion
Laptop won't boot after replacing ndis.sys?
Today i started my laptop but found that it would not detect any wi-fi connections.So i checked the device manager and found that everything under "Network Adapters" had a yellow exclamation and there were around 12 drivers listed under it. I scooped around the net and found that this problem is...
General Discussion
Ndis.sys BSOD
I got this bsod last night and its been a serious issue as i cannot do anything online with my pc. Please help me out. I've attached my dump file with this post. TIA.
BSOD Help and Support
Giday all. I am currently at war with windows, and windows is winning:huh: it would appear I either have a bug or virus that has resulted in the PC running slow and me having to double click on ok buttons etc, just odd behavoir. The PC is realivly new MB: Gigabyte 78LMT-S2P AMD CPU, dont know...
BSOD Help and Support
EUCK! formatted my computer the other day hoping not to get another BSOD, but heres a new one, dump provided. NDIS.sys.
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:52.
Twitter Facebook Google+