Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD when inserting USB Stick/Kindle

31 Dec 2013   #1

Windows 7 Professional x64,
BSOD when inserting USB Stick/Kindle

Attachment 299571


About two weeks ago I started getting the BSOD when I plugged in my Kindle to charge via the USB on my laptop. Never happened before.

I have tried plugging in the USB stick in Safemode and the same thing happens. The error always points to Partition Manager driver "partmgr.sys"

This also happens with my SD Cruzer USB Stick. Today I noticed this does not happen to a FAT formatted USB stick but only the NTFS formatted one.

I had installed some software around the time called Calibre, which I have uninstalled but am still getting the same issue.

I have uploaded the logs from the dump file and if anyone can help I would be most grateful.

Have a good new year an many thanks in advance!

My System SpecsSystem Spec
31 Dec 2013   #2

Windows 10

Hi and welcome to SF :).

The issue appears to be originating from a per-bundled encryption software that was installed
with your HP bloatware, but it is originally from McAfee.

mfeepehost.exe    c:\program files\hewlett-packard\drive encryption\eeagent\mfeepehost.exe
2: kd> k
 # Child-SP          RetAddr           Call Site
00 fffff880`039a62d8 fffff880`05e01d82 nt!KeBugCheckEx
01 fffff880`039a62e0 fffff880`05e3156d fastfat!FatExceptionFilter+0xaa
02 fffff880`039a6320 fffff800`02ef2cdc fastfat! ?? ::NNGAKEGL::`string'+0x3f3d
03 fffff880`039a6350 fffff800`02ef275d nt!_C_specific_handler+0x8c
04 fffff880`039a63c0 fffff800`02ef1535 nt!RtlpExecuteHandlerForException+0xd
05 fffff880`039a63f0 fffff800`02f024c1 nt!RtlDispatchException+0x415
06 fffff880`039a6ad0 fffff800`02ec7242 nt!KiDispatchException+0x135
07 fffff880`039a7170 fffff800`02ec5dba nt!KiExceptionDispatch+0xc2
08 fffff880`039a7350 fffff880`017d3079 nt!KiPageFault+0x23a
09 fffff880`039a74e0 fffff800`031e8699 partmgr!PmGlobalDispatch+0x69
0a fffff880`039a7510 fffff800`031e85d6 nt!FstubReadSector+0x79
0b fffff880`039a7590 fffff800`031e86f5 nt!FstubDetectPartitionStyle+0x22
0c fffff880`039a75c0 fffff880`017d5512 nt!IoReadPartitionTableEx+0x2d
0d fffff880`039a75f0 fffff880`017e15a6 partmgr!PmGetDriveLayoutEx+0x5d2
0e fffff880`039a76f0 fffff880`017d5d50 partmgr!PmIoctlGetPartitionInfoEx+0xa6
0f fffff880`039a7740 fffff880`05e15512 partmgr! ?? ::FNODOBFM::`string'+0xbeb
10 fffff880`039a77a0 fffff880`05e2099d fastfat!FatPerformDevIoCtrl+0xa2
11 fffff880`039a7830 fffff880`05e207e7 fastfat!FatMountVolume+0x181
12 fffff880`039a7a70 fffff880`05e20740 fastfat!FatCommonFileSystemControl+0x57
13 fffff880`039a7aa0 fffff880`00dd750c fastfat!FatFsdFileSystemControl+0xac
14 fffff880`039a7ae0 fffff880`00dd2971 fltmgr!FltpFsControlMountVolume+0x28c
15 fffff880`039a7bb0 fffff800`031334af fltmgr!FltpFsControl+0x101
16 fffff880`039a7c10 fffff800`032ba596 nt!IopMountVolume+0x28f
17 fffff880`039a7cd0 fffff880`01c5475f nt!IoVerifyVolume+0x176
18 fffff880`039a7d60 00000000`00000000 MfeEpePc+0x875f

Did you recently install Kaspersky?

Note   Note
Before continuing with the steps below create a System Restore Point
-- System Restore Point - Create --

After creating a restore point, start by disabling the service, thus preventing it to start, restarting the PC
and see if it still bugchecks when you're connecting one of the previously mentioned devices.
  1. Type, services.msc and hit enter.
  2. Look for a service called McAfee Endpoint Encryption Agent, double click it.
  3. Switch the Startup type and Service status to Disabled and Stopped, respectively.
  4. Press OK and restart the PC.
Let us know the results.
My System SpecsSystem Spec
01 Jan 2014   #3

Windows 7 Professional x64,

Hi YoYo155,

Thanks for the quick response!
I have had kaspersky for a few years now.

I disabled the mcafee service and I can confirm that your suggestion has fixed the issue.

Thank you so much for your help and have a great new year! :)
My System SpecsSystem Spec

02 Jan 2014   #4

Windows 10

It's my pleasure :).
Please mark the thread as solved by using the green button at the top or bottom of the thread.

Happy new year :).
My System SpecsSystem Spec

 BSOD when inserting USB Stick/Kindle

Thread Tools

Similar help and support threads
Thread Forum
BSOD when inserting a USB pen drive
I am getting BSOD when i insert a USB pendrive(Cruzer Blade) in a USB 2.0.The pendrive driver is not getting installed either on any of the USB ports but it was working fine some days back so i suspect a driver issue.However i can connect my phone via USB just fine
BSOD Help and Support
BSOD when connecting Kindle
I am not sure what is causing the issue but I cannot get my first generation Kindle Paperwhite to work on any of my USB ports. All other USB devices connect fine, but once I plug in the Paperwhite, BSOD 0x0000007E appears - sometimes even on ejection. Please help!
BSOD Help and Support
BSOD when inserting a USB pen
Hi all, Since a few days ago I am experiencing BSOD anytime I insert a USB pen in my Windows 7 Pro 64 notebook. Does anyone have a solution for this? Thanks
BSOD Help and Support
BSOD after inserting new USB flash drive
I bought 2 brand new Kingston DataTraveler 8GB USB 3.0 flash drives. The same thing happens with both of them: I insert the drive into ANY of my 4 usb ports, the computer plays the sound indicating it recognizes a new piece of hardware, the driver install popup appears in the system tray, and...
BSOD Help and Support
BSOD when inserting USB 3.0 drive
Hello All, I just got a USB 3.0 drive and when i insert it into my only USB 3.0 USB port i get BSOD physical mem dump. Here are the crash details. Problem signature: Problem Event Name: BlueScreen OS Version: 6.1.7601. Locale ID: 1033 Additional information...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:33.
Twitter Facebook Google+