Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD - Windbg shows issue is with WLAN adaptor (I think)

08 Jan 2014   #1

Windows 7 64bit
BSOD - Windbg shows issue is with WLAN adaptor (I think)

Hi, I'm troubleshooting a BSOD on my daughter's Lenovo B575.
First crack involved using Windbg to analyze the dump file and it indicated a possible problem with a driver but that more info was required. I then enabled and ran verifier.exe to collect additional driver info and waited for the next BSOD.
Once it happened again (which is almost always on startup or resume of the laptop) I again analyzed the new dump file with windbg.
Unless I am reading the windbg info wrong, it seems to be a problem with the wireless driver. I searched for a new driver for the adapter in use hoping to get a newer version which fixes the problem but on Lenovos site the one they have available is actually older than the one in use. Here is the relevant info:

WLAN adapter in use on the laptop:
Atheros AR9285 Wireless Network Adaptor
Driver Date 12-08-2010
Driver Version

Lenovos website for this driver shows is most current
Atheros AR9283/AR9285 Wireless LAN Driver

That alone is a head scratcher as to why the laptop has a newer version. Do I remove the current and install the older version

Here is the latest Windbg output:

Unable to load image \SystemRoot\system32\DRIVERS\athrx.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for athrx.sys
*** ERROR: Module load completed but symbols could not be loaded for athrx.sys
Probably caused by : vwififlt.sys ( vwififlt!AcquireSpinLock+52 )

Followup: MachineOwner

1: kd> !analyze -v
* *
* Bugcheck Analysis *
* *

A device driver attempting to corrupt the system has been caught. This is
because the driver was specified in the registry as being suspect (by the
administrator) and the kernel has enabled substantial checking of this driver.
If the driver attempts to corrupt the system, bugchecks 0xC4, 0xC1 and 0xA will
be among the most commonly seen crashes.
Arg1: 0000000000000040, Acquiring a spinlock at IRQL < DISPATCH_LEVEL.
Arg2: 0000000000000000, Current IRQL
Arg3: fffff9800ba88378, Spinlock address
Arg4: 0000000000000000

Debugging Details:






LAST_CONTROL_TRANSFER: from fffff800033133dc to fffff80002e89c40

fffff880`0a3ec998 fffff800`033133dc : 00000000`000000c4 00000000`00000040 00000000`00000000 fffff980`0ba88378 : nt!KeBugCheckEx
fffff880`0a3ec9a0 fffff800`033241af : fffffa80`069dfb60 fffff800`02eb55db fffff880`0a3ec9f0 fffffa80`069dfb60 : nt!VerifierBugCheckIfAppropriate+0x3c
fffff880`0a3ec9e0 fffff880`03b82032 : 00000000`00000246 fffff980`0ba88328 00000000`00000001 fffff880`0a3ecce8 : nt!VerifierKeAcquireSpinLockAtDpcLevel+0xa0
fffff880`0a3eca40 fffff880`03b7e8f3 : 00000000`00000000 00000000`00000001 00000000`00000001 fffff800`02f46803 : vwififlt!AcquireSpinLock+0x52
fffff880`0a3eca70 fffff880`014df4f7 : fffffa80`051e81a0 fffff980`0b648ed0 fffff980`0b648ed0 00000000`00000001 : vwififlt!FilterReceiveNetBufferLists+0x8b
fffff880`0a3ecad0 fffff880`040bd999 : fffffa80`051e8050 fffff800`0302a260 fffffa80`069dfb60 fffff980`aad24fc0 : ndis! ?? ::FNODOBFM::`string'+0xcf1f
fffff880`0a3ecb20 fffffa80`051e8050 : fffff800`0302a260 fffffa80`069dfb60 fffff980`aad24fc0 00000000`00000001 : athrx+0x1e999
fffff880`0a3ecb28 fffff800`0302a260 : fffffa80`069dfb60 fffff980`aad24fc0 00000000`00000001 00000000`00000000 : 0xfffffa80`051e8050
fffff880`0a3ecb30 fffffa80`069dfb60 : fffff980`aad24fc0 00000000`00000001 00000000`00000000 00000000`00000000 : nt!ExWorkerQueue
fffff880`0a3ecb38 fffff980`aad24fc0 : 00000000`00000001 00000000`00000000 00000000`00000000 00000000`00000000 : 0xfffffa80`069dfb60
fffff880`0a3ecb40 00000000`00000001 : 00000000`00000000 00000000`00000000 00000000`00000000 fffff980`0b648ed0 : 0xfffff980`aad24fc0
fffff880`0a3ecb48 00000000`00000000 : 00000000`00000000 00000000`00000000 fffff980`0b648ed0 00000001`00000001 : 0x1


fffff880`03b82032 eb09 jmp vwififlt!AcquireSpinLock+0x5d (fffff880`03b8203d)


SYMBOL_NAME: vwififlt!AcquireSpinLock+52


MODULE_NAME: vwififlt

IMAGE_NAME: vwififlt.sys


FAILURE_BUCKET_ID: X64_0xc4_40_VRF_vwififlt!AcquireSpinLock+52

BUCKET_ID: X64_0xc4_40_VRF_vwififlt!AcquireSpinLock+52

Followup: MachineOwner

My System SpecsSystem Spec
09 Jan 2014   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

My System SpecsSystem Spec
09 Jan 2014   #3

Windows 7 64bit

Apologies for not having collecting the diagnostic info earlier, I was under the assumption that the windbg analysis had the issue at the "almost solved" stage.
Here is the full blown diagnostics info
My System SpecsSystem Spec

10 Jan 2014   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Try Drivers for Atheros AR9285 and Windows 7

But it may not be the soul cause of the BSODs. If it occurs again, let us see the non-dv enabled crash dumps at first.
My System SpecsSystem Spec

 BSOD - Windbg shows issue is with WLAN adaptor (I think)

Thread Tools

Similar help and support threads
Thread Forum
Virtual Wifi Adaptor issue
Hello, I have a Dell Inspiron with Windows 7 and am 'a newbie.' I have followed the directions on setting up the Virtual Wifi but have an error. Is there anyway to erase what I have done and start all over again? Keeping in mind: will starting over reset the text box so it is editable? ...
Network & Sharing
No BSOD'S but event viewer shows one repeated entry/ WLAN
Hi everybody , i didn't put this into the BSOD forum because i have not had a BSOD in years. My issue is i clicked something by mistake(not sure exactly what) and now i am receiving one of the (see screenshot) entries on every reboot . No other entries just the one in the screenshot and they...
General Discussion
Network Adaptor Issue - Dell Insipron 1545 - Limited Connectivity
Wonder if anyone can assist please? Spec: Dell Insipron 1545 Win 7 64 Bit Intel Pent Dual Core 2.2GHZ Processor 3GB RAM All of a sudden the laptop will not connect to the internet wirelessly. I have done the following Installed Chipset
Network & Sharing
WLAN Polling Issue
Hey guys, first time poster here. I would assume that this has been brought up before, but I am unable to locate a post regarding it, so I figured I'd start a new one. If there is one open currently, or one with various fixes/troubleshooting, please point me to it. Since building my new computer...
Network & Sharing
Belkin F5D8053N Wireless Adaptor Windows 7 64 bit Issue
I am really confused ... basically I was using vista home premium 64bit, I bought the windows 7 home premium upgrade and installed it as an upgrade over Vista. Everything worked fine but my system seemed slow, I thought this may be down to lots of old unused Vista files clogging up my pc as i don't...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:51.
Twitter Facebook Google+