Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD from Photoshop - Bad Pool Header 0x00000019

13 Jan 2014   #1

Windows 7 Home Premium x64
BSOD from Photoshop - Bad Pool Header 0x00000019

So, today I was going to do some image editing, so I opened up photoshop cs6, and the computer crashed. So, I restarted the computer and opened up photoshop again. To my chagrin, it crashed again.

So I opened up the laptop reseated the ram, made sure nothings wrong, rebooted, and opened up photoshop. It crashed, again.

So then I updated my everything in Windows Update and tried again, but computer still crashed.

So then I put in a different RAM and it still crashed.

I also tested it it in safe mode, it also crashes in safe mode.

Basically, it crashes every single time I run photoshop.

My specs, from dxdiag
Time of this report: 1/13/2014, 11:58:29
Machine name: SUPERBARNIE-PC
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130828-1532)
Language: English (Regional Setting: English)
System Manufacturer: LENOVO
System Model: 0862                            
BIOS: InsydeH2O Version 03.60.4147CN34WW(V2.12)
Processor: Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz (8 CPUs), ~2.2GHz
Memory: 8192MB RAM
Available OS Memory: 8136MB RAM
Page File: 3163MB used, 13106MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode
Currently, I am also doing a scan with MBAM.
EDIT: MBAM scan done, nothing noteworthy found.

I'll also attach my minidumps.

My System SpecsSystem Spec
14 Jan 2014   #2

Windows 7 Home Premium x64

It is now crashing more frequently, even crashing when doing regular stuff (browsing, etc.). Still the same "Bad Pool Header" error.

Here are the new minidumps.
My System SpecsSystem Spec
14 Jan 2014   #3

Windows 7 Home Premium x64

Did a SFC, didn't find anything.
My System SpecsSystem Spec

14 Jan 2014   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hi superbarnie.

Browse to C:\Windows\Fonts, and delete the fonts those you have lately installed before the BSODs started to occur.

If you cannot access to the fonts folder in normal mode, try in safe mode. If even Safe Mode is unable to access there, too; you may take the help of a live linux distro like Puppy Live. If you have the windows installer disc, it also give you an idea to access there: Copy & Paste - in Windows Recovery Console

Then rebuild the font cache. Go to C:\Windows\System32\ and delete the "Fntcache.dat" file there. Then restart the computer. On restart, a fresh font cache will be built.

Let us know the results.
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 19, {20, fffff900c0d36000, fffff900c0d36240, 25240000}

Probably caused by : win32k.sys ( win32k!EngFreeMem+21 )

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The pool is already corrupt at the time of the current request.
This may or may not be due to the caller.
The internal pool links must be walked to figure out a possible cause of
the problem, and then special pool applied to the suspect tags or the driver
verifier to a suspect driver.
Arg1: 0000000000000020, a pool block header size is corrupt.
Arg2: fffff900c0d36000, The pool entry we were looking for within the page.
Arg3: fffff900c0d36240, The next pool entry.
Arg4: 0000000025240000, (reserved)

Debugging Details:

BUGCHECK_STR:  0x19_20

POOL_ADDRESS: GetPointerFromAddress: unable to read from fffff800030c1100



PROCESS_NAME:  csrss.exe


LAST_CONTROL_TRANSFER:  from fffff80002fbccae to fffff80002e89bc0

fffff880`0b5f1db8 fffff800`02fbccae : 00000000`00000019 00000000`00000020 fffff900`c0d36000 fffff900`c0d36240 : nt!KeBugCheckEx
fffff880`0b5f1dc0 fffff960`00099475 : 00000000`033504a6 00000000`00000000 fffff880`64667454 fffff880`0b5f1f10 : nt!ExDeferredFreePool+0x12da
fffff880`0b5f1e70 fffff960`000a1e3c : 00000000`033504a6 fffff880`0b5f1f20 00000000`00000000 00000000`03350012 : win32k!EngFreeMem+0x21
fffff880`0b5f1ea0 fffff960`000991bb : fffff900`c30d2d00 00000000`00000001 00000000`00000001 00000000`00000000 : win32k!bLoadGlyphSet+0x104
fffff880`0b5f1ed0 fffff960`0009935a : fffff900`c30d2d00 fffff900`00000001 fffff900`c30d2d00 fffff960`0020c584 : win32k!bReloadGlyphSet+0x24b
fffff880`0b5f2590 fffff960`000992b2 : 00000000`00000000 fffff900`c30d2d00 fffff900`00000001 fffff900`c28cce94 : win32k!ttfdQueryFontTree+0x66
fffff880`0b5f25e0 fffff960`000e60b7 : fffff960`00099258 fffff900`c30d1440 00000000`00000001 00000000`00000000 : win32k!ttfdSemQueryFontTree+0x5a
fffff880`0b5f2620 fffff960`000e5f63 : fffff880`0b5f2730 00000000`00000000 00000000`00000000 00000000`00000000 : win32k!PDEVOBJ::QueryFontTree+0x63
fffff880`0b5f26a0 fffff960`000a008a : fffff900`c008a010 fffff880`02f65180 00000000`00000000 00000000`00000000 : win32k!PFEOBJ::pfdg+0xa3
fffff880`0b5f2700 fffff960`000fa81c : fffff900`c28ccd80 fffff880`0b5f2990 fffff880`0b5f2890 fffff880`0b5f29e0 : win32k!RFONTOBJ::bRealizeFont+0x46
fffff880`0b5f2820 fffff960`000cb135 : 00000000`10010000 fffff900`00000000 000016dc`00000000 00000000`00000002 : win32k!RFONTOBJ::bInit+0x548
fffff880`0b5f2940 fffff960`000cb0cb : fffff900`c0081000 fffff880`0b5f2b60 00000000`322f534f 000007fe`f49443d6 : win32k!ulGetFontData2+0x31
fffff880`0b5f29b0 fffff960`000cafe1 : 00000000`ffffffff 00000000`ffffffff fffffa80`096ee010 fffff960`00146e46 : win32k!ulGetFontData+0x7f
fffff880`0b5f2a00 fffff800`02e88e53 : 00000000`010116dc 00000000`00000000 00000000`0aafd858 00000000`00000000 : win32k!NtGdiGetFontData+0x8d
fffff880`0b5f2a70 000007fe`fdef595a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0aafd838 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x7fe`fdef595a


fffff960`00099475 4883c420        add     rsp,20h


SYMBOL_NAME:  win32k!EngFreeMem+21

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  win32k.sys


FAILURE_BUCKET_ID:  X64_0x19_20_win32k!EngFreeMem+21

BUCKET_ID:  X64_0x19_20_win32k!EngFreeMem+21

Followup: MachineOwner
My System SpecsSystem Spec
14 Jan 2014   #5

Windows 7 Home Premium x64


Actually, I never installed any fonts. So I skipped that step and just deleted FNTCACHE.DAT. It seems to have fixed to problem. I can now run photoshop without the computer crashing. I'll have to do some more testing to make sure.

What do you think caused the problem?
My System SpecsSystem Spec
15 Jan 2014   #6

Windows 7 Home Premium x64

Looks like the problem is gone. Thanks. I'm still surprised at how you knew what was the problem. I looked through the minidumps myself and did not see anything about fonts.
My System SpecsSystem Spec
15 Jan 2014   #7

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Good to know that your issue is solved :)

Let us know for any further issue.
My System SpecsSystem Spec

 BSOD from Photoshop - Bad Pool Header 0x00000019

Thread Tools

Similar help and support threads
Thread Forum
bsod bad pool header 0x00000019 Please help guys:(
BSOD Help and Support
BSOD Bad Pool Header 0x00000019 (Random)
I also added the dump that I know for certain that was made during BSOD because I set it up myself to do this so I included it (092015-229087-01.dump.rar) This problem has happened on a gradient, once a week, once a day, now 2-3 times daily. Thanks Patrick Batman
BSOD Help and Support
BSOD, error 0x00000019 Bad Pool Header on start-up
*Typing from my phone as I cannot use my computer* It all started yesterday when my laptop was suddenly shut down because the battery ran out. When I started it back up again I got the Bad Pool Header BSOD. I tried to use the system repair, but it had no effect. I also tried CHKDSK /f...
BSOD Help and Support
BSOD in the last two days, bad pool header, 0x00000019
Right so I made myself a new computer not that long ago, September I think, and have had no problems with it, until two days ago anyway. The first time it BSOD was while playing minecraft restarted, checked the hard drive for errors, was clean. Then checked to see if I had a virus or anything,...
BSOD Help and Support
BSOD Bad Pool Header error 0x00000019
I have been getting a BSOD Bad Pool Header. I have recently updated my CPU and memory. My specs have also been updated to reflect the new hardware. Thank you for any info on what might be causing these. Jerry
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:30.
Twitter Facebook Google+