Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 0xf4 randomly appearing.

18 Jan 2014   #1

Windows 7 Ultimate x64
0xf4 randomly appearing.

I have had this problem for a long time now, and I have tried what I can to prevent it from happening, but to no success..

I get the 0xf4 BSOD both when I am using the computer and when I am not using it. I can see no connection/patterns between the BSOD’s so it bugs me terribly. The frequents of the BS is very random, and I am thinking it might be my hard drive. Just before I get the 0xf4 BS some programs start to freeze, and it can take up to 1 min before the PC stops and it freezes when the 0xf4 is showing so it does not write dump files… When I try to restart the PC using the power switch, it just gives med 0xe3 error message; corrupt/damaged winload file and I have to disconnect the power supply to get it to work. I have changed every hardware in my computer last summer, except my hard drive and RAM. I have tried to Google this problem, but there seem to be many errors connected to the 0xf4 BSOD. I have no problems with the PC elsewhere what so ever, so I hope I can get this really annoying problem out of my world xD

Thanks for taking you time reading this

Best regards

My System SpecsSystem Spec
18 Jan 2014   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Welcome to the forum.

Model	Corsair Force 3 SSD ATA Device
Model	Corsair Force GS ATA Device
Quote   Quote: Originally Posted by writhziden View Post
If you have an SSD, make sure the following are up to date:
  • SSD firmware
  • BIOS Version
  • Chipset Drivers
  • Hard disk controller drivers/SATA drivers
  • If you have a Marvell IDE ATA/ATAPI device, make sure the drivers are up to date from the Intel site or Marvell site and not from your motherboard/vendor support site.
Run Disk Check on your Hard Drive(s): Disk Check

Reduce items at start-up: Startup Programs - Change

Perform a clean boot: Troubleshoot Application Conflicts by Performing a Clean Startup

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7600 MP (8 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.17273.amd64fre.win7_gdr.130318-1532
Machine Name:
Kernel base = 0xfffff800`03066000 PsLoadedModuleList = 0xfffff800`032a2e70
Debug session time: Sat Jan 18 08:08:18.064 2014 (UTC + 6:00)
System Uptime: 0 days 0:00:10.032
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 50, {fffff8a00110d000, 0, fffff88006115b31, 0}

*** WARNING: Unable to verify timestamp for RzSynapse.sys
*** ERROR: Module load completed but symbols could not be loaded for RzSynapse.sys

Could not read faulting driver name
Probably caused by : RzSynapse.sys ( RzSynapse+9b31 )

Followup: MachineOwner

3: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arg1: fffff8a00110d000, memory referenced.
Arg2: 0000000000000000, value 0 = read operation, 1 = write operation.
Arg3: fffff88006115b31, If non-zero, the instruction address which referenced the bad memory
Arg4: 0000000000000000, (reserved)

Debugging Details:

Could not read faulting driver name

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff8000330d0e0
GetUlongFromAddress: unable to read from fffff8000330d198
 fffff8a00110d000 Paged pool

fffff880`06115b31 0fb74220        movzx   eax,word ptr [rdx+20h]







TRAP_FRAME:  fffff880033a1570 -- (.trap 0xfffff880033a1570)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=ffff000005295480 rbx=0000000000000000 rcx=0000057ff29115d8
rdx=fffff8a00110cfe0 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88006115b31 rsp=fffff880033a1700 rbp=0000000000000048
 r8=0000000000000000  r9=0000000000000040 r10=fffff80003066000
r11=0000000000000360 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na pe nc
fffff880`06115b31 0fb74220        movzx   eax,word ptr [rdx+20h] ds:fffff8a0`0110d000=????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80003155694 to fffff800030d5880


fffff880`06115b31 0fb74220        movzx   eax,word ptr [rdx+20h]


SYMBOL_NAME:  RzSynapse+9b31

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  RzSynapse.sys


FAILURE_BUCKET_ID:  X64_0x50_RzSynapse+9b31

BUCKET_ID:  X64_0x50_RzSynapse+9b31

Followup: MachineOwner

3: kd> lmvm RzSynapse
start             end                 module name
fffff880`0610c000 fffff880`0613b000   RzSynapse T (no symbols)           
    Loaded symbol image file: RzSynapse.sys
    Image path: \SystemRoot\system32\DRIVERS\RzSynapse.sys
    Image name: RzSynapse.sys
    Timestamp:        Tue Oct 11 16:31:47 2011 (4E941B13)
    CheckSum:         0002C4DC
    ImageSize:        0002F000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Update the drivers below:
Please update these older drivers. Links are included to assist in looking up the source of the drivers. If unable to find an update, please remove (un-install) the program responsible for that driver. DO NOT manually delete/rename the driver as it may make the system unbootable!:-
Driver Reference Table - RzSynapse.sys
Razer Synapse Engine/Razer Naga
Perform a clean install of a driver following: How to Clean Left Over Driver Files with Driver Sweeper
Install all windows updates including Service Pack One: Learn how to install Windows 7 Service Pack 1 (SP1)

Run a System file check (SFC): SFC /SCANNOW Command - System File Checker

Scan with Kaspersky TDSSKiller:Anti-rootkit utility TDSSKiller

ESET online scanner: Free Online Virus Scanner | ESET

Keep us posted.
My System SpecsSystem Spec
21 Jan 2014   #3

Windows 7 Ultimate x64

Hey and thanks for fast response!

I have tried the following:

Disk Check on my Hard Drive, found some errors that couldn’t be fixed :/

Reduced items at start-up

Updated all drivers

Installed all windows updates


Scanned with Kaspersky

I have not:

Updated SSD firmware, there is no new update for my SSD.

Could not find updates for BIOS, Chipset and SATA drivers… Any hint to how I can find this things for my hardware? :P

I have been using my computer active without turning it off in nearly 2 days now without any problems, so I hope some of the things I did helped! I will write a new replay in a couple of days if I get a new BSOD

Thank you for fast response and super good help!

Best regards!
My System SpecsSystem Spec

21 Jan 2014   #4

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Thanks for the updates.

Keep us posted :)
My System SpecsSystem Spec

 0xf4 randomly appearing.

Thread Tools

Similar help and support threads
Thread Forum
BSOD appearing randomly
Hello, I'm having BSOD with my HP Pavilion dv4 1114nr laptop recently. They appeared out of nowhere, when I playing video game, when I browsing, even just a switching between windows with Alt+Tab. I uploaded the dump files. Please help. Thank you.
BSOD Help and Support
BSODs randomly appearing
Hello everyone, first of all i want to thank anyone spending time with me solving this problem Where do I start? I encountered Bluescreens since I upgraded my gear a year ago. At first I thought I would get them solved by updating my local drivers ect. However by now I am almost certain that...
BSOD Help and Support
BSOD random occurrence , error 0xF4 (0x3, 0xFFFFFA800AAE1B30) Randomly
Hi guys, so i've just build my first computer (not literary build one but I hand picked the component myself). The component seems intact and during BIOS check everything working just fine. After finishing with Windows 7 installation I start using this computer for work (mainly using excel,...
BSOD Help and Support
BSOD (0xF4) seemingly randomly, ntoskrnl.exe?
So this started a few days ago, BSOD popped up with error code 0x000000f4. After that it popped up more randomly (Doesn't matter if playing a game or being idle or what). I have run diagnostics on my CPU,motherboard,RAM,HDD,SDD, and other hardware and haven't found anything wrong with them yet. I...
BSOD Help and Support
BSOD - randomly occurred, 0xf4 and ntoskrnl.exe
First off I wanna say thank you guys so much in advance. Having just recently discovered this forum, I'm still in awe of the wealth of knowledge on here as well as how quickly and effectively people seem to respond. Quite comforting to say the least! So here's my BSOD issue (the zipped dumpfile is...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:30.
Twitter Facebook Google+