Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Blue screen of death

09 Feb 2014   #1

windows 7 home premium x64
BSOD 0x0000000a

Recently encountered BsoD problem. The details are mentioned below:

Problem Event Name: BlueScreen
OS Version: 6.1.7601.
Locale ID: 1033

Additional information about the problem:
BCCode: a
BCP1: 000000010000024F
BCP2: 0000000000000002
BCP3: 0000000000000001
BCP4: FFFFF80002E9A258
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1

Files that help describe the problem:

Read our privacy statement online:
Windows 7 Privacy Statement - Microsoft Windows

If the online privacy statement is not available, please read our privacy statement offline:

This is from event viewer:

- System

- Provider

[ Name] Microsoft-Windows-Kernel-Power
[ Guid] {331C3B3A-2005-44C2-AC5E-77220C37D6B4}

EventID 41

Version 2

Level 1

Task 63

Opcode 0

Keywords 0x8000000000000002

- TimeCreated

[ SystemTime] 2014-02-09T11:17:33.198422300Z

EventRecordID 76770


- Execution

[ ProcessID] 4
[ ThreadID] 8

Channel System

Computer Toshiba-PC

- Security

[ UserID] S-1-5-18

- EventData

BugcheckCode 10
BugcheckParameter1 0x10000024f
BugcheckParameter2 0x2
BugcheckParameter3 0x1
BugcheckParameter4 0xfffff80002e9a258
SleepInProgress false
PowerButtonTimestamp 0

My System SpecsSystem Spec
09 Feb 2014   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hi hsk0891,

Get rid of intel rapid storage. First uninstall it from Control Panel > Programs and Features. Then Uninstall the driver from device manager.
  1. Right click on "my computer" icon and click "manage" on the context menu.
  2. It will open the "computer management" window.
  3. Select "Device Manager" in the left pane, It will list all the existing devices up.
  4. Expand "IDE ATA/ATAPI controllers" by clicking on the triangle in front of it.
  5. Select one Intel device item under it, right click, uninstall.
  6. Continue the process for all Intel items under "IDE ATA/ATAPI controllers"
  7. Now restart the computer. At restart, windows will auto configure the appropriate native system driver.
Let us know for any further issue.
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck A, {10000024f, 2, 1, fffff80002e9a258}

*** WARNING: Unable to verify timestamp for iaStor.sys
*** ERROR: Module load completed but symbols could not be loaded for iaStor.sys
Probably caused by : iaStor.sys ( iaStor+2d9b8 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: 000000010000024f, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff80002e9a258, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff800030b4100
GetUlongFromAddress: unable to read from fffff800030b41c0
 000000010000024f Nonpaged pool


fffff800`02e9a258 f04d0fc1aa50020000 lock xadd qword ptr [r10+250h],r13





ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre


TRAP_FRAME:  fffff880033228e0 -- (.trap 0xfffff880033228e0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000002 rbx=0000000000000000 rcx=fffff800030b7d68
rdx=fffffa8000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80002e9a258 rsp=fffff88003322a70 rbp=0000000000003c49
 r8=0000058000000000  r9=0000000000000000 r10=00000000ffffffff
r11=fffff88003328043 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz ac po cy
fffff800`02e9a258 f04d0fc1aa50020000 lock xadd qword ptr [r10+250h],r13 ds:00000001`0000024f=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002e7c169 to fffff80002e7cbc0

fffff880`03322798 fffff800`02e7c169 : 00000000`0000000a 00000001`0000024f 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`033227a0 fffff800`02e7ade0 : 00000000`00000000 00000000`00000000 fffffa80`04d92000 00000000`00000002 : nt!KiBugCheckDispatch+0x69
fffff880`033228e0 fffff800`02e9a258 : fffff6fc`4001e248 00000000`00003c49 00000000`00000001 00001f80`00d2021d : nt!KiPageFault+0x260
fffff880`03322a70 fffff800`02e803f8 : 00000000`00008043 00000000`00000000 00000000`00000002 00000000`00000000 : nt!MmUnlockPages+0x3e8
fffff880`03322b00 fffff880`0127d9b8 : fffffa80`0841f3f0 fffffa80`08f2e100 fffffa80`0837d2f0 00000000`00000000 : nt!IopfCompleteRequest+0x168
fffff880`03322bf0 fffffa80`0841f3f0 : fffffa80`08f2e100 fffffa80`0837d2f0 00000000`00000000 fffff880`03322ef8 : iaStor+0x2d9b8
fffff880`03322bf8 fffffa80`08f2e100 : fffffa80`0837d2f0 00000000`00000000 fffff880`03322ef8 fffff880`01259e7d : 0xfffffa80`0841f3f0
fffff880`03322c00 fffffa80`0837d2f0 : 00000000`00000000 fffff880`03322ef8 fffff880`01259e7d fffffa80`04b10700 : 0xfffffa80`08f2e100
fffff880`03322c08 00000000`00000000 : fffff880`03322ef8 fffff880`01259e7d fffffa80`04b10700 fffff880`03322cd0 : 0xfffffa80`0837d2f0


fffff880`0127d9b8 ??              ???


SYMBOL_NAME:  iaStor+2d9b8

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  iaStor.sys


FAILURE_BUCKET_ID:  X64_0xA_iaStor+2d9b8

BUCKET_ID:  X64_0xA_iaStor+2d9b8


FAILURE_ID_HASH_STRING:  km:x64_0xa_iastor+2d9b8

FAILURE_ID_HASH:  {d065dbac-33d1-e31a-00ad-06738086d323}

Followup: MachineOwner

1: kd> lmvm iaStor
start             end                 module name
fffff880`01250000 fffff880`01458000   iaStor   T (no symbols)           
    Loaded symbol image file: iaStor.sys
    Image path: \SystemRoot\system32\DRIVERS\iaStor.sys
    Image name: iaStor.sys
    Timestamp:        Sat Jan 16 01:51:57 2010 (4B50CE65)
    CheckSum:         00092B81
    ImageSize:        00208000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
09 Feb 2014   #3

windows 7 home premium x64

Hi Arc,

Thnx for your reply.
Did exactly same as said in your post.
Found only 1 driver under ATA/ATAPI contrllers (i.e. Intel(R) 5 series/3400 series chipset family 4 port SATA AHCI controller - 3B29), after removing the driver performed restart.
Windows auto configured native drives and installed this drivers.
Now 4 more drives can be seen under ATA/ATAPI contrllers which were not there before.
My System SpecsSystem Spec

10 Feb 2014   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Is it the image you wanted to upload?

I also have similar devices. Dont worry.

Attachment 305724

Let us know how the computer is running
My System SpecsSystem Spec
10 Feb 2014   #5

windows 7 home premium x64

yup that was the image i was trying to upload.
computer is running good at present.
i have a question .do i need intel rapid storage or not??
My System SpecsSystem Spec
10 Feb 2014   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Quote   Quote: Originally Posted by hsk0891 View Post
i have a question .do i need intel rapid storage or not??
No, you dont need it.

Let us know about any further issue.
My System SpecsSystem Spec
10 Feb 2014   #7

windows 7 home premium x64

Thanks a lot ARC
My System SpecsSystem Spec
10 Feb 2014   #8

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

You are most welcome mate
My System SpecsSystem Spec

 Blue screen of death

Thread Tools

Similar help and support threads
Thread Forum
Stuck on black screen of death, after blue screen of death
In need of serious help.* To begin, I am stupid and haven't backed up any of my files so for now a windows reinstall is out of the question. (unless it's completely necessary) okay, so the problem: I was using my computer as normal. Then while on Google Chrome, it started getting slow and said...
General Discussion
Geforce 7300 LE - Blue screen of death - Multiple lines down screen.
Today I booted my computer up to be promoted with a black screen, I gave it a good half an hour before forcing it to shutdown, to which when I booted it back up. Was then promoted with a blue screen about the video card not being able to lead, that happened twice. I then booted it into safe...
Graphic Cards
Blue screen of death!!
:cry: i am doing my own things when suddenly the blue screen of death appears.WINDOWS HAS SHUT DOWN TO PREVENT DAMAGE TO YOUR COMPUTER,it happened 3-5 times Help please:cry:
BSOD Help and Support
blue screen of death
Ok. I was looking for free movies online when when I click this download I know I shouldn't have but anyway I got the blue screen so I shut down my p.c rebooted then tried to restore it to factory settings but I stell have it I tried rolling back all the drive it would let me that didn't work after...
BSOD Help and Support
Black Screen of Death/Blue Screen of Death
Hello everyone. I have a Toshiba Satellite L450D-13X computer for the kids, and for the price it's a good laptop. Have had no issues with it until two weeks ago when the screen froze for the boys whilst playing a game and downloading a program from the net. Had to do a force shutdown and since...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App