Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD at startup

10 Feb 2014   #1
Tranquil Hegemo

Windows 7 64bit
BSOD at startup

Asking for some help here with a BSOD that I get on initial start up of my newly built Windows 7 PC. Seems to happen every time I start the PC for the first time that day but after that the system seems stable and gives no issues.

Ran sfc /scannow on Saturday and that detected a corrupt file (language pack IIRC) which I couldn't repair so have rebuilt yesterday from scratch in the hope that it would cure the issue but happened again this morning so my hopes that this was the issue appear to be in vain.

Uploaded SF file which I think is all that you require from reading the BSOD posting instructions but if you need anything else please ask.


My System SpecsSystem Spec
10 Feb 2014   #2

windows 7 ultimate 32 bit

i cant give an exact answer but it could be ram (the memory module) causing the problem.
the bsod gives out "page fault in non paged area" which mainly caused by hardware like faulty ram or even badly corrupted hard disk which the bad clusters that are on the paging file becomes damage so thats why give BSOD.

if your computer had multiple RAM, you can try to do isolation by running the computer with 1 RAM at a time to see if the problem still happen.
if you are not that tech-savy or worry that anything you touch will become spoil, easiest way will be to send to repair shop to check.
My System SpecsSystem Spec
08 Mar 2014   #3
Tranquil Hegemo

Windows 7 64bit

Back around again then.

Still getting the same issues after memory has been RMA'ed and replaced though the BSOD does seem to happen slightly later now. It was happening just before the login window was displayed but now getting past that stage (i.e. have entered my password and it is in the process of logging in or even to the stage where it is displaying the desktop now) before I get the BSOD with Memory Management being the issue. For the record new memory was installed and got two BSOD incidents so moved the memory from slots 1+3 to 2+4 and it "booted OK" in that I only get the one BSOD prior to it booting clean and being stable from there.

While I am tempted to think that I am the unluckiest man in history I am going to rule memory out as the issue unless someone can come up with a reason otherwise for now and I am looking at suspect hardware. I have attached the latest minidump files (six or seven of them in total) so if someone could have a look and suggest anything I would be most appreciative. I also have a Windows System Info dump (.nfo extension) and can upload that if it would help.

My System SpecsSystem Spec

14 Mar 2014   #4
Tranquil Hegemo

Windows 7 64bit

Just a quick bump for this - haven't had a chance to do much with it since the last post so going to reseat memory and cables to hard drives etc. tomorrow and see what happens but if someone could have a look at the minidump files and suggest anything else to try I'm all ears.

My System SpecsSystem Spec
15 Mar 2014   #5

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Please update these older drivers. Links are included to assist in looking up the source of the drivers. If unable to find an update, please remove (un-install) the program responsible for that driver. DO NOT manually delete/rename the driver as it may make the system unbootable!:-

E1G6032E.sys Wed Sep 24 05:09:49 2008 (48D9773D)
Intel Ethernet
Driver Reference Table - E1G6032E.sys

gdrv.sys Fri Mar 13 09:22:29 2009 (49B9D175)
Gigabyte Easy Saver - mobo power utility driver
Driver Reference Table - gdrv.sys

WMP54Gv41x64.sys Wed Apr 7 18:07:21 2010 (4BBC7579)
Linksys Wireless-G PCI Adapter Driver
Driver Reference Table - WMP54Gv41x64.sys

Rt64win7.sys Thu Oct 25 15:20:09 2012 (50890449)
Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC
Driver Reference Table - Rt64win7.sys

BitDefender & Avira contribute to BSOD's. Please remove them for testing purpose. Use Microsoft Security Essentials.

Recommended from a strict BSOD perspective, compatibility & stability compared to other security software:

Microsoft Security Essentials - Free Antivirus for Windows

Malwarebytes - Free

Good and Free system security combination.

Run a System file check (SFC): SFC /SCANNOW Command - System File Checker

Scan with Kaspersky TDSSKiller:Anti-rootkit utility TDSSKiller

ESET online scanner: Free Online Virus Scanner | ESET

Post screenshot(s) of your Hard Drive(s) using Crystal Disk Info Software: CrystalDiskInfo - Software - Crystal Dew World

Run a Hard Drive test:

Run Disk Check on your Hard Drive(s): Disk Check

AppleCharger.sys Mon Oct 28 07:59:21 2013 (526DC4F9)
GIGABYTE On/Off Charge driver. See here for details - GIGABYTE ON/OFF Charge [br] May cause BSOD on Win7/8 systems - uninstall to test (haven't seen recently (15Jan2013))
Driver Reference Table - AppleCharger.sys

Use Revo Uninstaller to uninstall stubborn software. Opt for Advance Mode while uninstalling which allows leftover registry removal:Download Revo Uninstaller Freeware - Free and Full Download - Uninstall software, remove programs, solve uninstall problems

If this does not provide stability. Test RAM.

Take memtest. Run for 8 passes and test each stick in a know good slot for an additional 6 passes.
The goal is to test all the RAM sticks and all the motherboard slots.

Check your motherboard manual to ensure the RAM sticks are in the recommended motherboard slots. Some motherboards have very specific slots required for the number of RAM sticks installed.

If you get errors, stop the test and continue with the next step.

1. Remove all but one stick of RAM from your computer (this will be RAM stick #1), and run Memtest86 again, for 7 passes.
*Be sure to note the RAM stick, use a piece of tape with a number, and note the motherboard slot.
If this stick passes the test then go to step #3.

2. If RAM stick #1 has errors, repeat the test with RAM stick #2 in the same motherboard slot.
*If RAM stick #2 passes, this indicates that RAM stick #1 may be bad. If you want to be absolutely sure, re-test RAM stick #1 in another known good slot.
*If RAM stick #2 has errors, this indicates another possible bad RAM stick, a possible motherboard slot failure or inadequate settings.
3. Test the next stick of RAM (stick #2) in the next motherboard slot.
*If this RAM stick has errors repeat step #2 using a known good stick if possible, or another stick.
*If this RAM stick has no errors and both sticks failed in slot#1, test RAM stick #1 in this slot.
4. If you find a stick that passes the test, test it in all the other motherboard slots.

If Part 2 testing shows errors, and all tests in Part 3 show errors, you will need to test the RAM sticks in another computer and/or test other RAM in your computer to identify the problem.

In this way, you can identify whether it is a bad stick of RAM, a bad motherboard, or incompatibility between the sticks.
information   Information
Errors are sometimes found after 8 passes.

Tip   Tip
Do this test overnight, before going to bed.

Built by: 7601.18247.amd64fre.win7sp1_gdr.130828-1532
Debug session time: Sat Mar  8 01:16:15.387 2014 (UTC + 6:00)
System Uptime: 0 days 0:03:14.199
BugCheck 1A, {41790, fffffa800a0e4ce0, ffff, 0}
Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+35084 )
BUGCHECK_STR:  0x1a_41790
PROCESS_NAME:  WerFault.exe
Built by: 7601.18247.amd64fre.win7sp1_gdr.130828-1532
Debug session time: Fri Mar  7 00:17:07.715 2014 (UTC + 6:00)
System Uptime: 0 days 0:01:20.527
BugCheck 1A, {41790, fffffa800a158030, ffff, 0}
Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+35084 )
BUGCHECK_STR:  0x1a_41790
PROCESS_NAME:  Settlers7R.exe
Built by: 7601.18247.amd64fre.win7sp1_gdr.130828-1532
Debug session time: Wed Mar  5 16:32:52.513 2014 (UTC + 6:00)
System Uptime: 0 days 0:00:14.325
BugCheck 1A, {41790, fffffa800a144d10, ffff, 0}
Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+35084 )
BUGCHECK_STR:  0x1a_41790
PROCESS_NAME:  wermgr.exe
Built by: 7601.18247.amd64fre.win7sp1_gdr.130828-1532
Debug session time: Wed Mar  5 16:32:13.662 2014 (UTC + 6:00)
System Uptime: 0 days 0:00:12.474
BugCheck 1A, {411, fffff68000012240, 800, fffff6ffffffe861}
Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+6071 )
BUGCHECK_STR:  0x1a_411
PROCESS_NAME:  services.exe
Built by: 7601.18247.amd64fre.win7sp1_gdr.130828-1532
Debug session time: Wed Mar  5 05:40:20.172 2014 (UTC + 6:00)
System Uptime: 0 days 0:00:13.984
BugCheck 3B, {c0000005, fffff800037929d9, fffff880061fd9b0, 0}
Probably caused by : ntkrnlmp.exe ( nt!CmpGetNameControlBlock+12e )
PROCESS_NAME:  svchost.exe
Built by: 7601.18247.amd64fre.win7sp1_gdr.130828-1532
Debug session time: Tue Mar  4 22:00:09.098 2014 (UTC + 6:00)
System Uptime: 0 days 0:00:11.910
BugCheck 1A, {41790, fffffa800a1ecd10, ffff, 0}
Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+35084 )
BUGCHECK_STR:  0x1a_41790
PROCESS_NAME:  drvinst.exe
My System SpecsSystem Spec
25 Mar 2014   #6
Tranquil Hegemo

Windows 7 64bit

Did as much as I could outlined below

Removed the Intel ethernet cards and drivers.

Replaced the Linksys Wireless card and replaced with a TP-Link TL-WDN3800 with latest drivers from their website.

Removed BitDefender - Avira was the previous AV but that was not always starting satisfactorily so was removed prior to install of BD. Installed MSE.

Installed MalwareBytes - full scan of C:\ and E:\ - one file related to BitDefender removed.

sfc/scannow - ran and all OK

TDSS Killer - ran and all OK

Crystal Info - screen shot attached

Seatools - Short DST, SMART and Short Generic ran on C:\ and E:\ - all OK

Chkdsk E: drive - OK

Apple Charger On\ Off removed

None of the above have made any difference so on to Memtest which is where things start to get interesting. It will not run (i.e. won't boot to) version 5 - of the three slots tested with the one stick in so far it always boots to version v. 4.3.6 which it should not be doing on the hardware I am running as far as I am concerned. This is off 2 different burned CD's with v5 on (one known to work and a second downloaded version that I burnt to make double sure it wasn't the CD) and also booting from a USB stick with the latest version on.

Also if I boot into v4.3.6 from cold (i.e. the PC has not been started for a short while) I can also get it to produce a memory error on the first pass but if I then reboot the system and back into Memtest it will run eight passes without error which is pretty much what I am getting now - boot from cold- log in - BSOD - restart normally and then it will work without issue for hours till shut down. BTW I appreciate that this is not the "correct" method of doing things but it was a test that I wanted to try to see if my hunch that I could reproduce the problem which it pretty much did.

I am beginning to suspect this is an issue with the motherboard so I have reset it to running optimised defaults which I am pretty certain is actually bog standard default in Gigabyte's language and the board works out it's best configuration so I will see what happens with that. To be honest I don't think I had tweaked much if anything in the BIOS but I have reset it anyway. Would it actually be worth getting these from the BIOS and hard setting these options? The other option is the memory controller on the board is suspect and it is not setting up correctly at boot up but does on the reboot.

Do these theories sound feasible?

My System SpecsSystem Spec
26 Mar 2014   #7

Windows 10 Pro/ Windows 10 Pro Insider

Hello Tranquil Hegemo, Let me try to figure this out with you as we go along. Strangely this is I think the third case I have worked on where a BSOD occurs on a cold boot only, if I understand you correctly. Strangely the others were with a Haswell CPU and a Gigabyte board. Just for your info, the memory controller is not on the board it is on the CPU. Are you overclocking the CPU? And, I take it you are using the on board graphics still with no discrete graphics card. Is that correct? Please, if you don't already have it, download and install CPUz. It will be the latest version from the far right column. The top one usually is the latest version. Also, I have had a problem with v. 5.0 of memtest+. If you will go back to memtest and scroll down to the downloads about half way down the page and download V 4.20. It works very well. When you install CPUz, please post screenshots of the CPU tab, the mainboard tab, the memory tab and the spd tab. The spd tab may be blank if you have no ram in Dimm slot 1, in the top left corner is a drop down where you can select each Dimm slot you have just select the slots where ram is installed. Please post screenshots of those here (Screenshots and Files - Upload and Post in Seven Forums). Also do one thing for me. On a cold boot, where you usually BSOD, when you start up first, go straight to bios and just sit there for a few minutes, then exit bios and boot into windows and see if you get a bsod. I suspect you won't.
My System SpecsSystem Spec
27 Mar 2014   #8
Tranquil Hegemo

Windows 7 64bit

Hi essenbe,

Thanks for taking the time to reply and giving me a little hope in resolving this issue - in a way it's nice to know that this is not the first instance of this ever occurring as it has been driving me nuts for a while now as it is a seemingly random problem but also too regular if that makes sense. Also thanks for the info on the memory controller - at least I can forget that as a potential issue now.

In reply to your questions:

I am only getting the BSOD from cold boot where the PC has sat for a duration without being started i.e. being left overnight and then started in the morning. As previously noted if you start Windows normally following the BSOD then it will run fine. As an example I got the usual BSOD at startup yesterday morning and then it ran without an issue for over 12 hours.

No overclocking is taking place - just running it as is and also using the on board graphics card - no tweaks have been carried out in the BIOS at all and it was set back to Gigabytes "optimised defaults" a couple of days ago with no change in the symptoms.

Screen shots have been taken and attached as requested - all are obviously named.

Lastly - tried the booting and letting it sit in BIOS for a few minutes and then booting into Windows. So far all working as expected and no BSOD.

If you need anything else please feel free to ask.

My System SpecsSystem Spec
27 Mar 2014   #9

Windows 10 Pro/ Windows 10 Pro Insider

Thanks for the update. Now, the bad news. Of the 3 or 4 cases I have worked on, there never has been a resolution found. I was wrong on one thing I told you. I said all previous cases were Haswell CPUs and all were Gigabyte boards. What I remembered after writing that was all were Haswell CPU's but one was an Asus board. What brand and model PSU do you have? I recall a discussion about Haswell. It was that the chip idles with such low voltage that some PUSs would not work Right with it. However, I wouldn't think that would be any factor in the cold boot problem. A cold boot makes me think of a PSU problem. If you consider that the computer is at a dead stop and all of a sudden you turn everything on; it puts tremendous stress on the whole system, particularly the power supply. It goes from a dead stop to 100% in an instant and has to start all of the hardware in your system at once. Now, having said that, please be aware that is just my assessment of what happens. My opinion only. Also, you have to factor in the fact that you get to bios just fine, it only happens when the OS starts. That is when the hard drive comes into play and the drivers begin being loaded. That makes it a rather complicated problem. It could be hardware, software or a driver issue. Did you run memtest86+ and run it for a full 8 passes? It takes 8 passes to do a complete test. Each pass tests a different thing and each pass consists of 9 tests. That is why we like 8 full passes to completely test the ram, even more is better. Hardware testing is extremely time consuming and tedious. Believe me I know as I've done them numerous times myself. And there are some parts that cannot be tested and have to be ruled in or out depending on the results of the other tests. Would you like to pursue that course of action?
My System SpecsSystem Spec
27 Mar 2014   #10
Tranquil Hegemo

Windows 7 64bit

Thanks once again for the reply - PSU is a Corsair 600W CXM Builder Modular 80 Plus Bronze PSU - same age as the rest of the system so about 2-3 months old.

I haven't done a full test with memtest yet - I started but then got a bit concerned when it wouldn't boot into version 5 and also when I figured out that I could get it to throw errors on the first pass from a cold boot but subsequently if I rebooted it after the first pass then it would pass without error. Guessing that we are heading down the memtest route again so I will use your trick of letting it sit in BIOS for a couple of minutes before starting the tests as that will hopefully stop the errors in the first instance (assuming of course that is OK). It certainly worked so far today - not a hint of a BSOD.

As for it being time consuming - I pretty much worked that out from the testing I have done so far...
My System SpecsSystem Spec

 BSOD at startup

Thread Tools

Similar help and support threads
Thread Forum
Semi-random BSOD on startup or within a few minutes of startup
First off, this is a friends computer that I'm working on so I only have the information she has given me. Essentially the computer will BSOD either during startup, or after a few minutes of using the computer. If it doesn't BSOD within a few minutes, the computer will run just fine until you turn...
BSOD Help and Support
BSOD during windows startup; can't safe mode; startup repair can't fix
Consistent BSOD during Windows startup for both normal mode and safe mode. BSOD problem started shortly after buggy installations of Microsoft Visual C++ 2005 x64, Microsoft .Net Framework 1.1, and AMD Catalyst Drivers 13.9; and turning off Microsoft .Net Framework 3.5.1. Startup Repair is...
BSOD Help and Support
Brief BSOD on Startup, Startup Recovery Hangs
I have Win 7 Home and in the last couple of days I have been trying to do a backup onto an external drive. The problem comes in when I attempt to start my laptop so that I can begin the backup process, the screen flickers a BSOD, says startup failed and do I want to run Startup Recovery. If I say...
BSOD Help and Support
BSOD on startup, unknown error, startup repair running too long
As the title suggests, my Acer Aspire has been running startup repair for over 20 hours following a BSOD yesterday. I'm not sure if it's worth the wait so maybe you all can shed some light. Yesterday I was stressfully trying to search for something (using Chrome) and the website I was on froze;...
BSOD Help and Support
BSOD on startup , error 0x000000f4 . startup takes half an hour
so everything was fine when my laptop started to become very slow and i used to get the BSOD very often so i decided to recover the system to the initial state . i did that and everything was fine , then i updated the windows 7 service pack 1 and finished the installation and rebooted my computer ,...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

й Designer Media Ltd

All times are GMT -5. The time now is 23:07.
Twitter Facebook Google+