Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New build, multiple random BSOD with various error codes

17 Apr 2014   #71

Windows 10 Pro

A bsod analyst will be with you as soon as they can, and please follow all instructions when asked. Thank you.

Also, thanks for being patient!

My System SpecsSystem Spec
17 Apr 2014   #72

Windows 7 Professional 64-bit

Thanks for everything! I feel like we're making progress and I couldn't have gotten this far without your and everyone's help. I wish I could thank you guys in some way, like buy a round of drinks or something.
My System SpecsSystem Spec
18 Apr 2014   #73


Right, I'm no expert at this so I might be wrong but I'll see if I can help you with this one.

As I've just said I'm no expert so any advice is welcome and don't hesitate to correct me if I'm wrong

First of all it looks like something is corrupting memory, it looks like a free list.
Where the memory manager thinks a page list is empty but it's actually got data left.
(This is my theory)

Anyway there is something in the stack that has caught my eye.

fffff880`09388258 fffff800`02e7e169 : 00000000`0000003b 00000000`c0000005 fffff800`02e76ac5 fffff880`09388b20 : nt!KeBugCheckEx
fffff880`09388260 fffff800`02e7dabc : fffff880`093883b8 fffff8a0`029c6cc0 00000000`00000000 00000000`00000014 : nt!KiBugCheckDispatch+0x69
fffff880`093883a0 fffff800`02ea975d : fffff800`0309f950 fffff800`02fda22c fffff800`02e09000 fffff880`093892c8 : nt!KiSystemServiceHandler+0x7c
fffff880`093883e0 fffff800`02ea8535 : fffff800`02fce6c4 fffff880`09388458 fffff880`093892c8 fffff800`02e09000 : nt!RtlpExecuteHandlerForException+0xd
fffff880`09388410 fffff800`02eb94c1 : fffff880`093892c8 fffff880`09388b20 fffff880`00000000 00000000`00000000 : nt!RtlDispatchException+0x415
fffff880`09388af0 fffff800`02e7e242 : fffff880`093892c8 00000000`00000000 fffff880`09389370 fffff800`030b9600 : nt!KiDispatchException+0x135
fffff880`09389190 fffff800`02e7cb4a : 00000000`00000001 00000000`00000000 fffff880`03365180 fffff880`093894a8 : nt!KiExceptionDispatch+0xc2
fffff880`09389370 fffff800`02e76ac5 : 00000000`00000000 fffff800`02e8eb5b 80000001`49b25963 fffff880`09389580 : nt!KiGeneralProtectionFault+0x10a (TrapFrame @ fffff880`09389370)
fffff880`09389500 fffff800`02e8eb5b : 80000001`49b25963 fffff880`09389580 fffff781`c0000000 fffff800`030b9600 : nt!ExpInterlockedPopEntrySListFault16
fffff880`09389510 fffff800`02e9bbfe : 00000000`00000001 fffff8a0`033e2000 fffff880`09389870 fffff6fc`50019f10 : nt!MiResolveDemandZeroFault+0x5cb
fffff880`09389600 fffff800`02e8bc3b : 00000000`00000000 00000000`00000000 fffffa80`15fdd060 00000000`00000000 : nt!MiDispatchFault+0x8ce
fffff880`09389710 fffff800`02e7ccee : 00000000`00000001 fffff8a0`033e2000 00000000`00000000 00000000`00000000 : nt!MmAccessFault+0xe1b
fffff880`09389870 fffff800`02e80e10 : fffff800`030ebb4f 00000000`00000000 00000000`00008000 00000000`00000000 : nt!KiPageFault+0x16e (TrapFrame @ fffff880`09389870)
fffff880`09389a08 fffff800`030ebb4f : 00000000`00000000 00000000`00008000 00000000`00000000 00000000`00000001 : nt!memset+0x80
fffff880`09389a10 fffff800`03141c94 : fffff8a0`0c153cc0 fffff800`00008000 fffff880`09389b01 fffff800`0334cda0 : nt!PiControlGetInterfaceDeviceList+0xab
fffff880`09389a90 fffff800`02e7de53 : fffffa80`15fdd060 00000000`0149e9e0 fffff880`09389b60 00000000`0149ea68 : nt!NtPlugPlayControl+0x100
fffff880`09389ae0 00000000`7796230a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13 (TrapFrame @ fffff880`09389ae0)
00000000`0149e9a8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x7796230a
Plug and play which I'm sure you've heard of manages devices (mainly peripherals.)

Now if I look at your unloaded modules I've noticed your android phone driver is being unloaded a lot of times which looks very suspicious.

Unloaded modules:
fffff880`0ce98000 fffff880`0cf09000   spsys.sys
fffff880`0ce8d000 fffff880`0ce98000   jnprva.sys
fffff880`0ce7a000 fffff880`0ce8d000   xusb21.sys
fffff880`0ce41000 fffff880`0ce4a000   cpuz136_x64.
fffff880`0ce4a000 fffff880`0ce52000   56991a56-182
fffff880`0ce0b000 fffff880`0ce41000   WUDFRd.sys
fffff880`0d3a4000 fffff880`0d3da000   WUDFRd.sys
fffff880`0d395000 fffff880`0d3a4000   ANDROIDUSB.s
fffff880`0d350000 fffff880`0d35f000   ANDROIDUSB.s
fffff880`0d35f000 fffff880`0d395000   WUDFRd.sys
fffff880`0d31a000 fffff880`0d350000   WUDFRd.sys
fffff880`0d30b000 fffff880`0d31a000   ANDROIDUSB.s
fffff880`0d2d5000 fffff880`0d30b000   WUDFRd.sys
fffff880`0d2c6000 fffff880`0d2d5000   ANDROIDUSB.s
fffff880`0d290000 fffff880`0d2c6000   WUDFRd.sys
fffff880`0d281000 fffff880`0d290000   ANDROIDUSB.s
fffff880`0d272000 fffff880`0d281000   ANDROIDUSB.s
fffff880`0d23c000 fffff880`0d272000   WUDFRd.sys
fffff880`0d22d000 fffff880`0d23c000   ANDROIDUSB.s
fffff880`0d1f7000 fffff880`0d22d000   WUDFRd.sys
fffff880`0d1e8000 fffff880`0d1f7000   ANDROIDUSB.s
fffff880`0d1a3000 fffff880`0d1b2000   ANDROIDUSB.s
fffff880`0d1b2000 fffff880`0d1e8000   WUDFRd.sys
fffff880`0d16d000 fffff880`0d1a3000   WUDFRd.sys
fffff880`0d14d000 fffff880`0d15c000   ANDROIDUSB.s
fffff880`0d117000 fffff880`0d14d000   WUDFRd.sys
fffff880`0d108000 fffff880`0d117000   ANDROIDUSB.s
fffff880`0d0d2000 fffff880`0d108000   WUDFRd.sys
fffff880`0d08d000 fffff880`0d09c000   ANDROIDUSB.s
fffff880`0d09c000 fffff880`0d0d2000   WUDFRd.sys
fffff880`0d057000 fffff880`0d08d000   WUDFRd.sys
fffff880`0d021000 fffff880`0d057000   WUDFRd.sys
fffff880`0d012000 fffff880`0d021000   ANDROIDUSB.s
fffff880`0cfdc000 fffff880`0d012000   WUDFRd.sys
fffff880`0cf3a000 fffff880`0cf49000   ANDROIDUSB.s
fffff880`0cfa6000 fffff880`0cfdc000   WUDFRd.sys
fffff880`0cf04000 fffff880`0cf3a000   WUDFRd.sys
fffff880`0cef5000 fffff880`0cf04000   ANDROIDUSB.s
fffff880`0ceb0000 fffff880`0cebf000   ANDROIDUSB.s
fffff880`0cebf000 fffff880`0cef5000   WUDFRd.sys
fffff880`0ce7a000 fffff880`0ceb0000   WUDFRd.sys
fffff880`0ce41000 fffff880`0ce50000   ANDROIDUSB.s
fffff880`0d3d4000 fffff880`0d3e3000   ANDROIDUSB.s
fffff880`0ce0b000 fffff880`0ce41000   WUDFRd.sys
fffff880`0d39e000 fffff880`0d3d4000   WUDFRd.sys
fffff880`0d359000 fffff880`0d368000   ANDROIDUSB.s
fffff880`0d368000 fffff880`0d39e000   WUDFRd.sys
fffff880`0d323000 fffff880`0d359000   WUDFRd.sys
fffff880`0d2de000 fffff880`0d2ed000   ANDROIDUSB.s
fffff880`0d2ed000 fffff880`0d323000   WUDFRd.sys
I believe it's a google android driver.

Can you remove it for the time being and see if that helps.
My System SpecsSystem Spec

18 Apr 2014   #74

Windows 7 Professional 64-bit

I used an app called USBDeview - View any installed/connected USB device on your system - and removed anything relating to android USB drivers.

I recently rooted my girlfriend's phone, which required lots of phone restarts and thus connections/disconnections for those drivers probably. I wasn't doing it during the blue screen though (the blue screen was at least a day after the rooting... though I didn't restart the computer). I'm just wondering if that's the explanation for what you see in the stack.

Anyways, now that the android usb drivers are uninstalled, I will let you know if another bsod occurs. Thanks for looking into it!
My System SpecsSystem Spec
18 Apr 2014   #75


It looks promising.
Yes, let us know the results.
When you feel confident that the problem has been resolved mark the thread as solved.
My System SpecsSystem Spec
21 Apr 2014   #76

Windows 7 Professional 64-bit

Woke up to another blue screen this morning. Logs are attached.
My System SpecsSystem Spec
21 Apr 2014   #77


Well yes first I would recommend running Memtest86 because you have memory corruption.

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {43, 2, 1, fffff88001a57603}

Probably caused by : memory_corruption

Followup: memory_corruption
Follow these instructions on how to run memtest86.

RAM - Test with Memtest86+

However because the bugcheck indicates a driver has corrupted the memory because it tried to access a page at an IRQL that was too high it seems a driver is probably at fault.

If we look at the thread stack we can see the driver is network related.

fffff800`00b97a58 fffff800`03082169 : 00000000`0000000a 00000000`00000043 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff800`00b97a60 fffff800`03080de0 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000014 : nt!KiBugCheckDispatch+0x69
fffff800`00b97ba0 fffff880`01a57603 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x260 (TrapFrame @ fffff800`00b97ba0)
fffff800`00b97d3c 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : tcpip!Ipv4pValidateNetBuffer+0x1d3
I recommend running Driver Verifier to see if a driver is responsible.
Follow these instructions.

Driver Verifier - Enable and Disable

Post back the results.
My System SpecsSystem Spec
21 Apr 2014   #78

Windows 7 Professional 64-bit

I will run memtest86+ again tonight, but all tests so far have come up without error (you can see some the results in previous posts).

I will run driver verifier and let you know what I get.

I was logging off of my work VPN and got another BSOD this morning (before starting driver verifier). Logs attached.
My System SpecsSystem Spec
21 Apr 2014   #79


Your Juniper Network Agent Intermediate Driver is causing issues, you could update it but I suggest removing.

Unable to load image \SystemRoot\system32\DRIVERS\jnprna6.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for jnprna6.sys
*** ERROR: Module load completed but symbols could not be loaded for jnprna6.sys
fffff880`04c50000 fffff880`04cd9000   jnprna6  T (no symbols)           
    Loaded symbol image file: jnprna6.sys
    Image path: \SystemRoot\system32\DRIVERS\jnprna6.sys
    Image name: jnprna6.sys
    Timestamp:        Wed May 29 17:43:33 2013 (51A63035)
    CheckSum:         000861F4
    ImageSize:        00089000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
22 Apr 2014   #80

Windows 7 Professional 64-bit

Been running driver verifier as outlined in the post for over 24 hours, and I have not gotten any blue screens. I included all non-Microsoft drivers, plus the Microsoft tcpip.sys driver that had caused an issue previously.

I have also removed the Juniper Networks/Junos Pulse stuff. That is my work VPN, so I may need to reinstall at some point, but I will see if the blue screens stop without it.
My System SpecsSystem Spec

 New build, multiple random BSOD with various error codes

Thread Tools

Similar help and support threads
Thread Forum
Random BSOD, multiple error codes, error ntoskrnl.exe
I recently upgrade my computer from Windows 7 Pro 32 bit to Windows 7 Pro 64 bit; so I'm pretty sure my issues are somewhat driver based. Most of the time the BSOD's happen randomly; though some of the times are when launching games. I'm a novice at understanding/interpreting the dump files...
BSOD Help and Support
Random multiple BSOD different error codes
I have stumbled upon this forum as im at the end of the road, for a while i have suffered random bsod at 1st i thought it was graphics driver as my card is outdated but i don't think it is after a while of this happening i decided to fresh install windows thinking this would cure the problem,...
BSOD Help and Support
BSOD New build, Random times, multiple stop codes
I have mostly a new build. The CPU, Mobo, SSD and GPU are all new. The RAM and PSU are taken from a previous build, but only a couple years old. I have had problems since I got this build together. I get random crashes or freezes. Sometimes it happens every hour, sometimes I can go a couple days...
BSOD Help and Support
Frequent random BSOD, Multiple error codes
Hi guys About a 2 month ago I built a new PC, installed a fresh copy of win 7 x64 and started getting random BSODs. It only happened once/twice a week but has started happening more requently, 5 times in the past 4 days. I've done several MemTests (both slots, single slot, different RAM in each...
BSOD Help and Support
Random BSOD even when idle Multiple error codes
Hi there New to the forums and really hoping someone could help. I have been having multiple BSOD over the past few weeks at random points, sometimes under load while playing games other times just when the machine is idle or simply logging into windows.. I am running 16GB of Corsair...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:46.
Twitter Facebook Google+