Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD : 0x00000009A : SYSTEM_LICENSE_VIOLATION

23 Apr 2014   #11

Windows 7 Pro x64

Hi Noel !

Thanks for your answer. But maybe I forgot to mention something : as I have a BSOD at start up, I can't access to the OS, it just shutdown and restart indefinitely with same BSOD ...

What I noticed is that in the past few days I experienced more and more BSOD according to hardware conflict ( when surfing on the web watching videos, sometime everything froze up and I had a BSOD of hardware conflict ).

I did the Windows Defender Offline option, after 4 hours of scanning it found nothing ...

I don't understand why I can't repair my Windows Installation with the DVD I have, why it says it's not compatible ... Or even why I can't restore to a previous point ( no need to be in the OS to restore, the Windows DVD option allows that ) but it tells there is a memory problem and some values couldn't be read ..

My System SpecsSystem Spec
23 Apr 2014   #12

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Reboot and try doing the Memory scan - have your tried rebooting to the Repair Environment and running the System Restore from there.
My System SpecsSystem Spec
23 Apr 2014   #13

Windows 7 Pro x64

Quote   Quote: Originally Posted by Hueyman View Post
When I tried to restore just prior that event, it told me some " 0x0000f something " memory values couldn't be read etc etc... so I ran the integrated RAM test in the boot options ( F8 ) to see what's going on and it found nothing wrong.
Thanks for your answer, but it might worth reading the originial post sometimes.. no the mem scan found nothing wrong ;-(

And yes I tried to restore from the boot repair env ... Have no ideas left now
My System SpecsSystem Spec

23 Apr 2014   #14

Windows 7 Pro x64

Okay, so I finally sorted out by myself ...

I downloaded some ISO image I found over the net of the same Windows version I have, and mounted it on a USB flash drive with " A bootable USB " little software. So I was able to access my restore points and restored to the 21st of April, when all worked OK.

All was restored greatly and now all works flawlessly... I'll run Windows Update to try to get all updates, maybe it will avoid such problems in the future... hope it won't deactivate my keyboard though ...

Have a nice day guys
My System SpecsSystem Spec
31 Mar 2018   #15

Windows 7 x64
I have a similar problem

I have the same problem getting a Blue Screen of Death that says "system_license_violation". I cannot boot at all, even in Safe Mode. I tried using Windows Defender Offline, and nothing was found. I tried going back to a system restore point but it could not find any.

I see that the original poster used an ISO of the same Windows version as a USB plugin and was able to find a restore point. I want to try that, but cannot find an ISO to use.
My System SpecsSystem Spec
01 Apr 2018   #16

Windows 7 x64

I post below the text of the BSOD I get (as good as I could get it). I have looked at this webpage and it seems like the BSOD I get is due to this cause: "The SetupType or SetupInProgress value from the setup key is missing, so setup mode could not be detected." So I tried to load the defaults for Setup in the BIOS but that didn't help.

My copy of Windows 7 is genuine, as it was on the laptop when I bought it 9 years ago. And I upgraded it to Windows 10 when Microsoft offered that, but I had to revert back to Windows 7 since some programs I needed did not work on Windows 10.

"A problem has been detected and windows has been shut down to prevent damage to your computer.


If this is the first time you've seen this stop error screen, restart your computer. If this screen appears again, follow these steps:

Check to make sure any new hardware or software is properly installed. If this is a new installation, ask your hardware or software manufacturer for any windows updates you might need.

If problems continue, disable or remove any newly installed hardware or software. Disable BIOS memory options such as caching or shadowing. If you need to use safe mode to remove or disable components, restart your computer, press F8 to select advanced startup options, and then select safe mode.

Technical information:

*** STOP: 0x0000009A (0x0000000000000003, 0x0000000C0000034, 0x0000000000000000, 0x0000000000000000)"
My System SpecsSystem Spec
09 Apr 2018   #17

Windows 10 Pro

Hi Daanii,

Could you export the HKEY_LOCAL_MACHINE\SYSTEM\Setup key and upload it as a text file.
My System SpecsSystem Spec
09 Apr 2018   #18

Windows 7 x64

Axe, thanks for your reply. I was able to fix the problem using the Lazesoft Registry Recovery tool on a USB flash drive. I suspect the Setup key you identified was the problem.

It was a nasty virus and I'm glad to have the laptop running again, but I think I will buy a new laptop anyway.
My System SpecsSystem Spec
18 Sep 2018   #19

Windows 7 SP1 Home Premium 64bit [x64]

I have also encountered the SYSTEM_LICENSE_VIOLATION blue screen error on my aunt's Dell Inspiron 580 computer running Windows 7 x64 after fixing the hard drive bad sector problems. seems like the NTUSER.dat and "System" registry files were caught in some bad sectors and may have corrupted or damaged these files, which were mentioned by CHKDSK when running that with the /R switch.

I ended up replacing the broken hard drive (it was a Samsung HD103SJ 1Tb drive) with a Seagate ST31000524AS 1Tb drive and have used the Dell recovery DVDs I created several years ago to restore the Win7 OS onto the Seagate hard drive and my aunt's Dell PC is working again
My System SpecsSystem Spec
28 Aug 2019   #20

Windows 7 Ultimate
Another solution for 0x9A code 3

I just encountered BSOD 0x9a param 3 "SYSTEM_LICENSE_VIOLATION" and would like to share my fix.

A post elsewhere from a clearly informed person noted that this error does not mean the license is invalid, but specifically that Windows could not read one or both registry keys at HKLM/SYSTEM/SETUP/SetupType and .../SystemSetupInProgress

Booting from a PE CD, I could load the registry hive from the system drive (the default being the irrelevant registry on the CD created for the PE) and clearly could read both values, and both were 0 as expected, so I spent considerable time following other suggestions.

Ultimately I simply changed both values to 1 and saved the edits, then loaded the hive again and set them back to zero. Problem solved.

Environment was an Intel-based RAID 10 system, fwiw. It reported no errors. No idea why Windows couldn't read the registry values. Hope this helps someone.
My System SpecsSystem Spec


Thread Tools

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:12.
Twitter Facebook