BSOD on booting after windows logo. Atikdmag.sys relat. Suspect virus.

Page 1 of 2 12 LastLast

  1. Posts : 7
    Windows 7 home premium x64 Service pack 1

    BSOD on booting after windows logo. Atikdmag.sys relat. Suspect virus.


    Warning: Depressed as F*** so sorry if I come off distasteful.

    I keep getting a BSOD crash on every load.
    It gets to the windows logo, the one that shines, and the screen goes black and the tower goes quiet.
    Then it BSOD's.

    Display failed to reboot.

    Says a massive string of 0's and mixed letters.

    The something about atikmdag.sys or something close. After that it comes out with:
    FFFFF88002F57EFC at base (something something) FFFFF8800707D000 (this part changes slightly each time.) (more numbers) DATESTAMP.

    I've had this problem for a month or two and I think the problem may be a virus.

    I downloaded a file called "Early game development" from 4chan. (I can hear your lecture now, don't worry.)
    Which is apparently lingo for "confirmed virus". A reference to Lostboy.exe if that helps.

    This instantly copied a file onto every hard drive I have in the base/root folder. I dont recall what it was called. I instantly deleted them.

    A few days later I got the BSOD. I tried several time to start it. All failed the same way.
    I couldnt figure it out so I Recovered my PC to the previous month.
    This fixed it.

    A few days later it crashed again. Again it didn't start several times.
    I went into safe mode and scoured the windows folders. In windows32 or system or something I found a folder system: W/A/L/M/A/R/T/ and a .dll file or two.

    I deleted that and it worked again.


    A few days later it crashed again. Again it didn't start several times.
    I went into safe mode with networking to search the net. I found out ATI cards suck dehydrated anus.
    Lots of atikdmag.sys errors.
    I went on and found a 'very' similar problem. Solution was just downloading antivirus software: Emisoft-Anti malware.
    Ran a scan and it found 72 viruses. Got them quarantined.

    This fixed the problem.

    A few days later it crashed again. Again it didn't start several times.

    Emisoft got 2 more from safe mode. Didn't help.

    Now I am here. Sorry for the wall of text.

    Any help would be much appreciated.
      My Computer

  2. Posts : 3,904
    Windows 7 Ultimate 64-bit

    What ever is causing this, it has emptied your event log. Im looking into this now.
      My Computer

  3. Posts : 3,904
    Windows 7 Ultimate 64-bit

    Okay all of your BSOD's Today. Are all related to the same thing:

    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    Use !analyze -v to get detailed debugging information.
    BugCheck 116, {fffffa80078d74e0, fffff8800711cefc, 0, 2}
    Unable to load image \SystemRoot\system32\DRIVERS\atikmpag.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for atikmpag.sys
    *** ERROR: Module load completed but symbols could not be loaded for atikmpag.sys
    *** WARNING: Unable to verify timestamp for win32k.sys
    *** ERROR: Module load completed but symbols could not be loaded for win32k.sys
    Probably caused by : atikmpag.sys ( atikmpag+8efc )
    Followup: MachineOwner
    0: kd> !analyze -v
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    Attempt to reset the display driver and recover from timeout failed.
    Arg1: fffffa80078d74e0, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT).
    Arg2: fffff8800711cefc, The pointer into responsible device driver module (e.g. owner tag).
    Arg3: 0000000000000000, Optional error code (NTSTATUS) of the last failed operation.
    Arg4: 0000000000000002, Optional internal context dependent data.
    Usual causes of this bugcheck: Video driver, overheating, bad video card, BIOS, Power to card.

    I would recommend updating your drivers. Or downgrading to a more stable version if you have updated recently.

    Stress test the Graphics Card using Furmark. Keep an Eye on the Temperatures.
    Video Card - Stress Test with Furmark
      My Computer

  4. Posts : 7
    Windows 7 home premium x64 Service pack 1
    Thread Starter

    Thanks for the responses.

    I realized I was looking at the wrong number strings so, 0x0000116, if that matters now.

    I just tried that Furmark. It installed but can't run. "Could not initialize ZoomGPU. Furmark setup failed. Bye!"
    I am running in safe mode though.

    I'll edit this when I try drivers.


    Downloaded them and ran them. On install this popped up:

    Existing packages AMD APP SDK Runtime AMD Display Driver HDMI Audio Driver AMD Accelerated Video Transcoding AMD Drag and Drop Transcoding AMD Media Foundation Decoders Catalyst Control Center
    Other detected devices
    Error messages Failed to load detection driver

    So many things hate Safe mode. This is the 3rd website I tried to register on for help. The only one that didn't need advanced functions.

    Rebooting because I read that helps.

    Oh and I cleaned 90% of the dust of the card with a paint brush and mouth air(relax I am dehydrated). So isn't dust anymore.


    Rebooting didn't help, I still can't install new drivers. Not sure if windows or AMD, but angry at one of them.
    Last edited by TheRealTenman; 02 Jul 2014 at 03:14. Reason: I said so.
      My Computer

  5. Posts : 7
    Windows 7 home premium x64 Service pack 1
    Thread Starter

    Well I just got a can of air and cleaned it all out. Graphics card, motherboard and all.

    Still the same crash. Going to try and find a manual install for video drivers since the installer doesn't work in safe mode.


    Interesting turn of events: I can't run the Catalyst control centre.
    It says I dont have drivers installed....
    Then it says I don't have any settings configured for the C.C.C.

    It might just be Safe mode but until I fix it I can't check.

    I just tried following:
    Failed. It says its up to date.

    Currently trying to find out how to run specific drivers in safe mode to run the Driver install program. (this is getting crazy)

    I am about to do something sane then something stupid: Uninstall video drivers from the software uninstall thingy and reinstall. It that don't work then completely through device manager.

    If I dont get back with in an hour, assume my computer is bricked.

    Edit4: No luck with drivers from Program files and asdasd.
    About to brick it....

    I am in normal mode and Un-installing drivers then installing drivers. Then restarting.

    F***ING A!
    Last edited by TheRealTenman; 04 Jul 2014 at 23:49. Reason: I tried several different things and didn't want to double post on the same day.
      My Computer

  6. Posts : 7
    Windows 7 home premium x64 Service pack 1
    Thread Starter

    So it turned out that the drivers corrupted themselves for some reason and doing the most retarded thing was the only option.

    Proplem solved cheers for the tincy bit of help.

    Turns out it was a bit qlitched and it said I had 2 monitors. My desktop was all smooshed to the side and asdasdasdasd.

    Trying to fix the 2 monitor error and I got another crash 0x00007e I think.
    Its all good now though. The glitch fixed it.
    Last edited by TheRealTenman; 05 Jul 2014 at 00:28. Reason: Windows crashed AGAIN!
      My Computer

  7. Posts : 3,904
    Windows 7 Ultimate 64-bit

    Glad i could help and thankyou for the rep!
      My Computer

  8. Posts : 7
    Windows 7 home premium x64 Service pack 1
    Thread Starter

    Okay, so this carpola has started again...

    I assume it is the same issue because it is driver related.

    I've been trying to play a game that my video card definitely can run (so sayeth the game developer) and after going through a bunch of hoops and text files for customer support they just said "your drivers are 4 years out of date."

    This is, I assume, because I uninstalled them and let the card do its' thing.

    I try to update using the auto detect feature of AMD's website. It says I need the 14.4 yadayada version (this is important later)

    So I install this. It fails and nothing happens. It gives me an error log that I didn't save.
    This failed the exact same way several times, so I gave up.

    I uninstalled Catalyst control center to avoid any corruption issues and reinstalled from the website.
    It installs no problem. Then I try to patch it again.

    It says I need 13.7 yadayada, (as apposed to 14.4)

    Now I can run fewer games than I could before, some running with a flicker that puts Brazilian raves to shame, some just running a black screen that freezes my PC...

    Needless to say: ARGH!
      My Computer

  9. Posts : 19,384
    Windows 10 Pro x64 ; Xubuntu x64

    Lets grab the Microsoft certified driver and try that instead:

    Uninstall the current driver/software fully. Reboot. Run Windows Update - it should give a driver for download and install. Do NOT update this driver further after installing it. Use PC as normal and monitor for further BSOD's. If it crashes, run the SF log collector tool again, and upload the new .zip in your next reply.
      My Computer

  10. Posts : 7
    Windows 7 home premium x64 Service pack 1
    Thread Starter

    It fixed the other games (the checkerbox, crashes and load times) but not the game I wanted...grumble grumble.

    Also, now it underscans. . . Is there a Windows option to change that? I only ever used Catalyst Control Center.

    Okay....well that didn't last long. Ran a game (that once worked but caused a BSOD during testing), Cargo commander, and it caused a BSOD like before. Graphical glitches then a 116 Atikmdag.sys error.

    Judging by the fact Atikmdag.sys is installed with the Catalyst drivers, I haven't cleared my computer of them.

    Now the PC cant boot, it stops as it loads the drivers, and I am posting from Safemode.

    Going to do a clean sweep of ATI files.
    Last edited by TheRealTenman; 31 Jul 2014 at 06:21. Reason: Turns out the thing is still stuffed....
      My Computer

Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 03:48.
Find Us