Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD before and after OS reinstall, DRIVER_IRQL_NOT_LESS_OR_EQUAL

12 Jul 2014   #1

Windows 7 Home Premium 64-bit
BSOD before and after OS reinstall, DRIVER_IRQL_NOT_LESS_OR_EQUAL

Hey, hum, you must have a ton of these already...

Short story: Sudden freezing and Kernel error one night after clearing dust and testing system limits, next morning had difficulty accessing/deleting one particular image file that crashed Safe Mode every time I tried copying/deleting it (wanted to backup a few folders for work), saved all except that problem file and reinstalled OS. Ran chkdsk twice and on pass 5 both times, crashed at ~74% with DRIVER_IRQL_NOT_LESS_OR_EQUAL. System currently stable but I haven't installed my old stuff yet, too anxious.

Long story and details:
I've had this computer for quite some time -perhaps 5 years?- without hiccups, but on July 11th at ~midnight I got hit with a BSOD about a kernel error. A bit of back story: I haven't dusted my computer since I got it, which is a terrible shame I know, and I've had it freeze on me occasionally since April this year. So on July 9th I carefully removed a huge dust bunny in my fan which made my cpu temp at least 20-30c lower even when super busy (it peak at 60c now instead of 80c...). I started checking temps recently but didn't think of dusting the innards, I'm so lame. I wanted to test and see if my computer would freeze on me again so I had Minecraft loaded for some time and a graphics heavy Firefox page (I could have opened anything but I just wanted to play MC, also I had the Java programs run with only 2 cores instead of all four of them). It was doing fine until the 10th in the afternoon or evening when it crashed. I had to force shut down/restart and when I wanted to update my backups, it gave me the kernel BSOD at midnight.

The next morning, I tried booting up again but I kept getting the BSODs so I went on Safe Mode. Very stable until I tried copying one particular folder with image files and it tells me it can't copy it because the folder doesn't exist or it's in a different destination. I opened the folder and all jpgs had their thumbnail showing except for one which crashed my system every time I tried deleting it. I believe it could have been a gif if that information helps. So I saved all the new stuff except that one file, tried chkdsk and system restore and most Windows recovery whathaveyous before I blew a fuse and wiped everything. I needed a major cleanup anyway.

So now it's all new and sparkly but after installing all the updates and running chkdsk twice it now gives me this error: DRIVER_IRQL_NOT_LESS_OR_EQUAL. So far it's stable but I haven't installed anything I used to have so I can't really say for sure. Attached are the DM logs required, but I have no information of the sort prior to reinstalling my OS.

Oh before I forget. When I tried System Restore, it gave me July 8th as a date (the only point/date available actually) which I beliiiieeeeve must have been a important Windows update but I can't remember. The freezing were not new, the BSODs came after the 8th so... coincidence?

What I have is a store-bought computer: Acer Aspire M3400, Win7 64bit, AMD Athlon II X4 635 Processor - 2.90 GHz, graph card ATI Radeon HD 4250.

Ah and here's some short info from Windows and BlueScreenView:

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.
Locale ID: 4105
Additional information about the problem:
BCCode: d1
BCP1: 0000000000000000
BCP2: 0000000000000006
BCP3: 0000000000000001
BCP4: FFFFF88001815DA9
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1
Files that help describe the problem:

(here's BlueScreenView)
Dump File : 071214-31309-01.dmp
Crash Time : 12/07/2014 1:29:54 AM
Bug Check Code : 0x000000d1
Parameter 1 : 00000000`00000000
Parameter 2 : 00000000`00000006
Parameter 3 : 00000000`00000001
Parameter 4 : fffff880`01815da9
Caused By Driver : ahcix64s.sys
Caused By Address : ahcix64s.sys+15da9
File Description :
Product Name :
Company :
File Version :
Processor : x64
Crash Address : ntoskrnl.exe+75bc0
Stack Address 1 :
Stack Address 2 :
Stack Address 3 :
Computer Name :
Full Path : C:\Windows\Minidump\071214-31309-01.dmp
Processors Count : 4
Major Version : 15
Minor Version : 7601
Dump File Size : 271,936
Dump File Time : 12/07/2014 1:31:26 AM

Sorry this was so long, I wanted to put as much information I could remember! If anything needs clearing up, please let me know. Thank you so much!

My System SpecsSystem Spec
12 Jul 2014   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Welcome to the forum Monostone,
Start Menu\Programs\McAfee	Public:Start Menu\Programs\McAfee	Public
McAfee is a known cause for BSOD's. PLease remove it and use MSE instead.

Microsoft Security Essentials is recommended from a strict BSOD perspective, compatibility & stability
compared to other antivirus or internet security software. It is free and lightweight:-
warning   Warning
Do not start the free trial of Malware Bytes; remember to deselect that option when prompted.

Make scans with the following:

Kaspersky TDSSKillerESET online scanner: Update all drivers listed here:

ahcix64s.sys Fri Dec 4 07:53:02 2009 (4B186B7E)
AMD AHCI Compatible RAID Controller
Driver Reference Table - ahcix64s.sys

mwlPSDFilter.sys Tue Jun 2 16:07:30 2009 (4A24F9E2)
EgisTec Inc. Fingerprint Biometrics
Driver Reference Table - mwlPSDFilter.sys

mwlPSDNServ.sys Tue Jun 2 16:07:39 2009 (4A24F9EB)
EgisTec Inc. Fingerprint Biometrics
Driver Reference Table - mwlPSDNServ.sys

mwlPSDVDisk.sys Tue Jun 2 16:15:29 2009 (4A24FBC1)
EgisTec Inc. Fingerprint Biometrics
Driver Reference Table - mwlPSDVDisk.sys

RTKVHD64.sys Tue Feb 9 21:28:17 2010 (4B717F11)
Realtek High Definition Audio Function Driver
Driver Reference Table - RTKVHD64.sys

atikmpag.sys Thu Feb 11 08:11:13 2010 (4B736741)
ATI Video driver (remove the Catalyst Control Center and only install the Display Driver)
Driver Reference Table - atikmpag.sys

atipmdag.sys Thu Feb 11 08:54:19 2010 (4B73715B)
ATI Video
Driver Reference Table - atipmdag.sys

Rt64win7.sys Thu Mar 4 19:42:52 2010 (4B8FB8DC)

Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC
Driver Reference Table - Rt64win7.sys

netr7364.sys Tue Oct 4 12:14:37 2011 (4E8AA44D)
Ralink RT2501/RT2573/T2601/RT2671 Wireless Adapter (you may have a different manufacturer)
Driver Reference Table - netr7364.sys

Sometimes drivers remain, not completely uninstalled. Follow this tutorial for complete removal of drivers of the particular program: How to Clean Left Over Driver Files with Driver SweeperUse Revo Uninstaller to uninstall stubborn software. Opt for Advance Mode while uninstalling which allows you to remove leftover registry:-Run the System File Checker that scans the of all protected Windows 7 system files and replaces incorrect corrupted, changed/modified, or damaged versions with the correct versions if possible:
  • Click on the
  • Type CMD on Search
  • Left click and Run as Administrator
  • Type SFC /scannow
Full tutorial here:Run Disk Check on your Hard Drive for file system errors and bad sectors on it:Upload a screenshot of your hard disk using Crystal Disk Info:Make a hard drive test from the hard drive manufacturers website:Test your Hard Drive with SeaTools:Good luck.

Microsoft (R) Windows Debugger Version 6.2.9200.20512 X86
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\admin\Downloads\ARSENALGEAR-12_07_2014__21716_55\071214-31309-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.18409.amd64fre.win7sp1_gdr.140303-2144
Machine Name:
Kernel base = 0xfffff800`03010000 PsLoadedModuleList = 0xfffff800`03253890
Debug session time: Sat Jul 12 11:29:54.909 2014 (UTC + 6:00)
System Uptime: 0 days 1:46:23.127
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {0, 6, 1, fffff88001815da9}

*** WARNING: Unable to verify timestamp for ahcix64s.sys
*** ERROR: Module load completed but symbols could not be loaded for ahcix64s.sys
Probably caused by : ahcix64s.sys ( ahcix64s+15da9 )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 0000000000000000, memory referenced
Arg2: 0000000000000006, IRQL
Arg3: 0000000000000001, value 0 = read operation, 1 = write operation
Arg4: fffff88001815da9, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff800032bd100
GetUlongFromAddress: unable to read from fffff800032bd1c0
 0000000000000000 Nonpaged pool


fffff880`01815da9 488910          mov     qword ptr [rax],rdx






TRAP_FRAME:  fffff80000b9c320 -- (.trap 0xfffff80000b9c320)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=fffffa8004702f38
rdx=fffffa8004dacef0 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88001815da9 rsp=fffff80000b9c4b8 rbp=00000000004c6910
 r8=0000000000000000  r9=fffff80000b9c4e0 r10=fffffa8004700460
r11=fffffa8004700400 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na pe cy
fffff880`01815da9 488910          mov     qword ptr [rax],rdx ds:00000000`00000000=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80003085169 to fffff80003085bc0

fffff800`00b9c1d8 fffff800`03085169 : 00000000`0000000a 00000000`00000000 00000000`00000006 00000000`00000001 : nt!KeBugCheckEx
fffff800`00b9c1e0 fffff800`03083de0 : fffffa80`04704a30 fffff880`01809a69 fffffa80`04704a38 fffffa80`04700400 : nt!KiBugCheckDispatch+0x69
fffff800`00b9c320 fffff880`01815da9 : fffff880`01804955 fffffa80`04700460 00000000`00000002 fffffa80`03636600 : nt!KiPageFault+0x260
fffff800`00b9c4b8 fffff880`01804955 : fffffa80`04700460 00000000`00000002 fffffa80`03636600 fffff880`01859ad4 : ahcix64s+0x15da9
fffff800`00b9c4c0 fffffa80`04700460 : 00000000`00000002 fffffa80`03636600 fffff880`01859ad4 fffffa80`04700460 : ahcix64s+0x4955
fffff800`00b9c4c8 00000000`00000002 : fffffa80`03636600 fffff880`01859ad4 fffffa80`04700460 00000028`00000000 : 0xfffffa80`04700460
fffff800`00b9c4d0 fffffa80`03636600 : fffff880`01859ad4 fffffa80`04700460 00000028`00000000 fffff800`00b9cc58 : 0x2
fffff800`00b9c4d8 fffff880`01859ad4 : fffffa80`04700460 00000028`00000000 fffff800`00b9cc58 00000000`00000002 : 0xfffffa80`03636600
fffff800`00b9c4e0 fffff880`01851228 : fffffa80`03636600 00000000`00000000 00000000`00000001 fffff800`00b9c600 : storport!RaidAdapterAcquireInterruptLock+0x74
fffff800`00b9c510 fffff800`0309085c : fffff800`00b9c600 00000000`00000000 00000000`406e0089 00000000`00000001 : storport!RaidpAdapterTimerDpcRoutine+0x68
fffff800`00b9c570 fffff800`030906f6 : fffffa80`03636b30 00000000`00063e54 00000000`00000000 00000000`00000000 : nt!KiProcessTimerDpcTable+0x6c
fffff800`00b9c5e0 fffff800`030905de : 0000000e`dca3e76d fffff800`00b9cc58 00000000`00063e54 fffff800`03203d08 : nt!KiProcessExpiredTimerList+0xc6
fffff800`00b9cc30 fffff800`030903c7 : 00000015`47d50bc1 00000015`00063e54 00000015`47d50b96 00000000`00000053 : nt!KiTimerExpiration+0x1be
fffff800`00b9ccd0 fffff800`0307d8ca : fffff800`03200e80 fffff800`0320ecc0 00000000`00000000 fffff880`04a8fdb0 : nt!KiRetireDpcList+0x277
fffff800`00b9cd80 00000000`00000000 : fffff800`00b9d000 fffff800`00b97000 fffff800`00b9cd40 00000000`00000000 : nt!KiIdleLoop+0x5a


fffff880`01815da9 488910          mov     qword ptr [rax],rdx


SYMBOL_NAME:  ahcix64s+15da9

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: ahcix64s

IMAGE_NAME:  ahcix64s.sys


FAILURE_BUCKET_ID:  X64_0xD1_ahcix64s+15da9

BUCKET_ID:  X64_0xD1_ahcix64s+15da9

Followup: MachineOwner

0: kd> lmvm ahcix64s
start             end                 module name
fffff880`01800000 fffff880`01850000   ahcix64s T (no symbols)           
    Loaded symbol image file: ahcix64s.sys
    Image path: \SystemRoot\system32\DRIVERS\ahcix64s.sys
    Image name: ahcix64s.sys
    Timestamp:        Fri Dec 04 07:53:02 2009 (4B186B7E)
    CheckSum:         00039B2D
    ImageSize:        00050000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
12 Jul 2014   #3

Windows 7 Home Premium 64-bit

Thank you for your response! I'm on it right now.

I used to have a Norton subscription though before the major wipe-out. McAfee (ugh) came with the computer reboot CDs. Should I install Norton or stick with MSE?
My System SpecsSystem Spec

12 Jul 2014   #4

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Quote   Quote: Originally Posted by Monostone View Post
Should I install Norton or stick with MSE?
Stick with MSE for now. You can install Norton at a later time or when the system is stable again
My System SpecsSystem Spec
13 Jul 2014   #5

Windows 7 Home Premium 64-bit

Posting from phone... Chkdsk is stuck at 74% for about 20mins. Please tell me I still need to wait it out? :<
My System SpecsSystem Spec
13 Jul 2014   #6

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Quote   Quote: Originally Posted by Monostone View Post
Posting from phone... Chkdsk is stuck at 74% for about 20mins. Please tell me I still need to wait it out? :<
Please wait
My System SpecsSystem Spec
13 Jul 2014   #7

Windows 7 Home Premium 64-bit

Oki doki, will do... :'<
My System SpecsSystem Spec
13 Jul 2014   #8

Windows 7 Home Premium 64-bit

So Germany just won the World Cup but we're still on 74% on the same cluster. Is it possible it can take longer than this? I'm afraid it's just frozen...
My System SpecsSystem Spec
13 Jul 2014   #9

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Quote   Quote: Originally Posted by Monostone View Post
So Germany just won the World Cup but we're still on 74% on the same cluster. Is it possible it can take longer than this? I'm afraid it's just frozen...
Oh well...

what about now?
My System SpecsSystem Spec
13 Jul 2014   #10

Windows 7 Home Premium 64-bit

Still not moving. :'<
My System SpecsSystem Spec

 BSOD before and after OS reinstall, DRIVER_IRQL_NOT_LESS_OR_EQUAL

Thread Tools

Similar help and support threads
Thread Forum
Bsod driver_irql_not_less_or_equal
I've been getting this BSOD for a while now called DRIVER_IRQL_NOT_LESS_OR_EQUAL. I know this has to do with a driver but I have no idea which one is causing it. Please help, thanks!
BSOD Help and Support
BSOD driver_irql_not_less_or_equal
Hello! I've had it once before and it was McAffe's fault. It came back and I'm not sure what it is now. Besides this issue, my computer also randomly turns off by itself sometimes with no error messages, I think they're related. I updated my system specs and am posting the kernel dump (is that...
BSOD Help and Support
Bsod Driver_irql_not_less_or_equal
Hi guys, I have this problem which i posted earlier which i accidentally clicked that it was solved and as it was my first post i was unaware of the rules. I have now followed the rules and done as told. I was told by my computer tech that this is a problem with regards to the devices which are...
BSOD Help and Support
BSOD driver_irql_not_less_or_equal
hi, My system is restarting and i am getting the above error in a blue screen. This is happening every now and then. i am using hp pavilion dv6 1350us laptop with intel core 2 duo. i am getting the following error code on start up : BCCode: d1 BCP2:0 BCP2:2
BSOD Help and Support
Bsod: Driver_irql_not_less_or_equal
I had this same problem a while ago, but after i did clean windows install it disappeared for 2 weeks. Now i have the same problem. How come? Could this be a hardware issue or what? Thanks for help. :o Windows 7 x64 full retail - What is the age of system (hardware)? 3 years
BSOD Help and Support
Bsod driver_irql_not_less_or_equal
Hello, I'm experiencing sporadic BSODs on Win 7 D1(ee0000000,0,2,8,0ee0000000). Quick look at dump file points to ntkrnlmp.exe, but I don't know how to locate the faulting driver using WinDbg. Can you guys help me out. I'm attaching the result from BSOD dump app. My laptop is ThinkPad T510 few...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App