Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD on shut down/sleep, error0x0000000A

21 Aug 2014   #1

Windows 7 Professional x64
BSOD on shut down/sleep, error0x0000000A


Every time I shut down my PC or put it to sleep, I get a BSOD. Can someone please help? I have already updated as many drivers as I know, reinstalled Windows 7 and uninstalled my antivirus software.

Any help would be appreciated.
Thank You

My System SpecsSystem Spec
22 Aug 2014   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

The issue is caused by Agere Systems PCI-SV92PP Soft Modem (c:\windows\system32\drivers\agrsm64.sys). The associated driver is too old, of 2008.

Either update the driver or remove the device.

Let us know the result.

BTW, you dont have the Ethernet driver installed. Willingly?
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck A, {0, 2, 1, fffff80002ed697c}

*** WARNING: Unable to verify timestamp for agrsm64.sys
*** ERROR: Module load completed but symbols could not be loaded for agrsm64.sys
Probably caused by : agrsm64.sys ( agrsm64+48380 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: 0000000000000000, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff80002ed697c, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff80003107100
GetUlongFromAddress: unable to read from fffff800031071c0
 0000000000000000 Nonpaged pool


fffff800`02ed697c 4c8938          mov     qword ptr [rax],r15





ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre

TRAP_FRAME:  fffff880037ee720 -- (.trap 0xfffff880037ee720)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=fffffa80099fdd68
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80002ed697c rsp=fffff880037ee8b0 rbp=0000000000000000
 r8=fffff78000000008  r9=fffffa80099fdd00 r10=0000000000000000
r11=fffff880009e9180 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
fffff800`02ed697c 4c8938          mov     qword ptr [rax],r15 ds:00000000`00000000=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002ecf169 to fffff80002ecfbc0

fffff880`037ee5d8 fffff800`02ecf169 : 00000000`0000000a 00000000`00000000 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`037ee5e0 fffff800`02ecdde0 : 00000000`00000000 fffffa80`0705ac18 00000000`00000010 00000000`00000000 : nt!KiBugCheckDispatch+0x69
fffff880`037ee720 fffff800`02ed697c : 00000000`00000001 fffff880`009e9180 fffffa80`069fb148 fffffa80`069fb148 : nt!KiPageFault+0x260
fffff880`037ee8b0 fffff800`0336f6c1 : 00000000`00000100 fffff800`00000000 fffff980`06d46d00 fffff800`03367e00 : nt!KeWaitForSingleObject+0x17c
fffff880`037ee950 fffff880`0485e380 : fffffa80`099fdd60 fffff980`00000000 00000000`00000000 fffffa80`00000000 : nt!VerifierKeWaitForSingleObject+0x151
fffff880`037ee9d0 fffffa80`099fdd60 : fffff980`00000000 00000000`00000000 fffffa80`00000000 00000000`00000000 : agrsm64+0x48380
fffff880`037ee9d8 fffff980`00000000 : 00000000`00000000 fffffa80`00000000 00000000`00000000 fffff980`06d46d80 : 0xfffffa80`099fdd60
fffff880`037ee9e0 00000000`00000000 : fffffa80`00000000 00000000`00000000 fffff980`06d46d80 fffff800`03377d52 : 0xfffff980`00000000


fffff880`0485e380 ??              ???


SYMBOL_NAME:  agrsm64+48380

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: agrsm64

IMAGE_NAME:  agrsm64.sys


FAILURE_BUCKET_ID:  X64_0xA_VRF_agrsm64+48380

BUCKET_ID:  X64_0xA_VRF_agrsm64+48380


FAILURE_ID_HASH_STRING:  km:x64_0xa_vrf_agrsm64+48380

FAILURE_ID_HASH:  {09151c29-8369-67d5-dc04-b6a670920912}

Followup: MachineOwner

1: kd> lmvm agrsm64
start             end                 module name
fffff880`04816000 fffff880`04938000   agrsm64  T (no symbols)           
    Loaded symbol image file: agrsm64.sys
    Image path: \SystemRoot\system32\DRIVERS\agrsm64.sys
    Image name: agrsm64.sys
    Timestamp:        Mon Nov 10 20:31:35 2008 (49184CCF)
    CheckSum:         00119433
    ImageSize:        00122000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
22 Aug 2014   #3

Windows 7 Professional x64

Yes that solved my problem. Thank you!
And no I haven't updated it. I don't use an Ethernet cable I use WiFi so didn't think I needed it. Should I update it?
My System SpecsSystem Spec

22 Aug 2014   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

If you dont use ethernet, dont get the driver.

Let us know for any further issue.
My System SpecsSystem Spec

 BSOD on shut down/sleep, error0x0000000A

Thread Tools

Similar help and support threads
Thread Forum
Laptop do not shut down after sleep
Hello, I've a Toshiba Tecra R840 laptop running Win7 Professional sp1 64 bit. It runs in a 512GB SSD. I use a Targus Bluetooth mouse. From 2 or 3 weeks ago (I think) after sleep 2 things happens: 1- mouse stop working (only after a computer restart it will work again) 2- windowns will not...
General Discussion
BSOD on shut-down, sleep or hibernate - DRIVER_POWER_STATE_FAILURE
Oh boy could I do with some help please! I've tried updating as many drivers as I can but I'm getting nowhere. BSOD every time I shut-down or sleep or hibernate. Problem signature: Problem Event Name: BlueScreen OS Version: 6.1.7601. Locale ID: 2057 Additional information...
BSOD Help and Support
BSOD with shut down/sleep mode, multiple errors
Hello! Thank you for the help. About a week after purchasing this laptop, I started getting BSODs when shutting down or going into sleep mode. It has increased in frequency recently. Each BSOD pops up with multiple errors.The .zip file attached has the dump files, but not a system health report...
BSOD Help and Support
how do i shut my display without going to sleep
I remember in earlier versions of windows I could put my computer to sleep and still have some functionality.. such as audio. How do I shut the display and still hear my audio? If I put the computer to sleep, the audio also shuts down.
General Discussion
Failure to shut down when using sleep
I have Windows 7 Ultimate 64 bit. When the computer goes to sleep, it wake up just fine and everything functions as it should. However, when I try to turn the computer off (via the start menu), the monitor shuts off, but the computer is still receiving power. I have to manually hold the power...
Performance & Maintenance
Sleep Mode vs Shut Down
I just read an old thread from last year on here about this subject. I had XP before I just switched to Win 7. I did not ever turn off the XP. I like the convenience of sitting down and starting to work. Booting each time was too much like Dial-Up. My power supply on the XP machine lasted 5...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App