Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: netr28ux.sys throwing BSODs

25 Aug 2014   #1

Windows 7 Home Premium 64bit
netr28ux.sys throwing BSODs

Hello, i'm using Edimax's EW-7711USn usb wifi dongle for quite some time but now it started to BSOD my PC.
I have updated drivers with no result. Same with removing and reinstalling them.

My System SpecsSystem Spec
25 Aug 2014   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit


The device is Edimax nLite Wireless USB Adapter.

The driver is made by Ralink (that needs to be updated to stop the BSODs).

Ralink got acquired by MediaTek.

So I dont know what should be your best choice. If you are aware of the chip type, search for a driver in Downloads - MediaTek

Otherwise get a new dongle, choose one where the vendor and the driver developer is the same (like Qualcomm Atheros) so that you can get flawless driver updates.
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {fffff880047ec000, 2, 0, fffff8800283ed6c}

*** WARNING: Unable to verify timestamp for netr28ux.sys
*** ERROR: Module load completed but symbols could not be loaded for netr28ux.sys
Probably caused by : netr28ux.sys ( netr28ux+16d6c )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: fffff880047ec000, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff8800283ed6c, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800038b8100
GetUlongFromAddress: unable to read from fffff800038b81c0
 fffff880047ec000 Nonpaged pool


fffff880`0283ed6c 0fb60410        movzx   eax,byte ptr [rax+rdx]




PROCESS_NAME:  deluge.exe

ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre

TRAP_FRAME:  fffff8800783fbc0 -- (.trap 0xfffff8800783fbc0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffff880047ebffd rbx=0000000000000000 rcx=fffff8800783fe34
rdx=0000000000000003 rsi=0000000000000000 rdi=0000000000000000
rip=fffff8800283ed6c rsp=fffff8800783fd50 rbp=fffffa8008142950
 r8=0000000000000000  r9=0000000000000037 r10=fffffa8009d5cc00
r11=fffffa800ab30030 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
fffff880`0283ed6c 0fb60410        movzx   eax,byte ptr [rax+rdx] ds:fffff880`047ec000=??
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80003680169 to fffff80003680bc0

fffff880`0783fa78 fffff800`03680169 : 00000000`0000000a fffff880`047ec000 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`0783fa80 fffff800`0367ede0 : 00000000`00008001 00000000`00000002 00000000`0004002f fffffa80`0926e1a0 : nt!KiBugCheckDispatch+0x69
fffff880`0783fbc0 fffff880`0283ed6c : fffffa80`0b5c1190 00000000`00000000 00000000`00000000 fffffa80`0b9b1150 : nt!KiPageFault+0x260
fffff880`0783fd50 fffffa80`0b5c1190 : 00000000`00000000 00000000`00000000 fffffa80`0b9b1150 00000000`00000100 : netr28ux+0x16d6c
fffff880`0783fd58 00000000`00000000 : 00000000`00000000 fffffa80`0b9b1150 00000000`00000100 fffff880`01462c60 : 0xfffffa80`0b5c1190


fffff880`0283ed6c 0fb60410        movzx   eax,byte ptr [rax+rdx]


SYMBOL_NAME:  netr28ux+16d6c

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: netr28ux

IMAGE_NAME:  netr28ux.sys


FAILURE_BUCKET_ID:  X64_0xD1_netr28ux+16d6c

BUCKET_ID:  X64_0xD1_netr28ux+16d6c


FAILURE_ID_HASH_STRING:  km:x64_0xd1_netr28ux+16d6c

FAILURE_ID_HASH:  {4c33591e-e7b0-e1f3-e206-91c5683bdcb0}

Followup: MachineOwner

1: kd> lmvm netr28ux
start             end                 module name
fffff880`02828000 fffff880`029d3000   netr28ux T (no symbols)           
    Loaded symbol image file: netr28ux.sys
    Image path: \SystemRoot\system32\DRIVERS\netr28ux.sys
    Image name: netr28ux.sys
    Timestamp:        Fri Mar 02 16:27:24 2012 (4F50A794)
    CheckSum:         001A5F72
    ImageSize:        001AB000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
25 Aug 2014   #3

Windows 7 Home Premium 64bit

I knew chip model before so just updated the driver from MediaTek's website. Works for now, but blue screens were random so i'll wait a few days and see if problem's gone.

Edit: Updating drivers did the trick.
My System SpecsSystem Spec


 netr28ux.sys throwing BSODs

Thread Tools

Similar help and support threads
Thread Forum
Random BSoD's throwing multiple errors
I built my PC about two years ago and it has sporadically had BSoD's the entire time. Sometimes it is while playing a game or just idling. I can't seem to replicate it, it just sort of happens. My first thought was perhaps bad memory. I initially had 8 GB of Corsair ram that I have ran Memtest on...
BSOD Help and Support
DISKPART throwing I/O error at create partition command
Hi, My laptop doesn't boot from hard disk anymore. So I tried to start system with Windows 7 installation DVD and ran DISKPART. It recognized disk 0 but when I execute "create partition primary size=80000" it runs for sometime and displays that it is not able to execute the operation...
Installation & Setup
Please save me from throwing my computer against a wall.
Forgive me, I know this kind of thing has probably been covered on here a million times but I ran a search and couldn't find anything that helped. Yesterday I purchased an AOC 22" monitor to use as an external display for my HP mini 110-3100 netbook via a vga connection. Unfortunately, and even...
General Discussion
So my new HD is throwing S.M.A.R.T errors...
My brand new 1TB HD just started throwing S.M.A.R.T errors, and I requested an RMA. In the meantime, I'd like to know how cloning a drive works. I downloaded Acronis Image Tool and I'm currently cloning my entire drive (two partitions) into my 500GB. My question is when I recieve my new drive,...
Hardware & Devices
is throwing a couple of these SSDs in RAID0 worthwhile? - Intel X25-V SSDSA2MP040G2R5 2.5" 40GB SATA II MLC Internal Solid State Drive (SSD) - Solid State Disks I'm looking at getting 2 of these to put in RAID0 for my boot and application drive as the price seems reasonable for what has to be a huge performance increase from the 1tb 16mb...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App