Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Random BSOD error 0x124, CPU suspected

01 Sep 2014   #1

Windows 7 Ultimate x64
Random BSOD error 0x124, CPU suspected

Hi sevenforums. I'm usually pretty good at solving PC problems but this one has me stumped. I've been using my custom built PC fine for about a year until about the past month or so I've been getting random BSOD. I've read a TON of stuff here and elsewhere on how to resolve it to no avail.

System Specs:
i5 3570k @ stock clocks(had it overclocked fine for about a year @ 4.2 1.15 vcore w/ normal temps)
ASUS p8z77-V LE Pro
8 GB Corsair Vengeance 1600
Enermax NAXN 550W PSU
Seagate Barricuda 1TB 7200

Things I've tried so far:
  • memtest 10 passes cleared. (I get BSOD with either of my 2 ram sticks installed 1 at a time or both)
  • prime95 for 24 hours(oddly enough it passed this fine with normal temps)
  • deleting known BSOD causing software and system files (sptd.sys, avast, etc.)
  • updating all drivers/BIOS and trying different (older) graphic drivers.
  • reverting to stock clock speeds on CPU/GPU.
  • chkdsk /r and sfc /scannow
  • removed GPU and still BSOD

I'm 99% sure its my CPU dying on me. This is because I'm even randomly freezing inside of my BIOS where I have to hard shutdown. I've tried numerous BIOS configurations (disabling/enabling C states, speedstep) to no avail. Sometimes I'll be fine for hours -- days even. Earlier tonight was the worst it's been, BSOD everytime I got to Windows Logo even in safe mode. Randomly, it finally let me in and I've been good for about 45 minutes. How can I be sure it's my cpu and not my motherboard though?

My log file collection is attached to this post. Thanks for any help you can give me.

My System SpecsSystem Spec
01 Sep 2014   #2

Windows 7 Ultimate x64

Still getting them tonight. Can anyone confirm or share my suspicions of the CPU before I drop $300 on an i7? That would really suck if it turns out to be the mobo but I guess there's no way to know for sure as I have no other PC to try the cpu in. Might also grab 2 new sticks of RAM just to be safe. On the brightside, this is an excuse to upgrade my rig
My System SpecsSystem Spec
02 Sep 2014   #3

Windows 10 Pro/ Windows 10 Pro Insider

conditions, I'll see if I can help. Unless you have seriously abused it, I doubt it is the CPU. The CPU is normally the last thing to suspect with hardware. Also, would you check your system specs. I cannot find the Motherboard you have listed anywhere. You have an ASUS p8z77-v LE Pro . I can find an ASUS p8z77-v LE and an ASUS p8z77-v Pro. Also, have you installed your Motherboard drivers and run all of the Windows Updates? I also don't understand what you mean about running Memtest. You say 10 passes cleared then say you get BSODs with either just 1 stick or both sticks. When did you get BSODs from the ram during memtest and if you were getting them, how did you run 10 passes? Also, you list 1 hard drive in your system specs. Do you have other drives and tell me the port numbers all are plugged into. I need you to be much more specific about your system specs. You obviously have a hardware problem, so I need detailed specs about everything in and connected to your computer. Sometimes I need to look up a piece of hardware, just like I tried to find your motherboard. for ram, 8 GB 1600 wouldn't help me if I needed to look it up. What about your PSU, what CPU cooler do you have. At the bottom left of this post, click my system specs and see mine, to get an idea of what I am looking for.

Now to the dump files. I can't tell you if these are the cause of your BSODs or the effect of them. Put another way, I don't know whether these caused it or if something else caused it, which made these crash and that is what the dump file caught.

lmvm atikmdag
start             end                 module name
fffff880`0f232000 fffff880`0fe7b000   atikmdag T (no symbols)           
    Loaded symbol image file: atikmdag.sys
    Image path: atikmdag.sys
    Image name: atikmdag.sys
    Timestamp:        Tue Oct 08 08:51:03 2013 (52540DC7)
    CheckSum:         00BFB253
    ImageSize:        00C49000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Your Graphics card drivers need to be updated. Download the latest WHQL driver from ,Uninstall your old drivers, then clean out all the parts left over following this install the new ones, but select custom install and only install the Graphics diver, or as little as you can. none of the other stuff is needed and can cause conflicts with other drivers.

lmvm mv91xx
start             end                 module name
fffff880`01000000 fffff880`0108d000   mv91xx   T (no symbols)           
    Loaded symbol image file: mv91xx.sys
    Image path: mv91xx.sys
    Image name: mv91xx.sys
    Timestamp:        Mon Nov 22 01:00:45 2010 (4CEA151D)
    CheckSum:         0004B35E
    ImageSize:        0008D000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
That is your Marvell MV91xx AHCI/RAID driver. If you only have one drive, you don't need the Marvell ports or the drivers and can and should disable the Marvell ports in BIOS.

lmvm partmgr
start             end                 module name
fffff880`00e3d000 fffff880`00e52000   partmgr    (no symbols)           
    Loaded symbol image file: partmgr.sys
    Mapped memory image file: c:\symcache\partmgr.sys\4F641BC115000\partmgr.sys
    Image path: partmgr.sys
    Image name: partmgr.sys
    Timestamp:        Sat Mar 17 00:06:09 2012 (4F641BC1)
    CheckSum:         0001DFC8
    ImageSize:        00015000
    File version:     6.1.7601.17796
    Product version:  6.1.7601.17796
    File flags:       0 (Mask 3F)
    File OS:          40004 NT Win32
    File type:        3.7 Driver
    File date:        00000000.00000000
    Translations:     0000.04b0
    CompanyName:      Microsoft Corporation
    ProductName:      Microsoft® Windows® Operating System
    InternalName:     partmgr.sys
Partition Management Driver that is from Windows Update

lmvm  rdbss
start             end                 module name
fffff880`040bc000 fffff880`0410d000   rdbss    T (no symbols)           
    Loaded symbol image file: rdbss.sys
    Image path: rdbss.sys
    Image name: rdbss.sys
    Timestamp:        Sat Nov 20 03:27:51 2010 (4CE79497)
    CheckSum:         0004D76F
    ImageSize:        00051000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Redirected Drive Buffering SubSystem Driver from Windows update

Please notice that all but the Graphics driver are related to the storage system. So, I would like you to run Data Lifeguard from Western Digital on your Hard drive. I would like you to use the test for DOS, run the short and the long test. The download and instructions are WD Support / Downloads / SATA & SAS / WD Black

Please find your Motherboards drivers from Asus web site and install all of the drivers you use, but especially the chipset drivers and the storage drivers. Also please run all Windows updates.
My System SpecsSystem Spec

02 Sep 2014   #4

Windows 7 Ultimate x64

Hi essenbe, thanks for your reply. First, here is a more detailed and corrected specs for my PC:

Mobo: ASUS P8z77-V LE PLUS(not pro sorry) can be found at Motherboards - P8Z77-V LE PLUS - ASUS

RAM: 2 sticks of Corsair Vengeance 4 GB found here: Vengeance® ? 4GB Single Module DDR3 Memory Kit (CMZ4GX3M1A1600C9B)

PSU: Enermax NAXN 550w specs found here: ENERMAX - Product

HDD: Seagate Barricuda 1 TB found at: Seagate Barracuda ST1000DM003 1TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive Bare Drive -

My CPU cooler is a CM Hyper 212 Evo.

I have the latest mobo/chipset/storage drivers and the latest BIOS version installed.

I have updated with all the latest critical Windows Updates.

When I ran memtest I let it go for 10 passes and it cleared. In addition to that, I still get BSOD in Windows if I try using only 1 stick at a time. I didn't get any BSOD or crashes in memtest itself.

I have only 1 harddrive and the sata cable is plugged into the Marvell enabled sata slot since that's what the mobo manual recommended. I'll go ahead and try a different SATA slot and disable marvel in BIOS. I just ran last night Seagate's Seatools and tested short pass and long pass with fix. It passed both with no errors or bad sectors.

My graphics drivers are old because I read a post here recommending to try older graphics drivers. I still BSOD with the latest WHQL drivers from AMD. In addition, I still BSOD with the GPU removed and onboard graphics used.

Finally, I would just like to reiterate that occasionally I am freezing within my BIOS even with my harddrive disconnected(I tried disconnecting it and reconfiguring BIOS settings to see if I would have problems within a bootable CD such as Hiren's boot CD which I did).

I appreciate you taking the time to assist me.
My System SpecsSystem Spec
02 Sep 2014   #5

Windows 10 Pro/ Windows 10 Pro Insider

Thanks. If you don't mind, please look at your last post and in the lower left corner, click my system specs. There will be a link there to 'update system specs' please update them and be sure to click save at the bottom. That way it will be available to us n any post rather than us having to hunt for them. I certainly would appreciate it.

Give me a little time to look at your files again and your manual. I am pretty sure it would not say to connect your boot drive to a Marvell port. You will always get better performance from the Native Intel ports. Your boot drive should be connected to port 1 or 0. The Marvell ports are add on ports not controlled by the chipset.
My System SpecsSystem Spec
02 Sep 2014   #6

Windows 7 Ultimate x64

I will do that, thanks. Also, just to update, you're right I had my HDD plugged into the Marvell SATA plug on my board which is probably wrong so I plugged it into the grey Sata intel 6 gb/s slot and installed the latest storage drivers for it. I also noticed the seatools diagnostic test has more available options now which I'm going to try. I may try another long test w/fix as well since it may have not detected a problem earlier since it was plugged into the wrong SATA slot.

EDIT: I found a firmware update for my drive, should I do that? Here is the link:

My drive model # is ST1000DM003 with part # 9YN162 so it's compatible with that update.
My System SpecsSystem Spec
02 Sep 2014   #7

Windows 10 Pro/ Windows 10 Pro Insider

Great, that's where your hard drive should be plugged into. OK, please make sure all of your Windows updates are installed. The only exception is don't use the Graphics card update. Keep checking for updates until it says there are no more. Once you finish whatever you do with Seatools, do one other thing for me.

Open a elevated command prompt ( click start, type cmd in the search box, right click on the cmd entry and select run as administrator) in the black box that opens, copy/paste sfc /scannow. If you decide to type it, notice the space between the sfc and the /. It is a system file checker which will scan your system files and attempt to correct any missing or corrupt files. What we want are the results to say windows found no integrity violations. If it says files were found but could not be repaired, close the box, reboot and run it again, after opening the administrative command prompt. You may have to reboot and run it three times for it to repair all system files. If it can't repair them after 3 reboots, let us know.
My System SpecsSystem Spec
03 Sep 2014   #8

Windows 10 Pro/ Windows 10 Pro Insider

You can, just be sure to read the warnings at the bottom of the page.
My System SpecsSystem Spec
03 Sep 2014   #9

Windows 7 Ultimate x64

Ok, so my HDD already had the latest firmware so I didn't need to deal with that.

My sfc /scannow found corrupt files but could not repair them so as per your instructions I rebooted and rescanned 3 times and tried again. On the third scan i'm still getting the could not repair message. The culprit seems to be iassdo.dll.mui:
2014-09-02 22:51:40, Info                  CSI    00000316 [SR] Cannot repair member file [l:28{14}]"iassdo.dll.mui" of Microsoft-Windows-Networking-Internet_Authentication_Service_Iassdo.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2014-09-02 22:51:40, Info                  CSI    00000318 [SR] Cannot repair member file [l:28{14}]"iassdo.dll.mui" of Microsoft-Windows-Networking-Internet_Authentication_Service_Iassdo.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2014-09-02 22:51:40, Info                  CSI    00000319 [SR] This component was referenced by [l:266{133}]"Microsoft-Windows-WindowsFoundation-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514.Windows Foundation Language Pack"
2014-09-02 22:51:40, Info                  CSI    0000031c [SR] Could not reproject corrupted file [ml:60{30},l:58{29}]"\??\C:\Windows\SysWOW64\en-US"\[l:28{14}]"iassdo.dll.mui"; source file in store is also corrupted
I've attached sfcdetails.txt and the raw CBS.log files to this post.
My System SpecsSystem Spec
03 Sep 2014   #10

Windows 10 Pro/ Windows 10 Pro Insider

conditions, it seems that much of your problem is likely the fact that you have an illegal Windows Ultimate. You are using an OEM_SLP key on a retail Motherboard. An OEM_SLP key is only good on the computer it was installed on when it came from the Manufacturer.

Counterfeit installations such as yours contain heavily modified code that causes the installation to behave it unexpected ways. Analyzing BSOD's and determining their causes on these sorts of installations is very unreliable. For this reason, many analysts won't attempt it.

My recommendation is to install a genuine Windows 7. This will minimize the problems you are experiencing, and make subsequent diagnosis of BSOD's far more reliable. Once you are running a Genuine Windows 7 installation, and are still experiencing BSOD's, we will be happy to help you solve them
My System SpecsSystem Spec

 Random BSOD error 0x124, CPU suspected

Thread Tools

Similar help and support threads
Thread Forum
Random BSOD error 0x124
So I recently reinstalled windows, and I'm experiencing BSOD 0x124. I'm leaving my dump file with this post.
BSOD Help and Support
Random BSOD, Error code 0x124
Hi! fist of all, sorry for my bad english. I've been getting BSOD for a like a month now, i had my laptop stored for a year because the power jack and poder cord of my laptop where broken. A month ago i asked a friend to help me soldering both. Since then, ive been getting bsod when i open...
BSOD Help and Support
0x124 BSOD,suspected CPU Cache failure....(had a go at debugging)
Various issues going on at moment,G700s and G930 problems. Custom Build been running ok for a good few months,this 0x124 is new. ******************************************************************************* * * * ...
BSOD Help and Support
BSOD After random amount of time, suspected hardware error
Since I moved to college, I decided to ship the desktop I built to my apartment. I had invested a decent amount into it so I didn't want to go many many months without using it. I decided to ship it via USPS after taking it apart. I thought that would have made it safe enough to ship, but I was...
BSOD Help and Support
BSOD at random times, error 0x124
Okay I've been getting BSOD of with the error 0x124 for awhile now. Sometimes I wouldn't get one for days, sometimes I'd get when ~5mins after I just got one. It happens a lot when playing games, but happens when I'm just surfing the web too. Can any of you great masters of the BSOD help me out?...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:48.
Twitter Facebook Google+