Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD on Internet Related Programs (tcpip.sys)

16 Sep 2014   #1

Windows 7 Professional 32bit
BSOD on Internet Related Programs (tcpip.sys)

For the past 2 months I have received an increased growth in BOSD relating to tcpip.sys. I have received over 50 BOSD in on week and approximately 10 in one day. It makes my life especially frustrating because of the delay in my school online homework, server hosting, and personal entertainment. I mainly receive BOSD on tcpip.sys address 86cD45AC base at 86c1b000. I have check many of my drivers for outdated and have attempted to fix corrupted registry keys. I do not have any experience in such things. I need urgent assistance. I'm not sure if it's a program, registry key, virus, or some other error.

Thanks in advance.

Other Info About problem below and The logs/analysis included below:

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.
Locale ID: 1033

Additional information about the problem:
BCCode: 50
BCP2: 00000000
BCP3: 86CD65AC
BCP4: 00000002
OS Version: 6_1_7601
Service Pack: 1_0
Product: 256_1

PC Specs(I have an old system)------
OS: Windows 7 Professional 32 bit
Processor: Intel core Quad Q6600 2.4 GHz
GPU: Geforce 9400 GT
HardDrive: Hitachi HDT735050VLA360 ATA9 (I believe this is it)
Network Adapter: Netgear RangeMax Wireless USB 2.0 WPN11(Although using FIOS Verizon Router)

Anti-Virus/Malware Software------
Microsoft Security Essentials
Spybot Free Edition
Malwarebytes Anti-Malware

Note: I sometimes turn off Real Time Scanning/ Add an exception for gaming reasons

PC Speed Boosters
Auslogics BoostSpeed 7
System Mechanic 14 (Don't use often)

My System SpecsSystem Spec
18 Sep 2014   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Before we suggest anything to you, upload your MSINFO32.nfo file. It is very much needed.
  1. Click on the start button
  2. Type "msinfo32" (without quotes) in the search bar of the start menu, click the resulting link. It will open the System Information window.
  3. File>Save. In the "File Name" filed, put "MSINFO32" (without Quote), give the save location to desktop, and click the "save" button.
  4. Give the time for processing, it will save a .nfo file on your desktop.
  5. Zip it, and upload it following the instruction.
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 50, {cccccdd8, 0, 86cd65ac, 2}

Unable to load image \??\C:\Windows\system32\drivers\mwac.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for mwac.sys
*** ERROR: Module load completed but symbols could not be loaded for mwac.sys

Could not read faulting driver name
Probably caused by : NETIO.SYS ( NETIO!ClassifyContextCleanupRoutine+62 )

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arg1: cccccdd8, memory referenced.
Arg2: 00000000, value 0 = read operation, 1 = write operation.
Arg3: 86cd65ac, If non-zero, the instruction address which referenced the bad memory
Arg4: 00000002, (reserved)

Debugging Details:

Could not read faulting driver name

READ_ADDRESS: GetPointerFromAddress: unable to read from 8356182c
Unable to read MiSystemVaType memory at 83541e60

86cd65ac 8b910c010000    mov     edx,dword ptr [ecx+10Ch]





PROCESS_NAME:  mbamservice.ex


ANALYSIS_VERSION: 6.3.9600.17237 (debuggers(dbg).140716-0327) amd64fre

TRAP_FRAME:  afd5fa10 -- (.trap 0xffffffffafd5fa10)
ErrCode = 00000000
eax=92e762f0 ebx=00000000 ecx=cccccccc edx=afd5fa9c esi=8d08bc28 edi=8ce37f30
eip=86cd65ac esp=afd5fa84 ebp=afd5fa88 iopl=0         nv up ei ng nz na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010286
86cd65ac 8b910c010000    mov     edx,dword ptr [ecx+10Ch] ds:0023:cccccdd8=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from 8343aa38 to 83460d5d

afd5f9f8 8343aa38 00000000 cccccdd8 00000000 nt!MmAccessFault+0xbd
afd5f9f8 86cd65ac 00000000 cccccdd8 00000000 nt!KiTrap0E+0xdc
afd5fa88 86b52a0f cccccccc afd5fa9c a1b2c714 tcpip!AlepFreeCloneConnectRedirectLayerData+0x15
afd5faa0 86b5297b 8d08bc28 afd5fabc 86b52bc9 NETIO!ClassifyContextCleanupRoutine+0x62
afd5faac 86b52bc9 8d08bc28 00000000 afd5facc NETIO!WfpObjectDereference+0x1e
afd5fabc 86d6fa84 00000142 00000145 afd5fae4 NETIO!FeReleaseClassifyHandle+0x2c
afd5facc a1b26749 00000142 00000145 a1b2c468 fwpkclnt!FwpsReleaseClassifyHandle0+0x18
WARNING: Stack unwind information not available. Following frames may be wrong.
afd5fae4 a1b26fc1 8ce37f30 00000002 a1b2c468 mwac+0x5749
afd5fafc a1b24c0a 8ce37f70 00000002 afd5fb6c mwac+0x5fc1
afd5fb14 a1b23ec3 00000000 afd5fb34 00000002 mwac+0x3c0a
afd5fb70 a1b23b20 a1b2c714 93c315a0 00000002 mwac+0x2ec3
afd5fb90 a1b24b18 a1b2c714 000001a0 00000002 mwac+0x2b20
afd5fbac a1b29266 a1b2c468 000001a0 00000002 mwac+0x3b18
afd5fbcc a1b28255 a1b2c7f0 b238af68 afd5fc00 mwac+0x8266
afd5fbdc 837286c3 8738c420 b238af68 8738c7f8 mwac+0x7255
afd5fc00 83430fe1 00000000 b238af68 8738c420 nt!IovCallDriver+0x258
afd5fc14 83606bbc 8738c7f8 b238af68 b238afd8 nt!IofCallDriver+0x1b
afd5fc34 83608f9f 8738c420 8738c7f8 00000000 nt!IopSynchronousServiceTail+0x1f8
afd5fcd0 8360ff71 8738c420 b238af68 00000000 nt!IopXxxControlFile+0x6aa
afd5fd04 83437856 00000494 000007d8 00000000 nt!NtDeviceIoControlFile+0x2a
afd5fd04 773370f4 00000494 000007d8 00000000 nt!KiSystemServicePostCall
2615fa1c 00000000 00000000 00000000 00000000 0x773370f4


86b52a0f 8b4dfc          mov     ecx,dword ptr [ebp-4]


SYMBOL_NAME:  NETIO!ClassifyContextCleanupRoutine+62

FOLLOWUP_NAME:  MachineOwner




IMAGE_VERSION:  6.1.7601.18327

FAILURE_BUCKET_ID:  0x50_VRF_NETIO!ClassifyContextCleanupRoutine+62

BUCKET_ID:  0x50_VRF_NETIO!ClassifyContextCleanupRoutine+62


FAILURE_ID_HASH_STRING:  km:0x50_vrf_netio!classifycontextcleanuproutine+62

FAILURE_ID_HASH:  {9d7e2087-2688-2a58-cfa0-d967bb05037d}

Followup: MachineOwner

2: kd> lmvm mwac
start    end        module name
a1b21000 a1b30000   mwac     T (no symbols)           
    Loaded symbol image file: mwac.sys
    Image path: \??\C:\Windows\system32\drivers\mwac.sys
    Image name: mwac.sys
    Timestamp:        Wed Mar 05 03:16:59 2014 (531649D3)
    CheckSum:         000191E5
    ImageSize:        0000F000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec

 BSOD on Internet Related Programs (tcpip.sys)

Thread Tools

Similar help and support threads
Thread Forum
Random BSOD Browsing Internet, tcpip.sys
Hey Guys, I get A Random BSOD when surfing the internet or some times even when I just connect to a network or even when i Just Open the Browser, I use a TP Link Tl-Wn722N but after getting the BSOD I stopped using it and now tether internet from My Huwawei Ideos cell phone but still get the BSOD.
BSOD Help and Support
tcpip.sys related bsod
Hi! I keep getting bsods and suspect it has something to do with Planetside 2, as it started to occur after I installed that game. I noticed tcpip.sys was mentioned on the bsod, as well as "driver_irql_not_less_or_equal". After restart i get information like this: BCCode: d1 ...
BSOD Help and Support
BSOD's after adding RAM [ tcpip.sys ] [ error:tcpip+7a6cc ]
Bsod's started since i added a 4gb ddr3 RAM(1333MHZ ddr3 corsair single stick) to my board which already has 2 more sticks of 2gb each(1333MHZ, ddr3 , kingston) They happen every few hours... I reinstalled(removed and installed) network driver thrice.(didnt reboot the system though) I...
BSOD Help and Support
BSOD, Randomly Occurs, Seems related to tcpip.sys D1 Stop Error
Hi, I have a Toshiba Qosmio F60 notebook that recently started with the following BSoD: 0x000000D1 DRIVER_IRQL_NOT_LESS_OR_EQUAL It happens completely random and I have tried the Hotifx and instructions from Microsoft's KB article 977067. We have not made any recent driver updates or...
BSOD Help and Support
BSOD while uploading the file, seems to be tcpip.sys related
Please, help, people! I have been through 3 hours of my technical support and they do not know what it is. I can't upload important file, my job is in jeopardy! This is a new laptop with 32bit windows professional OEM. Thanks in advance.
BSOD Help and Support
Problem while using internet related programs
I dunno if this is a real problem but it annoying as hell. Sometimes and I can't say when windows stops working and the computer freezes, my mouse stops working and the keyboard too also the computer is in processing, the processing light is turned on and you can hear the computer processing....
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:30.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App