Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD doing upgrade Win 7 involves Atheros Valkyrie BootROM

25 Sep 2014   #1

Win 7 home premium 64 bit
BSOD doing upgrade Win 7 involves Atheros Valkyrie BootROM

I've been trying to do this upgrade/install now for about 80 hours or more and have gotten nowhere. Initially, I set out to fix my Win 7 Home Premium system because it started behaving very weirdly. ALL of the network printers disappeared, including the icons. Investigated and found the spoolsv.exe print cannot continue running more than a few seconds.

At first I suspected some sort of virus, but I've tried Norton, Kaspersky, and AVG and they find nothing.

I keep getting a message window that pops up and claims that the copy of Windows is not genuine. It is. I spent a few hours on the phone with a Microsoft rep and after trying to sell me 12 months of support for $149.00 (or one month for $99.00), he gave up and tried to actually look at the system. It was half-hearted. He installed Hitman, looked around for a while, deleted a few insignificant things, then told me everything should be fine. Of course, nothing changed. I had already done far more than he had and knew it wouldn't help.

Anyway, the system is an Intel motherboard and uses a TP-Link wireless (Atheros chip AR9271). I've given up on trying to figure out how to fix the corrupt files and just figured I'd do the upgrade, such as shown in this thread.

When I start the upgrade and get to the part:

Upgrading Windows will affect the following devices and/or programs: *

These devices might not work properly after the upgrade. Before upgrading, we recommend updating the drivers for these devices. Cancel the upgrade, open Control Panel and search for "update device drivers", or go to the device manufacturer's website to search for updated drivers.*

Universal Serial Bus controllers: Atheros Valkyrie BootROM

Now, a little history. Over the past few months, anytime I've used Bluetooth on this machine, if I left it overnight, it would BSOD. No Bluetooth, no crash. I've removed anything Bluetooth from the machine. I don't believe it has any that is resident on the motherboard. I cannot find anything in the devices that relates to the Atheros Valkyrie. I do see the wireless stuff, but think it is unrelated.

Everytime I try to the upgrade, if I go beyond the above message, and let it upgrade, it spends about an hour doing the upgrade, then gets to the very last steps, where it is starting up processes and devices and then, surprise, it does a quick BSOD, then reboots, and puts out an error message about the upgrade failing and it restores to the original system.

I've tried everything I can think of, removing all the USB devices (except for the physical boards themselves, which I may try), nothing seems to matter. That message is always there. I can't imagine where to “remove” the Valkyrie bootROM? Finally, I unplugged the wireless dongle and used my Samsung phone as a tethered wireless device and removed the Atheros device from the system devices and removed the driver in Control Panel, it made no difference.

I do see a few items in the registry that refer to the Valkyrie, but I'm not one to delete things in the registry without good guidance. I've always seen registry work right up there with being on a bomb squad.

I'd love to be able to complete the upgrade, but it always dies when it tries to enable the devices, and I'm pretty certain it is when it hits the Valkyrie activation.

Is there a way to remove Valkyrie? If not, is there a way to make the upgrade ignore it? (I suspect not.) I'm at wits end and any suggestions would be appreciated. An MGADiag I did a few days back follows:

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->
Validation Code: 0x8004FE21
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-RBVK8-98C7J-6897J
Windows Product Key Hash: bhA9DvCJ7wTL2tprC/9j9f386Fg=
Windows Product ID: 00359-OEM-9816576-42434
Windows Product ID Type: 8
Windows License Type: COA SLP
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {F72C57DD-3F13-4F14-B41D-CE50408BF323}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.140303-2144
TTS Error:*
Validation Diagnostic:*
Resolution Status: N/A
Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002
OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002
OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3
Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Users\Owner\AppData\Local\Google\Chrome\Application\chrome.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed
File Scan Data-->
File Mismatch: C:\Windows\system32\sppcext.dll[Hr = 0x800b0100]
File Mismatch: C:\Windows\system32\slcext.dll[Hr = 0x80004005]
Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{F72C57DD-3F13-4F14-B41D-CE50408BF323}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-6897J</PKey><PID>00359-OEM-9816576-42434</PID><PIDType>8</PIDType><SID>S-1-5-21-2548310804-1380299124-3519938251</SID><SYSTEM><Manufacturer>INTEL_</Manufacturer><Model>DH61BE__</Model></SYSTEM><BIOS><Manufacturer>Intel Corp.</Manufacturer><Version>BEH6110H.86A.0016.2011.0118.1128</Version><SMBIOSVersion major="2" minor="6"/><Date>20110118000000.000000+000</Date></BIOS><HWID>B0433E07018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults> *
Spsys.log Content: 0x80070002
Licensing Data-->
Software licensing service version: 6.1.7601.17514
Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_SLP channel
Activation ID: 5e017a8a-f3f9-4167-b1bd-ba3e236a4d8f
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00196-165-742434-02-1033-7601.0000-3042011
Installation ID: 017600078530568486891743681083149865206093723551769664
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: 6897J
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 9/20/2014 4:57:18 PM
Windows Activation Technologies-->
HrOffline: 0x8004FE21
HrOnline: N/A
HealthStatus: 0x0000000000000240
Event Time Stamp: 9:19:2014 15:08
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:
Tampered File: %systemroot%\system32\sppcext.dll|sppcext.dll.mui
Tampered File: %systemroot%\system32\slcext.dll|slcext.dll.mui
HWID Data-->
OEM Activation 1.0 Data-->
OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes, but no SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information:*
* ACPI Table Name OEMID Value OEMTableID Value

My System SpecsSystem Spec
25 Sep 2014   #2

64-bit Windows 10 Pro

Hello k1ypp, and welcome to Seven Forums.

Please read the instructions here: Blue Screen of Death (BSOD) Posting Instructions, and post back with the needed information. One of our BSOD experts should be by later when able to further help. :)
My System SpecsSystem Spec
25 Sep 2014   #3

Win 7 home premium 64 bit

Apologies first: I originally posted this in the incorrect place. No excuse, but I was so totally exhausted I just didn't see the BSOD guideline first.

To summarize, I attempted to do the repair/install at:

Repair Install

Obviously, I'm no expert. (It should have been in this forum.)

I've done as requested and included the BSOD dump file.
My System SpecsSystem Spec

25 Sep 2014   #4

Win 7 home premium 64 bit
here is the "not genuine windows" message that keeps popping up.

Incidentally, here is the "Not genuine Windows" message that keeps popping up.
My System SpecsSystem Spec
26 Sep 2014   #5

Win 7 home premium 64 bit

If someone could suggest a way to eliminate the Atheros Valkyrie BootROM driver, I might be able to bypass the BSOD crash and complete the upgrade. Any ideas?

My System SpecsSystem Spec
27 Sep 2014   #6

Win 7 home premium 64 bit

I tried to uninstall the Atheros program in Control Panel, but it balks with a "Please wait until the current program is finished uninstalling or being changed" If I could eliminate it, then I could possibly get the upgrade to go and get around the BSOD. Anyone have a suggestion how to make this happen? I've been fighting this thing for two weeks now. Here is the error message when it find the Atheros Valkyrie BootROM while trying to upgrade:

Error Code: -5005 : 0x80070002
Error Information:
>Kernel\KernelMedia.cpp (95)
>SetupNew\setup.cpp (811)
PAPP:Atheros Client Installation Program
PVENDOR:Atheros Communications, Inc.
@Windows 7 / Server 2008 R2 Service Pack 1 (7601)
IE Version: 9.11.9600.17239
My System SpecsSystem Spec
27 Sep 2014   #7

Win 7 home premium 64 bit
I just tried to do complete install, still BSOD when install finishes!

I tried doing the complete re-install, the one where it is supposed to wipe everything out and create a windows.old file, and even that one does the BSOD at the end and then returns to the original install. What does one have to do to make this program install and ignore the Atheros Valkyrie BootROM that it complains about when it starts the install? I'm going out of my mind with this, I'm in the third week of fighting this battle.

My System SpecsSystem Spec
28 Sep 2014   #8

Win 7 home premium 64 bit
Her is a BSOD SF diagnotic of the crash.

I've re-run the SF diagnostic tool and uploaded the zip file here. Can anyone determine anything about the BSOD that happens when the upgrade attempts to activate the devices?
My System SpecsSystem Spec
28 Sep 2014   #9

Win 7 home premium 64 bit

I'm wondering if I'm using the incorrect build. I'm using X17-58997 from the site. There are several flavors there and I haven't figured out a way to relate the *.iso version to the version currently running on the system.

It is Win 7 Home Premium, SP1, but that isn't a very narrow definition when I look a the list of versions there, such a RTM, U, etc. Any comments? (Please, someone, do chime in, all I have been hearing is crickets...)

My System SpecsSystem Spec

 BSOD doing upgrade Win 7 involves Atheros Valkyrie BootROM

Thread Tools

Similar help and support threads
Thread Forum
Atheros Valkyrie BootRom
Hello. I'm new to this Forums and I'm in need of some help. I have an on-going error message. This is the message. "Your Atheros Valkyrie BootROM isn't working properly because a compatible driver is not available for this version of Windows." First question: What is the BootROM?...
Your Atheros Valkyrie BootROM has stopped working
When i go to Device and printers i see a ! this sing with a yellow mark on my dive Amir-Pc and when i hit Troubleshoot i get this message Your Atheros Valkyrie BootROM has stopped working properly because a compatible driver isn't available for this version of Windows. The model name of your...
atheros valkyrie bootrom wont install
i just bought the ASUS USB-BT211 so i can connect an Apple Magic Touchpad to my computer. the computer recognizes the bluetooth dongle but it wont install the driver. i downloaded the ASUS driver and installed it already i also get BSOD when i restart after installing the driver from asus...
Atheros Valkyrie BootROM help please
My thumb drives kept disappearing then I noticed this notification (attached), I Google the name and came across these 2 posts, and...
Atheros Valkyrie BootROM Help
I'm getting a message that says Address a problem with your Atheros Valkyrie BootROM Your Atheros Valkyrie BootROM has stopped working properly because a compatible driver isn't available for this version of Windows. The model name of your Atheros Valkyrie BootROM is Atheros Bluetooth...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:23.
Twitter Facebook Google+