Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD problem

07 Oct 2014   #1

windows 7 home premium 64bit
BSOD problem

Hi guys, this is my first time on this forum, I have from what I can tell about the same problem like dewviking had and it is very annoying, I hope you can help me too
I have attached the debug file for you to view
As suggested in this post I have also ran Driver Verifier and got a BSOD at the restart multiple times about a week ago and I remember seeing Bad Driver somewhere in that report, I need help fixing this system freeze as it is happening every day, thank you very much.

My System SpecsSystem Spec
09 Oct 2014   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Welcome to the forum.

Please uninstall Daemon Tools. It uses a driver called sptd.sys which is known to cause BSODs in Windows 7.

Uninstall the software using Add/Remove Programs. Reboot the system. Once the program is uninstalled, run sptd.sys uninstaller to remove the driver from your system.

As an alternative, many people recommend the use of Total Mounter or Magic ISO
Microsoft (R) Windows Debugger Version 6.2.9200.20512 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\USER\Downloads\Compressed\SF_08-10-2014\SF_08-10-2014\100114-20420-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.18409.amd64fre.win7sp1_gdr.140303-2144
Machine Name:
Kernel base = 0xfffff800`0305d000 PsLoadedModuleList = 0xfffff800`032a0890
Debug session time: Wed Oct  1 18:33:23.975 2014 (UTC + 6:00)
System Uptime: 0 days 0:00:56.036
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck C9, {23e, fffff88004415324, fffff98012f7aee0, 0}

*** WARNING: Unable to verify timestamp for dtsoftbus01.sys
*** ERROR: Module load completed but symbols could not be loaded for dtsoftbus01.sys
Probably caused by : dtsoftbus01.sys ( dtsoftbus01+1324 )

Followup: MachineOwner

3: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The IO manager has caught a misbehaving driver.
Arg1: 000000000000023e, A driver has marked an IRP pending but didn't return STATUS_PENDING.
Arg2: fffff88004415324, The address in the driver's code where the error was detected.
Arg3: fffff98012f7aee0, IRP address.
Arg4: 0000000000000000, Status code.

Debugging Details:

BUGCHECK_STR:  0xc9_23e


fffff880`04415324 4053            push    rbx

fffff880`04415324 4053            push    rbx

IRP_ADDRESS:  fffff98012f7aee0

DEVICE_OBJECT: fffffa800a094a30





LAST_CONTROL_TRANSFER:  from fffff8000355f4ec to fffff800030d2bc0

fffff880`037bc8b8 fffff800`0355f4ec : 00000000`000000c9 00000000`0000023e fffff880`04415324 fffff980`12f7aee0 : nt!KeBugCheckEx
fffff880`037bc8c0 fffff800`0356958a : fffff800`0355db00 fffff880`04415324 fffff980`12f7aee0 00000000`00000000 : nt!VerifierBugCheckIfAppropriate+0x3c
fffff880`037bc900 fffff800`0356a45e : 00000000`0000023e 00000000`00000000 fffff980`12f7aee0 00000000`ffffffff : nt!ViErrorFinishReport+0xda
fffff880`037bc950 fffff800`0357582f : fffffa80`0a0def10 fffffa80`09927480 fffffa80`09927538 fffff880`04419228 : nt!VfErrorReport6+0x6e
fffff880`037bca20 fffff800`03575c73 : fffffa80`09927480 00000000`00000002 fffffa80`0a094a30 fffff880`044153f4 : nt!IovpCallDriver2+0x13f
fffff880`037bca80 fffff800`0357bd3e : fffff980`12f7aee0 fffff980`12f7aee0 00000000`00000002 fffffa80`0a094a30 : nt!VfAfterCallDriver+0x353
fffff880`037bcad0 fffff880`00ea2617 : fffff880`00f31d20 fffff880`037bcba0 00000000`00000025 fffffa80`09927480 : nt!IovCallDriver+0x57e
fffff880`037bcb30 fffff880`00ea2ec5 : 00000000`00000000 00000000`00000000 00000000`00000000 fffffa80`0b1acda0 : Wdf01000!FxIoTarget::SubmitSync+0x24b
fffff880`037bcbe0 fffff880`04476e95 : fffffa80`00000020 fffffa80`0b1acda0 fffffa80`0a135930 fffffa80`08bfbc40 : Wdf01000!imp_WdfRequestSend+0x2d1
fffff880`037bcc70 fffff880`044772f4 : 00000000`00000000 00000000`00000024 00000000`00000001 fffff880`037bce30 : cdrom!DeviceSendRequestSynchronously+0xc9
fffff880`037bccd0 fffff880`04475f04 : 0000057f`f5ec3728 fffff880`037bce30 fffffa80`0a0daf10 00000000`00000024 : cdrom!DeviceSendSrbSynchronously+0x3ec
fffff880`037bce00 fffff880`04474825 : fffffa80`00000002 fffffa80`0a13cb80 fffff880`0446c3b8 0000057f`f5ec3728 : cdrom!DeviceCacheDeviceInquiryData+0xbc
fffff880`037bced0 fffff880`00ed04a8 : 00000000`00000000 00000000`00000010 00000000`0000000c fffff880`00f320c0 : cdrom!DeviceEvtSelfManagedIoInit+0x105
fffff880`037bcf10 fffff880`00ebc926 : fffffa80`0a13d7b0 00000000`0000000c fffff880`00f320c0 00000000`00000002 : Wdf01000!FxSelfManagedIoMachine::Init+0x34
fffff880`037bcf40 fffff880`00ec4463 : 00000000`00000000 00000000`00000000 fffff880`037bd0e0 fffff880`00f320c0 : Wdf01000!FxSelfManagedIoMachine::ProcessEvent+0x14a
fffff880`037bcfb0 fffff880`00eb20f8 : 00000000`00000312 fffff880`037bd0e0 00000000`ffff7fff fffffa80`0a13bae0 : Wdf01000!FxPkgPnp::PowerD0StartingStartSelfManagedIo+0x2f
fffff880`037bcfe0 fffff880`00eb1da6 : fffff880`00f31e80 fffffa80`0a13bc98 fffffa80`0a13bae0 fffffa80`0a13bae0 : Wdf01000!FxPkgPnp::PowerEnterNewState+0x1d8
fffff880`037bd140 fffff880`00eb2627 : 00000000`00000000 fffff880`037bd220 fffffa80`0a13bc80 fffffa80`0a13bae0 : Wdf01000!FxPkgPnp::PowerProcessEventInner+0x13e
fffff880`037bd1b0 fffff880`00eca1be : 00000000`00000000 00000000`00000501 00000000`00000501 fffff800`035671de : Wdf01000!FxPkgPnp::PowerProcessEvent+0x1b3
fffff880`037bd250 fffff880`00eb45d5 : 00000000`00000501 fffff880`037bd2f0 00000000`00000500 fffffa80`0a13bae0 : Wdf01000!FxPkgPnp::NotPowerPolOwnerStarting+0xe
fffff880`037bd280 fffff880`00eae853 : fffffa80`0a13bd48 fffffa80`0a13bd50 fffffa80`0a13bae0 fffffa80`0a13bd48 : Wdf01000!FxPkgPnp::NotPowerPolicyOwnerEnterNewState+0x1c9
fffff880`037bd320 fffff880`00eb2a01 : 00000000`00000000 fffff880`037bd400 fffffa80`0a13bd38 fffffa80`0a13bae0 : Wdf01000!FxPkgPnp::PowerPolicyProcessEventInner+0x3df
fffff880`037bd390 fffff880`00ec4d59 : 00000000`00000000 fffffa80`0a135e10 00000000`00000000 00000000`00000000 : Wdf01000!FxPkgPnp::PowerPolicyProcessEvent+0x1c1
fffff880`037bd430 fffff880`00ec3df5 : 00000000`00000101 00000000`00000108 00000000`00000108 fffffa80`0a13bae0 : Wdf01000!FxPkgPnp::PnpEventHardwareAvailable+0x111
fffff880`037bd470 fffff880`00ec3ac6 : 00000000`00000002 fffffa80`0a13bc08 fffffa80`0a13bae0 fffffa80`0a13bae0 : Wdf01000!FxPkgPnp::PnpEnterNewState+0x1a1
fffff880`037bd510 fffff880`00ec3879 : 00000000`00000000 fffff880`037bd5f0 fffffa80`0a13bbf0 fffffa80`0a13bae0 : Wdf01000!FxPkgPnp::PnpProcessEventInner+0x122
fffff880`037bd580 fffff880`00ec4b66 : 00000000`00000000 fffffa80`0a13bae0 fffffa80`0a0f0710 00000000`00000000 : Wdf01000!FxPkgPnp::PnpProcessEvent+0x18d
fffff880`037bd620 fffff880`00e9e5d7 : fffffa80`097b31c0 fffff880`037bd6a0 00000000`00000000 fffffa80`0a12e788 : Wdf01000!FxPkgPnp::_PnpStartDevice+0x1e
fffff880`037bd650 fffff880`00e9d79a : fffff980`12f64e50 00000000`00000051 fffff980`12f64e50 00000000`00000000 : Wdf01000!FxPkgPnp::Dispatch+0x18f
fffff880`037bd6b0 fffff880`00e9d866 : fffff980`12f64e50 00000000`00000002 fffffa80`0a135e10 fffffa80`0a135e10 : Wdf01000!FxDevice::Dispatch+0x19a
fffff880`037bd6f0 fffff800`0357bd26 : fffff980`12f64e50 00000000`00000002 fffffa80`0a135e10 fffffa80`0a135e10 : Wdf01000!FxDevice::DispatchWithLock+0xa6
fffff880`037bd730 fffff800`0348f18e : fffff980`12f64e50 fffffa80`0b151d70 fffffa80`0a135e10 fffffa80`0b0c0580 : nt!IovCallDriver+0x566
fffff880`037bd790 fffff800`031c97ad : fffffa80`0a094a30 fffffa80`0b151d70 fffff800`031d2ed0 00000000`00000000 : nt!PnpAsynchronousCall+0xce
fffff880`037bd7d0 fffff800`0349e506 : fffff800`032d6b60 fffffa80`0a149d90 fffffa80`0b151d70 fffffa80`0a149f38 : nt!PnpStartDevice+0x11d
fffff880`037bd890 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!PnpStartDeviceNode+0x156

STACK_COMMAND:  .bugcheck ; kb

SYMBOL_NAME:  dtsoftbus01+1324

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: dtsoftbus01

IMAGE_NAME:  dtsoftbus01.sys


FAILURE_BUCKET_ID:  X64_0xc9_23e_VRF_dtsoftbus01+1324

BUCKET_ID:  X64_0xc9_23e_VRF_dtsoftbus01+1324

Followup: MachineOwner

3: kd> lmvm dtsoftbus01
start             end                 module name
fffff880`04414000 fffff880`0445d000   dtsoftbus01 T (no symbols)           
    Loaded symbol image file: dtsoftbus01.sys
    Image path: \SystemRoot\system32\DRIVERS\dtsoftbus01.sys
    Image name: dtsoftbus01.sys
    Timestamp:        Fri Jan 13 19:45:46 2012 (4F10358A)
    CheckSum:         00046D1E
    ImageSize:        00049000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Please turn off driver verifier.

Run the System File Checker that scans the of all protected Windows 7 system files and replaces incorrect corrupted, changed/modified, or damaged versions with the correct versions if possible:
  • Click on the
  • Type CMD on Search
  • Left click and Run as Administrator
  • Type SFC /scannow
Full tutorial here:
My System SpecsSystem Spec
09 Oct 2014   #3

windows 7 home premium 64bit

Thank you koolkat, will try everything you said and get back to you
My System SpecsSystem Spec

11 Oct 2014   #4

windows 7 home premium 64bit

Hi, well what can I say...IT WORKED, straight away;
Thank you very much for your help, much appreciated, all the best to you mate
Just curious how did you tell that it was Daemon Tools to blame for the freeze
Thank you again!
My System SpecsSystem Spec
12 Oct 2014   #5

windows 7 home premium 64bit

ok, looks like I was singing victory a bit too early, my welcome screen/desktop freeze is back after 2 days only

looks like there is more to it, I will be waiting for another suggestion please. Thank you
My System SpecsSystem Spec
12 Oct 2014   #6

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Did you run the system file check.
My System SpecsSystem Spec
13 Oct 2014   #7

windows 7 home premium 64bit

yes I did, it did not find any integrity violation
My System SpecsSystem Spec
13 Oct 2014   #8

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Any new BSOD's?
My System SpecsSystem Spec
14 Oct 2014   #9

windows 7 home premium 64bit

Hi, no system freeze since Sunday when I had three consecutive ones
My System SpecsSystem Spec
15 Oct 2014   #10

windows 7 home premium 64bit

just had 4 consecutives freeze, 3 at welcome screen and the last one on desktop, very annoying
My System SpecsSystem Spec

 BSOD problem

Thread Tools

Similar help and support threads
Thread Forum
BSOD problem
Hi, One day, my computer was working perfectly, next day I start computer, and I was not able to get to the Windows. I'm getting BSOD: Can someone help me to solve this problem because I don't have any idea what's going on? Thanks in advance for any...
BSOD Help and Support
Bsod problem
Done it, when I then tried to view the result, then my gfx crashed. I used most of the day yesterday to fix all my problems with my pc. The thing is that my pc have been making BSOD's so often lately, at first I suspected an error in my installation, but after viewing the logs of my BSOD's I've...
BSOD Help and Support
Help with BSOD please don't know problem.
Here's my minidump files and etc. My computer will run perfectly fine, and then suddenly, not when running any specific application, starts to freeze up and then BSOD. No idea what's causing it and I would appreciate any help.
BSOD Help and Support
Still got a BSOD problem, Win 7 x64!
Hi! I got some BSOD after I installed windows 7 ultimatium x64 with SP1. A had this problem more frequently (many times per day) just after install of the new OS, and I fond the issue with my wireless adapter. This device is now removed and replaced with a new (PCI). My problem is that I...
BSOD Help and Support
BSOD problem.
I have a problem when quiting CS-Source. I have MSE antivirus. I've read that antivirus programs could cause this, or some other app. Right now I'm running sfc /scannow to see if something wrong here. After I tried different things, like uninstalling some programs, disabling themes and other...
BSOD Help and Support
BSOD Problem
Hi guys, I'm hoping somebody can help me with a BSOD problem I've had a couple times now. I have a HP Laptop Model: DV71285Dx. I got it from a store with Windows Vista Home Premium but I upgrade it to windows 7 recently. I only use it for simple web browsing, instant messaging, email, etc. ...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App