Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD instaling driver for Gigabyte Radeon R5 230 graphics card

18 Oct 2014   #1

Windows 7 Home Premium
BSOD instaling driver for Gigabyte Radeon R5 230 graphics card


Bought a brand new Gigabyte Radeon R5 230 graphics card. intended for use in a Dell Optiplex 755 desktop PC. PC is running Win 7 Home Premium.

When I run the driver installation program on the CD it crashes with a BSOD which only displays for a couple of seconds.

Without the driver, can only use VGA port.

Have tried to install card in a Dell Dimension E521 as well. Driver doesn't install there either but HDMI port works. However, the picture is terrible.

Dump and reports are attached. hope someone can help. Thanks

My System SpecsSystem Spec
18 Oct 2014   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

OptiPlex 755 is a branded desktop of a very congested build. Plus it is almost two years old. So the possibility of failure remains in both the parts.

For your desktop .... was there any previous card? How did it work?

Check if the Power Supply Unit (PSU) supplying adequate power to the computer or not.
eXtreme Power Supply Calculator - The most trusted PSU Wattage Calculator
Also let us know the wattage of the PSU. It is a MUST.

Is the computer hot? Report us the heat of the computer after a couple of hours of your normal usage. Upload a screenshot of the summery tab of Speccy. Alternatively, you can publish a Speccy snapshot too: Speccy - Publish Snapshot of your System Specs .

Lastly, if you try to apply another card in the OptiPlex 755, how it behaves?

Let us know.

As the GPU is failing on multiple computers, there is a good probability that the card is failing itself. The crash dump also says in this line. But there remains a little doubt because both the computers are branded desktops with congested case build.
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck CA, {b, fffffa8003bde910, 1, 0}

Probably caused by : pci.sys

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

PnP encountered a severe error, either as a result of a problem in a driver or
a problem in PnP itself.  The first argument describes the nature of the
problem, the second argument is the address of the PDO.  The other arguments
vary depending on argument 1.
Arg1: 000000000000000b, Deleted PDO reported as relation
    One of the removal relations for the device being removed has
    already been deleted.
Arg2: fffffa8003bde910, Related PDO
Arg3: 0000000000000001, Removal relations
Arg4: 0000000000000000

Debugging Details:


DEVICE_OBJECT: fffffa8003bde910

DRIVER_OBJECT: fffffa8003824390

IMAGE_NAME:  pci.sys



FAULTING_MODULE: fffff88000f70000 pci





ANALYSIS_VERSION: 6.3.9600.17237 (debuggers(dbg).140716-0327) amd64fre

LAST_CONTROL_TRANSFER:  from fffff8000331bc25 to fffff80002edabc0

fffff880`02fe8a18 fffff800`0331bc25 : 00000000`000000ca 00000000`0000000b fffffa80`03bde910 00000000`00000001 : nt!KeBugCheckEx
fffff880`02fe8a20 fffff800`0331c329 : 00000000`00000003 fffff880`00000003 fffff880`00000001 fffff880`02fe8c38 : nt!PnpProcessRelation+0x695
fffff880`02fe8a90 fffff800`033575d5 : 00000000`00000000 fffffa80`042ce010 fffff8a0`0b4342d0 fffff880`02fe8cb8 : nt!PnpBuildRemovalRelationList+0x69
fffff880`02fe8ae0 fffff800`0335853c : fffff880`02fe8cb8 fffffa80`0458ba00 fffffa80`0385b040 fffffa80`00000000 : nt!PnpProcessQueryRemoveAndEject+0x325
fffff880`02fe8c20 fffff800`0324173e : 00000000`00000000 fffffa80`0458ba20 fffff8a0`0b4342d0 00000000`00000000 : nt!PnpProcessTargetDeviceEvent+0x4c
fffff880`02fe8c50 fffff800`02ee4261 : fffff800`031453d8 fffff8a0`0b4342d0 fffff800`030802d8 fffff800`030802d8 : nt! ?? ::NNGAKEGL::`string'+0x54d9b
fffff880`02fe8cb0 fffff800`0317673a : 00000000`00000000 fffffa80`0385b040 00000000`00000080 fffffa80`037eb890 : nt!ExpWorkerThread+0x111
fffff880`02fe8d40 fffff800`02ecb8e6 : fffff880`009eb180 fffffa80`0385b040 fffff880`009f5f40 00000000`00000000 : nt!PspSystemThreadStartup+0x5a
fffff880`02fe8d80 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxStartSystemThread+0x16


FOLLOWUP_NAME:  MachineOwner

IMAGE_VERSION:  6.1.7601.17514


BUCKET_ID:  X64_0xCA_b_IMAGE_pci.sys


FAILURE_ID_HASH_STRING:  km:x64_0xca_b_image_pci.sys

FAILURE_ID_HASH:  {6f075453-86e2-9026-3fae-ddadebe53dc3}

Followup: MachineOwner

0: kd> !devobj fffffa8003bde910 f
fffff8000308b1d0: Unable to get value of ObpRootDirectoryObject
Device object (fffffa8003bde910) is for:
 Cannot read info offset from nt!ObpInfoMaskToOffset
 \Driver\pci DriverObject fffffa8003824390
Current Irp 00000000 RefCount 0 Type 00000022 Flags 00000040
DevExt fffffa8003bdea60 DevObjExt fffffa8003bdee88 
ExtensionFlags (0x00000800)  DOE_DEFAULT_SD_PRESENT
Characteristics (0000000000)  
Device queue is not busy.
0: kd> !drvobj fffffa8003824390 f
fffff8000308b1d0: Unable to get value of ObpRootDirectoryObject
fffff8000308b1d0: Unable to get value of ObpRootDirectoryObject
Driver object (fffffa8003824390) is for:
Driver Extension List: (id , addr)

Device Object list:
fffffa8003c88680: Could not read device object

DriverEntry:   fffff88000f9e1a0    pci!GsDriverEntry
DriverStartIo: 00000000    
DriverUnload:  fffff88000f9326c    pci!PciDriverUnload
AddDevice:     00000000    

Dispatch routines:
[00] IRP_MJ_CREATE                      fffff80002ebfb30    nt!IopInvalidDeviceRequest
[01] IRP_MJ_CREATE_NAMED_PIPE           fffff80002ebfb30    nt!IopInvalidDeviceRequest
[02] IRP_MJ_CLOSE                       fffff80002ebfb30    nt!IopInvalidDeviceRequest
[03] IRP_MJ_READ                        fffff80002ebfb30    nt!IopInvalidDeviceRequest
[04] IRP_MJ_WRITE                       fffff80002ebfb30    nt!IopInvalidDeviceRequest
[05] IRP_MJ_QUERY_INFORMATION           fffff80002ebfb30    nt!IopInvalidDeviceRequest
[06] IRP_MJ_SET_INFORMATION             fffff80002ebfb30    nt!IopInvalidDeviceRequest
[07] IRP_MJ_QUERY_EA                    fffff80002ebfb30    nt!IopInvalidDeviceRequest
[08] IRP_MJ_SET_EA                      fffff80002ebfb30    nt!IopInvalidDeviceRequest
[09] IRP_MJ_FLUSH_BUFFERS               fffff80002ebfb30    nt!IopInvalidDeviceRequest
[0a] IRP_MJ_QUERY_VOLUME_INFORMATION    fffff80002ebfb30    nt!IopInvalidDeviceRequest
[0b] IRP_MJ_SET_VOLUME_INFORMATION      fffff80002ebfb30    nt!IopInvalidDeviceRequest
[0c] IRP_MJ_DIRECTORY_CONTROL           fffff80002ebfb30    nt!IopInvalidDeviceRequest
[0d] IRP_MJ_FILE_SYSTEM_CONTROL         fffff80002ebfb30    nt!IopInvalidDeviceRequest
[0e] IRP_MJ_DEVICE_CONTROL              fffff88000f8e748    pci!PciDispatchDeviceControl
[0f] IRP_MJ_INTERNAL_DEVICE_CONTROL     fffff80002ebfb30    nt!IopInvalidDeviceRequest
[10] IRP_MJ_SHUTDOWN                    fffff80002ebfb30    nt!IopInvalidDeviceRequest
[11] IRP_MJ_LOCK_CONTROL                fffff80002ebfb30    nt!IopInvalidDeviceRequest
[12] IRP_MJ_CLEANUP                     fffff80002ebfb30    nt!IopInvalidDeviceRequest
[13] IRP_MJ_CREATE_MAILSLOT             fffff80002ebfb30    nt!IopInvalidDeviceRequest
[14] IRP_MJ_QUERY_SECURITY              fffff80002ebfb30    nt!IopInvalidDeviceRequest
[15] IRP_MJ_SET_SECURITY                fffff80002ebfb30    nt!IopInvalidDeviceRequest
[16] IRP_MJ_POWER                       fffff88000f74908    pci!PciDispatchPnpPower
[17] IRP_MJ_SYSTEM_CONTROL              fffff88000f8e6e4    pci!PciDispatchSystemControl
[18] IRP_MJ_DEVICE_CHANGE               fffff80002ebfb30    nt!IopInvalidDeviceRequest
[19] IRP_MJ_QUERY_QUOTA                 fffff80002ebfb30    nt!IopInvalidDeviceRequest
[1a] IRP_MJ_SET_QUOTA                   fffff80002ebfb30    nt!IopInvalidDeviceRequest
[1b] IRP_MJ_PNP                         fffff88000f74908    pci!PciDispatchPnpPower

0: kd> !sysinfo machineid
Machine ID Information [From Smbios 2.5, DMIVersion 37, Size=2864]
BiosMajorRelease = 18
BiosMinorRelease = 0
BiosVendor = Dell Inc.
BiosVersion = A22
BiosReleaseDate = 06/11/2012
SystemManufacturer = Dell Inc.
SystemProductName = OptiPlex 755                 
BaseBoardManufacturer = Dell Inc.
BaseBoardProduct = 0PU052
BaseBoardVersion =
My System SpecsSystem Spec
18 Oct 2014   #3

Windows 7 Home Premium

Thanks Arc. Had written comprehensive report based on your help but SevenForums lost it when I went to submit it. Card works in Dell Optiplex 755 running Windows 8.1 Home.
My System SpecsSystem Spec

19 Oct 2014   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Its ok then.
My System SpecsSystem Spec

 BSOD instaling driver for Gigabyte Radeon R5 230 graphics card

Thread Tools

Similar help and support threads
Thread Forum
Gigabyte’s Waterforce triple GTX 980 graphics card kit needs its own..
Gigabyte’s Waterforce triple GTX 980 graphics card kit needs its own radiator case Source A Guy
PC Custom Builds and Overclocking
Graphics Card/Driver Crashing MSI AMD Radeon R9 270x
I'm having troubles with video. below are computer specs. I play command & conqueer tiberium alliances, running firefox multiple profile. 9 profiles running concurently with greasemonkey scripts in each. Irrelevent but so you know what is running at time of crash. I've got MSI afterburner on....
Graphic Cards
BSOD after installing AMD Radeon HD 7970M graphics driver
I found an older thread here with the exact same problem on your forums but a solution had not been found then. I was playing a video game when my laptop crashed. I restarted it and got BSOD. On other attempts I would get to the Windows loading screen but it would then result in a blank black...
BSOD Help and Support
Graphics Card/Driver Crashing AMD Radeon R9 290
Hi I am having some trouble with my graphics card or driver crashing on a new PC when trying to play World of Warcraft, It will only last anything between 5-15 minutes. I have been only using Mac's for a long time so really don't know about the various tools etc out there to assist. So far I...
Graphic Cards
Trying to set up 3 monitors with Gigabyte Radeon 6950 card
Greetings, I am trying to set up 3 separate monitors using a Gigabyte Radeon 6950 graphics card in Windows 7 HP x64. The monitors: 2 - Acer 21.5" DVI-D widescreen 16:9 running natively at 1920x1080 1 - 32" Sony HDTV also at 1920x1080, via HDMI The graphic card's physical outputs are:...
Graphic Cards
Problem with instaling smart card driver - SCFILTER
Ok...i have Omnikey Cardman 3021 witch works fine on windows 7 with drivers. But when i insert my card into card reader windows can't install Smart Card driver on system. Hardware ID is: SCFILTER\CID_8031e06b042005023a555555555555 and i can't find solution anywhere. Any help maybe from u guys?...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App