Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Notebook crashes with BSOD during shutdown

22 Oct 2014   #1

Windows 7 Ultimate x64
Notebook crashes with BSOD during shutdown

Hi again!
I own a 2 month old Acer Aspire E1-572G and haven't had any problems with it until now: I have experieced a BSOD on a Windows shutdown and on the following one. Now it works again...

I have no idea what happened and I'd be really greatful for some help!

The specs:
CPU: Intel i7-4500U
GPU: AMD Radeon HD 8750 2GB (not sure about the Catalyst version since I have now updated it)
Anitivirus: Avast

Thanks in advance!

My System SpecsSystem Spec
22 Oct 2014   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Welcome to the forum Nuc1eoN,

The msinfo file is corrupted.

  • Please go to Start and type in "msinfo32.exe" (without the quotes) and press Enter.
  • Save the report as an .nfo file, then zip up the .nfo file and upload/attach the .zip file with your next post.
  • Also, save a copy as a .txt file and include it also (it's much more difficult to read, but we have greater success in getting the info from it).
Perform a Clean boot:Reduce items at start-up. No software except anti-virus is required plus doing this improves the time for logging into windows:Run the System File Checker that scans the of all protected Windows 7 system files and replaces incorrect corrupted, changed/modified, or damaged versions with the correct versions if possible:
  • Click on the
  • Type CMD on Search
  • Left click and Run as Administrator
  • Type SFC /scannow
Full tutorial here:Run Disk Check on your Hard Drive for file system errors and bad sectors on it:Upload a screenshot of your hard disk using Crystal Disk Info:
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck C2, {7, 109b, 4050008, fffffa8009910b10}

GetPointerFromAddress: unable to read from fffff80002ec4100
GetUlongFromAddress: unable to read from fffff80002ec41c0
Probably caused by : ndis.sys ( ndis!nullDeleteFilter+15 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The current thread is making a bad pool request.  Typically this is at a bad IRQL level or double freeing the same allocation, etc.
Arg1: 0000000000000007, Attempt to free pool which was already freed
Arg2: 000000000000109b, (reserved)
Arg3: 0000000004050008, Memory contents of the pool block
Arg4: fffffa8009910b10, Address of the block of pool being deallocated

Debugging Details:

POOL_ADDRESS:  fffffa8009910b10 Nonpaged pool


BUGCHECK_STR:  0xc2_7_NDrw





LAST_CONTROL_TRANSFER:  from fffff80002dbfbe9 to fffff80002c8cbc0

fffff880`03316468 fffff800`02dbfbe9 : 00000000`000000c2 00000000`00000007 00000000`0000109b 00000000`04050008 : nt!KeBugCheckEx
fffff880`03316470 fffff880`016ffae5 : fffffa80`07b96da0 fffffa80`0728db30 fffffa80`0927e050 fffffa80`07b96da0 : nt!ExDeferredFreePool+0x1201
fffff880`03316520 fffff880`017005ce : fffffa80`0927e1a0 fffffa80`07b96c40 fffff880`01720110 fffff800`02c8be53 : ndis!nullDeleteFilter+0x15
fffff880`03316550 fffff880`01749fd4 : 00000000`00000001 fffff880`01720110 00000000`00000000 00000000`000007ff : ndis!ndisDeleteMiniportOnLastDeref+0xde
fffff880`03316590 fffff880`01779b76 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ndis! ?? ::DKGKHJNI::`string'+0x1507
fffff880`033165d0 fffff800`02ef8571 : fffff8a0`02541bd0 fffffa80`0927e050 fffff880`03316728 fffffa80`0a218280 : ndis!ndisPnPDispatch+0x616
fffff880`03316670 fffff800`030793a1 : fffffa80`0a218280 00000000`00000000 fffffa80`08260b10 00000000`00000801 : nt!IopSynchronousCall+0xe1
fffff880`033166e0 fffff800`02d8f063 : fffff8a0`0258d9c0 fffff8a0`0258d9c0 00000000`00000018 00000000`00000000 : nt!IopRemoveDevice+0x101
fffff880`033167a0 fffff800`03078ef4 : fffffa80`08260b10 00000000`00000000 00000000`00000002 00000000`00000000 : nt!PnpRemoveLockedDeviceNode+0x1a3
fffff880`033167f0 fffff800`03079000 : 00000000`00000000 fffffa80`0a218200 fffff8a0`04b7a820 fffff800`02e90ca0 : nt!PnpDeleteLockedDeviceNode+0x44
fffff880`03316820 fffff800`030790f9 : fffffa80`099f0102 fffffa80`099f0160 00000000`00000001 00000000`00000000 : nt!PnpDeleteLockedDeviceNodes+0xa0
fffff880`03316890 fffff800`03079271 : fffffa80`099f0160 00000000`00000000 fffffa80`099f0160 00000000`00000001 : nt!PnpDelayedRemoveWorker+0x79
fffff880`033168e0 fffff800`02d8f29a : 00000000`00000000 fffffa80`08c05310 00000000`0000000a 00000000`00000000 : nt!PnpChainDereferenceComplete+0x131
fffff880`03316920 fffff800`0310a2a0 : 00000000`00000000 fffffa80`08260b10 fffff8a0`0a571240 00000000`00000001 : nt!PnpIsChainDereferenced+0xda
fffff880`033169a0 fffff800`0310a53c : fffff880`03316b78 fffffa80`07718b00 fffffa80`07301600 fffffa80`00000000 : nt!PnpProcessQueryRemoveAndEject+0xff0
fffff880`03316ae0 fffff800`02ff373e : 00000000`00000000 fffffa80`07718b70 fffff8a0`0a571240 00000000`00000000 : nt!PnpProcessTargetDeviceEvent+0x4c
fffff880`03316b10 fffff800`02c96261 : fffff800`02ef73d8 fffff8a0`0a571240 fffff800`02e322d8 fffff800`02e322d8 : nt! ?? ::NNGAKEGL::`string'+0x54d9b
fffff880`03316b70 fffff800`02f2873a : 00000000`00000000 fffffa80`07301660 00000000`00000080 fffffa80`0728db30 : nt!ExpWorkerThread+0x111
fffff880`03316c00 fffff800`02c7d8e6 : fffff880`02fd7180 fffffa80`07301660 fffff880`02fe1fc0 00000000`00000000 : nt!PspSystemThreadStartup+0x5a
fffff880`03316c40 00000000`00000000 : fffff880`03317000 fffff880`03311000 fffff880`033165c0 00000000`00000000 : nt!KxStartSystemThread+0x16


fffff880`016ffae5 33d2            xor     edx,edx


SYMBOL_NAME:  ndis!nullDeleteFilter+15

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  ndis.sys


FAILURE_BUCKET_ID:  X64_0xc2_7_NDrw_ndis!nullDeleteFilter+15

BUCKET_ID:  X64_0xc2_7_NDrw_ndis!nullDeleteFilter+15

Followup: MachineOwner
My System SpecsSystem Spec
25 Oct 2014   #3

Windows 7 Ultimate x64

Hi and thanks for the help!
I searched for the error in your analysis and some people say it's an issue with the Atheros wifi driver (there's more of this threads tho). This sounded resonably since I remembered to have had some issues with it (wifi and bluetooth is in one chip, but there are seperate divers... it got kinda messy). No I have downloaded the correct drivers from and installed them properly.
I guess it should have solved the issue. If not I will report back and try out your suggestions

Many thanks!
My System SpecsSystem Spec

25 Oct 2014   #4

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Good news! thanks for posting back.
My System SpecsSystem Spec

 Notebook crashes with BSOD during shutdown

Thread Tools

Similar help and support threads
Thread Forum
Notebook reboots when choosing Start > Shutdown
G'day, I'm setting up a brand new ASUS A54C Notebook for a friend, and am having some trouble : each time I choose to Shutdown the notebook, either when logged in using Start > Shutdown, or from the login screen, the notebook does the following: - logs off user as normal - shuts down...
Hardware & Devices
Notebook crashes while on battery
While using my notebook on battery it crashes. There is no BSOD and I need to plug in to AC and turn back on. When I turn it back on the battery level can sometimes be at 41%. It does not give a warning or noise just switches off. I have tried to follow some of the previous posting...
BSOD Help and Support
Dell notebook crashes when sent to sleep or hibernate
Hi Folks, Am using company notebook Dell Latitude E6410 (core i3, 4GB ram), past 3 weeks notebook keeps hanging each time i send it to hibernate or to sleep. It happens with docking station, but also when it is standalone same thing happens. am attaching several minidump files. Could you...
BSOD Help and Support
Shutdown when I close the lid in my Notebook
Hi, I'm just reinstalled my Acer 4736G with Win7. The previous one is Win XP. After I installed Win7 Ultimate, there's something that don't go right, 1. When I close the lid of my notebook, it's shutdown not go to sleep mode even the setting in power management is Sleep. What should I do ? ...
HP Notebook BSOD - Everytime on Shutdown.
BSOD on shutdown every time. HPdm4-1160us notebook, new in Dec 2010, OEM Windows 7 64bit, 4GB OEM Ram. Here are the files for analysis. Thanks in advance. Blacksheep
BSOD Help and Support
Crashes at shutdown
My computer is running win7 professional RTM (waiting for my bought retail to arrive) and every now and then it crashes when I shutdown with seemingly different error messages BSOD this is the dump(see sysdata dump as well) from the last time it happened was wondering if anyone could tell me why...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App