Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD when connecting USB 3.0 Kingston DataTraveler 16 GB pen drive

28 Oct 2014   #1

Windows 7 Professional 64bit
BSOD when connecting USB 3.0 Kingston DataTraveler 16 GB pen drive

Dear All,

When I try to connect my USB 3.0 Kingston DataTraveler 16 GB pen drive to my HP ProBook 4530s laptop it says device driver is installing but then BSOD happens before completion of driver installation. I tried it in another laptop and the pen drive works fine. I have Renesas USB 3.0 utility in my laptop and I've installed latest version from HP site but BSOD still happens. As I can see from the blue screen the cause maybe due to "partmgr.sys". Can somebody help me with this please? Thanks in advance. Logs are attached.

My System SpecsSystem Spec
30 Oct 2014   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Welcome to the forum.

Microsoft (R) Windows Debugger Version 6.2.9200.20512 X86
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\admin\Downloads\Naveen87\SF_28-10-2014\102814-70340-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.18409.amd64fre.win7sp1_gdr.140303-2144
Machine Name:
Kernel base = 0xfffff800`03655000 PsLoadedModuleList = 0xfffff800`03898890
Debug session time: Tue Oct 28 22:46:11.754 2014 (UTC + 6:00)
System Uptime: 0 days 0:06:53.769
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 1000007E, {ffffffffc0000005, fffff88000e54079, fffff880033a08a8, fffff880033a0100}

*** WARNING: Unable to verify timestamp for MfeEpePc.sys
*** ERROR: Module load completed but symbols could not be loaded for MfeEpePc.sys
Probably caused by : partmgr.sys ( partmgr!PmGlobalDispatch+69 )

Followup: MachineOwner
McAfee is known to cause BSOD's. Uninstall McAfee and other antivirus software that you have fora test. Replace with MSE.

Microsoft Security Essentials is recommended from a strict BSOD perspective, compatibility & stability compared to other internet security software. Malwarebytes is a great combo to MSE. They are free and lightweight.

Also uninstall your existing Antivirus software before you install MSE.

Good and Free system security combination.

warning   Warning
Do not start the free trial of Malware Bytes; remember to deselect that option when prompted.

Perform a Clean boot:Reduce items at start-up. No software except anti-virus is required plus doing this improves the time for logging into windows:Run the System File Checker that scans the of all protected Windows 7 system files and replaces incorrect corrupted, changed/modified, or damaged versions with the correct versions if possible:
  • Click on the
  • Type CMD on Search
  • Left click and Run as Administrator
  • Type SFC /scannow
Full tutorial here:Run Disk Check on your Hard Drive for file system errors and bad sectors on it.

Upload a screenshot of your hard disk using Crystal Disk Info.
My System SpecsSystem Spec
31 Oct 2014   #3

Windows 7 Professional 64bit

Thank you very much for your reply KOOLKAT77. Kinda busy in past few days. I'm trying your suggestions now.
My System SpecsSystem Spec

02 Nov 2014   #4

Windows 7 Professional 64bit

I solved it. The culprit is HP ProtectTools Drive Encryption utility which uses McAfee Endpoint Encryption module. After uninstalling HP ProtectTools Drive Encryption, all is well. Thanx KOOLKAT77. You are a lifesaver.
My System SpecsSystem Spec
02 Nov 2014   #5

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Thanks for posting back, good luck!
My System SpecsSystem Spec

 BSOD when connecting USB 3.0 Kingston DataTraveler 16 GB pen drive

Thread Tools

Similar help and support threads
Thread Forum
Kingston USB Drive 32gb Don't Works at all
Hello there, I bought a new Kingston USB 32GB, but its not working. When I opened the USB from the pack and attached for the first time, it had virus in it. I cleared it and it was working. But now I try to plug in it, but it don't works. Windows keep saying that USB not recoganized.. I get...
Hardware & Devices
Kingston Datatraveler USB Stick
Hi guys, I bought a 16gb Kingston Datatraveler USB drive. I want to format it and I'm unsure as to what Allocation Unit Size I should choose. My options are: Default 4096 bytes 8192 bytes
Hardware & Devices
Kingston flash drive not detected (probably hardware)
I have a Kingston flash drive 8gb usb 2.0 just like this one: but for some reason it's not working on my pc/laptop/ps3 and any other computer I tried it on. when I plug in the flash drive I don't get any detected sound on my windows...
Kingston DataTraveler 16Gb pen drive - slow speed under Windows 7?
Dear SevenForums, I recently bought a Kingston DataTraveler 16Gb Usb 2.0 pen drive and last night I tried timing some write speeds on it, as I thought it was kind of slow (real slow for my machine as a matter of fact). Formatted it as NTFS, default unit allocation size, and tried copying a...
Hardware & Devices
Kingston Flash Drive Hoax
Well I need a new flash drive and was searching on ebay. I found this product: Kingston 64 GB Data Traveler 300 perfect condition USB - eBay (item 350375474636 end time Jul-28-10 18:56:35 PDT) only problem is is that the seller claims it to be a datatraveler 300, now that searies only is...
Hardware & Devices
Kingston Flash drive won't open
Hi, I have a Kingston DataTraveler 100 (8GB) flash dive. My pc detects it, installs the driver but the USB doesn't show in 'my computer'. So, I can't open it and the device is also not shown in 'disk management' but it is listed in 'device manager'. I also have another USB drive that works...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App