Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD error 0x51 REGISTRY_ERROR with no system restore point

25 Nov 2014   #1

Windows 64-bit
BSOD error 0x51 REGISTRY_ERROR with no system restore point

SF diagnostic tool info ZIP attached.
After logging in, about 10-20sec later, I get a BSOD with 0x51 REGISTRY_ERROR.
I do not have a system restore point.
I have tried most of all of the things found when googling this: chkdsk, ccleaner, scf /scannow, etc...
Starts up fine in safe mode. I tried turning off all services and startups and still crashes.
Thanks in advance.
My System SpecsSystem Spec
25 Nov 2014   #2

Windows 64-bit

More info:
Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.
Locale ID: 1033
Additional information about the problem:
BCCode: 51
BCP1: 0000000000000001
BCP2: FFFFF8A000024010
BCP3: 0000000001877000
BCP4: 0000000000000374
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1
My System SpecsSystem Spec
25 Nov 2014   #3

Windows 64-bit

Also ran TDSSKiller and it came up with no threats.
My System SpecsSystem Spec

25 Nov 2014   #4

Windows 64-bit

More info from (analysis of my .dmp file). I do not know how to interpret this. Thanks in advance:

Crash Dump Analysis provided by OSR Open Systems Resources, Inc. (OSR Homepage - OSR)
Online Crash Dump Analysis Service
See OSR Online - The Home Page for Windows Driver Developers for more information
Windows 7 Kernel Version 7601 (Service Pack 1) MP (8 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.18409.amd64fre.win7sp1_gdr.140303-2144
Machine Name:
Kernel base = 0xfffff800`0360c000 PsLoadedModuleList = 0xfffff800`0384f890
Debug session time: Tue Nov 25 16:59:54.174 2014 (UTC - 5:00)
System Uptime: 0 days 0:12:24.033
* *
* Bugcheck Analysis *
* *

Something has gone badly wrong with the registry. If a kernel debugger
is available, get a stack trace. It can also indicate that the registry got
an I/O error while trying to read one of its files, so it can be caused by
hardware problems or filesystem corruption.
It may occur due to a failure in a refresh operation, which is used only
in by the security system, and then only when resource limits are encountered.
Arg1: 0000000000000001, (reserved)
Arg2: fffff8a000024010, (reserved)
Arg3: 0000000001877000, depends on where Windows bugchecked, may be pointer to hive
Arg4: 0000000000000374, depends on where Windows bugchecked, may be return code of
HvCheckHive if the hive is corrupt.

Debugging Details:

TRIAGER: Could not open triage file : e:\dump_analysis\program\triage\modclass.ini, error 2




PROCESS_NAME: services.exe


LAST_CONTROL_TRANSFER: from fffff800039b2158 to fffff80003681bc0

fffff880`0d0b72f8 fffff800`039b2158 : 00000000`00000051 00000000`00000001 fffff8a0`00024010 00000000`01877000 : nt!KeBugCheckEx
fffff880`0d0b7300 fffff800`0391ac95 : 00000000`0001c887 00000000`0000c3b7 00000000`000073bf fffff8a0`00000004 : nt! ?? ::NNGAKEGL::`string'+0x9d9a
fffff880`0d0b7360 fffff800`0391aa6c : fffff8a0`00024010 fffff8a0`00024010 fffff8a0`00033cc0 00000000`000e6b76 : nt!HvMarkDirty+0x176
fffff880`0d0b73c0 fffff800`038de01b : 00000000`00000001 fffff8a0`083fc15c fffff8a0`085e8b54 fffff8a0`00024010 : nt!HvMarkCellDirty+0x150
fffff880`0d0b7410 fffff800`038dddf4 : fffff8a0`085e8b54 00000000`ffffffff fffff8a0`085e8b54 fffff8a0`00024010 : nt!CmpMarkKeyValuesDirty+0x14b
fffff880`0d0b74b0 fffff800`038dd4fa : fffff8a0`00024010 00000000`ffffffff fffff8a0`085e8b54 fffff8a0`00024010 : nt!CmpFreeKeyValues+0x24
fffff880`0d0b74e0 fffff800`038dd228 : fffff8a0`00024010 00000000`00e27bc8 fffff8a0`085e8b54 fffff8a0`00e77b50 : nt!CmpSyncKeyValues+0x7a
fffff880`0d0b75c0 fffff800`038df4de : fffff8a0`1596c000 00000000`003fa3b8 fffffa80`00000000 00000000`00000000 : nt!CmpCopySyncTree2+0x2a8
fffff880`0d0b7670 fffff800`038df3f7 : 00000000`00000000 00000000`00000002 fffff8a0`06236e20 fffff8a0`1562b6b0 : nt!CmpCopySyncTree+0x6e
fffff880`0d0b76c0 fffff800`038defc6 : fffff8a0`1524b360 00000000`00000000 00000000`00000001 00000000`00000000 : nt!CmpSaveBootControlSet+0x307
fffff880`0d0b78a0 fffff800`03680e53 : fffffa80`15292060 00000000`00000000 fffff880`0d0b7970 00000000`00000001 : nt!NtInitializeRegistry+0xc6
fffff880`0d0b78f0 fffff800`0367d410 : fffff800`038def6f 00000000`00000220 00000000`0134e6a8 00000000`0134e9d8 : nt!KiSystemServiceCopyEnd+0x13
fffff880`0d0b7a88 fffff800`038def6f : 00000000`00000220 00000000`0134e6a8 00000000`0134e9d8 00000000`000a001f : nt!KiServiceLinkage
fffff880`0d0b7a90 fffff800`03680e53 : fffffa80`15292060 fffff880`0d0b7b60 fffff880`0d0b7b60 00000000`00000002 : nt!NtInitializeRegistry+0x6f
fffff880`0d0b7ae0 00000000`778f205a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0134e958 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x778f205a


nt! ?? ::NNGAKEGL::`string'+9d9a
fffff800`039b2158 cc int 3


SYMBOL_NAME: nt! ?? ::NNGAKEGL::`string'+9d9a



IMAGE_NAME: ntkrnlmp.exe


FAILURE_BUCKET_ID: X64_0x51_nt!_??_::NNGAKEGL::_string_+9d9a

BUCKET_ID: X64_0x51_nt!_??_::NNGAKEGL::_string_+9d9a

Followup: MachineOwner
My System SpecsSystem Spec
25 Nov 2014   #5

Windows 64-bit

Also, full computer diagnostic (memory, disk, etc) came up negative.
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 - System Restore, Saving a Backup & Permanant Restore Point
My questions are on Windows 7 System Restore, Restore Points and Backups; specifically, potentially using a Backup as a Permanent Restore Point. Here is the situation... About a month ago, I did a complete Factory Restore on my HP desktop and returned it to it's factory condition. After...
Backup and Restore
BSOD after login, error 0x00000051 REGISTRY_ERROR
Hi, My machine was running smoothly until recently it became infected with adware. I tried to remove the uninvited software through Uninstall Programs in control panel, and also by using Malwarebytes to quarantine anything it found objectionable. It then seemed to work fine after all of this...
BSOD Help and Support
Can System Restore Automatically Generate Daily Restore Point?
I used to be able to get a System Restore point generated daily and accessible on a calendar. I understand that the Restore Point calendar has been done away with, can't imagine why? Is it now possible to have a daily System Restore point automatically generated and easily accessible somewhere?...
Backup and Restore
System Restore how to set to show every past restore point inc/manual
I am having difficulties with this. 1. Does Win 7 limit the quantity of past restore points it shows upon user request? 2. If stored elsewhere where do I find them? 3. Is there a way to set it up to show at least the last 10 restore pointsd created, or is there a smaller limit. Right now the...
General Discussion
System Restore- restore point creation error
Hi guys, I'm a newbie on this forum and this is my first thread. I just tried to create a restore point and ended up with this error: Any help would be much appreciated.
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:19.
Twitter Facebook